]> git.pld-linux.org Git - SPECS.git/blob - transifex-client.spec
SPECS updated Wed 28 Jul 14:48:01 CEST 2021
[SPECS.git] / transifex-client.spec
1 #
2 # Conditional build:
3 %bcond_with     tests   # do not perform "make test"
4
5 %define         module          txclib
6 %define         egg_name        transifex_client
7 %define         pypi_name       transifex-client
8 Summary:        Command line tool for Transifex translation management
9 Name:           transifex-client
10 Version:        0.12.4
11 Release:        1
12 License:        GPL v2
13 Group:          Development/Tools
14 Source0:        https://files.pythonhosted.org/packages/source/t/%{pypi_name}/%{pypi_name}-%{version}.tar.gz
15 # Source0-md5:  a4eefdf7d29198bc8363e087d26712d1
16 URL:            https://www.transifex.com/
17 BuildRequires:  python-setuptools
18 BuildRequires:  rpm-pythonprov
19 BuildRequires:  rpmbuild(macros) >= 1.714
20 BuildArch:      noarch
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 The Transifex Command-line Client is a command line tool that enables
25 you to easily manage your translations within a project without the
26 need of an elaborate UI system.
27
28 %prep
29 %setup -q
30
31 %build
32 %py_build %{?with_tests:test}
33
34 %install
35 rm -rf $RPM_BUILD_ROOT
36 %py_install
37
38 %clean
39 rm -rf $RPM_BUILD_ROOT
40
41 %files
42 %defattr(644,root,root,755)
43 %doc LICENSE README.md
44 %attr(755,root,root) %{_bindir}/tx
45 %{py_sitescriptdir}/%{module}
46 %{py_sitescriptdir}/%{egg_name}-%{version}-py*.egg-info
This page took 0.206125 seconds and 3 git commands to generate.