]> git.pld-linux.org Git - packages/transcode.git/blob - transcode.spec
- bcond_with(out) is followed by one \t, then bcond's name.
[packages/transcode.git] / transcode.spec
1 #
2 # todo:
3 # - split plugins into subpackages
4 # - disable building of libraries which exist in system (libdv,libmpeg2 etc.)
5 # - cmov test is broken, ignores --enable-cmov-extension and tries to read /proc/cpuinfo
6 #
7 # Conditional build:
8 %bcond_without  gtk             # disable GTK+ dependent stuff
9 %bcond_without  avifile                 # disable avifile module
10 %bcond_without  sdl             # disable SDL support
11 %bcond_without  im              # disable imagemagick module
12 %bcond_without  libmpeg3                # disable libmpeg3 support
13 %bcond_without  quicktime       # disable quicktime support
14 #
15 Summary:        Video stream converter
16 Summary(pl):    Konwerter strumieni video
17 Name:           transcode
18 Version:        0.6.12
19 Release:        9
20 License:        GPL
21 Group:          Applications
22 Source0:        http://www.jakemsr.com/transcode/%{name}-%{version}.tar.gz
23 # Source0-md5:  550214ed9f85224423ca8c7308ed96ce
24 Patch0:         %{name}-altivec.patch
25 Patch1:         %{name}-pic.patch
26 Patch2:         %{name}-amfix.patch
27 Patch3:         %{name}-gcc34.patch
28 URL:            http://www.transcoding.org/
29 %{?with_im:BuildRequires:       ImageMagick-devel >= 5.4.3}
30 %{?with_sdl:BuildRequires:      SDL-devel >= 1.1.6}
31 BuildRequires:  XFree86-devel
32 BuildRequires:  a52dec-libs-devel
33 BuildRequires:  autoconf
34 BuildRequires:  automake >= 1.3
35 %{?with_avifile:BuildRequires:  avifile-devel >= 3:0.7.32-0.20030219}
36 BuildRequires:  freetype-devel >= 2.1.2
37 BuildRequires:  glib-devel >= 0.99.7
38 %{?with_gtk:BuildRequires:      gtk+-devel}
39 BuildRequires:  lame-libs-devel >= 3.89
40 BuildRequires:  libdv-devel
41 BuildRequires:  libdvdread-devel
42 BuildRequires:  libfame-devel
43 BuildRequires:  libjpeg-devel
44 %{?with_libmpeg3:BuildRequires: libmpeg3-devel}
45 # liblve-devel ???
46 BuildRequires:  libogg-devel
47 BuildRequires:  libtheora-devel
48 BuildRequires:  libtool >= 2:1.5
49 BuildRequires:  libvorbis-devel
50 BuildRequires:  libxml2-devel
51 BuildRequires:  lzo-devel
52 BuildRequires:  mjpegtools-devel
53 %ifarch %{ix86}
54 BuildRequires:  nasm >= 0.98.34
55 %endif
56 %{?with_quicktime:BuildRequires:        quicktime4linux-devel >= 1.5.5}
57 BuildRequires:  xvid-devel
58 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
59
60 %define         specflags       -fomit-frame-pointer
61
62 %description
63 Linux Video Stream Processing Tool.
64
65 %description -l pl
66 Linuksowe narzêdzie do obróbki strumieni video.
67
68 %package avilib
69 Summary:        library to handle avi files from transcode
70 Summary(pl):    biblioteka do obróbki plików avi pochodz±ca z transcode
71 Group:          Development/Libraries
72
73 %description avilib
74 Avilib is part of transcode made accessible for other programs that
75 require it. So far I know of one such program - ogmtools.
76
77 %description avilib -l pl
78 Avifile jest czê¶ci± programu transcode udostêpnion± dla innych
79 programów, które jej wymagaj±. Jak na razie znam jeden taki program -
80 ogmtools.
81
82 %prep
83 %setup -q
84 %patch0 -p1
85 %patch1 -p1
86 %patch2 -p1
87 %patch3 -p1
88
89 %build
90 %{__libtoolize}
91 %{__aclocal}
92 %{__autoconf}
93 %{__autoheader}
94 %{__automake}
95 # ac_cv_* to avoid detection of libdivxdecore as divx4linux (leading to errors)
96 # or divx4linux itself (make bcond_with if you want it)
97 %configure \
98         ac_cv_header_decore_h=no \
99         ac_cv_header_encore2_h=no \
100 %ifarch ppc
101         --disable-altivec \
102 %endif
103 %ifarch %{ix86}
104 %ifarch i386 i486 i586 \
105         --disable-cmov-extension \
106 %else
107         --enable-cmov-extension \
108 %endif
109 %endif
110         --with-a52 \
111         --with-a52-include=%{_prefix} \
112         --with-a52-libs=%{_prefix} \
113         --with-avifile-mods \
114         --with-avifile-exec-prefix=%{_prefix} \
115         --with-dv \
116         --with-dv-includes=%{_prefix} \
117         --with-dv-libs=%{_prefix} \
118         --with-dvdread \
119         --with-dvdread-includes=%{_prefix} \
120         --with-dvdread-libs=%{_prefix} \
121         --with-gtk-prefix=%{_prefix} \
122         --with-gtk-exec-prefix=%{_prefix} \
123         --with-lame \
124         --with-lame-includes=%{_prefix} \
125         --with-lame-libs=%{_prefix} \
126         --with-libfame-prefix=%{_prefix} \
127         --with-libfame-exec-prefix=%{_prefix} \
128         --with-libjpeg-mods \
129         --with-libmpeg3 \
130         --with-libmpeg3-includes=%{_prefix} \
131         --with-libmpeg3-libs=%{_prefix} \
132         --with-magick-mods \
133         --with-magick-exec-prefix=%{_prefix} \
134         --with-mod-path=%{_libdir}/transcode \
135         --with-ogg \
136         --with-ogg-includes=%{_prefix} \
137         --with-ogg-libs=%{_prefix} \
138         --with-qt \
139         --with-qt-includes=%{_prefix} \
140         --with-qt-libs=%{_prefix} \
141         --with-sdl-prefix=%{_prefix} \
142         --with-sdl-exec-prefix=%{_prefix} \
143         --with-vorbis \
144         --with-vorbis-includes=%{_prefix} \
145         --with-vorbis-libs=%{_prefix} \
146         --with-x \
147         --without-pvm3
148
149 %{__make}
150
151 %install
152 rm -rf $RPM_BUILD_ROOT
153
154 %{__make} install \
155         DESTDIR=$RPM_BUILD_ROOT
156
157 install -D avilib/avilib.h $RPM_BUILD_ROOT%{_includedir}/avilib.h
158 install -D avilib/libavi.a $RPM_BUILD_ROOT%{_libdir}/libavi.a
159
160 %clean
161 rm -rf $RPM_BUILD_ROOT
162
163 %files
164 %defattr(644,root,root,755)
165 %doc README ChangeLog docs/README* docs/*.txt docs/html
166 %attr(755,root,root) %{_bindir}/*
167 # todo: split it into subpackages export-*, import-* and filter-*
168 %dir %{_libdir}/%{name}
169 %attr(755,root,root) %{_libdir}/%{name}/*.so*
170 %attr(755,root,root) %{_libdir}/%{name}/*.awk
171 %{_libdir}/%{name}/*.la
172 %{_libdir}/%{name}/*.conf
173 %{_libdir}/%{name}/*.cfg
174 %{_mandir}/man1/*
175
176 %files avilib
177 %defattr(644,root,root,755)
178 %doc avilib/README.avilib
179 %{_includedir}/avilib.h
180 %{_libdir}/libavi.a
This page took 0.104743 seconds and 4 git commands to generate.