]> git.pld-linux.org Git - packages/transcode.git/blob - transcode.spec
- release 4
[packages/transcode.git] / transcode.spec
1 # TODO:
2 # - disable building of libraries which exist in system (libdv?,libmpeg2 etc.)
3 # - cmov test is broken, ignores --enable-cmov-extension and tries to read /proc/cpuinfo
4 # - pvm3 needs recompiled with -fPIC, then it can be used here
5 # - --enable-xio requires some libs from http://loci.cs.utk.edu/
6 # - rm Makefiles from htmldir
7 #
8 # Conditional build:
9 %bcond_without  im                      # disable imagemagick module
10 %bcond_without  libmpeg2        # disable libmpeg2 support
11 %bcond_without  lzo                     # disable lzo support
12 %bcond_without  mjpeg           # disable mjpegtools support
13 %bcond_without  quicktime       # disable libquicktime support
14 %bcond_without  sdl                     # disable SDL support
15 %bcond_with     jpegmmx         # jpeg-mmx
16 %bcond_with     pvm3            # pvm3
17
18 # no jpeg-mmx there (doesn't compile)
19 %ifnarch i586 i686 athlon
20 %undefine       with_jpegmmx
21 %endif
22 # pvm3 needs recompiled with -fPIC
23 %ifarch %{x8664} alpha
24 %undefine       with_pvm3
25 %endif
26 #
27 Summary:        Video stream converter
28 Summary(pl.UTF-8):      Konwerter strumieni video
29 Name:           transcode
30 Version:        1.1.5
31 Release:        4
32 License:        GPL
33 Group:          Applications
34 Source0:        http://download.berlios.de/tcforge/%{name}-%{version}.tar.bz2
35 # Source0-md5:  41ac6b1c0fe30f3aab286e771fc31b9e
36 Patch0:         %{name}-libx86_64.patch
37 Patch1:         %{name}-ImageMagick.patch
38 Patch2:         %{name}-mpa.patch
39 Patch3:         %{name}-ffmpeg.patch
40 URL:            http://tcforge.berlios.de/
41 %{?with_im:BuildRequires:       ImageMagick-devel >= 6.4.1-2}
42 %{?with_sdl:BuildRequires:      SDL-devel >= 1.1.6}
43 BuildRequires:  a52dec-libs-devel
44 BuildRequires:  autoconf
45 BuildRequires:  automake >= 1.3
46 BuildRequires:  ffmpeg-devel >= 0.7.1
47 BuildRequires:  freetype-devel >= 2.1.2
48 %{?with_jpegmmx:BuildRequires:  jpeg-mmx}
49 BuildRequires:  lame-libs-devel >= 3.89
50 BuildRequires:  libdv-devel >= 0.104-3
51 BuildRequires:  libdvdread-devel
52 BuildRequires:  libfame-devel >= 0.9.1
53 BuildRequires:  libgomp-devel
54 BuildRequires:  libjpeg-devel
55 %{?with_libmpeg2:BuildRequires: libmpeg2-devel >= 0.4.0b}
56 BuildRequires:  libogg-devel
57 BuildRequires:  libpng-devel
58 %{?with_quicktime:BuildRequires:        libquicktime-devel}
59 BuildRequires:  libstdc++-devel
60 BuildRequires:  libtheora-devel
61 BuildRequires:  libtool >= 2:1.5
62 BuildRequires:  libvorbis-devel
63 BuildRequires:  libxml2-devel
64 %{?with_lzo:BuildRequires:      lzo-devel >= 2.0}
65 %{?with_mjpeg:BuildRequires:    mjpegtools-devel}
66 %ifarch %{ix86}
67 BuildRequires:  nasm >= 0.98.34
68 %endif
69 BuildRequires:  pkgconfig
70 %{?with_pvm3:BuildRequires:     pvm-devel}
71 BuildRequires:  xorg-lib-libXaw-devel
72 BuildRequires:  xorg-lib-libXpm-devel
73 BuildRequires:  xvid-devel
74 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
75
76 %define         specflags       -fomit-frame-pointer
77
78 %description
79 Linux Video Stream Processing Tool.
80
81 %description -l pl.UTF-8
82 Linuksowe narzędzie do obróbki strumieni video.
83
84 %package avilib
85 Summary:        library to handle avi files from transcode
86 Summary(pl.UTF-8):      biblioteka do obróbki plików avi pochodząca z transcode
87 Group:          Development/Libraries
88
89 %description avilib
90 Avilib is part of transcode made accessible for other programs that
91 require it. So far I know of one such program - ogmtools.
92
93 %description avilib -l pl.UTF-8
94 Avifile jest częścią programu transcode udostępnioną dla innych
95 programów, które jej wymagają. Jak na razie znam jeden taki program -
96 ogmtools.
97
98 %package export
99 Summary:        export plugins for transcode
100 Summary(pl.UTF-8):      wtyczki eksportowe transcode
101 Group:          Development/Libraries
102 Requires:       %{name} = %{version}-%{release}
103
104 %description export
105 Export plugins for transcode.
106
107 %description export -l pl.UTF-8
108 Wtyczki eksportowe dla transcode.
109
110 %package import
111 Summary:        import plugins for transcode
112 Summary(pl.UTF-8):      wtyczki importujące transcode
113 Group:          Development/Libraries
114 Requires:       %{name} = %{version}-%{release}
115
116 %description import
117 Import plugins for transcode.
118
119 %description import -l pl.UTF-8
120 Wtyczki importujące dla transcode.
121
122 %package filter
123 Summary:        filters for transcode
124 Summary(pl.UTF-8):      filtry transcode
125 Group:          Development/Libraries
126 Requires:       %{name} = %{version}-%{release}
127
128 %description filter
129 Filters for transcode.
130
131 %description filter -l pl.UTF-8
132 Filtry transcode.
133
134 %prep
135 %setup -q
136 %patch0 -p1
137 %patch1 -p1
138 %patch2 -p1
139 %patch3 -p1
140
141 %build
142 %{__libtoolize}
143 %{__aclocal}
144 %{__autoconf}
145 %{__autoheader}
146 %{__automake}
147 # ac_cv_* to avoid detection of libdivxdecore as divx4linux (leading to errors)
148 # or divx4linux itself (make bcond_with if you want it)
149 %configure \
150         ac_cv_header_decore_h=no \
151         ac_cv_header_encore2_h=no \
152 %ifarch ppc
153         --enable-altivec \
154 %endif
155 %ifarch %{ix86} %{x8664}
156         --enable-mmx \
157         --enable-3dnow \
158         --enable-sse \
159         --enable-sse2 \
160 %endif
161         --disable-bktr \
162         --disable-bsdav \
163         --disable-sunau \
164         --enable-a52 \
165         --enable-freetype2 \
166         --enable-iconv \
167         --%{!?with_im:dis}%{?with_im:en}able-imagemagick \
168         --enable-lame \
169         --enable-libavcodec \
170         --enable-libdv \
171         --enable-libdvdread \
172         --enable-libjpeg \
173         --%{!?with_libmpeg2:dis}%{?with_libmpeg2:en}able-libmpeg2 \
174         --enable-libpostproc \
175         --%{!?with_quicktime:dis}%{?with_quicktime:en}able-libquicktime \
176         --enable-libxml2 \
177         --%{!?with_lzo:dis}%{?with_lzo:en}able-lzo \
178         --with-lzo-includes=%{_includedir}/lzo \
179         --%{!?with_mjpeg:dis}%{?with_mjpeg:en}able-mjpegtools \
180         --enable-ogg \
181         --enable-oss \
182         --enable-sdl \
183         --enable-statbuffer \
184         --enable-theora \
185         --enable-v4l \
186         --enable-vorbis \
187         --%{!?with_jpegmmx:dis}%{?with_jpegmmx:en}able-libjpegmmx \
188         --%{!?with_pvm3:dis}%{?with_pvm3:en}able-pvm3 \
189         --with-libpostproc-includes=%{_includedir}/postproc \
190         --with-x
191
192 %{__make}
193
194 %install
195 rm -rf $RPM_BUILD_ROOT
196
197 %{__make} install \
198         DESTDIR=$RPM_BUILD_ROOT
199
200 install -D avilib/avilib.h $RPM_BUILD_ROOT%{_includedir}/avilib.h
201
202 # duplicate
203 rm -rf $RPM_BUILD_ROOT%{_docdir}/transcode
204
205 %clean
206 rm -rf $RPM_BUILD_ROOT
207
208 %files
209 %defattr(644,root,root,755)
210 %doc README ChangeLog docs/README* docs/*.txt docs/html
211 %attr(755,root,root) %{_bindir}/*
212 %dir %{_libdir}/%{name}
213 %{_libdir}/%{name}/a52_decore.la
214 %{_libdir}/%{name}/a52_decore.so
215 %{_libdir}/%{name}/parse_csv.awk
216 %{_libdir}/%{name}/*.cfg
217 %{_mandir}/man1/*
218
219 %files avilib
220 %defattr(644,root,root,755)
221 %doc avilib/README.avilib
222 %{_includedir}/avilib.h
223
224 %files export
225 %defattr(644,root,root,755)
226 %attr(755,root,root) %{_libdir}/%{name}/export*.la*
227 %attr(755,root,root) %{_libdir}/%{name}/export*.so*
228
229 %files import
230 %defattr(644,root,root,755)
231 %attr(755,root,root) %{_libdir}/%{name}/import*.la*
232 %attr(755,root,root) %{_libdir}/%{name}/import*.so*
233
234 %files filter
235 %defattr(644,root,root,755)
236 %attr(755,root,root) %{_libdir}/%{name}/filter*.la*
237 %attr(755,root,root) %{_libdir}/%{name}/filter*.so*
238 %attr(755,root,root) %{_libdir}/%{name}/filter*.awk
This page took 0.113662 seconds and 4 git commands to generate.