]> git.pld-linux.org Git - packages/transcode.git/blob - transcode.spec
- lzo detection fix
[packages/transcode.git] / transcode.spec
1 # TODO:
2 # - split plugins into subpackages. (how? splitting criteria? perhaps by external deps, not by functionality (import/export/..?)
3 # - disable building of libraries which exist in system (libdv?,libmpeg2 etc.)
4 # - cmov test is broken, ignores --enable-cmov-extension and tries to read /proc/cpuinfo
5 # - pvm3 needs recompiled with -fPIC, then it can be used here
6 #
7 # Conditional build:
8 %bcond_without  avifile         # disable avifile module
9 %bcond_without  gtk                     # disable GTK+ dependent stuff
10 %bcond_without  im                      # disable imagemagick module
11 %bcond_without  libmpeg2        # disable libmpeg2 support
12 %bcond_without  libmpeg3        # disable libmpeg3 support
13 %bcond_without  lzo                     # disable lzo support
14 %bcond_without  mjpeg           # disable mjpegtools support
15 %bcond_without  sdl                     # disable SDL support
16 %bcond_with     jpegmmx         # jpeg-mmx
17 %bcond_with     pvm3            # pvm3
18
19 # no jpeg-mmx there (doesn't compile)
20 %ifnarch i586 i686 athlon
21 %undefine       with_jpegmmx
22 %endif
23 # pvm3 needs recompiled with -fPIC
24 %ifarch %{x8664} alpha
25 %undefine       with_pvm3
26 %endif
27 #
28 Summary:        Video stream converter
29 Summary(pl):    Konwerter strumieni video
30 Name:           transcode
31 Version:        1.0.2
32 Release:        1.2
33 License:        GPL
34 Group:          Applications
35 Source0:        http://www.jakemsr.com/transcode/%{name}-%{version}.tar.gz
36 # Source0-md5:  e353c0ab7e927a8672528e05a9ae960b
37 Patch0:         %{name}-ac.patch
38 Patch1:         %{name}-lzo2.patch
39 Patch2:         %{name}-bigdir.patch
40 Patch3:         %{name}-mpeg3.patch
41 URL:            http://www.transcoding.org/
42 BuildRequires:  xorg-lib-libXaw-devel
43 BuildRequires:  xorg-lib-libXpm-devel
44 %{?with_im:BuildRequires:       ImageMagick-devel >= 5.4.3}
45 %{?with_sdl:BuildRequires:      SDL-devel >= 1.1.6}
46 BuildRequires:  a52dec-libs-devel
47 BuildRequires:  autoconf
48 BuildRequires:  automake >= 1.3
49 %{?with_avifile:BuildRequires:  avifile-devel > 3:0.7.43-1}
50 BuildRequires:  ffmpeg-devel >= 0.4.9-0.pre1
51 BuildRequires:  freetype-devel >= 2.1.2
52 %{?with_gtk:BuildRequires:      gtk+-devel}
53 %{?with_jpegmmx:BuildRequires:  jpeg-mmx}
54 BuildRequires:  lame-libs-devel >= 3.89
55 BuildRequires:  libdv-devel >= 0.104-3
56 BuildRequires:  libdvdread-devel
57 BuildRequires:  libfame-devel
58 BuildRequires:  libjpeg-devel
59 %{?with_libmpeg3:BuildRequires: libmpeg3-devel}
60 BuildRequires:  libogg-devel
61 BuildRequires:  libpng-devel
62 %{?with_quicktime:BuildRequires:        libquicktime-devel}
63 BuildRequires:  libstdc++-devel
64 BuildRequires:  libtheora-devel
65 BuildRequires:  libtool >= 2:1.5
66 BuildRequires:  libvorbis-devel
67 BuildRequires:  libxml2-devel
68 %{?with_lzo:BuildRequires:      lzo-devel}
69 %{?with_mjpeg:BuildRequires:    mjpegtools-devel}
70 %{?with_libmpeg2:BuildRequires: mpeg2dec-devel >= 0.4.0b}
71 %ifarch %{ix86}
72 BuildRequires:  nasm >= 0.98.34
73 %endif
74 BuildRequires:  pkgconfig
75 %{?with_pvm3:BuildRequires:     pvm-devel}
76 BuildRequires:  xvid-devel
77 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
78
79 %define         specflags       -fomit-frame-pointer
80
81 %description
82 Linux Video Stream Processing Tool.
83
84 %description -l pl
85 Linuksowe narzêdzie do obróbki strumieni video.
86
87 %package avilib
88 Summary:        library to handle avi files from transcode
89 Summary(pl):    biblioteka do obróbki plików avi pochodz±ca z transcode
90 Group:          Development/Libraries
91
92 %description avilib
93 Avilib is part of transcode made accessible for other programs that
94 require it. So far I know of one such program - ogmtools.
95
96 %description avilib -l pl
97 Avifile jest czê¶ci± programu transcode udostêpnion± dla innych
98 programów, które jej wymagaj±. Jak na razie znam jeden taki program -
99 ogmtools.
100
101 %prep
102 %setup -q
103 %patch0 -p1
104 %patch1 -p1
105 %patch2 -p0
106 %patch3 -p0
107
108 %build
109 %{__libtoolize}
110 %{__aclocal}
111 %{__autoconf}
112 %{__autoheader}
113 %{__automake}
114 # ac_cv_* to avoid detection of libdivxdecore as divx4linux (leading to errors)
115 # or divx4linux itself (make bcond_with if you want it)
116 %configure \
117         ac_cv_header_decore_h=no \
118         ac_cv_header_encore2_h=no \
119 %ifarch ppc
120         --disable-altivec \
121 %endif
122 %ifarch %{ix86} %{x8664}
123         --enable-mmx \
124         --enable-3dnow \
125         --enable-sse \
126         --enable-sse2 \
127 %endif
128 %ifarch %{ix86}
129 %ifarch i386 i486 i586 \
130         --disable-cmov-extension \
131 %else
132         --enable-cmov-extension \
133 %endif
134 %endif
135         --disable-bktr \
136         --disable-bsdav \
137         --disable-sunau \
138         --enable-a52 \
139         --enable-a52-default-decoder \
140         --enable-freetype2 \
141         --%{!?with_gtk:dis}%{?with_gtk:en}able-gtk \
142         --enable-ibp \
143         --enable-iconv \
144         --enable-imagemagick \
145         --enable-lame \
146         --enable-libavcodec \
147         --enable-libdv \
148         --enable-libdvdread \
149         --enable-libfame \
150         --enable-libjpeg \
151         --%{!?with_libmpeg2:dis}%{?with_libmpeg2:en}able-libmpeg2 \
152         --%{!?with_libmpeg3:dis}%{?with_libmpeg3:en}able-libmpeg3 \
153         --enable-libpostproc \
154         --%{!?with_quicktime:dis}%{?with_quicktime:en}able-libquicktime \
155         --enable-libxml2 \
156         --%{!?with_lzo:dis}%{?with_lzo:en}able-lzo \
157         --with-lzo-includes=%{_includedir}/lzo \
158         --%{!?with_mjpeg:dis}%{?with_mjpeg:en}able-mjpegtools \
159         --enable-netstream \
160         --enable-ogg \
161         --enable-oss \
162         --enable-sdl \
163         --enable-statbuffer \
164         --enable-theora \
165         --enable-v4l \
166         --enable-vorbis \
167         --enable-xio \
168         --%{!?with_avifile:dis}%{?with_avifile:en}able-avifile \
169         --%{!?with_jpegmmx:dis}%{?with_jpegmmx:en}able-libjpegmmx \
170         --%{!?with_pvm3:dis}%{?with_pvm3:en}able-pvm3 \
171         --with-libpostproc-includes=%{_includedir}/postproc \
172         --with-x
173
174 %{__make} \
175         LDFLAGS="%{rpmldflags}"
176
177 %install
178 rm -rf $RPM_BUILD_ROOT
179
180 %{__make} install \
181         DESTDIR=$RPM_BUILD_ROOT
182
183 install -D avilib/avilib.h $RPM_BUILD_ROOT%{_includedir}/avilib.h
184
185 # duplicate
186 rm -rf $RPM_BUILD_ROOT%{_docdir}/transcode
187
188 %clean
189 rm -rf $RPM_BUILD_ROOT
190
191 %files
192 %defattr(644,root,root,755)
193 %doc README ChangeLog docs/README* docs/*.txt docs/html
194 %attr(755,root,root) %{_bindir}/*
195 # TODO: split it into subpackages export-*, import-* and filter-*
196 %dir %{_libdir}/%{name}
197 %attr(755,root,root) %{_libdir}/%{name}/*.so*
198 %attr(755,root,root) %{_libdir}/%{name}/*.awk
199 %{_libdir}/%{name}/*.la
200 %{_libdir}/%{name}/*.conf
201 %{_libdir}/%{name}/*.cfg
202 %{_mandir}/man1/*
203
204 %files avilib
205 %defattr(644,root,root,755)
206 %doc avilib/README.avilib
207 %{_includedir}/avilib.h
This page took 0.06109 seconds and 4 git commands to generate.