]> git.pld-linux.org Git - packages/transcode.git/blob - transcode.spec
- release 4
[packages/transcode.git] / transcode.spec
1 # TODO:
2 # - disable building of libraries which exist in system (libdv?,libmpeg2 etc.)
3 # - cmov test is broken, ignores --enable-cmov-extension and tries to read /proc/cpuinfo
4 # - pvm3 needs recompiled with -fPIC, then it can be used here
5 # - --enable-xio requires some libs from http://loci.cs.utk.edu/
6 # - rm Makefiles from htmldir
7 #
8 # Conditional build:
9 %bcond_without  im                      # disable imagemagick module
10 %bcond_without  libmpeg2        # disable libmpeg2 support
11 %bcond_without  lzo                     # disable lzo support
12 %bcond_without  mjpeg           # disable mjpegtools support
13 %bcond_without  quicktime       # disable libquicktime support
14 %bcond_without  sdl                     # disable SDL support
15 %bcond_with     jpegmmx         # jpeg-mmx
16 %bcond_with     pvm3            # pvm3
17
18 # no jpeg-mmx there (doesn't compile)
19 %ifnarch i586 i686 athlon
20 %undefine       with_jpegmmx
21 %endif
22 # pvm3 needs recompiled with -fPIC
23 %ifarch %{x8664} alpha
24 %undefine       with_pvm3
25 %endif
26 #
27 Summary:        Video stream converter
28 Summary(pl.UTF-8):      Konwerter strumieni video
29 Name:           transcode
30 Version:        1.1.0
31 Release:        4
32 License:        GPL
33 Group:          Applications
34 Source0:        http://fromani.exit1.org/%{name}-%{version}.tar.bz2
35 # Source0-md5:  5ca205e32b546402a48ea8004a7b3232
36 Patch0:         %{name}-libx86_64.patch
37 Patch1:         %{name}-ImageMagick.patch
38 URL:            http://www.transcoding.org/
39 %{?with_im:BuildRequires:       ImageMagick-devel >= 6.4.1-2}
40 %{?with_sdl:BuildRequires:      SDL-devel >= 1.1.6}
41 BuildRequires:  a52dec-libs-devel
42 BuildRequires:  autoconf
43 BuildRequires:  automake >= 1.3
44 BuildRequires:  ffmpeg-devel >= 0.4.9-0.pre1
45 BuildRequires:  freetype-devel >= 2.1.2
46 %{?with_jpegmmx:BuildRequires:  jpeg-mmx}
47 BuildRequires:  lame-libs-devel >= 3.89
48 BuildRequires:  libdv-devel >= 0.104-3
49 BuildRequires:  libdvdread-devel
50 BuildRequires:  libfame-devel >= 0.9.1
51 BuildRequires:  libgomp-devel
52 BuildRequires:  libjpeg-devel
53 BuildRequires:  libogg-devel
54 BuildRequires:  libpng-devel
55 %{?with_quicktime:BuildRequires:        libquicktime-devel}
56 BuildRequires:  libstdc++-devel
57 BuildRequires:  libtheora-devel
58 BuildRequires:  libtool >= 2:1.5
59 BuildRequires:  libvorbis-devel
60 BuildRequires:  libxml2-devel
61 %{?with_lzo:BuildRequires:      lzo-devel >= 2.0}
62 %{?with_mjpeg:BuildRequires:    mjpegtools-devel}
63 %{?with_libmpeg2:BuildRequires: mpeg2dec-devel >= 0.4.0b}
64 %ifarch %{ix86}
65 BuildRequires:  nasm >= 0.98.34
66 %endif
67 BuildRequires:  pkgconfig
68 %{?with_pvm3:BuildRequires:     pvm-devel}
69 BuildRequires:  xorg-lib-libXaw-devel
70 BuildRequires:  xorg-lib-libXpm-devel
71 BuildRequires:  xvid-devel
72 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
73
74 %define         specflags       -fomit-frame-pointer
75
76 %description
77 Linux Video Stream Processing Tool.
78
79 %description -l pl.UTF-8
80 Linuksowe narzędzie do obróbki strumieni video.
81
82 %package avilib
83 Summary:        library to handle avi files from transcode
84 Summary(pl.UTF-8):      biblioteka do obróbki plików avi pochodząca z transcode
85 Group:          Development/Libraries
86
87 %description avilib
88 Avilib is part of transcode made accessible for other programs that
89 require it. So far I know of one such program - ogmtools.
90
91 %description avilib -l pl.UTF-8
92 Avifile jest częścią programu transcode udostępnioną dla innych
93 programów, które jej wymagają. Jak na razie znam jeden taki program -
94 ogmtools.
95
96 %package export
97 Summary:        export plugins for transcode
98 Summary(pl.UTF-8):      wtyczki eksportowe transcode
99 Group:          Development/Libraries
100 Requires:       %{name} = %{version}-%{release}
101
102 %description export
103 Export plugins for transcode.
104
105 %description export -l pl.UTF-8
106 Wtyczki eksportowe dla transcode.
107
108 %package import
109 Summary:        import plugins for transcode
110 Summary(pl.UTF-8):      wtyczki importujące transcode
111 Group:          Development/Libraries
112 Requires:       %{name} = %{version}-%{release}
113
114 %description import
115 Import plugins for transcode.
116
117 %description import -l pl.UTF-8
118 Wtyczki importujące dla transcode.
119
120 %package filter
121 Summary:        filters for transcode
122 Summary(pl.UTF-8):      filtry transcode
123 Group:          Development/Libraries
124 Requires:       %{name} = %{version}-%{release}
125
126 %description filter
127 Filters for transcode.
128
129 %description filter -l pl.UTF-8
130 Filtry transcode.
131
132 %prep
133 %setup -q
134 %patch0 -p1
135 %patch1 -p1
136
137 %build
138 %{__libtoolize}
139 %{__aclocal}
140 %{__autoconf}
141 %{__autoheader}
142 %{__automake}
143 # ac_cv_* to avoid detection of libdivxdecore as divx4linux (leading to errors)
144 # or divx4linux itself (make bcond_with if you want it)
145 %configure \
146         ac_cv_header_decore_h=no \
147         ac_cv_header_encore2_h=no \
148 %ifarch ppc
149         --enable-altivec \
150 %endif
151 %ifarch %{ix86} %{x8664}
152         --enable-mmx \
153         --enable-3dnow \
154         --enable-sse \
155         --enable-sse2 \
156 %endif
157         --disable-bktr \
158         --disable-bsdav \
159         --disable-sunau \
160         --enable-a52 \
161         --enable-freetype2 \
162         --enable-iconv \
163         --%{!?with_im:dis}%{?with_im:en}able-imagemagick \
164         --enable-lame \
165         --enable-libavcodec \
166         --enable-libdv \
167         --enable-libdvdread \
168         --enable-libjpeg \
169         --%{!?with_libmpeg2:dis}%{?with_libmpeg2:en}able-libmpeg2 \
170         --enable-libpostproc \
171         --%{!?with_quicktime:dis}%{?with_quicktime:en}able-libquicktime \
172         --enable-libxml2 \
173         --%{!?with_lzo:dis}%{?with_lzo:en}able-lzo \
174         --with-lzo-includes=%{_includedir}/lzo \
175         --%{!?with_mjpeg:dis}%{?with_mjpeg:en}able-mjpegtools \
176         --enable-ogg \
177         --enable-oss \
178         --enable-sdl \
179         --enable-statbuffer \
180         --enable-theora \
181         --enable-v4l \
182         --enable-vorbis \
183         --%{!?with_jpegmmx:dis}%{?with_jpegmmx:en}able-libjpegmmx \
184         --%{!?with_pvm3:dis}%{?with_pvm3:en}able-pvm3 \
185         --with-libpostproc-includes=%{_includedir}/postproc \
186         --with-x
187
188 %{__make}
189
190 %install
191 rm -rf $RPM_BUILD_ROOT
192
193 %{__make} install \
194         DESTDIR=$RPM_BUILD_ROOT
195
196 install -D avilib/avilib.h $RPM_BUILD_ROOT%{_includedir}/avilib.h
197
198 # duplicate
199 rm -rf $RPM_BUILD_ROOT%{_docdir}/transcode
200
201 %clean
202 rm -rf $RPM_BUILD_ROOT
203
204 %files
205 %defattr(644,root,root,755)
206 %doc README ChangeLog docs/README* docs/*.txt docs/html
207 %attr(755,root,root) %{_bindir}/*
208 %dir %{_libdir}/%{name}
209 %{_libdir}/%{name}/a52_decore.la
210 %{_libdir}/%{name}/a52_decore.so
211 %{_libdir}/%{name}/parse_csv.awk
212 %{_libdir}/%{name}/*.cfg
213 %{_mandir}/man1/*
214
215 %files avilib
216 %defattr(644,root,root,755)
217 %doc avilib/README.avilib
218 %{_includedir}/avilib.h
219
220 %files export
221 %defattr(644,root,root,755)
222 %attr(755,root,root) %{_libdir}/%{name}/export*.la*
223 %attr(755,root,root) %{_libdir}/%{name}/export*.so*
224
225 %files import
226 %defattr(644,root,root,755)
227 %attr(755,root,root) %{_libdir}/%{name}/import*.la*
228 %attr(755,root,root) %{_libdir}/%{name}/import*.so*
229
230 %files filter
231 %defattr(644,root,root,755)
232 %attr(755,root,root) %{_libdir}/%{name}/filter*.la*
233 %attr(755,root,root) %{_libdir}/%{name}/filter*.so*
234 %attr(755,root,root) %{_libdir}/%{name}/filter*.awk
This page took 0.09469 seconds and 4 git commands to generate.