]> git.pld-linux.org Git - packages/transcode.git/blob - transcode.spec
- fixed gtk bcond
[packages/transcode.git] / transcode.spec
1 # TODO:
2 # - split plugins into subpackages. (how? splitting criteria? perhaps by external deps, not by functionality (import/export/..?)
3 # - disable building of libraries which exist in system (libdv?,libmpeg2 etc.)
4 # - cmov test is broken, ignores --enable-cmov-extension and tries to read /proc/cpuinfo
5 # - pvm3 needs recompiled with -fPIC, then it can be used here
6 #
7 # Conditional build:
8 %bcond_without  avifile         # disable avifile module
9 %bcond_without  gtk                     # disable GTK+ dependent stuff
10 %bcond_without  im                      # disable imagemagick module
11 %bcond_without  libmpeg2        # disable libmpeg2 support
12 %bcond_without  libmpeg3        # disable libmpeg3 support
13 %bcond_without  lzo                     # disable lzo support
14 %bcond_without  mjpeg           # disable mjpegtools support
15 %bcond_without  sdl                     # disable SDL support
16 %bcond_with     jpegmmx         # jpeg-mmx
17 %bcond_with     pvm3            # pvm3
18
19 # no jpeg-mmx there (doesn't compile)
20 %ifnarch i586 i686 athlon
21 %undefine       with_jpegmmx
22 %endif
23 # pvm3 needs recompiled with -fPIC
24 %ifarch %{x8664} alpha
25 %undefine       with_pvm3
26 %endif
27 #
28 Summary:        Video stream converter
29 Summary(pl):    Konwerter strumieni video
30 Name:           transcode
31 Version:        1.0.2
32 Release:        1.1
33 License:        GPL
34 Group:          Applications
35 Source0:        http://www.jakemsr.com/transcode/%{name}-%{version}.tar.gz
36 # Source0-md5:  e353c0ab7e927a8672528e05a9ae960b
37 URL:            http://www.transcoding.org/
38 BuildRequires:  xorg-lib-libXaw-devel
39 BuildRequires:  xorg-lib-libXpm-devel
40 %{?with_im:BuildRequires:       ImageMagick-devel >= 5.4.3}
41 %{?with_sdl:BuildRequires:      SDL-devel >= 1.1.6}
42 BuildRequires:  a52dec-libs-devel
43 BuildRequires:  autoconf
44 BuildRequires:  automake >= 1.3
45 %{?with_avifile:BuildRequires:  avifile-devel > 3:0.7.43-1}
46 BuildRequires:  ffmpeg-devel >= 0.4.9-0.pre1
47 BuildRequires:  freetype-devel >= 2.1.2
48 %{?with_gtk:BuildRequires:      gtk+-devel}
49 %{?with_jpegmmx:BuildRequires:  jpeg-mmx}
50 BuildRequires:  lame-libs-devel >= 3.89
51 BuildRequires:  libdv-devel >= 0.104-3
52 BuildRequires:  libdvdread-devel
53 BuildRequires:  libfame-devel
54 BuildRequires:  libjpeg-devel
55 %{?with_libmpeg3:BuildRequires: libmpeg3-devel}
56 BuildRequires:  libogg-devel
57 BuildRequires:  libpng-devel
58 %{?with_quicktime:BuildRequires:        libquicktime-devel}
59 BuildRequires:  libstdc++-devel
60 BuildRequires:  libtheora-devel
61 BuildRequires:  libtool >= 2:1.5
62 BuildRequires:  libvorbis-devel
63 BuildRequires:  libxml2-devel
64 %{?with_lzo:BuildRequires:      lzo-devel}
65 %{?with_mjpeg:BuildRequires:    mjpegtools-devel}
66 %{?with_libmpeg2:BuildRequires: mpeg2dec-devel >= 0.4.0b}
67 %ifarch %{ix86}
68 BuildRequires:  nasm >= 0.98.34
69 %endif
70 BuildRequires:  pkgconfig
71 %{?with_pvm3:BuildRequires:     pvm-devel}
72 BuildRequires:  xvid-devel
73 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
74
75 %define         specflags       -fomit-frame-pointer
76
77 %description
78 Linux Video Stream Processing Tool.
79
80 %description -l pl
81 Linuksowe narzêdzie do obróbki strumieni video.
82
83 %package avilib
84 Summary:        library to handle avi files from transcode
85 Summary(pl):    biblioteka do obróbki plików avi pochodz±ca z transcode
86 Group:          Development/Libraries
87
88 %description avilib
89 Avilib is part of transcode made accessible for other programs that
90 require it. So far I know of one such program - ogmtools.
91
92 %description avilib -l pl
93 Avifile jest czê¶ci± programu transcode udostêpnion± dla innych
94 programów, które jej wymagaj±. Jak na razie znam jeden taki program -
95 ogmtools.
96
97 %prep
98 %setup -q
99
100 %build
101 %if 0
102 %{__libtoolize}
103 %{__aclocal}
104 %{__autoconf}
105 %{__autoheader}
106 %{__automake}
107 %endif
108 # ac_cv_* to avoid detection of libdivxdecore as divx4linux (leading to errors)
109 # or divx4linux itself (make bcond_with if you want it)
110 %configure \
111         ac_cv_header_decore_h=no \
112         ac_cv_header_encore2_h=no \
113 %ifarch ppc
114         --disable-altivec \
115 %endif
116 %ifarch %{ix86} %{x8664}
117         --enable-mmx \
118         --enable-3dnow \
119         --enable-sse \
120         --enable-sse2 \
121 %endif
122 %ifarch %{ix86}
123 %ifarch i386 i486 i586 \
124         --disable-cmov-extension \
125 %else
126         --enable-cmov-extension \
127 %endif
128 %endif
129         --disable-bktr \
130         --disable-bsdav \
131         --disable-sunau \
132         --enable-a52 \
133         --enable-a52-default-decoder \
134         --enable-freetype2 \
135         --%{!?with_gtk:dis}%{?with_gtk:en}able-gtk \
136         --enable-ibp \
137         --enable-iconv \
138         --enable-imagemagick \
139         --enable-lame \
140         --enable-libavcodec \
141         --enable-libdv \
142         --enable-libdvdread \
143         --enable-libfame \
144         --enable-libjpeg \
145         --%{!?with_libmpeg2:dis}%{?with_libmpeg2:en}able-libmpeg2 \
146         --%{!?with_libmpeg3:dis}%{?with_libmpeg3:en}able-libmpeg3 \
147         --enable-libpostproc \
148         --%{!?with_quicktime:dis}%{?with_quicktime:en}able-libquicktime \
149         --enable-libxml2 \
150         --%{!?with_lzo:dis}%{?with_lzo:en}able-lzo \
151         --%{!?with_mjpeg:dis}%{?with_mjpeg:en}able-mjpegtools \
152         --enable-netstream \
153         --enable-ogg \
154         --enable-oss \
155         --enable-sdl \
156         --enable-statbuffer \
157         --enable-theora \
158         --enable-v4l \
159         --enable-vorbis \
160         --enable-xio \
161         --%{!?with_avifile:dis}%{?with_avifile:en}able-avifile \
162         --%{!?with_jpegmmx:dis}%{?with_jpegmmx:en}able-libjpegmmx \
163         --%{!?with_pvm3:dis}%{?with_pvm3:en}able-pvm3 \
164         --with-libpostproc-includes=%{_includedir}/postproc \
165         --with-x
166
167 %{__make}
168
169 %install
170 rm -rf $RPM_BUILD_ROOT
171
172 %{__make} install \
173         DESTDIR=$RPM_BUILD_ROOT
174
175 install -D avilib/avilib.h $RPM_BUILD_ROOT%{_includedir}/avilib.h
176
177 # duplicate
178 rm -rf $RPM_BUILD_ROOT%{_docdir}/transcode
179
180 %clean
181 rm -rf $RPM_BUILD_ROOT
182
183 %files
184 %defattr(644,root,root,755)
185 %doc README ChangeLog docs/README* docs/*.txt docs/html
186 %attr(755,root,root) %{_bindir}/*
187 # TODO: split it into subpackages export-*, import-* and filter-*
188 %dir %{_libdir}/%{name}
189 %attr(755,root,root) %{_libdir}/%{name}/*.so*
190 %attr(755,root,root) %{_libdir}/%{name}/*.awk
191 %{_libdir}/%{name}/*.la
192 %{_libdir}/%{name}/*.conf
193 %{_libdir}/%{name}/*.cfg
194 %{_mandir}/man1/*
195
196 %files avilib
197 %defattr(644,root,root,755)
198 %doc avilib/README.avilib
199 %{_includedir}/avilib.h
This page took 0.042 seconds and 4 git commands to generate.