]> git.pld-linux.org Git - packages/transcode.git/blob - transcode.spec
- up to 1.0.6
[packages/transcode.git] / transcode.spec
1 # TODO:
2 # - split plugins into subpackages. (how? splitting criteria? perhaps by external deps, not by functionality (import/export/..?)
3 # - disable building of libraries which exist in system (libdv?,libmpeg2 etc.)
4 # - cmov test is broken, ignores --enable-cmov-extension and tries to read /proc/cpuinfo
5 # - pvm3 needs recompiled with -fPIC, then it can be used here
6 # - --enable-xio requires some libs from http://loci.cs.utk.edu/
7 # - rm Makefiles from htmldir
8 #
9 # Conditional build:
10 %bcond_without  avifile         # disable avifile module
11 %bcond_without  gtk                     # disable GTK+ dependent stuff
12 %bcond_without  im                      # disable imagemagick module
13 %bcond_without  libmpeg2        # disable libmpeg2 support
14 %bcond_without  libmpeg3        # disable libmpeg3 support
15 %bcond_without  lzo                     # disable lzo support
16 %bcond_without  mjpeg           # disable mjpegtools support
17 %bcond_without  quicktime       # disable libquicktime support
18 %bcond_without  sdl                     # disable SDL support
19 %bcond_with     jpegmmx         # jpeg-mmx
20 %bcond_with     pvm3            # pvm3
21
22 # no jpeg-mmx there (doesn't compile)
23 %ifnarch i586 i686 athlon
24 %undefine       with_jpegmmx
25 %endif
26 # pvm3 needs recompiled with -fPIC
27 %ifarch %{x8664} alpha
28 %undefine       with_pvm3
29 %endif
30 #
31 Summary:        Video stream converter
32 Summary(pl.UTF-8):      Konwerter strumieni video
33 Name:           transcode
34 Version:        1.0.6
35 Release:        1
36 License:        GPL
37 Group:          Applications
38 Source0:        http://fromani.exit1.org/%{name}-%{version}.tar.bz2
39 # Source0-md5:  7c3a341b0e4540e34ef50c66b0ab751d
40 Patch0:         %{name}-bigdir.patch
41 Patch1:         %{name}-libx86_64.patch
42 Patch2:         %{name}-mm_accel.patch
43 Patch3:         %{name}-ImageMagick.patch
44 Patch4:         %{name}-ffmpeg.patch
45 URL:            http://www.transcoding.org/
46 %{?with_im:BuildRequires:       ImageMagick-devel >= 6.4.1-2}
47 %{?with_sdl:BuildRequires:      SDL-devel >= 1.1.6}
48 BuildRequires:  a52dec-libs-devel
49 BuildRequires:  autoconf
50 BuildRequires:  automake >= 1.3
51 %{?with_avifile:BuildRequires:  avifile-devel > 3:0.7.43-1}
52 BuildRequires:  ffmpeg-devel >= 0.4.9-0.pre1
53 BuildRequires:  freetype-devel >= 2.1.2
54 %{?with_gtk:BuildRequires:      gtk+-devel}
55 %{?with_jpegmmx:BuildRequires:  jpeg-mmx}
56 BuildRequires:  lame-libs-devel >= 3.89
57 BuildRequires:  libdv-devel >= 0.104-3
58 BuildRequires:  libdvdread-devel
59 BuildRequires:  libfame-devel >= 0.9.1
60 BuildRequires:  libjpeg-devel
61 %{?with_libmpeg3:BuildRequires: libmpeg3-devel}
62 BuildRequires:  libogg-devel
63 BuildRequires:  libpng-devel
64 %{?with_quicktime:BuildRequires:        libquicktime-devel}
65 BuildRequires:  libstdc++-devel
66 BuildRequires:  libtheora-devel
67 BuildRequires:  libtool >= 2:1.5
68 BuildRequires:  libvorbis-devel
69 BuildRequires:  libxml2-devel
70 %{?with_lzo:BuildRequires:      lzo-devel >= 2.0}
71 %{?with_mjpeg:BuildRequires:    mjpegtools-devel}
72 %{?with_libmpeg2:BuildRequires: mpeg2dec-devel >= 0.4.0b}
73 %ifarch %{ix86}
74 BuildRequires:  nasm >= 0.98.34
75 %endif
76 BuildRequires:  pkgconfig
77 %{?with_pvm3:BuildRequires:     pvm-devel}
78 BuildRequires:  xorg-lib-libXaw-devel
79 BuildRequires:  xorg-lib-libXpm-devel
80 BuildRequires:  xvid-devel
81 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
82
83 %define         specflags       -fomit-frame-pointer
84
85 %description
86 Linux Video Stream Processing Tool.
87
88 %description -l pl.UTF-8
89 Linuksowe narzędzie do obróbki strumieni video.
90
91 %package avilib
92 Summary:        library to handle avi files from transcode
93 Summary(pl.UTF-8):      biblioteka do obróbki plików avi pochodząca z transcode
94 Group:          Development/Libraries
95
96 %description avilib
97 Avilib is part of transcode made accessible for other programs that
98 require it. So far I know of one such program - ogmtools.
99
100 %description avilib -l pl.UTF-8
101 Avifile jest częścią programu transcode udostępnioną dla innych
102 programów, które jej wymagają. Jak na razie znam jeden taki program -
103 ogmtools.
104
105 %prep
106 %setup -q
107 %patch0 -p0
108 %patch1 -p0
109 %patch2 -p1
110 %patch3 -p1
111 %patch4 -p1
112
113 %build
114 %{__libtoolize}
115 %{__aclocal}
116 %{__autoconf}
117 %{__autoheader}
118 %{__automake}
119 # ac_cv_* to avoid detection of libdivxdecore as divx4linux (leading to errors)
120 # or divx4linux itself (make bcond_with if you want it)
121 %configure \
122         ac_cv_header_decore_h=no \
123         ac_cv_header_encore2_h=no \
124 %ifarch ppc
125         --enable-altivec \
126 %endif
127 %ifarch %{ix86} %{x8664}
128         --enable-mmx \
129         --enable-3dnow \
130         --enable-sse \
131         --enable-sse2 \
132 %endif
133 %ifarch %{ix86}
134 %ifarch i386 i486 i586 \
135         --disable-cmov-extension \
136 %else
137         --enable-cmov-extension \
138 %endif
139 %endif
140         --disable-bktr \
141         --disable-bsdav \
142         --disable-sunau \
143         --enable-a52 \
144         --enable-a52-default-decoder \
145         --enable-freetype2 \
146         --%{!?with_gtk:dis}%{?with_gtk:en}able-gtk \
147         --enable-ibp \
148         --enable-iconv \
149         --%{!?with_im:dis}%{?with_im:en}able-imagemagick \
150         --enable-lame \
151         --enable-libavcodec \
152         --enable-libdv \
153         --enable-libdvdread \
154         --enable-libfame \
155         --enable-libjpeg \
156         --%{!?with_libmpeg2:dis}%{?with_libmpeg2:en}able-libmpeg2 \
157         --%{!?with_libmpeg3:dis}%{?with_libmpeg3:en}able-libmpeg3 \
158         --enable-libpostproc \
159         --%{!?with_quicktime:dis}%{?with_quicktime:en}able-libquicktime \
160         --enable-libxml2 \
161         --%{!?with_lzo:dis}%{?with_lzo:en}able-lzo \
162         --with-lzo-includes=%{_includedir}/lzo \
163         --%{!?with_mjpeg:dis}%{?with_mjpeg:en}able-mjpegtools \
164         --enable-netstream \
165         --enable-ogg \
166         --enable-oss \
167         --enable-sdl \
168         --enable-statbuffer \
169         --enable-theora \
170         --enable-v4l \
171         --enable-vorbis \
172         --disable-xio \
173         --%{!?with_avifile:dis}%{?with_avifile:en}able-avifile \
174         --%{!?with_jpegmmx:dis}%{?with_jpegmmx:en}able-libjpegmmx \
175         --%{!?with_pvm3:dis}%{?with_pvm3:en}able-pvm3 \
176         --with-libpostproc-includes=%{_includedir}/postproc \
177         --with-x
178
179 %{__make}
180
181 %install
182 rm -rf $RPM_BUILD_ROOT
183
184 %{__make} install \
185         DESTDIR=$RPM_BUILD_ROOT
186
187 install -D avilib/avilib.h $RPM_BUILD_ROOT%{_includedir}/avilib.h
188
189 # duplicate
190 rm -rf $RPM_BUILD_ROOT%{_docdir}/transcode
191
192 %clean
193 rm -rf $RPM_BUILD_ROOT
194
195 %files
196 %defattr(644,root,root,755)
197 %doc README ChangeLog docs/README* docs/*.txt docs/html
198 %attr(755,root,root) %{_bindir}/*
199 # TODO: split it into subpackages export-*, import-* and filter-*
200 %dir %{_libdir}/%{name}
201 %attr(755,root,root) %{_libdir}/%{name}/*.so*
202 %attr(755,root,root) %{_libdir}/%{name}/*.awk
203 %{_libdir}/%{name}/*.la
204 %{_libdir}/%{name}/*.conf
205 %{_libdir}/%{name}/*.cfg
206 %{_mandir}/man1/*
207
208 %files avilib
209 %defattr(644,root,root,755)
210 %doc avilib/README.avilib
211 %{_includedir}/avilib.h
This page took 0.041278 seconds and 4 git commands to generate.