]> git.pld-linux.org Git - packages/transcode.git/blob - transcode.spec
- merged 1.0.2 from DEVEL; previous version AC-branched
[packages/transcode.git] / transcode.spec
1 # TODO:
2 # - split plugins into subpackages. (how? splitting criteria? perhaps by external deps, not by functionality (import/export/..?)
3 # - disable building of libraries which exist in system (libdv?,libmpeg2 etc.)
4 # - cmov test is broken, ignores --enable-cmov-extension and tries to read /proc/cpuinfo
5 # - pvm3 needs recompiled with -fPIC, then it can be used here
6 #
7 # Conditional build:
8 %bcond_without  gtk             # disable GTK+ dependent stuff
9 %bcond_without  avifile         # disable avifile module
10 %bcond_without  sdl             # disable SDL support
11 %bcond_without  im              # disable imagemagick module
12 %bcond_without  libmpeg3        # disable libmpeg3 support
13 %bcond_without  quicktime       # build with quicktime4linux support
14 %bcond_with     jpegmmx         # jpeg-mmx
15 %bcond_with     pvm3            # pvm3
16
17 # no jpeg-mmx there (doesn't compile)
18 %ifnarch i586 i686 athlon
19 %undefine       with_jpegmmx
20 %endif
21 # pvm3 needs recompiled with -fPIC
22 %ifarch %{x8664} alpha
23 %undefine       with_pvm3
24 %endif
25 #
26 Summary:        Video stream converter
27 Summary(pl):    Konwerter strumieni video
28 Name:           transcode
29 Version:        1.0.2
30 Release:        1
31 License:        GPL
32 Group:          Applications
33 Source0:        http://www.jakemsr.com/transcode/%{name}-%{version}.tar.gz
34 # Source0-md5:  e353c0ab7e927a8672528e05a9ae960b
35 URL:            http://www.transcoding.org/
36 %{?with_im:BuildRequires:       ImageMagick-devel >= 5.4.3}
37 %{?with_sdl:BuildRequires:      SDL-devel >= 1.1.6}
38 BuildRequires:  XFree86-devel
39 BuildRequires:  a52dec-libs-devel
40 BuildRequires:  autoconf
41 BuildRequires:  automake >= 1.3
42 %{?with_avifile:BuildRequires:  avifile-devel > 3:0.7.43-1}
43 BuildRequires:  ffmpeg-devel >= 0.4.9-0.pre1
44 BuildRequires:  freetype-devel >= 2.1.2
45 BuildRequires:  glib-devel >= 0.99.7
46 %{?with_gtk:BuildRequires:      gtk+-devel}
47 %{?with_jpegmmx:BuildRequires:  jpeg-mmx}
48 BuildRequires:  lame-libs-devel >= 3.89
49 BuildRequires:  libdv-devel >= 0.103
50 BuildRequires:  libdvdread-devel
51 BuildRequires:  libfame-devel
52 BuildRequires:  libjpeg-devel
53 %{?with_libmpeg3:BuildRequires: libmpeg3-devel}
54 BuildRequires:  libogg-devel
55 BuildRequires:  libtheora-devel
56 BuildRequires:  libtool >= 2:1.5
57 BuildRequires:  libvorbis-devel
58 BuildRequires:  libquicktime-devel
59 BuildRequires:  libxml2-devel
60 BuildRequires:  lzo-devel
61 BuildRequires:  mjpegtools-devel
62 BuildRequires:  mpeg2dec-devel >= 0.4.0b
63 %ifarch %{ix86}
64 BuildRequires:  nasm >= 0.98.34
65 %endif
66 %{?with_pvm3:BuildRequires:     pvm-devel}
67 #%{?with_quicktime:BuildRequires:       quicktime4linux-devel >= 1.5.5}
68 BuildRequires:  xvid-devel
69 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
70
71 %define         specflags       -fomit-frame-pointer
72
73 %description
74 Linux Video Stream Processing Tool.
75
76 %description -l pl
77 Linuksowe narzêdzie do obróbki strumieni video.
78
79 %package avilib
80 Summary:        library to handle avi files from transcode
81 Summary(pl):    biblioteka do obróbki plików avi pochodz±ca z transcode
82 Group:          Development/Libraries
83
84 %description avilib
85 Avilib is part of transcode made accessible for other programs that
86 require it. So far I know of one such program - ogmtools.
87
88 %description avilib -l pl
89 Avifile jest czê¶ci± programu transcode udostêpnion± dla innych
90 programów, które jej wymagaj±. Jak na razie znam jeden taki program -
91 ogmtools.
92
93 %prep
94 %setup -q
95
96 %build
97 %if 0
98 %{__libtoolize}
99 %{__aclocal}
100 %{__autoconf}
101 %{__autoheader}
102 %{__automake}
103 %endif
104 # ac_cv_* to avoid detection of libdivxdecore as divx4linux (leading to errors)
105 # or divx4linux itself (make bcond_with if you want it)
106 %configure \
107         ac_cv_header_decore_h=no \
108         ac_cv_header_encore2_h=no \
109 %ifarch ppc
110         --disable-altivec \
111 %endif
112 %ifarch %{ix86} %{x8664}
113         --enable-mmx \
114         --enable-3dnow \
115         --enable-sse \
116         --enable-sse2 \
117 %endif
118 %ifarch %{ix86}
119 %ifarch i386 i486 i586 \
120         --disable-cmov-extension \
121 %else
122         --enable-cmov-extension \
123 %endif
124 %endif
125         --disable-bktr \
126         --disable-bsdav \
127         --disable-sunau \
128         --enable-a52 \
129         --enable-a52-default-decoder \
130         --enable-freetype2 \
131         --enable-gtk \
132         --enable-ibp \
133         --enable-iconv \
134         --enable-imagemagick \
135         --enable-lame \
136         --enable-libavcodec \
137         --enable-libdv \
138         --enable-libdvdread \
139         --enable-libfame \
140         --enable-libjpeg \
141         --enable-libmpeg2 \
142         --enable-libmpeg3 \
143         --enable-libpostproc \
144         --enable-libquicktime \
145         --enable-libxml2 \
146         --enable-lzo \
147         --enable-mjpegtools \
148         --enable-netstream \
149         --enable-ogg \
150         --enable-oss \
151         --enable-sdl \
152         --enable-statbuffer \
153         --enable-theora \
154         --enable-v4l \
155         --enable-vorbis \
156         --enable-xio \
157         --%{!?with_avifile:dis}%{?with_avifile:en}able-avifile \
158         --%{!?with_jpegmmx:dis}%{?with_jpegmmx:en}able-libjpegmmx \
159         --%{!?with_pvm3:dis}%{?with_pvm3:en}able-pvm3 \
160         --with-libpostproc-includes=%{_includedir}/postproc \
161         --with-x
162
163 %{__make}
164
165 %install
166 rm -rf $RPM_BUILD_ROOT
167
168 %{__make} install \
169         DESTDIR=$RPM_BUILD_ROOT
170
171 install -D avilib/avilib.h $RPM_BUILD_ROOT%{_includedir}/avilib.h
172
173 # duplicate
174 rm -rf $RPM_BUILD_ROOT%{_docdir}/transcode
175
176 %clean
177 rm -rf $RPM_BUILD_ROOT
178
179 %files
180 %defattr(644,root,root,755)
181 %doc README ChangeLog docs/README* docs/*.txt docs/html
182 %attr(755,root,root) %{_bindir}/*
183 # TODO: split it into subpackages export-*, import-* and filter-*
184 %dir %{_libdir}/%{name}
185 %attr(755,root,root) %{_libdir}/%{name}/*.so*
186 %attr(755,root,root) %{_libdir}/%{name}/*.awk
187 %{_libdir}/%{name}/*.la
188 %{_libdir}/%{name}/*.conf
189 %{_libdir}/%{name}/*.cfg
190 %{_mandir}/man1/*
191
192 %files avilib
193 %defattr(644,root,root,755)
194 %doc avilib/README.avilib
195 %{_includedir}/avilib.h
This page took 0.076262 seconds and 3 git commands to generate.