]> git.pld-linux.org Git - packages/transcode.git/blob - transcode.spec
0ed675527c9647cbdb6d36dcd512c63070649c4e
[packages/transcode.git] / transcode.spec
1 # TODO:
2 # - split plugins into subpackages. (how? splitting criteria? perhaps by external deps, not by functionality (import/export/..?)
3 # - disable building of libraries which exist in system (libdv?,libmpeg2 etc.)
4 # - cmov test is broken, ignores --enable-cmov-extension and tries to read /proc/cpuinfo
5 # - pvm3 needs recompiled with -fPIC, then it can be used here
6 # - --enable-xio requires some libs from http://loci.cs.utk.edu/
7 # - rm Makefiles from htmldir
8 #
9 # Conditional build:
10 %bcond_without  avifile         # disable avifile module
11 %bcond_without  im                      # disable imagemagick module
12 %bcond_without  libmpeg2        # disable libmpeg2 support
13 %bcond_without  libmpeg3        # disable libmpeg3 support
14 %bcond_without  lzo                     # disable lzo support
15 %bcond_without  mjpeg           # disable mjpegtools support
16 %bcond_without  quicktime       # disable libquicktime support
17 %bcond_without  sdl                     # disable SDL support
18 %bcond_with     jpegmmx         # jpeg-mmx
19 %bcond_with     pvm3            # pvm3
20
21 # no jpeg-mmx there (doesn't compile)
22 %ifnarch i586 i686 athlon
23 %undefine       with_jpegmmx
24 %endif
25 # pvm3 needs recompiled with -fPIC
26 %ifarch %{x8664} alpha
27 %undefine       with_pvm3
28 %endif
29 #
30 Summary:        Video stream converter
31 Summary(pl.UTF-8):      Konwerter strumieni video
32 Name:           transcode
33 Version:        1.0.6
34 Release:        3
35 License:        GPL
36 Group:          Applications
37 Source0:        http://fromani.exit1.org/%{name}-%{version}.tar.bz2
38 # Source0-md5:  7c3a341b0e4540e34ef50c66b0ab751d
39 Patch0:         %{name}-bigdir.patch
40 Patch1:         %{name}-libx86_64.patch
41 Patch2:         %{name}-mm_accel.patch
42 Patch3:         %{name}-ImageMagick.patch
43 Patch4:         %{name}-ffmpeg.patch
44 URL:            http://www.transcoding.org/
45 %{?with_im:BuildRequires:       ImageMagick-devel >= 6.4.1-2}
46 %{?with_sdl:BuildRequires:      SDL-devel >= 1.1.6}
47 BuildRequires:  a52dec-libs-devel
48 BuildRequires:  autoconf
49 BuildRequires:  automake >= 1.3
50 %{?with_avifile:BuildRequires:  avifile-devel > 3:0.7.43-1}
51 BuildRequires:  ffmpeg-devel >= 0.4.9-0.pre1
52 BuildRequires:  freetype-devel >= 2.1.2
53 %{?with_jpegmmx:BuildRequires:  jpeg-mmx}
54 BuildRequires:  lame-libs-devel >= 3.89
55 BuildRequires:  libdv-devel >= 0.104-3
56 BuildRequires:  libdvdread-devel
57 BuildRequires:  libfame-devel >= 0.9.1
58 BuildRequires:  libjpeg-devel
59 %{?with_libmpeg3:BuildRequires: libmpeg3-devel}
60 BuildRequires:  libogg-devel
61 BuildRequires:  libpng-devel
62 %{?with_quicktime:BuildRequires:        libquicktime-devel}
63 BuildRequires:  libstdc++-devel
64 BuildRequires:  libtheora-devel
65 BuildRequires:  libtool >= 2:1.5
66 BuildRequires:  libvorbis-devel
67 BuildRequires:  libxml2-devel
68 %{?with_lzo:BuildRequires:      lzo-devel >= 2.0}
69 %{?with_mjpeg:BuildRequires:    mjpegtools-devel}
70 %{?with_libmpeg2:BuildRequires: mpeg2dec-devel >= 0.4.0b}
71 %ifarch %{ix86}
72 BuildRequires:  nasm >= 0.98.34
73 %endif
74 BuildRequires:  pkgconfig
75 %{?with_pvm3:BuildRequires:     pvm-devel}
76 BuildRequires:  xorg-lib-libXaw-devel
77 BuildRequires:  xorg-lib-libXpm-devel
78 BuildRequires:  xvid-devel
79 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
80
81 %define         specflags       -fomit-frame-pointer
82
83 %description
84 Linux Video Stream Processing Tool.
85
86 %description -l pl.UTF-8
87 Linuksowe narzędzie do obróbki strumieni video.
88
89 %package avilib
90 Summary:        library to handle avi files from transcode
91 Summary(pl.UTF-8):      biblioteka do obróbki plików avi pochodząca z transcode
92 Group:          Development/Libraries
93
94 %description avilib
95 Avilib is part of transcode made accessible for other programs that
96 require it. So far I know of one such program - ogmtools.
97
98 %description avilib -l pl.UTF-8
99 Avifile jest częścią programu transcode udostępnioną dla innych
100 programów, które jej wymagają. Jak na razie znam jeden taki program -
101 ogmtools.
102
103 %prep
104 %setup -q
105 %patch0 -p0
106 %patch1 -p0
107 %patch2 -p1
108 %patch3 -p1
109 %patch4 -p1
110
111 %build
112 %{__libtoolize}
113 %{__aclocal}
114 %{__autoconf}
115 %{__autoheader}
116 %{__automake}
117 # ac_cv_* to avoid detection of libdivxdecore as divx4linux (leading to errors)
118 # or divx4linux itself (make bcond_with if you want it)
119 %configure \
120         ac_cv_header_decore_h=no \
121         ac_cv_header_encore2_h=no \
122 %ifarch ppc
123         --enable-altivec \
124 %endif
125 %ifarch %{ix86} %{x8664}
126         --enable-mmx \
127         --enable-3dnow \
128         --enable-sse \
129         --enable-sse2 \
130 %endif
131 %ifarch %{ix86}
132 %ifarch i386 i486 i586 \
133         --disable-cmov-extension \
134 %else
135         --enable-cmov-extension \
136 %endif
137 %endif
138         --disable-bktr \
139         --disable-bsdav \
140         --disable-sunau \
141         --enable-a52 \
142         --enable-a52-default-decoder \
143         --enable-freetype2 \
144         --enable-ibp \
145         --enable-iconv \
146         --%{!?with_im:dis}%{?with_im:en}able-imagemagick \
147         --enable-lame \
148         --enable-libavcodec \
149         --enable-libdv \
150         --enable-libdvdread \
151         --enable-libfame \
152         --enable-libjpeg \
153         --%{!?with_libmpeg2:dis}%{?with_libmpeg2:en}able-libmpeg2 \
154         --%{!?with_libmpeg3:dis}%{?with_libmpeg3:en}able-libmpeg3 \
155         --enable-libpostproc \
156         --%{!?with_quicktime:dis}%{?with_quicktime:en}able-libquicktime \
157         --enable-libxml2 \
158         --%{!?with_lzo:dis}%{?with_lzo:en}able-lzo \
159         --with-lzo-includes=%{_includedir}/lzo \
160         --%{!?with_mjpeg:dis}%{?with_mjpeg:en}able-mjpegtools \
161         --enable-netstream \
162         --enable-ogg \
163         --enable-oss \
164         --enable-sdl \
165         --enable-statbuffer \
166         --enable-theora \
167         --enable-v4l \
168         --enable-vorbis \
169         --disable-xio \
170         --%{!?with_avifile:dis}%{?with_avifile:en}able-avifile \
171         --%{!?with_jpegmmx:dis}%{?with_jpegmmx:en}able-libjpegmmx \
172         --%{!?with_pvm3:dis}%{?with_pvm3:en}able-pvm3 \
173         --with-libpostproc-includes=%{_includedir}/postproc \
174         --with-x
175
176 %{__make}
177
178 %install
179 rm -rf $RPM_BUILD_ROOT
180
181 %{__make} install \
182         DESTDIR=$RPM_BUILD_ROOT
183
184 install -D avilib/avilib.h $RPM_BUILD_ROOT%{_includedir}/avilib.h
185
186 # duplicate
187 rm -rf $RPM_BUILD_ROOT%{_docdir}/transcode
188
189 %clean
190 rm -rf $RPM_BUILD_ROOT
191
192 %files
193 %defattr(644,root,root,755)
194 %doc README ChangeLog docs/README* docs/*.txt docs/html
195 %attr(755,root,root) %{_bindir}/*
196 # TODO: split it into subpackages export-*, import-* and filter-*
197 %dir %{_libdir}/%{name}
198 %attr(755,root,root) %{_libdir}/%{name}/*.so*
199 %attr(755,root,root) %{_libdir}/%{name}/*.awk
200 %{_libdir}/%{name}/*.la
201 %{_libdir}/%{name}/*.conf
202 %{_libdir}/%{name}/*.cfg
203 %{_mandir}/man1/*
204
205 %files avilib
206 %defattr(644,root,root,755)
207 %doc avilib/README.avilib
208 %{_includedir}/avilib.h
This page took 0.036348 seconds and 2 git commands to generate.