]> git.pld-linux.org Git - SPECS.git/blob - trac-plugin-timingandestimation.spec
SPECS updated Wed 28 Jul 14:48:01 CEST 2021
[SPECS.git] / trac-plugin-timingandestimation.spec
1 %define         trac_ver        0.12
2 %define         plugin          timingandestimation
3 Summary:        Trac plugin to track hours spent on tickets
4 Name:           trac-plugin-timingandestimation
5 Version:        1.0.6
6 Release:        0.2
7 License:        BSD-like
8 Group:          Applications/WWW
9 Source0:        http://trac-hacks.org/changeset/latest/timingandestimationplugin/branches/trac0.12?old_path=/&filename=timingandestimationplugin/branches/trac0.12&format=zip
10 # Source0-md5:  d2ed4beba5e99d1758e7e9c57cb74f5f
11 URL:            http://trac-hacks.org/wiki/TimingAndEstimationPlugin
12 BuildRequires:  python-devel
13 BuildRequires:  unzip
14 Requires:       python >= 1:2.4
15 Requires:       trac >= %{trac_ver}
16 BuildArch:      noarch
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19 %description
20 The goal of this plugin is to help keep trac of hours worked on
21 tickets.
22
23 %prep
24 %setup -qc
25
26 %build
27 cd %{plugin}plugin/branches/trac%{trac_ver}
28 %{__python} setup.py build
29 %{__python} setup.py egg_info
30
31 ver=$(awk '$1 == "Version:" {print $2}' *.egg-info/PKG-INFO)
32 test "$ver" = %{version}
33
34 %install
35 rm -rf $RPM_BUILD_ROOT
36 cd %{plugin}plugin/branches/trac%{trac_ver}
37 %{__python} setup.py install \
38         --single-version-externally-managed \
39         --optimize=2 \
40         --root=$RPM_BUILD_ROOT
41
42 %py_postclean
43
44 %clean
45 rm -rf $RPM_BUILD_ROOT
46
47 %post
48 trac-enableplugin "trac%{plugin}.*"
49
50 if [ "$1" = "1" ]; then
51         %banner -e %{name} <<-'EOF'
52 TODO
53 EOF
54 fi
55
56 %files
57 %defattr(644,root,root,755)
58 %{py_sitescriptdir}/%{plugin}plugin
59 %{py_sitescriptdir}/*-*.egg-info
This page took 0.379543 seconds and 3 git commands to generate.