]> git.pld-linux.org Git - SPECS.git/blob - trac-plugin-paste.spec
SPECS updated Wed 28 Jul 14:48:01 CEST 2021
[SPECS.git] / trac-plugin-paste.spec
1 %define         trac_ver        0.11
2 %define         plugin          paste
3 Summary:        Pastebin Plugin for Trac
4 Name:           trac-plugin-%{plugin}
5 Version:        0.2.2
6 Release:        0.1
7 License:        BSD-like / GPL / ...
8 Group:          Applications/WWW
9 Source0:        http://trac-hacks.org/changeset/latest/tracpasteplugin?old_path=/&format=zip#/trac%{plugin}plugin.zip
10 # Source0-md5:  a3245291029bc84636eaa2de9e6dc877
11 URL:            http://trac-hacks.org/wiki/TracPastePlugin
12 BuildRequires:  python-devel
13 Requires:       python-pygments > 0.5
14 Requires:       trac >= %{trac_ver}
15 BuildArch:      noarch
16 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17
18 %description
19
20 %prep
21 %setup -q -n trac%{plugin}plugin
22 mv %{trac_ver}/* .
23
24 %build
25 %{__python} setup.py build
26 %{__python} setup.py egg_info
27
28 ver=$(awk '$1 == "Version:" {print $2}' *.egg-info/PKG-INFO)
29 test "$ver" = %{version}
30
31 %install
32 rm -rf $RPM_BUILD_ROOT
33 %{__python} setup.py install \
34         --single-version-externally-managed \
35         --optimize 2 \
36         --root=$RPM_BUILD_ROOT
37
38 %py_postclean
39
40 %clean
41 rm -rf $RPM_BUILD_ROOT
42
43 %post
44 # XXX: try to figure out from .egg-info / __init__py at build time
45 #trac-enableplugin "%{plugin}.Trac%{plugin}Module"
46
47 %files
48 %defattr(644,root,root,755)
49 %{py_sitescriptdir}/trac%{plugin}
50 %{py_sitescriptdir}/*-*.egg-info
This page took 1.095618 seconds and 3 git commands to generate.