]> git.pld-linux.org Git - SPECS.git/blob - trac-plugin-graphviz.spec
SPECS updated Wed 28 Jul 14:48:01 CEST 2021
[SPECS.git] / trac-plugin-graphviz.spec
1 %define         trac_ver        0.12
2 %define         plugin          graphviz
3 Summary:        Graphviz Plugin for Trac
4 Name:           trac-plugin-%{plugin}
5 Version:        0.7.5
6 Release:        1
7 License:        BSD-like
8 Group:          Applications/WWW
9 Source0:        http://trac-hacks.org/changeset/latest/graphvizplugin/0.11-%{version}?old_path=/&format=zip#/%{plugin}-%{version}.zip
10 # Source0-md5:  5ffbcb4743c85c0a34eff98918c814b6
11 URL:            http://trac-hacks.org/wiki/GraphvizPlugin
12 BuildRequires:  python-devel
13 BuildRequires:  python-modules
14 BuildRequires:  python-setuptools
15 BuildRequires:  rpm-pythonprov
16 BuildRequires:  rpmbuild(macros) >= 1.553
17 BuildRequires:  unzip
18 Requires:       graphviz
19 Requires:       trac >= %{trac_ver}
20 BuildArch:      noarch
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 The graphviz wiki processor is a plugin for Trac that allows the the
25 dynamic generation of diagrams by the various graphviz programs. The
26 text of a wiki page can contain the source text for graphviz and the
27 web browser will show the resulting image.
28
29 %prep
30 %setup -qc
31 mv %{plugin}plugin/0.11-%{version}/* .
32
33 %build
34 %{__python} setup.py build
35 %{__python} setup.py egg_info
36
37 ver=$(awk '$1 == "Version:" {print $2}' *.egg-info/PKG-INFO)
38 test "$ver" = %{version}
39
40 %install
41 rm -rf $RPM_BUILD_ROOT
42 %{__python} setup.py install \
43         --single-version-externally-managed \
44         --optimize 2 \
45         --root=$RPM_BUILD_ROOT
46
47 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
48 cp -a examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
49
50 %py_postclean
51
52 %clean
53 rm -rf $RPM_BUILD_ROOT
54
55 %post
56 trac-enableplugin "graphviz.*"
57
58 %files
59 %defattr(644,root,root,755)
60 %doc COPYING README.txt ReleaseNotes.txt
61 %{py_sitescriptdir}/%{plugin}
62 %{py_sitescriptdir}/*-*.egg-info
63 %{_examplesdir}/%{name}-%{version}
This page took 0.278966 seconds and 3 git commands to generate.