]> git.pld-linux.org Git - SPECS.git/blob - trac-plugin-autocompleteusers.spec
SPECS updated Tue 30 Apr 15:06:09 CEST 2024
[SPECS.git] / trac-plugin-autocompleteusers.spec
1 %define         trac_ver        0.11
2 %define         plugin          autocompleteusers
3 %define         revision        10429
4 Summary:        Autocomplete user fields (assigned to and CC) on tickets
5 Name:           trac-plugin-%{plugin}
6 Version:        0.4.1
7 Release:        0.r%{revision}
8 License:        BSD
9 Group:          Applications/WWW
10 # Source0Download:      http://trac-hacks.org/changeset/latest/autocompleteusersplugin?old_path=/&filename=autocompleteusersplugin&format=zip
11 Source0:        %{plugin}plugin-r%{revision}.zip
12 # Source0-md5:  8c28c08ec2314721c82ffc61358476c7
13 URL:            http://trac-hacks.org/wiki/AutocompleteUsersPlugin
14 BuildRequires:  python-devel
15 BuildRequires:  python-setuptools
16 BuildRequires:  rpm-pythonprov
17 Requires:       trac >= %{trac_ver}
18 BuildArch:      noarch
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %description
22 The AutocompleteUsersPlugin allows AJAX completion of users for the
23 owner and CC fields on new and existing tickets. Currently, all the
24 known users are autocompleted though this could be restricted to those
25 that have the ticket owner permission. A /users URL is served which
26 presents the user data in a format suitable to the javascript
27 autocompleter.
28
29 %prep
30 %setup -q -n %{plugin}plugin
31
32 %build
33 cd %{trac_ver}
34 %{__python} setup.py build
35 %{__python} setup.py egg_info
36
37 ver=$(awk '$1 == "Version:" {print $2}' *.egg-info/PKG-INFO)
38 test "$ver" = %{version}
39
40 %install
41 rm -rf $RPM_BUILD_ROOT
42 cd %{trac_ver}
43 %{__python} setup.py install \
44         --single-version-externally-managed \
45         --optimize 2 \
46         --root=$RPM_BUILD_ROOT
47
48 %py_postclean
49
50 %clean
51 rm -rf $RPM_BUILD_ROOT
52
53 %post
54 if [ "$1" = "1" ]; then
55         %banner -e %{name} <<-'EOF'
56         To enable the %{plugin} plugin, add to conf/trac.ini:
57
58         [components]
59         %{plugin}.* = enabled
60 EOF
61 fi
62
63 %files
64 %defattr(644,root,root,755)
65 %{py_sitescriptdir}/%{plugin}
66 %{py_sitescriptdir}/AutocompleteUsers-*.egg-info
This page took 0.237344 seconds and 3 git commands to generate.