]> git.pld-linux.org Git - packages/tor.git/blob - tor.spec
- 0.2.0.34
[packages/tor.git] / tor.spec
1 Summary:        Anonymizing overlay network for TCP (The onion router)
2 Summary(pl.UTF-8):      Sieć nakładkowa dla TCP zapewniająca anonimowość (router cebulowy)
3 Name:           tor
4 Version:        0.2.0.34
5 Release:        1
6 License:        BSD-like
7 Group:          Networking/Daemons
8 Source0:        http://www.torproject.org/dist/%{name}-%{version}.tar.gz
9 # Source0-md5:  f20011be23d5a76988233df12c346f41
10 Source1:        %{name}.logrotate
11 Source2:        %{name}.init
12 Source3:        %{name}.sysconfig
13 URL:            http://www.torproject.org/
14 # http://archives.seul.org/or/announce/Feb-2009/msg00000.html
15 #BuildRequires: security(0.2.0.34)
16 BuildRequires:  libevent-devel >= 1.1
17 BuildRequires:  openssl-devel >= 0.9.6
18 BuildRequires:  rpm-build >= 4.0
19 BuildRequires:  rpmbuild(macros) >= 1.268
20 Requires(post,preun):   /sbin/chkconfig
21 Requires(pre):  /bin/id
22 Requires(pre):  /usr/bin/getgid
23 Requires(pre):  /usr/sbin/groupadd
24 Requires(pre):  /usr/sbin/useradd
25 Requires:       rc-scripts
26 Provides:       group(tor)
27 Provides:       user(tor)
28 Conflicts:      logrotate < 3.7-4
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %description
32 Tor is a connection-based low-latency anonymous communication system.
33
34 This package provides the "tor" program, which serves as both a client
35 and a relay node. Scripts will automatically create a "tor" user and
36 group, and set tor up to run as a daemon when the system is rebooted.
37
38 Applications connect to the local Tor proxy using the SOCKS protocol.
39 The local proxy chooses a path through a set of relays, in which each
40 relay knows its predecessor and successor, but no others. Traffic
41 flowing down the circuit is unwrapped by a symmetric key at each
42 relay, which reveals the downstream relay.
43
44 Warnings: Tor does no protocol cleaning. That means there is a danger
45 that application protocols and associated programs can be induced to
46 reveal information about the initiator. Tor depends on Privoxy and
47 similar protocol cleaners to solve this problem. This is alpha code,
48 and is even more likely than released code to have anonymity-spoiling
49 bugs. The present network is very small -- this further reduces the
50 strength of the anonymity provided. Tor is not presently suitable for
51 high-stakes anonymity.
52
53 %description -l pl.UTF-8
54 Tor to oparty na połączeniach system anonimowej komunikacji o
55 małych opóźnieniach.
56
57 Ten pakiet dostarcza program "tor", służący zarówno jako klient,
58 jak i węzeł przekaźnikowy. Skrypty automatycznie tworzą
59 użytkownika i grupę "tor" i konfigurują tora do działania jako
60 demon po uruchomieniu systemu.
61
62 Aplikacje łączą się z lokalnym proxy Tor przy użyciu protokołu
63 SOCKS. Lokalne proxy wybiera ścieżkę poprzez zbiór przekaźników,
64 z których każdy zna swojego poprzednika i następnika, ale żadnego
65 więcej. Ruch przychodzący jest rozpakowywany przy użyciu klucza
66 symetrycznego na każdym przekaźniku, który odsłania kolejny
67 przekaźnik.
68
69 Uwaga: Tor nie oczyszcza protokołów. Oznacza to, że istnieje
70 niebezpieczeństwo, że protokoły aplikacji i powiązane programy
71 mogą odkryć informacje o pochodzeniu. Tor polega na Privoxy i
72 podobnych oczyszczaczach protokołów w celu rozwiązania tego
73 problemu. To jest kod alpha, więc może mieć więcej błędów
74 psujących anonimowość niż kod wydany. Obecna sieć jest bardzo
75 mała - co w dalszym stopniu ogranicza zapewnianą anonimowość. Tor
76 aktualnie nie nadaje się do zadań wymagających anonimowości na
77 wysoką stawkę.
78
79 %prep
80 %setup -q
81
82 %build
83 %configure
84 %{__make}
85
86 %install
87 rm -rf $RPM_BUILD_ROOT
88
89 %{__make} install \
90         DESTDIR=$RPM_BUILD_ROOT
91
92 mv $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/torrc{.sample,}
93 install -D %{SOURCE1} $RPM_BUILD_ROOT/etc/logrotate.d/%{name}
94 install -D %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
95 install -D %{SOURCE3} $RPM_BUILD_ROOT/etc/sysconfig/%{name}
96
97 install -d $RPM_BUILD_ROOT/var/lib/%{name}
98 install -d $RPM_BUILD_ROOT/var/run/%{name}
99 install -d $RPM_BUILD_ROOT/var/log/{,archive/}%{name}
100
101 %clean
102 rm -rf $RPM_BUILD_ROOT
103
104 %pre
105 %groupadd -g 156 tor
106 %useradd  -u 156 -r -d /var/lib/tor -s /bin/false -c "Tor" -g tor tor
107
108 %post
109 /sbin/chkconfig --add %{name}
110 %service %{name} restart
111
112 %preun
113 if [ "$1" = "0" ]; then
114         %service -q %{name} stop
115         /sbin/chkconfig --del %{name}
116 fi
117
118 %postun
119 if [ "$1" = "0" ]; then
120         %userremove  tor
121         %groupremove tor
122 fi
123
124 %files
125 %defattr(644,root,root,755)
126 %doc AUTHORS INSTALL LICENSE README ChangeLog doc/HACKING doc/TODO
127 %attr(755,root,root) %{_bindir}/*
128 %{_mandir}/man?/*
129 %attr(754,root,root) /etc/rc.d/init.d/%{name}
130 %dir %attr(750,root,tor) %{_sysconfdir}/%{name}
131 %attr(640,root,tor)  %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/*
132 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/*
133 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/%{name}
134 %dir %attr(750,root,tor) /var/lib/%{name}
135 %dir %attr(750,root,tor) /var/run/%{name}
136 %dir %attr(750,root,tor) /var/log/%{name}
137 %dir %attr(750,root,tor) /var/log/archive/%{name}
This page took 0.041295 seconds and 3 git commands to generate.