]> git.pld-linux.org Git - packages/tor.git/blob - tor.spec
- fix chkconfig, rc-scripts deps
[packages/tor.git] / tor.spec
1 Summary:        Anonymizing overlay network for TCP (The onion router)
2 Summary(pl):    Sieæ nak³adkowa dla TCP zapewniaj±ca anonimowo¶æ (router cebulowy)
3 Name:           tor
4 Version:        0.1.0.17
5 Release:        2
6 License:        BSD-like
7 Group:          Networking/Daemons
8 Source0:        http://tor.eff.org/dist/%{name}-%{version}.tar.gz
9 # Source0-md5:  83c4afe29fa82473afcb2ec7e17771b9
10 Source1:        %{name}.logrotate
11 Source2:        %{name}.init
12 Source3:        %{name}.sysconfig
13 URL:            http://tor.eff.org/
14 BuildRequires:  libevent-devel
15 BuildRequires:  openssl-devel >= 0.9.6
16 BuildRequires:  rpm-build >= 4.0
17 BuildRequires:  rpmbuild(macros) >= 1.268
18 Requires(post,preun):   /sbin/chkconfig
19 Requires(pre):  /bin/id
20 Requires(pre):  /usr/bin/getgid
21 Requires(pre):  /usr/sbin/groupadd
22 Requires(pre):  /usr/sbin/useradd
23 Requires:       rc-scripts
24 Provides:       group(tor)
25 Provides:       user(tor)
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 Tor is a connection-based low-latency anonymous communication system.
30
31 This package provides the "tor" program, which serves as both a client
32 and a relay node. Scripts will automatically create a "tor" user and
33 group, and set tor up to run as a daemon when the system is rebooted.
34
35 Applications connect to the local Tor proxy using the SOCKS protocol.
36 The local proxy chooses a path through a set of relays, in which each
37 relay knows its predecessor and successor, but no others. Traffic
38 flowing down the circuit is unwrapped by a symmetric key at each
39 relay, which reveals the downstream relay.
40
41 Warnings: Tor does no protocol cleaning. That means there is a danger
42 that application protocols and associated programs can be induced to
43 reveal information about the initiator. Tor depends on Privoxy and
44 similar protocol cleaners to solve this problem. This is alpha code,
45 and is even more likely than released code to have anonymity-spoiling
46 bugs. The present network is very small -- this further reduces the
47 strength of the anonymity provided. Tor is not presently suitable for
48 high-stakes anonymity.
49
50 %description -l pl
51 Tor to oparty na po³±czeniach system anonimowej komunikacji o ma³ych
52 opó¼nieniach.
53
54 Ten pakiet dostarcza program "tor", s³u¿±cy zarówno jako klient, jak i
55 wêze³ przeka¼nikowy. Skrypty automatycznie tworz± u¿ytkownika i grupê
56 "tor" i konfiguruj± tora do dzia³ania jako demon po uruchomieniu
57 systemu.
58
59 Aplikacje ³±cz± siê z lokalnym proxy Tor przy u¿yciu protoko³u SOCKS.
60 Lokalne proxy wybiera ¶cie¿kê poprzez zbiór przeka¼ników, z których
61 ka¿dy zna swojego poprzednika i nastêpnika, ale ¿adnego wiêcej. Ruch
62 przychodz±cy jest rozpakowywany przy u¿yciu klucza symetrycznego na
63 ka¿dym przeka¼niku, który ods³ania kolejny przeka¼nik.
64
65 Uwaga: Tor nie oczyszcza protoko³ów. Oznacza to, ¿e istnieje
66 niebezpieczeñstwo, ¿e protoko³y aplikacji i powi±zane programy mog±
67 odkryæ informacje o pochodzeniu. Tor polega na Privoxy i podobnych
68 oczyszczaczach protoko³ów w celu rozwi±zania tego problemu. To jest
69 kod alpha, wiêc mo¿e mieæ wiêcej b³êdów psuj±cych anonimowo¶æ ni¿ kod
70 wydany. Obecna sieæ jest bardzo ma³a - co w dalszym stopniu ogranicza
71 zapewnian± anonimowo¶æ. Tor aktualnie nie nadaje siê do zadañ
72 wymagaj±cych anonimowo¶ci na wysok± stawkê.
73
74 %prep
75 %setup -q
76
77 %build
78 %configure
79 %{__make}
80
81 %install
82 rm -rf $RPM_BUILD_ROOT
83
84 %{__make} install \
85         DESTDIR=$RPM_BUILD_ROOT
86
87 mv $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/torrc{.sample,}
88 install -D %{SOURCE1} $RPM_BUILD_ROOT/etc/logrotate.d/%{name}
89 install -D %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
90 install -D %{SOURCE3} $RPM_BUILD_ROOT/etc/sysconfig/%{name}
91
92 install -d $RPM_BUILD_ROOT/var/lib/%{name}
93 install -d $RPM_BUILD_ROOT/var/run/%{name}
94 install -d $RPM_BUILD_ROOT/var/log/{,archiv/}%{name}
95
96 %clean
97 rm -rf $RPM_BUILD_ROOT
98
99 %pre
100 %groupadd -g 156 tor
101 %useradd  -u 156 -r -d /var/lib/tor -s /bin/false -c "Tor" -g tor tor
102
103 %post
104 /sbin/chkconfig --add %{name}
105 %service %{name} restart
106
107 %preun
108 if [ "$1" = "0" ]; then
109         %service -q %{name} stop
110         /sbin/chkconfig --del %{name}
111 fi
112
113 %postun
114 if [ "$1" = "0" ]; then
115         %userremove  tor
116         %groupremove tor
117 fi
118
119 %files
120 %defattr(644,root,root,755)
121 %doc AUTHORS INSTALL LICENSE README ChangeLog doc/HACKING doc/TODO doc/FAQ
122 %attr(755,root,root) %{_bindir}/*
123 %{_mandir}/man?/*
124 %attr(754,root,root) /etc/rc.d/init.d/%{name}
125 %dir %attr(750,root,tor) %{_sysconfdir}/%{name}
126 %attr(640,root,tor)  %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/*
127 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/*
128 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/%{name}
129 %dir %attr(750,root,tor) /var/lib/%{name}
130 %dir %attr(750,root,tor) /var/run/%{name}
131 %dir %attr(750,root,tor) /var/log/%{name}
132 %dir %attr(750,root,tor) /var/log/archiv/%{name}
This page took 0.070429 seconds and 3 git commands to generate.