]> git.pld-linux.org Git - packages/tmux.git/blob - tmux.spec
- rpmcppflags
[packages/tmux.git] / tmux.spec
1 # TODO:
2 # - vim doesn't detect filetype
3 # - pass LDFLAGS (fix as-needed problem first)
4 Summary:        tmux is a terminal multiplexer
5 Summary(hu.UTF-8):      tmux egy terminál-sokszorozó
6 Name:           tmux
7 Version:        1.4
8 Release:        2
9 License:        BSD
10 Group:          Applications/Terminal
11 Source0:        http://dl.sourceforge.net/tmux/%{name}-%{version}.tar.gz
12 # Source0-md5:  0bfc7dd9a5bab192406167589c716a21
13 Source1:        %{name}-filedetect.vim
14 Patch0:         %{name}-makefile.patch
15 BuildRequires:  libevent-devel
16 BuildRequires:  ncurses-devel
17 URL:            http://tmux.sourceforge.net/
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %description
21 tmux is a terminal multiplexer: it enables a number of terminals (or
22 windows), each running a separate program, to be created, accessed,
23 and controlled from a single screen. tmux may be detached from a
24 screen and continue running in the background, then later reattached.
25
26 %description -l hu.UTF-8
27 tmux egy terminál-sokszorozó: terminálok (vagy ablakok) sokaságát
28 hozhatd létre, mindegyikben egy külön program fut, létrehozhatsz,
29 csatlakozhatsz és irányíthatod egyetlen képernyőről. tmux
30 lecsatlakozhat a képernyőről és folytathatja a futását a háttérben, és
31 később újracsatlakozhatsz.
32
33 %package -n vim-syntax-tmux
34 Summary:        Vim syntax file to tmux config files
35 Summary(hu.UTF-8):      Vim syntax fájl a tmux konfigurációs fájljához
36 Group:          Applications/Editors/Vim
37
38 %description -n vim-syntax-tmux
39 Vim syntax file to tmux config files.
40
41 %description -n vim-syntax-tmux -l hu.UTF-8
42 Vim syntax fájl a tmux konfigurációs fájljához.
43
44 %package -n bash-completion-tmux
45 Summary:        Bash completion for tmux
46 Group:          Applications/Shell
47 Requires:       bash-completion
48
49 %description -n bash-completion-tmux
50 This package provides bash-completion for tmux.
51
52 %prep
53 %setup -q
54 %patch0 -p1
55
56 %build
57 ./configure
58 CFLAGS="%{rpmcppflags} %{rpmcflags} -I/usr/include/ncursesw" %{__make} \
59         CC="%{__cc}" \
60         PREFIX=%{_prefix}
61
62 %install
63 rm -rf $RPM_BUILD_ROOT
64
65 %{__make} install \
66         DESTDIR=$RPM_BUILD_ROOT \
67         PREFIX=%{_prefix}
68
69 install -d $RPM_BUILD_ROOT%{_datadir}/vim/vimfiles/{ftdetect,syntax}
70 install %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/vim/vimfiles/ftdetect/tmux.vim
71 install examples/tmux.vim $RPM_BUILD_ROOT%{_datadir}/vim/vimfiles/syntax
72 install -d $RPM_BUILD_ROOT%{_datadir}/bash-completion
73 install examples/bash_completion_tmux.sh $RPM_BUILD_ROOT%{_datadir}/bash-completion/%{name}
74 install -d $RPM_BUILD_ROOT%{_sysconfdir}/bash_completion.d
75 ln -s ../../%{_datadir}/bash-completion/%{name} $RPM_BUILD_ROOT%{_sysconfdir}/bash_completion.d
76
77 %clean
78 rm -rf $RPM_BUILD_ROOT
79
80 %files
81 %defattr(644,root,root,755)
82 %doc CHANGES FAQ NOTES TODO examples/*.conf
83 %attr(755,root,root) %{_bindir}/*
84 %{_mandir}/man1/tmux*
85
86 %files -n vim-syntax-tmux
87 %defattr(644,root,root,755)
88 %{_datadir}/vim/vimfiles/ftdetect/tmux.vim
89 %{_datadir}/vim/vimfiles/syntax/tmux.vim
90
91 %files -n bash-completion-tmux
92 %defattr(644,root,root,755)
93 %{_sysconfdir}/bash_completion.d/%{name}
94 %{_datadir}/bash-completion/%{name}
This page took 0.032576 seconds and 4 git commands to generate.