]> git.pld-linux.org Git - packages/tla.git/blob - tla.spec
- unify ftp.gnu.org urls
[packages/tla.git] / tla.spec
1 Summary:        tla arch - revision control system
2 Summary(pl.UTF-8):      tla arch - system kontroli wersji
3 Name:           tla
4 Version:        1.3.5
5 Release:        2
6 Epoch:          1
7 License:        GPL v2
8 Group:          Development/Version Control
9 Source0:        http://ftp.gnu.org/gnu/gnu-arch/%{name}-%{version}.tar.gz
10 # Source0-md5:  db31ee89bc4788eef1eba1cee6c176ef
11 Patch0:         %{name}-neon.patch
12 URL:            http://www.gnu.org/software/gnu-arch/
13 BuildRequires:  findutils
14 BuildRequires:  libtool
15 BuildRequires:  neon-devel
16 Requires:       diffutils
17 Requires:       patch
18 Requires:       tar
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %description
22 tla arch is a revision control system: a program that lets programmers
23 archive a history of changes made to the software they maintain and
24 that, more importantly, helps programmers to coordinate, synchronize,
25 and combine multiple lines of development for a single project.
26
27 arch version tla is a C version of the reference arch concepts.
28
29 %description -l pl.UTF-8
30 tla arch jest systemem kontroli wersji - programem, który pozwala
31 programistom archiwizować historię zmian wykonanych w rozwijanym przez
32 nich oprogramowaniu oraz, co ważniejsze, pomaga programistom
33 koordynować, synchronizować i łączyć wiele linii kodu podczas rozwoju
34 projektu.
35
36 arch w wersji tla to wersja w C wzorcowych idei arch.
37
38 %prep
39 %setup -q
40 %patch0 -p1
41
42 rm -rf src/libneon src/expat
43
44 %build
45 cd src
46 mkdir =build
47 cd =build
48
49 CFLAGS="%{rpmcflags}"
50 CXXFLAGS="%{rpmcflags}"
51 FFLAGS="%{rpmcflags}"
52 export CFLAGS CXXFLAGS FFLAGS
53
54 # custom configure script
55 ../configure \
56         --destdir=$RPM_BUILD_ROOT \
57         --prefix=%{_prefix} \
58         --with-cc="%{__cc}" \
59         --with-ssh-type=openssh
60 %{__make} -j1
61
62 # ok, I tested already
63 %{__make} -j1 test
64
65 %install
66 rm -rf $RPM_BUILD_ROOT
67
68 %{__make} -j1 -C src/=build install
69
70 rm -rf html
71 cp -a src/docs-tla html
72 find html -type f ! -name "*.html" -exec rm -rf "{}" ";"
73 find html -type d -name ".arch-ids" -exec rm -rf "{}" ";" || :
74 find html -type d -name "{arch}" -exec rm -rf "{}" ";" || :
75
76 rm -rf $RPM_BUILD_ROOT%{_libdir}
77 rm -rf $RPM_BUILD_ROOT%{_prefix}/src
78
79 %clean
80 rm -rf $RPM_BUILD_ROOT
81
82 %files
83 %defattr(644,root,root,755)
84 %doc html
85 %attr(755,root,root) %{_bindir}/*
This page took 0.031615 seconds and 3 git commands to generate.