]> git.pld-linux.org Git - SPECS.git/blob - tix.spec
SPECS updated Wed 28 Jul 14:48:01 CEST 2021
[SPECS.git] / tix.spec
1 %define         major 8.4
2 Summary:        Many metawidgets (such as notepads) for Tk
3 Summary(de.UTF-8):      Zahlreiche Metawidgets (wie etwa Notepads) für Tk
4 Summary(fr.UTF-8):      Nombreux meta-widgets (comme les bloc-notes) pour Tk
5 Summary(pl.UTF-8):      Wiele widgetów (takich jak notepad) dla Tk
6 Summary(tr.UTF-8):      Tk için ek arayüz elemanları (not defterleri v.b.)
7 Name:           tix
8 Version:        %{major}.3
9 Release:        3
10 Epoch:          1
11 License:        BSD
12 Group:          Development/Languages/Tcl
13 Source0:        http://download.sourceforge.net/tix/Tix%{version}-src.tar.gz
14 # Source0-md5:  2b8bf4b10a852264678182652f477e59
15 Patch0:         %{name}-scriptpaths.patch
16 Patch2:         fixInterpResult.patch
17 URL:            http://tix.sourceforge.net/
18 BuildRequires:  autoconf
19 BuildRequires:  automake
20 BuildRequires:  groff
21 BuildRequires:  tcl-devel >= 8.4.6
22 BuildRequires:  tk-devel >= 8.4.6
23 BuildRequires:  which
24 BuildRequires:  xorg-lib-libX11-devel
25 Requires:       tcl >= 8.4.6
26 Requires:       tk >= 8.4.6
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %define         groff_version   %(rpm -q --qf %{V} groff)
30
31 %description
32 Tix is a add on for the Tk widget set which adds many complex widgets
33 which are built from Tk building blocks. The extra widgets include
34 combo box, file selection, notebooks, paned windows, spin controls,
35 and hierarchical list boxes.
36
37 %description -l de.UTF-8
38 Tix ist ein Zusatzprogramm für den 'Tk widget set', das viele komplexe
39 Widgets hinzufügt, die aus Tk-Bausteinen bestehen, z.B.
40 Kombinationsfelder, Dateiauswahl, Notizblöcke, überlappende Fenster,
41 Drehknöpfe und hierarchische Listenfelder.
42
43 %description -l fr.UTF-8
44 tix est un ajout à l'ensemble des widgets Tk qui apporte de nombreux
45 widgets complexes construits à partir des briques de Tk. Les widgets
46 supplémentaires incluent les combo box, la sélection de fichiers, les
47 notebooks, les fenêtres « paned » et les listes hiérarchisées.
48
49 %description -l pl.UTF-8
50 Tix jest dodatkiem dla Tk, zawierającym wiele interesujących widgetów.
51
52 %description -l tr.UTF-8
53 Tix, Tk yapıtaşları kullanılarak oluşturulmuş bir çok karmaşık arayüz
54 elemanı bulunduran bir eklemedir. Bu yeni elemanlar arasında çoktan
55 seçmeli kutular, dosya seçim kutuları, not defterleri, çok kısımlı
56 pencereler yer almaktadır.
57
58 %package devel
59 Summary:        Tix development documentation
60 Summary(pl.UTF-8):      Dokumentacja programisty do rozszerzenia Tix
61 Group:          Development/Languages/Tcl
62 Requires:       %{name} = %{epoch}:%{version}-%{release}
63
64 %description devel
65 Tix development documentation.
66
67 %description devel -l pl.UTF-8
68 Dokumentacja programisty do rozszerzenia Tix.
69
70 %package demo
71 Summary:        Tix - demo programs
72 Summary(pl.UTF-8):      Tix - programy demostracjne
73 Group:          Development/Languages/Tcl
74 Requires:       %{name} = %{epoch}:%{version}-%{release}
75
76 %description demo
77 Tix - demo programs.
78
79 %description demo -l pl.UTF-8
80 Tix - programy demostracjne.
81
82 %prep
83 %setup -q -n Tix%{version}
84 %patch0 -p1
85 %patch2 -p1
86
87 %build
88 %{__aclocal} -I tclconfig
89 %{__autoconf}
90 %configure \
91         --enable-shared
92
93 %{__make}
94
95 %install
96 rm -rf $RPM_BUILD_ROOT
97 install -d $RPM_BUILD_ROOT{%{_mandir},%{_examplesdir}/%{name}-%{version}}
98
99 %{__make} install \
100         DESTDIR=$RPM_BUILD_ROOT
101
102 install -d $RPM_BUILD_ROOT%{_mandir}/mann
103 install man/*.n $RPM_BUILD_ROOT%{_mandir}/mann
104
105 install -d $RPM_BUILD_ROOT%{_datadir}/groff/%{groff_version}/tmac
106 sed -i -e 's/.so man.macros/.mso tix.tmac/g' $RPM_BUILD_ROOT%{_mandir}/mann/*.n
107 install man/man.macros $RPM_BUILD_ROOT%{_datadir}/groff/%{groff_version}/tmac/tix.tmac
108
109 cp -af demos $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
110
111 rm -f $RPM_BUILD_ROOT%{_libdir}/Tix%{major}/bitmaps/mktransgif.tcl*
112
113 %clean
114 rm -rf $RPM_BUILD_ROOT
115
116 %files
117 %defattr(644,root,root,755)
118 %doc ABOUT.html ChangeLog README.txt index.html license.terms docs/FAQ.html
119 %dir %{_libdir}/Tix%{version}
120 %attr(755,root,root) %{_libdir}/Tix%{version}/libTix%{version}.so
121 %{_libdir}/Tix%{version}/*.tcl
122 %{_libdir}/Tix%{version}/bitmaps
123 %{_libdir}/Tix%{version}/pref
124
125 %files devel
126 %defattr(644,root,root,755)
127 %doc docs/*.txt docs/{pdf,tix-book}
128 %{_mandir}/mann/TixIntro.n*
129 %{_mandir}/mann/compound.n*
130 %{_mandir}/mann/pixmap.n*
131 %{_mandir}/mann/tix*.n*
132 %{_datadir}/groff/%{groff_version}/tmac/tix.tmac
133
134 %files demo
135 %defattr(644,root,root,755)
136 %dir %{_examplesdir}/%{name}-%{version}
137 %dir %{_examplesdir}/%{name}-%{version}/demos
138 %{_examplesdir}/%{name}-%{version}/demos/Mk*.tcl
139 %{_examplesdir}/%{name}-%{version}/demos/bitmaps
140 %{_examplesdir}/%{name}-%{version}/demos/samples
141 %{_examplesdir}/%{name}-%{version}/demos/tclIndex
142 %{_examplesdir}/%{name}-%{version}/demos/widget
143 %attr(755,root,root) %{_examplesdir}/%{name}-%{version}/demos/tixwidgets.tcl
This page took 0.447302 seconds and 3 git commands to generate.