]> git.pld-linux.org Git - packages/tinyxml.git/blob - tinyxml.spec
- rebuild to fix broken filedigests
[packages/tinyxml.git] / tinyxml.spec
1 %define         file_version    %(echo %{version} | tr . _)
2 Summary:        A simple, small, C++ XML parser
3 Summary(pl.UTF-8):      Prosty, mały, napisany w C++ parser XML
4 Name:           tinyxml
5 Version:        2.6.2
6 Release:        5
7 License:        zlib
8 Group:          Libraries
9 Source0:        http://downloads.sourceforge.net/tinyxml/%{name}_%{file_version}.tar.gz
10 # Source0-md5:  c1b864c96804a10526540c664ade67f0
11 Patch0:         %{name}-flags.patch
12 Patch1:         enforce-use-stl.patch
13 URL:            http://www.grinninglizard.com/tinyxml/
14 BuildRequires:  libstdc++-devel
15 BuildRequires:  libtool
16 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17
18 %description
19 TinyXML is a simple, small, C++ XML parser that can be easily
20 integrating into other programs.
21
22 %description -l pl.UTF-8
23 TinyXML to prosty, mały, napisany w C++ parser XML, który może być w
24 łatwy sposób integrowany z innymi programami.
25
26 %package devel
27 Summary:        Header files for tinyxml library
28 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki tinyxml
29 Group:          Development/Libraries
30 Requires:       %{name} = %{version}-%{release}
31 Requires:       libstdc++-devel
32
33 %description devel
34 Header files for tinyxml library.
35
36 %description devel -l pl.UTF-8
37 Pliki nagłówkowe biblioteki tinyxml.
38
39 %package static
40 Summary:        Static tinyxml library
41 Summary(pl.UTF-8):      Statyczna biblioteka tinyxml
42 Group:          Development/Libraries
43 Requires:       %{name}-devel = %{version}-%{release}
44
45 %description static
46 Static tinyxml library.
47
48 %description static -l pl.UTF-8
49 Statyczna biblioteka tinyxml.
50
51 %prep
52 %setup -q -n %{name}
53 %patch0 -p1
54 %patch1 -p1
55
56 %build
57 %{__make} \
58         CXX="%{__cxx}" \
59         LD="%{__cxx}" \
60         OPTFLAGS="%{rpmcppflags} %{rpmcxxflags} -DTIXML_USE_STL" \
61         LDFLAGS="%{rpmldflags}"
62
63 # Not really designed to be built as lib
64 for i in tinyxml.cpp tinystr.cpp tinyxmlerror.cpp tinyxmlparser.cpp; do
65         libtool --tag=CXX --mode=compile \
66                 %{__cxx} %{rpmcppflags} %{rpmcxxflags} -DTIXML_USE_STL -o $i.lo -c $i
67 done
68 libtool --tag=CXX --mode=link \
69         %{__cxx} %{rpmcxxflags} %{rpmldflags} \
70         -rpath %{_libdir} -version-info 0:0:0 \
71         -o libtinyxml.la *.cpp.lo
72
73 %install
74 rm -rf $RPM_BUILD_ROOT
75 install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir},%{_includedir}}
76
77 cp -a xmltest $RPM_BUILD_ROOT%{_bindir}
78 cp -a tiny*.h $RPM_BUILD_ROOT%{_includedir}
79 libtool --mode=install %{__install} libtinyxml.la $RPM_BUILD_ROOT%{_libdir}
80
81 %clean
82 rm -rf $RPM_BUILD_ROOT
83
84 %post   -p /sbin/ldconfig
85 %postun -p /sbin/ldconfig
86
87 %files
88 %defattr(644,root,root,755)
89 %doc changes.txt readme.txt
90 %attr(755,root,root) %{_bindir}/xmltest
91 %attr(755,root,root) %{_libdir}/libtinyxml.so.*.*.*
92 %attr(755,root,root) %ghost %{_libdir}/libtinyxml.so.0
93
94 %files devel
95 %defattr(644,root,root,755)
96 %attr(755,root,root) %{_libdir}/libtinyxml.so
97 %{_libdir}/libtinyxml.la
98 %{_includedir}/tinystr.h
99 %{_includedir}/tinyxml.h
100
101 %files static
102 %defattr(644,root,root,755)
103 %{_libdir}/libtinyxml.a
This page took 0.073249 seconds and 4 git commands to generate.