]> git.pld-linux.org Git - SPECS.git/blob - tifm.spec
SPECS updated Mon 29 Apr 22:05:02 CEST 2024
[SPECS.git] / tifm.spec
1 #
2 # Conditional build:
3 %bcond_without  dist_kernel     # allow non-distribution kernel
4 %bcond_with     verbose         # verbose build (V=1)
5
6 %define         _rel    0.1
7 %define         _module tifm
8 Summary:        Linux driver for TI FlashMedia xx12/xx21 storage controllers
9 Summary(pl.UTF-8):      Linuksowy sterownik dla kontrolerów pamięci TI FlashMedia xx12/xx21
10 Name:           %{_module}
11 Version:        0.8e
12 Release:        %{_rel}@%{_kernel_ver_str}
13 License:        GPL v2
14 Group:          Base/Kernel
15 Source0:        http://download.berlios.de/tifmxx/%{name}-%{version}.tar.bz2
16 # Source0-md5:  5a148e53eeaadde1d0e1284e367d563b
17 URL:            http://developer.berlios.de/projects/tifmxx
18 %{?with_dist_kernel:BuildRequires:      kernel-module-build >= 3:2.6.21}
19 BuildRequires:  rpmbuild(macros) >= 1.308
20 ExclusiveArch:  %{ix86}
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 This project is devoted to the development of the acceptable and free
25 source Linux driver for TI FlashMedia family of devices. These devices
26 are found in a vast majority of the modern laptops. Unfortunately, TI
27 refused to publish a complete datasheet for any of the FlashMedia
28 devices rendering them useless anywhere except MS Windows (not unlike
29 many other hardware vendors).
30
31 Windows drivers to the mentioned devices are available from nearly all
32 major computer vendors both for Win32 and Win64 platforms. They
33 support all the expected functionality: SM/xD cards, MMC, SD and SDIO,
34 MemoryStick and MSpro including security/DRM features.
35
36 %description -l pl.UTF-8
37 Ten projekt służy rozwojowi akceptowalnego i mającego wolne źródła
38 linuksowego sterownika dla urządzeń z rodziny TI FlashMedia.
39 Urządzenia te można znaleźć w większości współczesnych laptopów.
40 Niestety TI odmówił opublikowania pełnej specyfikacji jakiegokolwiek z
41 urządzeń FlashMedia czyniąc je bezużytecznymi poza MS Windows (w
42 przeciwieństwie do wielu innych producentów sprzętu).
43
44 Sterowniki windowsowe dla wspomnianych urządzeń są dostępne u prawie
45 każdego dużego dostawcy komputerów dla platform Win32 i Win64.
46 Obsługują całą oczekiwaną funkcjonalność: karty SM/xD, MMC, SD i SDIO,
47 MemoryStick i MSpro wraz z opcjami bezpieczeństwa/DRM.
48
49 # kernel subpackages.
50 %package -n kernel%{_alt_kernel}-misc-%{_module}
51 Summary:        Linux driver for TI FlashMedia xx12/xx21 storage controllers
52 Summary(pl.UTF-8):      Sterownik dla Linuksa do kontrolerów pamięci TI FlashMedia xx12/xx21
53 Release:        %{_rel}@%{_kernel_ver_str}
54 Group:          Base/Kernel
55 Requires(post,postun):  /sbin/depmod
56 %if %{with dist_kernel}
57 %requires_releq_kernel
58 Requires(postun):       %releq_kernel
59 %endif
60
61 %description -n kernel%{_alt_kernel}-misc-%{_module}
62 This package contains Linux driver for TI FlashMedia xx12/xx21 storage
63 controllers.
64
65 This project is devoted to the development of the acceptable and free
66 source Linux driver for TI FlashMedia family of devices. These devices
67 are found in a vast majority of the modern laptops. Unfortunately, TI
68 refused to publish a complete datasheet for any of the FlashMedia
69 devices rendering them useless anywhere except MS Windows (not unlike
70 many other hardware vendors).
71
72 Windows drivers to the mentioned devices are available from nearly all
73 major computer vendors both for Win32 and Win64 platforms. They
74 support all the expected functionality: SM/xD cards, MMC, SD and SDIO,
75 MemoryStick and MSpro including security/DRM features.
76
77 %description -n kernel%{_alt_kernel}-misc-%{_module} -l pl.UTF-8
78 Ten pakiet zawiera sterownik dla Linuksa do kontrolerów pamięci TI
79 FlashMedia xx12/xx21.
80
81 Ten projekt służy rozwojowi akceptowalnego i mającego wolne źródła
82 linuksowego sterownika dla urządzeń z rodziny TI FlashMedia.
83 Urządzenia te można znaleźć w większości współczesnych laptopów.
84 Niestety TI odmówił opublikowania pełnej specyfikacji jakiegokolwiek z
85 urządzeń FlashMedia czyniąc je bezużytecznymi poza MS Windows (w
86 przeciwieństwie do wielu innych producentów sprzętu).
87
88 Sterowniki windowsowe dla wspomnianych urządzeń są dostępne u prawie
89 każdego dużego dostawcy komputerów dla platform Win32 i Win64.
90 Obsługują całą oczekiwaną funkcjonalność: karty SM/xD, MMC, SD i SDIO,
91 MemoryStick i MSpro wraz z opcjami bezpieczeństwa/DRM.
92
93 %prep
94 %setup -q -c
95
96 %build
97 %build_kernel_modules -m %{_module}{_7xx1,_core,_sd}
98
99 %install
100 rm -rf $RPM_BUILD_ROOT
101 %install_kernel_modules  -s current -n %{_module} -m %{_module}{_7xx1,_core,_sd} -d misc
102
103 %clean
104 rm -rf $RPM_BUILD_ROOT
105
106 %post -n kernel%{_alt_kernel}-misc-%{_module}
107 %depmod %{_kernel_ver}
108
109 %postun -n kernel%{_alt_kernel}-misc-%{_module}
110 %depmod %{_kernel_ver}
111
112 %if %{with dist_kernel}
113 %files -n kernel%{_alt_kernel}-misc-%{_module}
114 %defattr(644,root,root,755)
115 /lib/modules/%{_kernel_ver}/misc/%{_module}*.ko*
116 %{_sysconfdir}/modprobe.d/%{_kernel_ver}/%{name}.conf
117 %endif
This page took 0.412076 seconds and 3 git commands to generate.