]> git.pld-linux.org Git - packages/tesseract.git/blob - tesseract.spec
bab92e357b4c54da5149941e7a2016e74e6365ba
[packages/tesseract.git] / tesseract.spec
1 # TODO:
2 # - tensorflow support
3 #
4 # Conditional build:
5 %bcond_without  openmp          # OpenMP support
6 %bcond_with     opencl          # OpenCL support
7 %bcond_without  static_libs     # static library
8
9 Summary:        Tesseract Open Source OCR Engine
10 Summary(pl.UTF-8):      Tesseract - silnik OCR o otwartych źródłach
11 Name:           tesseract
12 Version:        5.3.4
13 Release:        1
14 License:        Apache v2.0
15 Group:          Applications/Graphics
16 #Source0Download: https://github.com/tesseract-ocr/tesseract/releases
17 Source0:        https://github.com/tesseract-ocr/tesseract/archive/%{version}/%{name}-%{version}.tar.gz
18 # Source0-md5:  53de961804ccbcb83b73122f721d8f83
19 URL:            https://github.com/tesseract-ocr/
20 %{?with_opencl:BuildRequires:   OpenCL-devel}
21 BuildRequires:  asciidoc
22 BuildRequires:  autoconf >= 2.69
23 BuildRequires:  automake
24 BuildRequires:  cairo-devel
25 BuildRequires:  curl-devel
26 BuildRequires:  leptonlib-devel >= 1.74
27 BuildRequires:  libarchive-devel
28 %{?with_openmp:BuildRequires:   libgomp-devel}
29 BuildRequires:  libicu-devel >= 52.1
30 BuildRequires:  libstdc++-devel >= 6:7
31 BuildRequires:  libtiff-devel
32 BuildRequires:  libtool >= 2:2
33 BuildRequires:  libxslt-progs
34 BuildRequires:  pango-devel >= 1:1.38.0
35 BuildRequires:  rpmbuild(macros) >= 1.527
36 Requires:       leptonlib >= 1.74
37 Suggests:       tesseract-data >= 3
38 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
39
40 %description
41 A commercial quality OCR engine originally developed at HP between
42 1985 and 1995. In 1995, this engine was among the top 3 evaluated by
43 UNLV. It was open-sourced by HP and UNLV in 2005.
44
45 %description -l pl.UTF-8
46 Silnik OCR o komercyjnej jakości oryginalnie stworzony przez HP w
47 latach 1985-1995. W 1995 roku był jednym z 3 najlepszych wg UNLV.
48 Źródła zostały uwolnione przez HP i UNLV w 2005 roku.
49
50 %package training
51 Summary:        Tesseract training tools
52 Summary(pl.UTF-8):      Narzędzia treningowe Tesseracta
53 Group:          Applications/Graphics
54 Requires:       %{name} = %{version}-%{release}
55 Requires:       pango >= 1:1.38.0
56
57 %description training
58 This package contains the Tesseract training tools.
59
60 %description training -l pl.UTF-8
61 Ten pakiet zawiera programy do trenowania Tesseracta.
62
63 %package devel
64 Summary:        Header files for Tesseract libraries
65 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek Tesseracta
66 Group:          Development/Libraries
67 Requires:       %{name} = %{version}-%{release}
68 Requires:       curl-devel
69 Requires:       leptonlib-devel >= 1.74
70 Requires:       libarchive-devel
71 Requires:       libstdc++-devel >= 6:7
72
73 %description devel
74 This package contains the development header files necessary to
75 develop applications using Tesseract API.
76
77 %description devel -l pl.UTF-8
78 Ten pakiet zawiera pliki nagłówkowe potrzebne do tworzenia programów
79 wykorzystujących API Tesseracta.
80
81 %package static
82 Summary:        Static Tesseract libraries
83 Summary(pl.UTF-8):      Statyczne biblioteki Tesseracta
84 Group:          Development/Libraries
85 Requires:       %{name}-devel = %{version}-%{release}
86
87 %description static
88 Static Tesseract libraries.
89
90 %description static -l pl.UTF-8
91 Statyczne biblioteki Tesseracta.
92
93 %prep
94 %setup -q
95
96 %build
97 %{__libtoolize}
98 %{__aclocal}
99 %{__autoconf}
100 %{__autoheader}
101 %{__automake}
102 %configure \
103         %{?with_opencl:--enable-opencl} \
104         %{!?with_openmp:--disable-openmp} \
105         --disable-silent-rules \
106         %{__enable_disable static_libs static}
107 %{__make}
108 %{__make} training
109
110 %install
111 rm -rf $RPM_BUILD_ROOT
112 install -d $RPM_BUILD_ROOT%{_datadir}/tessdata/script
113
114 %{__make} install \
115         DESTDIR=$RPM_BUILD_ROOT
116
117 %{__make} training-install \
118         DESTDIR=$RPM_BUILD_ROOT
119
120 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libtesseract.la
121
122 %clean
123 rm -rf $RPM_BUILD_ROOT
124
125 %post   -p /sbin/ldconfig
126 %postun -p /sbin/ldconfig
127
128 %files
129 %defattr(644,root,root,755)
130 %doc AUTHORS ChangeLog README.md
131 %attr(755,root,root) %{_bindir}/tesseract
132 %attr(755,root,root) %{_libdir}/libtesseract.so.*.*.*
133 %attr(755,root,root) %ghost %{_libdir}/libtesseract.so.5
134 %dir %{_datadir}/tessdata
135 %{_datadir}/tessdata/configs
136 %dir %{_datadir}/tessdata/script
137 %{_datadir}/tessdata/tessconfigs
138 %{_datadir}/tessdata/pdf.ttf
139 %{_mandir}/man1/tesseract.1*
140
141 %files training
142 %defattr(644,root,root,755)
143 %attr(755,root,root) %{_bindir}/ambiguous_words
144 %attr(755,root,root) %{_bindir}/classifier_tester
145 %attr(755,root,root) %{_bindir}/cntraining
146 %attr(755,root,root) %{_bindir}/combine_lang_model
147 %attr(755,root,root) %{_bindir}/combine_tessdata
148 %attr(755,root,root) %{_bindir}/dawg2wordlist
149 %attr(755,root,root) %{_bindir}/lstmeval
150 %attr(755,root,root) %{_bindir}/lstmtraining
151 %attr(755,root,root) %{_bindir}/merge_unicharsets
152 %attr(755,root,root) %{_bindir}/mftraining
153 %attr(755,root,root) %{_bindir}/set_unicharset_properties
154 %attr(755,root,root) %{_bindir}/shapeclustering
155 %attr(755,root,root) %{_bindir}/text2image
156 %attr(755,root,root) %{_bindir}/unicharset_extractor
157 %attr(755,root,root) %{_bindir}/wordlist2dawg
158 %{_mandir}/man1/ambiguous_words.1*
159 %{_mandir}/man1/classifier_tester.1*
160 %{_mandir}/man1/cntraining.1*
161 %{_mandir}/man1/combine_lang_model.1*
162 %{_mandir}/man1/combine_tessdata.1*
163 %{_mandir}/man1/dawg2wordlist.1*
164 %{_mandir}/man1/lstmeval.1*
165 %{_mandir}/man1/lstmtraining.1*
166 %{_mandir}/man1/merge_unicharsets.1*
167 %{_mandir}/man1/mftraining.1*
168 %{_mandir}/man1/set_unicharset_properties.1*
169 %{_mandir}/man1/shapeclustering.1*
170 %{_mandir}/man1/text2image.1*
171 %{_mandir}/man1/unicharset_extractor.1*
172 %{_mandir}/man1/wordlist2dawg.1*
173
174 %files devel
175 %defattr(644,root,root,755)
176 %attr(755,root,root) %{_libdir}/libtesseract.so
177 %{_includedir}/%{name}
178 %{_pkgconfigdir}/tesseract.pc
179 %{_mandir}/man5/unicharambigs.5*
180 %{_mandir}/man5/unicharset.5*
181
182 %if %{with static_libs}
183 %files static
184 %defattr(644,root,root,755)
185 %{_libdir}/libtesseract.a
186 %endif
This page took 0.064828 seconds and 3 git commands to generate.