]> git.pld-linux.org Git - packages/tenshi.git/blob - tenshi.spec
- added chkconfig
[packages/tenshi.git] / tenshi.spec
1 Summary:        Log parsing and notification program
2 Summary(pl):    Program do analizy logów i powiadamiania
3 Name:           tenshi
4 Version:        0.3.2
5 Release:        0.5
6 License:        GPL
7 Group:          Applications/System
8 Source0:        http://dev.gentoo.org/~lcars/tenshi/%{name}-%{version}.tar.gz
9 Source1:        %{name}.init
10 Patch0:         %{name}-root.patch
11 URL:            http://www.gentoo.org/proj/en/infrastructure/tenshi/index.xml
12 Requires:       perl-base >= 1:5.6
13 Requires:       perl-modules >= 1:5.8.0
14 Obsoletes:      wasabi
15 BuildArch:      noarch
16 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17
18 %description
19 Tenshi is a log monitoring program, designed to watch one or more log
20 files for lines matching user defined regular expressions and report
21 on the matches. The regular expressions are assigned to queues which
22 have an alert interval and a list of mail recipients.
23
24 Queues can be set to send a notification as soon as there is a log
25 line assigned to it, or to send periodic reports.
26
27 Additionally, uninteresting fields in the log lines (such as PID
28 numbers) can be masked with the standard regular expression grouping
29 operators ( ). This allows cleaner and more readable reports. All
30 reports are separated by hostname and all messages are condensed when
31 possible.
32
33 %description -l pl
34 Tenshi to program do monitorowania logów zaprojektowany do ogl±dania
35 jednego lub wiêkszej liczby plików logów pod k±tem linii pasuj±cych do
36 zdefiniowanych przez u¿ytkownika wyra¿eñ regularnych i raportowania
37 tych dopasowañ. Wyra¿enia regularne s± przypisywane do kolejek
38 maj±cych czêstotliwo¶æ alarmowania i listê adresatów pocztowych.
39
40 Kolejki mog± byæ konfigurowane do wysy³ania powiadomieñ zaraz po
41 napotkaniu linii w logu lub wysy³ania regularnych raportów.
42
43 Dodatkowo nieciekawe pola z linii logów (takie jak numery procesów)
44 mog± byæ pokrywane standardowymi operatorami grupowania wyra¿eñ
45 regularnych ( ). Daje to bardziej przejrzyste i bardziej czytelne
46 raporty. Wszystkie raporty s± oddzielane nazw± hosta, a wszystkie
47 wiadomo¶ci s± tak skondensowane, jak to tylko mo¿liwe.
48
49 %prep
50 %setup -q
51 %patch0 -p1
52
53 %install
54 rm -rf $RPM_BUILD_ROOT
55 install -d $RPM_BUILD_ROOT{%{_mandir}/man8,/etc/rc.d/init.d}
56
57 %{__make} install \
58         DESTDIR=$RPM_BUILD_ROOT
59
60 install %{name}.8 $RPM_BUILD_ROOT%{_mandir}/man8
61 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
62
63 %clean
64 rm -rf $RPM_BUILD_ROOT
65
66 %post
67 /sbin/chkconfig --add %{name}
68 if [ -f /var/lock/subsys/%{name} ]; then
69         /etc/rc.d/init.d/%{name} restart >&2
70 else
71         echo "Run \"/etc/rc.d/init.d/%{name} start\" to start %{name} daemon."
72 fi
73
74 %preun
75 if [ "$1" = "0" ]; then
76         if [ -f /var/lock/subsys/%{name} ]; then
77                 /etc/rc.d/init.d/%{name} stop >&2
78         fi
79         /sbin/chkconfig --del %{name}
80 fi
81
82 %files
83 %defattr(644,root,root,755)
84 %doc README INSTALL CREDITS Changelog
85 %attr(755,root,root) %{_sbindir}/*
86 %attr(750,root,root) %dir %{_sysconfdir}/%{name}
87 %attr(640,root,root) %config(noreplace) %{_sysconfdir}/%{name}/%{name}.conf
88 %attr(754,root,root) /etc/rc.d/init.d/%{name}
89 %{_mandir}/man8/*
This page took 0.055577 seconds and 3 git commands to generate.