]> git.pld-linux.org Git - projects/template-specs.git/blob - template.spec
- sed understands \r, use it
[projects/template-specs.git] / template.spec
1 #
2 # Conditional build:
3 %bcond_with     tests           # build with tests
4 %bcond_without  tests           # build without tests
5 #
6 Summary:        -
7 Summary(pl):    -
8 Name:           template
9 Version:        _
10 Release:        0.1
11 License:        - (enter GPL/GPL v2/LGPL/BSD/BSD-like/other license name here)
12 #Vendor:                -
13 Group:          Applications
14 #Icon:          -
15 Source0:        %{name}-%{version}.tar.gz
16 # Source0-md5:  -
17 #Source1:       -
18 # Source1-md5:  -
19 #Patch0:                %{name}-DESTDIR.patch
20 URL:            -
21 %if %{with initscript}
22 BuildRequires:  rpmbuild(macros) >= 1.228
23 Requires(post,preun):   /sbin/chkconfig
24 %endif
25 #BuildRequires: -
26 #BuildRequires: autoconf
27 #BuildRequires: automake
28 #BuildRequires: intltool
29 #BuildRequires: libtool
30 #Requires(postun):      -
31 #Requires(pre,post):    -
32 #Requires(preun):       -
33 #Requires:      -
34 #Provides:      group(foo)
35 #Provides:      user(foo)
36 #Provides:      -
37 #Obsoletes:     -
38 #Conflicts:     -
39 #BuildArch:     noarch
40 #ExclusiveArch: %{ix86}
41 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
42
43 %description
44
45 %description -l pl
46
47 %package subpackage
48 Summary:        -
49 Summary(pl):    -
50 Group:          -
51
52 %description subpackage
53
54 %description subpackage -l pl
55
56 %package libs
57 Summary:        -
58 Summary(pl):    -
59 Group:          Libraries
60
61 %description libs
62
63 %description libs -l pl
64
65
66 %package devel
67 Summary:        Header files for ... library
68 Summary(pl):    Pliki nag³ówkowe biblioteki ...
69 Group:          Development/Libraries
70 #Requires:      %{name} = %{version}-%{release}
71
72 %description devel
73 This is the package containing the header files for ... library.
74
75 %description devel -l pl
76 Ten pakiet zawiera pliki nag³ówkowe biblioteki ....
77
78 %package static
79 Summary:        Static ... library
80 Summary(pl):    Statyczna biblioteka ...
81 Group:          Development/Libraries
82 Requires:       %{name}-devel = %{version}-%{release}
83
84 %description static
85 Static ... library.
86
87 %description static -l pl
88 Statyczna biblioteka ....
89
90 %prep
91 %setup -q
92 #%setup -q -c -T
93 #%setup -q -n %{name}
94 #%%setup -q -n %{name}-%{version}.orig -a 1
95 #%patch0 -p1
96
97 # undos the source
98 #find '(' -name '*.php' -o -name '*.inc' ')' -print0 | xargs -0 sed -i -e 's,\r$,,'
99
100 # remove CVS control files
101 #find -name CVS -print0 | xargs -0 rm -rf
102
103 %build
104 # if ac/am/* rebuilding is necessary, do it in this order and add
105 # appropriate BuildRequires
106 #%%{__intltoolize}
107 #%%{__gettextize}
108 #%%{__libtoolize}
109 #%%{__aclocal}
110 #%%{__autoconf}
111 #%%{__autoheader}
112 #%%{__automake}
113 #cp -f /usr/share/automake/config.sub .
114 %configure
115 %{__make}
116
117 #%{__make} \
118 #       CFLAGS="%{rpmcflags}" \
119 #       LDFLAGS="%{rpmldflags}"
120
121 %install
122 rm -rf $RPM_BUILD_ROOT
123 # create directories if necessary
124 #install -d $RPM_BUILD_ROOT
125 #install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
126
127 %{__make} install \
128         DESTDIR=$RPM_BUILD_ROOT
129
130 %clean
131 rm -rf $RPM_BUILD_ROOT
132
133 %pre
134
135 %post
136
137 %preun
138
139 %postun
140
141 %if %{with ldconfig}
142 %post   -p /sbin/ldconfig
143 %postun -p /sbin/ldconfig
144 %endif
145
146 %if %{with initscript}
147 %post init
148 /sbin/chkconfig --add %{name}
149 %service %{name} restart
150
151 %preun init
152 if [ "$1" = "0" ]; then
153         %service -q %{name} stop
154         /sbin/chkconfig --del %{name}
155 fi
156 %endif
157
158 %files
159 %defattr(644,root,root,755)
160 %doc AUTHORS CREDITS ChangeLog NEWS README THANKS TODO
161
162 %if 0
163 # if _sysconfdir != /etc:
164 #%%dir %{_sysconfdir}
165 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/*
166 %attr(755,root,root) %{_bindir}/*
167 %{_datadir}/%{name}
168 %endif
169
170 # initscript and its config
171 %if %{with initscript}
172 %attr(754,root,root) /etc/rc.d/init.d/%{name}
173 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/%{name}
174 %endif
175
176 #%{_examplesdir}/%{name}-%{version}
177
178 %if %{with subpackage}
179 %files subpackage
180 %defattr(644,root,root,755)
181 #%doc extras/*.gz
182 #%{_datadir}/%{name}-ext
183 %endif
This page took 0.053838 seconds and 4 git commands to generate.