]> git.pld-linux.org Git - projects/template-specs.git/blob - template.spec
- unneccessary quoting removed
[projects/template-specs.git] / template.spec
1 #
2 # Conditional build:
3 %bcond_with     tests           # build with tests
4 %bcond_without  tests           # build without tests
5 #
6 Summary:        -
7 Summary(pl):    -
8 Name:           template
9 Version:        _
10 Release:        0.1
11 #Epoch:         -
12 License:        - (enter GPL/GPL v2/LGPL/BSD/BSD-like/other license name here)
13 Group:          Applications
14 Source0:        %{name}-%{version}.tar.gz
15 # Source0-md5:  -
16 #Source1:       -
17 # Source1-md5:  -
18 #Patch0:                %{name}-DESTDIR.patch
19 URL:            -
20 %if %{with initscript}
21 BuildRequires:  rpmbuild(macros) >= 1.228
22 Requires(post,preun):   /sbin/chkconfig
23 %endif
24 #BuildRequires: -
25 #BuildRequires: autoconf
26 #BuildRequires: automake
27 #BuildRequires: intltool
28 #BuildRequires: libtool
29 #Requires(postun):      -
30 #Requires(pre,post):    -
31 #Requires(preun):       -
32 #Requires:      -
33 #Provides:      -
34 #Provides:      group(foo)
35 #Provides:      user(foo)
36 #Obsoletes:     -
37 #Conflicts:     -
38 #BuildArch:     noarch
39 #ExclusiveArch: %{ix86}
40 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
41
42 %description
43
44 %description -l pl
45
46 %package subpackage
47 Summary:        -
48 Summary(pl):    -
49 Group:          -
50
51 %description subpackage
52
53 %description subpackage -l pl
54
55 %package libs
56 Summary:        -
57 Summary(pl):    -
58 Group:          Libraries
59
60 %description libs
61
62 %description libs -l pl
63
64 %package devel
65 Summary:        Header files for ... library
66 Summary(pl):    Pliki nag³ówkowe biblioteki ...
67 Group:          Development/Libraries
68 # if base package contains shared library for which these headers are
69 #Requires:      %{name} = %{version}-%{release}
70 # if -libs package contains shared library for which these headers are
71 #Requires:      %{name}-libs = %{version}-%{release}
72
73 %description devel
74 Header files for ... library.
75
76 %description devel -l pl
77 Pliki nag³ówkowe biblioteki ....
78
79 %package static
80 Summary:        Static ... library
81 Summary(pl):    Statyczna biblioteka ...
82 Group:          Development/Libraries
83 Requires:       %{name}-devel = %{version}-%{release}
84
85 %description static
86 Static ... library.
87
88 %description static -l pl
89 Statyczna biblioteka ....
90
91 %prep
92 %setup -q
93 #%setup -q -c -T
94 #%setup -q -n %{name}
95 #%setup -q -n %{name}-%{version}.orig -a 1
96 #%patch0 -p1
97
98 # undos the source
99 #find '(' -name '*.php' -o -name '*.inc' ')' -print0 | xargs -0 sed -i -e 's,\r$,,'
100
101 # remove CVS control files
102 #find -name CVS -print0 | xargs -0 rm -rf
103
104 # you'll need this if you cp -a complete dir in source
105 # cleanup backups after patching
106 find . '(' -name '*~' -o -name '*.orig' ')' -print0 | xargs -0 -r -l512 rm -f
107
108 %build
109 # if ac/am/* rebuilding is necessary, do it in this order and add
110 # appropriate BuildRequires
111 #%%{__intltoolize}
112 #%%{__gettextize}
113 #%%{__libtoolize}
114 #%%{__aclocal}
115 #%%{__autoconf}
116 #%%{__autoheader}
117 #%%{__automake}
118 #cp -f /usr/share/automake/config.sub .
119 %configure
120 %{__make}
121
122 #%{__make} \
123 #       CFLAGS="%{rpmcflags}" \
124 #       LDFLAGS="%{rpmldflags}"
125
126 %install
127 rm -rf $RPM_BUILD_ROOT
128 # create directories if necessary
129 #install -d $RPM_BUILD_ROOT
130 #install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
131
132 %{__make} install \
133         DESTDIR=$RPM_BUILD_ROOT
134
135 %clean
136 rm -rf $RPM_BUILD_ROOT
137
138 %pre
139
140 %post
141
142 %preun
143
144 %postun
145
146 %if %{with ldconfig}
147 %post   -p /sbin/ldconfig
148 %postun -p /sbin/ldconfig
149 %endif
150
151 %if %{with initscript}
152 %post init
153 /sbin/chkconfig --add %{name}
154 %service %{name} restart
155
156 %preun init
157 if [ "$1" = "0" ]; then
158         %service -q %{name} stop
159         /sbin/chkconfig --del %{name}
160 fi
161 %endif
162
163 %files
164 %defattr(644,root,root,755)
165 %doc AUTHORS CREDITS ChangeLog NEWS README THANKS TODO
166
167 %if 0
168 # if _sysconfdir != /etc:
169 #%%dir %{_sysconfdir}
170 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/*
171 %attr(755,root,root) %{_bindir}/*
172 %{_datadir}/%{name}
173 %endif
174
175 # initscript and its config
176 %if %{with initscript}
177 %attr(754,root,root) /etc/rc.d/init.d/%{name}
178 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/%{name}
179 %endif
180
181 #%{_examplesdir}/%{name}-%{version}
182
183 %if %{with subpackage}
184 %files subpackage
185 %defattr(644,root,root,755)
186 #%doc extras/*.gz
187 #%{_datadir}/%{name}-ext
188 %endif
This page took 0.079197 seconds and 3 git commands to generate.