]> git.pld-linux.org Git - SPECS.git/blob - telnet-ssl.spec
SPECS updated Wed 28 Jul 14:48:01 CEST 2021
[SPECS.git] / telnet-ssl.spec
1 Summary:        Client for the telnet remote login protocol with support for SSL
2 Summary(pl.UTF-8):      Klient protokołu telnet ze wsparciem dla SSL
3 Name:           telnet-ssl
4 Version:        0.17.24
5 Release:        6
6 License:        GPL
7 Group:          Networking
8 # based on debian (netkit-)telnet-ssl package
9 Source0:        %{name}-%{version}.tar.gz
10 # Source0-md5:  43a402139ed6b86434fdb83256feaad8
11 Source1:        telnetd-ssl.inetd
12 Patch0:         %{name}-debian.patch
13 Patch1:         %{name}-install.patch
14 # better url?
15 URL:            http://packages.debian.org/telnet-ssl
16 BuildRequires:  libstdc++-devel
17 BuildRequires:  ncurses-devel
18 BuildRequires:  openssl-devel
19 BuildRequires:  rpmbuild(macros) >= 1.268
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 The telnet command is used for interactive communication with another
24 host using the TELNET protocol.
25
26 SSL telnet(d) replaces normal telnet(d) using SSL authentication and
27 encryption. It interoperates with normal telnet(d) in both directions.
28 It checks if the other side is also talking SSL, if not it falls back
29 to normal telnet protocol.
30
31 Advantages over normal telnet(d): Your passwords and the data you send
32 will not go in cleartext over the line. Nobody can get it with tcpdump
33 or similar tools. With SSLtelnet you can also connect to https-server
34 like https://www.netscape.com.
35
36 %description -l pl.UTF-8
37 Polecenie telnet jest wykorzystywane do interaktywnej komunikacji z
38 innym komputerem przy użyciu protokołu TELNET.
39
40 Telnet(d)-SSL zastępuje telnet(d) dostarczając wersję rozszerzoną o
41 możliwość uwierzytelniania i szyfrowania SSL. Telnet(d)-SSL w pełni
42 współpracuje ze standardowym telnet(d) - sprawdza czy aplikacja po
43 drugiej stronie wspiera SSL, jeśli nie przełącza się do standardowego
44 protokołu TELNET.
45
46 Korzyści względem klasycznego telnet(d): hasła i dane nie będą wysłane
47 czystym tekstem. Nikt nie będzie mógł ich zobaczyć korzystając z
48 aplikacji takich jak tcpdump. Przy użyciu telnet-ssl możliwe jest
49 także połączenie się z serwerem www (n.p. https://www.netscape.com)
50 przy użyciu SSL.
51
52 %package -n telnetd-ssl
53 Summary:        Server for the telnet-ssl remote login protocol
54 Summary(pl.UTF-8):      Serwer usługi telnet-ssl
55 Group:          Networking
56 Requires:       inetdaemon
57 Requires:       login
58 Requires:       rc-inetd >= 0.8
59 Obsoletes:      inetutils-telnetd
60 Obsoletes:      telnet-server
61
62 %description -n telnetd-ssl
63 The telnet command is used for interactive communication with another
64 host using the TELNET protocol.
65
66 SSL telnet(d) replaces normal telnet(d) using SSL authentication and
67 encryption. It interoperates with normal telnet(d) in both directions.
68 It checks if the other side is also talking SSL, if not it falls back
69 to normal telnet protocol.
70
71 Advantages over normal telnet(d): Your passwords and the data you send
72 will not go in cleartext over the line. Nobody can get it with tcpdump
73 or similar tools. With SSLtelnet you can also connect to https-server
74 like https://www.netscape.com. Just do 'telnet www.netscape.com 443'.
75
76 This package provides server for the telnet-ssl.
77
78 %description -n telnetd-ssl -l pl.UTF-8
79 Polecenie telnet jest wykorzystywane do interaktywnej komunikacji z
80 innym komputerem przy użyciu protokołu TELNET.
81
82 Telnet(d)-SSL zastępuje telnet(d) dostarczając wersję rozszerzoną o
83 możliwość uwierzytelniania i szyfrowania SSL. Telnet(d)-SSL w pełni
84 współpracuje ze standardowym telnet(d) - sprawdza czy aplikacja po
85 drugiej stronie wspiera SSL, jeśli nie przełącza się do standardowego
86 protokołu TELNET.
87
88 Korzyści względem klasycznego telnet(d): hasła i dane nie będą wysłane
89 czystym tekstem. Nikt nie będzie mógł ich zobaczyć korzystając z
90 aplikacji takich jak tcpdump. Przy użyciu telnet-ssl możliwe jest
91 także połączenie się z serwerem www (n.p. https://www.netscape.com)
92 przy użyciu SSL.
93
94 Ten pakiet dostarcza serwer telnet-ssl.
95
96 %prep
97 %setup -q -n netkit-%{name}-%{version}+0.1.orig
98 %patch0 -p1
99 %patch1 -p1
100
101 sed -i -e "s|/usr/lib/telnetlogin|%{_sbindir}/telnetlogin|" telnetd/Makefile
102
103 %build
104 CFLAGS="%{rpmcflags} -D_GNU_SOURCE"
105 CXXFLAGS="%{rpmcflags} -D_GNU_SOURCE"
106 export CFLAGS CXXFLAGS
107 ./configure \
108         --prefix=%{_prefix} \
109         --exec-prefix=%{_prefix} \
110         --installroot=$RPM_BUILD_ROOT \
111         --with-c-compiler="%{__cc}" \
112         --with-c++-compiler="%{__cxx}"
113
114 %{__make} -j1
115
116 %install
117 rm -rf $RPM_BUILD_ROOT
118 install -d $RPM_BUILD_ROOT{%{_bindir},%{_sbindir},%{_mandir}/man{1,5,8}} \
119         $RPM_BUILD_ROOT/etc/sysconfig/rc-inetd
120
121 %{__make} install \
122         DESTDIR=$RPM_BUILD_ROOT \
123         MANDIR="%{_mandir}" \
124         SUB="telnet telnetd telnetlogin"
125
126 install %{SOURCE1} $RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/telnetd
127
128 %clean
129 rm -rf $RPM_BUILD_ROOT
130
131 %post -n telnetd-ssl
132 %service -q rc-inetd reload
133
134 %postun -n telnetd-ssl
135 if [ "$1" = "0" ]; then
136         %service -q rc-inetd reload
137 fi
138
139 %files
140 %defattr(644,root,root,755)
141 %attr(755,root,root) %{_bindir}/telnet-ssl
142 %{_mandir}/man1/telnet-ssl*
143
144 %files -n telnetd-ssl
145 %defattr(644,root,root,755)
146 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/rc-inetd/telnetd
147 %attr(755,root,root) %{_sbindir}/in.telnetd
148 %attr(4750,root,adm) %{_sbindir}/telnetlogin
149 %{_mandir}/man8/*
This page took 1.338778 seconds and 3 git commands to generate.