]> git.pld-linux.org Git - SPECS.git/blob - telepathy-qt5.spec
SPECS updated Mon 29 Apr 22:05:02 CEST 2024
[SPECS.git] / telepathy-qt5.spec
1 # "telepathy_qt" name is occupied by earlier work under the same name from different project;
2 # we used original "telepathy-qt4" name of this project (used before 0.9.0 release) until 0.9.7
3 # (the last version with qt4 support), then we moved to "telepathy-qt5".
4 %define         orgname telepathy-qt
5 %define         qt5_ver         5.6.0
6
7 Summary:        Library for Qt5-based Telepathy clients
8 Summary(pl.UTF-8):      Biblioteka dla klientów Telepathy opartych na Qt5
9 Name:           telepathy-qt5
10 Version:        0.9.8
11 Release:        3
12 License:        LGPL v2.1+
13 Group:          Libraries
14 Source0:        https://telepathy.freedesktop.org/releases/telepathy-qt/%{orgname}-%{version}.tar.gz
15 # Source0-md5:  2d55d477778ff7be9115746759bc398f
16 Patch0:         telepathy-qt-warnings.patch
17 URL:            https://telepathy.freedesktop.org/components/telepathy-qt/
18 BuildRequires:  Qt5Core-devel >= %{qt5_ver}
19 BuildRequires:  Qt5DBus-devel >= %{qt5_ver}
20 BuildRequires:  Qt5Network-devel >= %{qt5_ver}
21 BuildRequires:  Qt5Test-devel >= %{qt5_ver}
22 BuildRequires:  Qt5Xml-devel >= %{qt5_ver}
23 BuildRequires:  cmake >= 3.5
24 BuildRequires:  dbus-devel
25 BuildRequires:  dbus-glib-devel
26 BuildRequires:  farstream-devel >= 0.2.0
27 BuildRequires:  glib2-devel >= 1:2.16
28 BuildRequires:  libstdc++-devel >= 6:4.7
29 BuildRequires:  libxml2-devel >= 2.0
30 BuildRequires:  pkgconfig
31 BuildRequires:  python3-dbus
32 BuildRequires:  python3-devel >= 1:3.2
33 BuildRequires:  python3-modules >= 1:3.2
34 BuildRequires:  python3-pygobject3
35 BuildRequires:  qt5-assistant >= %{qt5_ver}
36 BuildRequires:  qt5-build >= %{qt5_ver}
37 BuildRequires:  qt5-qmake >= %{qt5_ver}
38 BuildRequires:  rpm-build >= 4.6
39 BuildRequires:  rpmbuild(macros) >= 1.293
40 BuildRequires:  telepathy-farstream-devel >= 0.6.0
41 BuildRequires:  telepathy-glib-devel >= 0.18.0
42 Requires:       Qt5Core >= %{qt5_ver}
43 Requires:       Qt5DBus >= %{qt5_ver}
44 Requires:       Qt5Network >= %{qt5_ver}
45 Requires:       Qt5Xml >= %{qt5_ver}
46 Requires:       telepathy-farstream >= 0.6.0
47 Requires:       telepathy-glib >= 0.18.0
48 Obsoletes:      telepathy-qt4-yell
49 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
50
51 %description
52 Library for Qt5-based Telepathy clients.
53
54 %description -l pl.UTF-8
55 Biblioteka dla klientów Telepathy opartych na Qt5.
56
57 %package devel
58 Summary:        Header files for telepathy-qt5 library
59 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki telepathy-qt5
60 Group:          Development/Libraries
61 Requires:       %{name} = %{version}-%{release}
62 Requires:       Qt5Core-devel >= %{qt5_ver}
63 Requires:       Qt5DBus-devel >= %{qt5_ver}
64 Requires:       Qt5Network-devel >= %{qt5_ver}
65 Requires:       Qt5Xml-devel >= %{qt5_ver}
66
67 %description devel
68 Header files for telepathy-qt5 library.
69
70 %description devel -l pl.UTF-8
71 Pliki nagłówkowe biblioteki telepathy-qt5.
72
73 %package apidocs
74 Summary:        API documentation for telepathy-qt4 and telepathy-qt5 libraries
75 Summary(pl.UTF-8):      Dokumentacja API bibliotek telepathy-qt5 i telepathy-qt5
76 Group:          Documentation
77 BuildArch:      noarch
78
79 %description apidocs
80 API documentation for telepathy-qt4 and telepathy-qt5 libraries.
81
82 %description apidocs -l pl.UTF-8
83 Dokumentacja API bibliotek telepathy-qt5 i telepathy-qt5.
84
85 %prep
86 %setup -q -n %{orgname}-%{version}
87 %patch0 -p1
88
89 %build
90 install -d build-qt5
91 cd build-qt5
92 %cmake .. \
93         -DENABLE_FARSTREAM:BOOL=ON \
94         -DDESIRED_QT_VERSION=5 \
95         -DQT_QMAKE_EXECUTABLE_FINDQT=%{_libdir}/qt5/bin/qmake
96
97 %{__make}
98 cd ..
99
100 %install
101 rm -rf $RPM_BUILD_ROOT
102
103 %{__make} -C build-qt5 install \
104         DESTDIR=$RPM_BUILD_ROOT
105
106 %clean
107 rm -rf $RPM_BUILD_ROOT
108
109 %post   -p /sbin/ldconfig
110 %postun -p /sbin/ldconfig
111
112 %files
113 %defattr(644,root,root,755)
114 %doc AUTHORS ChangeLog NEWS README
115 %attr(755,root,root) %{_libdir}/libtelepathy-qt5.so.*.*.*
116 %attr(755,root,root) %ghost %{_libdir}/libtelepathy-qt5.so.0
117 %attr(755,root,root) %{_libdir}/libtelepathy-qt5-farstream.so.*.*.*
118 %attr(755,root,root) %ghost %{_libdir}/libtelepathy-qt5-farstream.so.0
119 %attr(755,root,root) %{_libdir}/libtelepathy-qt5-service.so.*.*.*
120 %attr(755,root,root) %ghost %{_libdir}/libtelepathy-qt5-service.so.1
121
122 %files devel
123 %defattr(644,root,root,755)
124 %attr(755,root,root) %{_libdir}/libtelepathy-qt5.so
125 %attr(755,root,root) %{_libdir}/libtelepathy-qt5-farstream.so
126 %attr(755,root,root) %{_libdir}/libtelepathy-qt5-service.so
127 %{_libdir}/cmake/TelepathyQt5
128 %{_libdir}/cmake/TelepathyQt5Farstream
129 %{_libdir}/cmake/TelepathyQt5Service
130 %{_includedir}/telepathy-qt5
131 %{_pkgconfigdir}/TelepathyQt5.pc
132 %{_pkgconfigdir}/TelepathyQt5Farstream.pc
133 %{_pkgconfigdir}/TelepathyQt5Service.pc
134
135 %files apidocs
136 %defattr(644,root,root,755)
137 %doc doc/html/*
This page took 0.276966 seconds and 3 git commands to generate.