]> git.pld-linux.org Git - SPECS.git/blob - tawara.spec
SPECS updated Tue 30 Apr 15:06:09 CEST 2024
[SPECS.git] / tawara.spec
1 # NOTE: previous names of this projects were: tide, celduin, jonen
2 #
3 # Conditional build:
4 %bcond_without  apidocs         # do not build and package API docs
5
6 %define rel     4
7 %define snap    20130819
8 Summary:        Tawara file format implementation
9 Summary(pl.UTF-8):      Implementacja formatu plików Tawara
10 Name:           tawara
11 Version:        0.1.0
12 Release:        0.%{snap}.%{rel}
13 License:        BSD
14 Group:          Libraries
15 Source0:        http://github.com/gbiggs/tawara/archive/master/%{name}-%{snap}.tar.gz
16 # Source0-md5:  682d240fad7fd3e74026fa7c2a660b1f
17 Patch0:         %{name}-lib.patch
18 Patch1:         missing-header.patch
19 URL:            http://gbiggs.github.io/tawara/
20 # filesystem, system, date_time
21 BuildRequires:  boost-devel
22 BuildRequires:  cmake >= 2.8
23 %if %{with apidocs}
24 BuildRequires:  doxygen
25 BuildRequires:  python-breathe
26 BuildRequires:  sphinx-pdg
27 %endif
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %description
31 An interface, with implementations, for a channel-based system for
32 storing data that is indexed by time. Multiple channels of data can be
33 stored. Extensive meta-data is available, including channel names,
34 stored data type information, and key-value tags (capable of storing
35 anything that can be converted to binary data).
36
37 %description -l pl.UTF-8
38 Interfejs wraz z implementacjami opartego na kanałach systemu
39 przechowywania danych indeksowanych po czasie. Pozwala na
40 przechowywanie wielu kanałów. Dostępne są rozszerzalne metadane, w tym
41 nazwy kanałów, informacje o przechowywanym typie danych oraz znaczniki
42 klucz-wartość (pozwalające przechowywać wszystko, co można
43 przekształcić do danych binarnych).
44
45 %package devel
46 Summary:        Header files for Tawara library
47 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki Tawara
48 Group:          Development/Libraries
49 Requires:       %{name} = %{version}-%{release}
50
51 %description devel
52 Header files for Tawara library.
53
54 %description devel -l pl.UTF-8
55 Pliki nagłówkowe biblioteki Tawara.
56
57 %package apidocs
58 Summary:        Tawara API documentation
59 Summary(pl.UTF-8):      Dokumentacja API biblioteki Tawara
60 Group:          Documentation
61 BuildArch:      noarch
62
63 %description apidocs
64 API documentation for Tawara library.
65
66 %description apidocs -l pl.UTF-8
67 Dokumentacja API biblioteki Tawara.
68
69 %prep
70 %setup -q -n %{name}-master
71 %patch0 -p1
72 %patch1 -p1
73
74 %build
75 %cmake . \
76         %{!?with_apidocs:-DBUILD_DOCUMENTATION=OFF} \
77         -DBUILD_EXAMPLES=OFF
78
79 %{__make}
80
81 %install
82 rm -rf $RPM_BUILD_ROOT
83
84 %{__make} install \
85         DESTDIR=$RPM_BUILD_ROOT
86
87 # packaged as %doc
88 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/tawara-0
89
90 %clean
91 rm -rf $RPM_BUILD_ROOT
92
93 %post   -p /sbin/ldconfig
94 %postun -p /sbin/ldconfig
95
96 %files
97 %defattr(644,root,root,755)
98 %doc LICENSE.txt README.txt
99 %attr(755,root,root) %{_bindir}/tawara_info
100 %attr(755,root,root) %{_libdir}/libtawara.so
101
102 %files devel
103 %defattr(644,root,root,755)
104 %{_includedir}/tawara-0
105 %{_pkgconfigdir}/tawara.pc
106 %{_libdir}/tawara
107 %{_datadir}/tawara-0
108
109 %if %{with apidocs}
110 %files apidocs
111 %defattr(644,root,root,755)
112 %doc doc/html/{_static,doxygen,*.html,*.js}
113 %endif
This page took 0.262038 seconds and 3 git commands to generate.