]> git.pld-linux.org Git - packages/taskwarrior.git/blob - taskwarrior.spec
- install bash_completiion file to proper place
[packages/taskwarrior.git] / taskwarrior.spec
1 %define         shortname       task
2 Summary:        Taskwarrior is a command-line to do list manager
3 Summary(hu.UTF-8):      Taskwarrior egy parancssoros ToDo-kezelő
4 Name:           taskwarrior
5 Version:        1.9.2
6 Release:        0.9
7 License:        GPL v2
8 Group:          Applications
9 Source0:        http://www.taskwarrior.org/download/%{shortname}-%{version}.tar.gz
10 # Source0-md5:  be98cc74fe03b8336250e0b7ed3cd8c7
11 Patch0:         %{name}-flags.patch
12 Patch1:         %{name}-tinfo.patch
13 URL:            http://taskwarrior.org/
14 BuildRequires:  autoconf
15 BuildRequires:  automake
16 BuildRequires:  intltool
17 BuildRequires:  libstdc++-devel
18 BuildRequires:  libtool
19 BuildRequires:  ncurses-ext-devel
20 BuildRequires:  pkgconfig
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %define bashdir %{_sysconfdir}/bash_completion.d
24 %define vimdir %{_datadir}/vim/vimfiles
25
26 %description
27 Taskwarrior is an ambitious project to supercharge task (most
28 excellent CLI task manager by Paul Beckingham) with an interactive
29 interface, a powerful search tool, hotkeys, forms data entry, and a
30 host of new features.
31
32 %description -l hu.UTF-8
33 Taskwarrior egy törekvő project, amely a task-ot bővíti ki (a legjobb
34 CLI feladatkezelő Paul Beckingham-től) egy interaktív felületettel,
35 hatékony kereső eszközzel, hotkey-ekkel, űrlapokkal és új lehetőségek
36 tömegeivel.
37
38 %package -n bash-completion-taskwarrior
39 Summary:        bash-completion for taskwarrior
40 Group:          Applications/Shells
41 Requires:       %{name} = %{version}-%{release}
42
43 %description -n bash-completion-taskwarrior
44 bash-completion for taskwarrior.
45
46 %package -n vim-syntax-taskwarrior
47 Summary:        Vim-syntax: taskwarrior
48 Group:          Applications/Editors/Vim
49 Requires:       %{name} = %{version}-%{release}
50
51 %description -n vim-syntax-taskwarrior
52 Vim-syntax: taskwarrior.
53
54 %prep
55 %setup -q -n %{shortname}-%{version}
56 %patch0 -p1
57 %patch1 -p1
58
59 %build
60 %{__libtoolize}
61 %{__aclocal}
62 %{__autoconf}
63 %{__autoheader}
64 %{__automake}
65 %configure \
66         --with-ncurses-inc="$(pkg-config --variable=includedir ncurses++w)" \
67         --with-ncurses-lib="$(pkg-config --libs ncurses++w)"
68 %{__make}
69
70 %install
71 rm -rf $RPM_BUILD_ROOT
72
73 %{__make} install \
74         DESTDIR=$RPM_BUILD_ROOT \
75         bashscriptsdir=%{_sysconfdir}/bash_completion.d
76
77 %{__rm} -rf $RPM_BUILD_ROOT%{_docdir}/%{shortname}
78
79 install -d $RPM_BUILD_ROOT%{vimdir}/{ftdetect,syntax}
80 for dir in ftdetect syntax; do
81         install -d $RPM_BUILD_ROOT%{vimdir}/$dir
82         install scripts/vim/$dir/* $RPM_BUILD_ROOT%{vimdir}/$dir
83 done
84
85 %clean
86 rm -rf $RPM_BUILD_ROOT
87
88 %files
89 %defattr(644,root,root,755)
90 %doc AUTHORS ChangeLog NEWS README i18n doc/rc
91 %attr(755,root,root) %{_bindir}/%{shortname}
92 %{_mandir}/man1/*1*
93 %{_mandir}/man5/*5*
94
95 %files -n bash-completion-taskwarrior
96 %defattr(644,root,root,755)
97 %{_sysconfdir}/bash_completion.d/*
98
99 %files -n vim-syntax-taskwarrior
100 %defattr(644,root,root,755)
101 %{vimdir}/ftdetect/*
102 %{vimdir}/syntax/*
This page took 0.072377 seconds and 4 git commands to generate.