]> git.pld-linux.org Git - packages/taskwarrior.git/blob - taskwarrior.spec
- fix linking (-tinfo.patch)
[packages/taskwarrior.git] / taskwarrior.spec
1 # TODO:
2 # - zsh completion subpackage (I don't know, what is the correct place)
3 %define shortname task
4 Summary:        Taskwarrior is a command-line to do list manager
5 Summary(hu.UTF-8):      Taskwarrior egy parancssoros ToDo-kezelő
6 Name:           taskwarrior
7 Version:        1.9.2
8 Release:        0.9
9 License:        GPL v2
10 Group:          Applications
11 Source0:        http://www.taskwarrior.org/download/%{shortname}-%{version}.tar.gz
12 # Source0-md5:  be98cc74fe03b8336250e0b7ed3cd8c7
13 Patch0:         %{name}-flags.patch
14 Patch1:         %{name}-tinfo.patch
15 URL:            http://taskwarrior.org/
16 BuildRequires:  autoconf
17 BuildRequires:  automake
18 BuildRequires:  intltool
19 BuildRequires:  libstdc++-devel
20 BuildRequires:  libtool
21 BuildRequires:  ncurses-ext-devel
22 BuildRequires:  pkgconfig
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %define bashdir %{_sysconfdir}/bash_completion.d
26 %define vimdir %{_datadir}/vim/vimfiles
27
28 %description
29 Taskwarrior is an ambitious project to supercharge task (most
30 excellent CLI task manager by Paul Beckingham) with an interactive
31 interface, a powerful search tool, hotkeys, forms data entry, and a
32 host of new features.
33
34 %description -l hu.UTF-8
35 Taskwarrior egy törekvő project, amely a task-ot bővíti ki (a legjobb
36 CLI feladatkezelő Paul Beckingham-től) egy interaktív felületettel,
37 hatékony kereső eszközzel, hotkey-ekkel, űrlapokkal és új lehetőségek
38 tömegeivel.
39
40 %package -n bash-completion-taskwarrior
41 Summary:        bash-completion for taskwarrior
42 Group:          Applications/Shells
43 Requires:       %{name} = %{version}-%{release}
44
45 %description -n bash-completion-taskwarrior
46 bash-completion for taskwarrior.
47
48 %package -n vim-syntax-taskwarrior
49 Summary:        Vim-syntax: taskwarrior
50 Group:          Applications/Editors/Vim
51 Requires:       %{name} = %{version}-%{release}
52
53 %description -n vim-syntax-taskwarrior
54 Vim-syntax: taskwarrior.
55
56 %prep
57 %setup -q -n %{shortname}-%{version}
58 %patch0 -p1
59 %patch1 -p1
60
61 %build
62 %{__libtoolize}
63 %{__aclocal}
64 %{__autoconf}
65 %{__autoheader}
66 %{__automake}
67 %configure \
68         --with-ncurses-inc="$(pkg-config --variable=includedir ncurses++w)" \
69         --with-ncurses-lib="$(pkg-config --libs ncurses++w)"
70 %{__make}
71
72 %install
73 rm -rf $RPM_BUILD_ROOT
74
75 %{__make} install \
76         DESTDIR=$RPM_BUILD_ROOT
77
78 %{__rm} -rf $RPM_BUILD_ROOT%{_docdir}/%{shortname}
79
80 install -d $RPM_BUILD_ROOT%{bashdir}
81 install scripts/bash/task_completion.sh $RPM_BUILD_ROOT%{bashdir}/%{shortname}
82
83 install -d $RPM_BUILD_ROOT%{vimdir}/{ftdetect,syntax}
84 for dir in ftdetect syntax; do
85         install -d $RPM_BUILD_ROOT%{vimdir}/$dir
86         install scripts/vim/$dir/* $RPM_BUILD_ROOT%{vimdir}/$dir
87 done
88
89 %clean
90 rm -rf $RPM_BUILD_ROOT
91
92 %files
93 %defattr(644,root,root,755)
94 %doc AUTHORS ChangeLog NEWS README i18n doc/rc
95 %attr(755,root,root) %{_bindir}/%{shortname}
96 %{_mandir}/man1/*1*
97 %{_mandir}/man5/*5*
98
99 %files -n bash-completion-taskwarrior
100 %defattr(644,root,root,755)
101 %{bashdir}/%{shortname}
102
103 %files -n vim-syntax-taskwarrior
104 %defattr(644,root,root,755)
105 %{vimdir}/ftdetect/*
106 %{vimdir}/syntax/*
This page took 0.111039 seconds and 4 git commands to generate.