]> git.pld-linux.org Git - packages/taskwarrior.git/blob - taskwarrior.spec
- 1.9.2
[packages/taskwarrior.git] / taskwarrior.spec
1 # TODO:
2 # - zsh completion subpackage (I don't know, what is the correct place)
3 %define shortname task
4 Summary:        Taskwarrior is a command-line to do list manager
5 Summary(hu.UTF-8):      Taskwarrior egy parancssoros ToDo-kezelő
6 Name:           taskwarrior
7 Version:        1.9.2
8 Release:        0.9
9 License:        GPL v2
10 Group:          Applications
11 Source0:        http://www.taskwarrior.org/download/%{shortname}-%{version}.tar.gz
12 # Source0-md5:  be98cc74fe03b8336250e0b7ed3cd8c7
13 Patch0:         %{name}-flags.patch
14 URL:            http://taskwarrior.org/
15 BuildRequires:  autoconf
16 BuildRequires:  automake
17 BuildRequires:  intltool
18 BuildRequires:  libstdc++-devel
19 BuildRequires:  libtool
20 BuildRequires:  ncurses-devel
21 BuildRequires:  pkgconfig
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %define bashdir %{_sysconfdir}/bash_completion.d
25 %define vimdir %{_datadir}/vim/vimfiles
26
27 %description
28 Taskwarrior is an ambitious project to supercharge task (most
29 excellent CLI task manager by Paul Beckingham) with an interactive
30 interface, a powerful search tool, hotkeys, forms data entry, and a
31 host of new features.
32
33 %description -l hu.UTF-8
34 Taskwarrior egy törekvő project, amely a task-ot bővíti ki (a legjobb
35 CLI feladatkezelő Paul Beckingham-től) egy interaktív felületettel,
36 hatékony kereső eszközzel, hotkey-ekkel, űrlapokkal és új lehetőségek
37 tömegeivel.
38
39 %package -n bash-completion-taskwarrior
40 Summary:        bash-completion for taskwarrior
41 Group:          Applications/Shells
42 Requires:       %{name} = %{version}-%{release}
43
44 %description -n bash-completion-taskwarrior
45 bash-completion for taskwarrior.
46
47 %package -n vim-syntax-taskwarrior
48 Summary:        Vim-syntax: taskwarrior
49 Group:          Applications/Editors/Vim
50 Requires:       %{name} = %{version}-%{release}
51
52 %description -n vim-syntax-taskwarrior
53 Vim-syntax: taskwarrior.
54
55 %prep
56 %setup -q -n %{shortname}-%{version}
57 %patch0 -p1
58
59 %build
60 %{__libtoolize}
61 %{__aclocal}
62 %{__autoconf}
63 %{__autoheader}
64 %{__automake}
65 %configure \
66         --with-ncurses-inc="$(pkg-config --variable=includedir ncurses++w)" \
67         --with-ncurses-lib="$(pkg-config --libs ncurses++w)"
68 %{__make}
69
70 %install
71 rm -rf $RPM_BUILD_ROOT
72
73 %{__make} install \
74         DESTDIR=$RPM_BUILD_ROOT
75
76 %{__rm} -rf $RPM_BUILD_ROOT%{_docdir}/%{shortname}
77
78 install -d $RPM_BUILD_ROOT%{bashdir}
79 install scripts/bash/task_completion.sh $RPM_BUILD_ROOT%{bashdir}/%{shortname}
80
81 install -d $RPM_BUILD_ROOT%{vimdir}/{ftdetect,syntax}
82 for dir in ftdetect syntax; do
83         install -d $RPM_BUILD_ROOT%{vimdir}/$dir
84         install scripts/vim/$dir/* $RPM_BUILD_ROOT%{vimdir}/$dir
85 done
86
87 %clean
88 rm -rf $RPM_BUILD_ROOT
89
90 %files
91 %defattr(644,root,root,755)
92 %doc AUTHORS ChangeLog NEWS README i18n doc/rc
93 %attr(755,root,root) %{_bindir}/%{shortname}
94 %{_mandir}/man1/*1*
95 %{_mandir}/man5/*5*
96
97 %files -n bash-completion-taskwarrior
98 %defattr(644,root,root,755)
99 %{bashdir}/%{shortname}
100
101 %files -n vim-syntax-taskwarrior
102 %defattr(644,root,root,755)
103 %{vimdir}/ftdetect/*
104 %{vimdir}/syntax/*
This page took 0.059475 seconds and 3 git commands to generate.