]> git.pld-linux.org Git - SPECS.git/blob - sysrqd.spec
SPECS updated Wed 28 Jul 14:48:01 CEST 2021
[SPECS.git] / sysrqd.spec
1 Summary:        Linux SysRq over network daemon
2 Name:           sysrqd
3 Version:        13
4 Release:        2
5 License:        GPL v2+
6 Group:          Applications/Networking
7 Source0:        http://julien.danjou.info/sysrqd/%{name}-%{version}.tar.xz
8 # Source0-md5:  0d7b17acc32679aba16d19f140e04f39
9 Source1:        %{name}.init
10 BuildRequires:  tar >= 1:1.22
11 BuildRequires:  xz
12 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
13
14 %description
15 sysrqd is a small daemon intended to manage Linux SysRq over network.
16 Its philosophy is to be very responsive under heavy load and try to be
17 somehow reliable. Authentication is made by clear password.
18
19 %prep
20 %setup -q
21
22 %build
23 %{__make} \
24         CC="%{__cc}" \
25         CFLAGS="%{rpmcflags}"
26
27 %install
28 rm -rf $RPM_BUILD_ROOT
29 %{__make} install \
30         DESTDIR=$RPM_BUILD_ROOT
31
32 install -d $RPM_BUILD_ROOT/etc/rc.d/init.d
33 install -p %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/sysrqd
34
35 :> $RPM_BUILD_ROOT%{_sysconfdir}/sysrqd.secret
36 echo 0.0.0.0 > $RPM_BUILD_ROOT%{_sysconfdir}/sysrqd.bind
37
38 %clean
39 rm -rf $RPM_BUILD_ROOT
40
41 %post
42 /sbin/chkconfig --add sysrqd
43 %service sysrqd restart "sysrqd daemon"
44
45 %preun
46 if [ "$1" = "0" ]; then
47         %service sysrqd stop
48         /sbin/chkconfig --del sysrqd
49 fi
50
51 %files
52 %defattr(644,root,root,755)
53 %doc AUTHORS ChangeLog INSTALL README
54 %attr(755,root,root) %{_sbindir}/sysrqd
55 %attr(754,root,root) /etc/rc.d/init.d/sysrqd
56 %attr(600,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/sysrqd.*
This page took 0.11274 seconds and 3 git commands to generate.