]> git.pld-linux.org Git - SPECS.git/blob - svn-all-fast-export.spec
SPECS updated Wed 28 Jul 14:48:01 CEST 2021
[SPECS.git] / svn-all-fast-export.spec
1 Summary:        A fast-import based converter for an svn repo to git repos
2 Name:           svn-all-fast-export
3 Version:        1.0.10
4 Release:        1
5 License:        GPL v3
6 Group:          Development/Tools
7 Source0:        https://github.com/svn-all-fast-export/svn2git/archive/%{version}.tar.gz
8 # Source0-md5:  c94acdfb6eeb210fb8654436d179d946
9 Patch0:         git.patch
10 URL:            https://github.com/svn-all-fast-export/svn2git
11 BuildRequires:  QtCore-devel
12 BuildRequires:  apr-devel
13 BuildRequires:  libstdc++-devel
14 BuildRequires:  qt4-qmake >= 4.3.3-3
15 BuildRequires:  rpmbuild(macros) >= 1.484
16 BuildRequires:  subversion-devel
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19 %description
20 svn-all-fast-export is a tool to convert your svn repositories to git.
21
22 You will need to have a copy of your svn repository and to write some
23 rules to specify how the conversion will be done, for instance, you
24 can manage how the tags and branches will be managed writing the
25 appropriate rules. You have examples in
26 %{_examplesdir}/%{name}-%{version}
27
28 Also, you can provide a file mapping the old svn accounts to the
29 authors names in the format "Author Name <email>" so will not need to
30 use git filter-branch to amend the commiters' names.
31
32 #'<- for vim
33
34 %prep
35 %setup -qc
36 mv svn2git-*/* .
37 %patch0 -p1
38
39 %build
40 cd src
41
42 cat > local-config.pri <<EOF
43 APR_INCLUDE = $(apr-1-config --includedir)
44 EOF
45
46 qmake-qt4
47 %{__make} \
48         CXX="%{__cxx}"
49
50 %install
51 rm -rf $RPM_BUILD_ROOT
52 install -d $RPM_BUILD_ROOT{%{_bindir},%{_examplesdir}/%{name}-%{version}}
53 install -p svn-all-fast-export $RPM_BUILD_ROOT%{_bindir}
54 cp -a samples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
55
56 %clean
57 rm -rf $RPM_BUILD_ROOT
58
59 %files
60 %defattr(644,root,root,755)
61 %attr(755,root,root) %{_bindir}/svn-all-fast-export
62 %{_examplesdir}/%{name}-%{version}
This page took 1.250518 seconds and 3 git commands to generate.