]> git.pld-linux.org Git - SPECS.git/blob - suil.spec
SPECS updated Wed 19 Jun 22:35:01 CEST 2024
[SPECS.git] / suil.spec
1 #
2 # Conditional build:
3 %bcond_with     apidocs # API documentation
4 %bcond_without  gtk     # GTK+ (2,3) support
5 %bcond_without  qt5     # Qt5 support
6
7 Summary:        Lightweight C library for loading and wrapping LV2 plugin UIs
8 Summary(pl.UTF-8):      Lekka biblioteka C do ładowania i obudowywania UI wtyczek LV2
9 Name:           suil
10 Version:        0.10.20
11 Release:        1
12 License:        ISC
13 Group:          Libraries
14 Source0:        http://download.drobilla.net/%{name}-%{version}.tar.xz
15 # Source0-md5:  2c4a47fcb71648430e0762d29d8db032
16 URL:            http://drobilla.net/software/suil/
17 %{?with_qt5:BuildRequires:      Qt5Widgets-devel >= 5.1.0}
18 %{?with_qt5:BuildRequires:      Qt5X11Extras-devel >= 5.1.0}
19 %{?with_gtk:BuildRequires:      gtk+2-devel >= 2:2.18.0}
20 %{?with_gtk:BuildRequires:      gtk+3-devel >= 3.14.0}
21 BuildRequires:  libstdc++-devel >= 6:5
22 BuildRequires:  lv2-devel >= 1.18.3
23 BuildRequires:  meson >= 0.56.0
24 BuildRequires:  ninja >= 1.5
25 BuildRequires:  pkgconfig
26 BuildRequires:  rpmbuild(macros) >= 1.736
27 BuildRequires:  tar >= 1:1.22
28 BuildRequires:  xorg-lib-libX11-devel
29 BuildRequires:  xz
30 %if %{with apidocs}
31 BuildRequires:  doxygen
32 BuildRequires:  sphinx-pdg
33 %endif
34 Requires:       lv2 >= 1.18.3
35 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
36
37 %description
38 Suil is a lightweight C library for loading and wrapping LV2 plugin
39 UIs.
40
41 Suil makes it possible to load a UI of any toolkit in a host using any
42 other toolkit (assuming the toolkits are both supported by Suil).
43 Hosts do not need to build against or link to foreign toolkit
44 libraries to use UIs written with that toolkit (Suil performs its
45 magic at runtime using dynamically loaded modules). The API is
46 designed such that hosts do not need to explicitly support particular
47 toolkits whatsoever - if Suil supports a particular toolkit, then all
48 hosts that use Suil will support that toolkit "for free".
49
50 %description -l pl.UTF-8
51 Suil to lekka biblioteka C do ładowania i obudowywania interfejsów
52 użytkownika (UI) wtyczek LV2.
53
54 Suil umożliwia wczytanie UI dowolnego toolkitu do hosta
55 wykorzystującego dowolny inny toolkit (zakładając, że oba toolkity są
56 obsługiwane prez Suil). Hosty nie muszą być budowane z obsługą obcych
57 bibliotek toolkitów, aby można było używać UI napisanego z użyciem
58 danego toolkitu (Suil wykonuje całą potrzebną magię w czasie działania
59 przy użyciu modułów ładowanych dynamicznie). API jest zaprojektowane
60 tak, że hosty nie muszą jawnie obsługiwać konkretnego toolkitu - jeśli
61 Suil obsługuje ten toolkit, to wszystkie hosty wykorzystujące Suil
62 będą obsługiwały ten toolkit za darmo.
63
64 %package modules
65 Summary:        UI wrapper modules for suil library
66 Summary(pl.UTF-8):      Moduły obudowujące UI dla biblioteki suil
67 Group:          Libraries
68 Requires:       %{name} = %{version}-%{release}
69 %{?with_qt5:Requires:   Qt5Widgets >= 5.1.0}
70 %{?with_qt5:Requires:   Qt5X11Extras >= 5.1.0}
71 %{?with_gtk:Requires:   gtk+2 >= 2:2.18.0}
72 %{?with_gtk:Requires:   gtk+3 >= 3.14.0}
73
74 %description modules
75 Dynamically loaded modules for suil library, allowing to use X11
76 UIs in GTK+ or Qt host, GTK+ UI in Qt host, Qt UI in GTK+ host.
77
78 %description modules -l pl.UTF-8
79 Dynamicznie wczytywane moduły dla biblioteki suil, pozwalające na
80 używanie interfejsów użytkownika X11 w hostach GTK+ lub Qt,
81 interfejsów GTK+ w hostach Qt oraz  interfejsów Qt w hostach GTK+.
82
83 %package devel
84 Summary:        Header files for suil library
85 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki suil
86 Group:          Development/Libraries
87 Requires:       %{name} = %{version}-%{release}
88 Requires:       lv2-devel >= 1.18.3
89
90 %description devel
91 Header files for suil library.
92
93 %description devel -l pl.UTF-8
94 Pliki nagłówkowe biblioteki suil.
95
96 %prep
97 %setup -q
98
99 %build
100 %meson build \
101         --default-library=shared \
102         %{!?with_apidocs:-Ddocs=disabled} \
103         %{!?with_gtk:-Dgtk2=disabled} \
104         %{!?with_gtk:-Dgtk3=disabled} \
105         %{!?with_qt5:-Dqt5=disabled}
106
107 %ninja_build -C build
108
109 %install
110 rm -rf $RPM_BUILD_ROOT
111
112 %ninja_install -C build
113
114 %clean
115 rm -rf $RPM_BUILD_ROOT
116
117 %post   -p /sbin/ldconfig
118 %postun -p /sbin/ldconfig
119
120 %files
121 %defattr(644,root,root,755)
122 %doc AUTHORS COPYING NEWS README.md
123 %attr(755,root,root) %{_libdir}/libsuil-0.so.*.*.*
124 %attr(755,root,root) %ghost %{_libdir}/libsuil-0.so.0
125 %dir %{_libdir}/suil-0
126
127 %files modules
128 %defattr(644,root,root,755)
129 %attr(755,root,root) %{_libdir}/suil-0/libsuil_x11.so
130 %if %{with gtk}
131 %attr(755,root,root) %{_libdir}/suil-0/libsuil_x11_in_gtk2.so
132 %attr(755,root,root) %{_libdir}/suil-0/libsuil_x11_in_gtk3.so
133 %endif
134 %if %{with qt5}
135 %attr(755,root,root) %{_libdir}/suil-0/libsuil_x11_in_qt5.so
136 %endif
137
138 %files devel
139 %defattr(644,root,root,755)
140 %attr(755,root,root) %{_libdir}/libsuil-0.so
141 %{_includedir}/suil-0
142 %{_pkgconfigdir}/suil-0.pc
This page took 0.177458 seconds and 4 git commands to generate.