]> git.pld-linux.org Git - SPECS.git/blob - suil.spec
SPECS updated Wed 28 Jul 14:48:01 CEST 2021
[SPECS.git] / suil.spec
1 #
2 # Conditional build:
3 %bcond_without  gtk     # GTK+ (2,3) support
4 %bcond_without  qt4     # Qt4 support
5 %bcond_without  qt5     # Qt5 support
6
7 Summary:        Lightweight C library for loading and wrapping LV2 plugin UIs
8 Summary(pl.UTF-8):      Lekka biblioteka C do ładowania i obudowywania UI wtyczek LV2
9 Name:           suil
10 Version:        0.10.10
11 Release:        1
12 License:        ISC
13 Group:          Libraries
14 Source0:        http://download.drobilla.net/%{name}-%{version}.tar.bz2
15 # Source0-md5:  565c25c3b231e050642517a63627e64a
16 Patch0:         %{name}-build.patch
17 URL:            http://drobilla.net/software/suil/
18 %{?with_qt4:BuildRequires:      QtGui-devel >= 4.4.0}
19 %{?with_qt5:BuildRequires:      Qt5Widgets-devel >= 5.1.0}
20 %{?with_gtk:BuildRequires:      gtk+2-devel >= 2:2.18.0}
21 %{?with_gtk:BuildRequires:      gtk+3-devel >= 3.14.0}
22 BuildRequires:  libstdc++-devel
23 BuildRequires:  lv2-devel >= 1.16.0
24 BuildRequires:  python >= 2
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 Suil is a lightweight C library for loading and wrapping LV2 plugin
29 UIs.
30
31 Suil makes it possible to load a UI of any toolkit in a host using any
32 other toolkit (assuming the toolkits are both supported by Suil).
33 Hosts do not need to build against or link to foreign toolkit
34 libraries to use UIs written with that toolkit (Suil performs its
35 magic at runtime using dynamically loaded modules). The API is
36 designed such that hosts do not need to explicitly support particular
37 toolkits whatsoever - if Suil supports a particular toolkit, then all
38 hosts that use Suil will support that toolkit "for free".
39
40 %description -l pl.UTF-8
41 Suil to lekka biblioteka C do ładowania i obudowywania interfejsów
42 użytkownika (UI) wtyczek LV2.
43
44 Suil umożliwia wczytanie UI dowolnego toolkitu do hosta
45 wykorzystującego dowolny inny toolkit (zakładając, że oba toolkity są
46 obsługiwane prez Suil). Hosty nie muszą być budowane z obsługą obcych
47 bibliotek toolkitów, aby można było używać UI napisanego z użyciem
48 danego toolkitu (Suil wykonuje całą potrzebną magię w czasie działania
49 przy użyciu modułów ładowanych dynamicznie). API jest zaprojektowane
50 tak, że hosty nie muszą jawnie obsługiwać konkretnego toolkitu - jeśli
51 Suil obsługuje ten toolkit, to wszystkie hosty wykorzystujące Suil
52 będą obsługiwały ten toolkit za darmo.
53
54 %package modules
55 Summary:        UI wrapper modules for suil library
56 Summary(pl.UTF-8):      Moduły obudowujące UI dla biblioteki suil
57 Group:          Libraries
58 Requires:       %{name} = %{version}-%{release}
59 %{?with_qt4:Requires:   QtGui >= 4.4.0}
60 %{?with_qt5:Requires:   Qt5Widgets >= 5.1.0}
61 %{?with_gtk:Requires:   gtk+2 >= 2:2.18.0}
62 %{?with_gtk:Requires:   gtk+3 >= 3.14.0}
63
64 %description modules
65 Dynamically loaded modules for suil library, allowing to use X11
66 UIs in GTK+ or Qt host, GTK+ UI in Qt host, Qt UI in GTK+ host.
67
68 %description modules -l pl.UTF-8
69 Dynamicznie wczytywane moduły dla biblioteki suil, pozwalające na
70 używanie interfejsów użytkownika X11 w hostach GTK+ lub Qt,
71 interfejsów GTK+ w hostach Qt oraz  interfejsów Qt w hostach GTK+.
72
73 %package devel
74 Summary:        Header files for suil library
75 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki suil
76 Group:          Development/Libraries
77 Requires:       %{name} = %{version}-%{release}
78 Requires:       lv2-devel >= 1.16.0
79
80 %description devel
81 Header files for suil library.
82
83 %description devel -l pl.UTF-8
84 Pliki nagłówkowe biblioteki suil.
85
86 %prep
87 %setup -q
88 %patch0 -p1
89
90 %build
91 CC="%{__cc}" \
92 CFLAGS="%{rpmcflags}" \
93 ./waf configure \
94         --prefix=%{_prefix} \
95         --libdir=%{_libdir} \
96         --gtk2-lib-name=libgtk-x11-2.0.so.0 \
97         --gtk3-lib-name=libgtk-3.so.0 \
98         %{!?with_gtk:--no-gtk} \
99         %{!?with_qt4:--no-qt4} \
100         %{!?with_qt4:--no-qt4} \
101         %{!?with_qt5:--no-qt5}
102
103 ./waf -v
104
105 %install
106 rm -rf $RPM_BUILD_ROOT
107
108 ./waf install \
109         --destdir=$RPM_BUILD_ROOT
110
111 %clean
112 rm -rf $RPM_BUILD_ROOT
113
114 %post   -p /sbin/ldconfig
115 %postun -p /sbin/ldconfig
116
117 %files
118 %defattr(644,root,root,755)
119 %doc AUTHORS COPYING NEWS README.md
120 %attr(755,root,root) %{_libdir}/libsuil-0.so.*.*.*
121 %attr(755,root,root) %ghost %{_libdir}/libsuil-0.so.0
122 %dir %{_libdir}/suil-0
123
124 %files modules
125 %defattr(644,root,root,755)
126 %attr(755,root,root) %{_libdir}/suil-0/libsuil_x11.so
127 %if %{with gtk}
128 %attr(755,root,root) %{_libdir}/suil-0/libsuil_x11_in_gtk2.so
129 %attr(755,root,root) %{_libdir}/suil-0/libsuil_x11_in_gtk3.so
130 %endif
131 %if %{with qt4}
132 %attr(755,root,root) %{_libdir}/suil-0/libsuil_x11_in_qt4.so
133 %endif
134 %if %{with qt5}
135 %attr(755,root,root) %{_libdir}/suil-0/libsuil_x11_in_qt5.so
136 %endif
137 %if %{with gtk} && %{with qt4}
138 %attr(755,root,root) %{_libdir}/suil-0/libsuil_gtk2_in_qt4.so
139 %attr(755,root,root) %{_libdir}/suil-0/libsuil_qt4_in_gtk2.so
140 %endif
141 %if %{with gtk} && %{with qt5}
142 %attr(755,root,root) %{_libdir}/suil-0/libsuil_gtk2_in_qt5.so
143 %attr(755,root,root) %{_libdir}/suil-0/libsuil_qt5_in_gtk2.so
144 %attr(755,root,root) %{_libdir}/suil-0/libsuil_qt5_in_gtk3.so
145 %endif
146
147 %files devel
148 %defattr(644,root,root,755)
149 %attr(755,root,root) %{_libdir}/libsuil-0.so
150 %{_includedir}/suil-0
151 %{_pkgconfigdir}/suil-0.pc
This page took 0.550729 seconds and 3 git commands to generate.