]> git.pld-linux.org Git - packages/subversion.git/blob - subversion.spec
- unified, missing ldconfig calls
[packages/subversion.git] / subversion.spec
1 # TODO:
2 # - remove net_client_only and add db bcond (then without apache and
3 #   without db => net_client_only - spec will be more simpler, I think)
4 # - finish ruby
5 #
6 # Conditional build:
7 %bcond_with     net_client_only         # build only net client
8 %bcond_without  python                  # build without python bindings (broken)
9 %bcond_without  perl                    # build without perl bindings
10 %bcond_without  ruby
11 %bcond_without  apache                  # build without apache support (webdav, etc)
12 %bcond_without  javahl                  # build without javahl support (Java high-level bindings)
13 %bcond_without  tests                   # don't perform "make check"
14 #
15 %{!?with_net_client_only:%include       /usr/lib/rpm/macros.perl}
16 %define apxs    /usr/sbin/apxs
17 %define pdir    SVN
18 %define pnam    _Core
19 #
20 %define snap    rc7
21 Summary:        A Concurrent Versioning system similar to but better than CVS
22 Summary(pl.UTF-8):      System kontroli wersji podobny, ale lepszy, niż CVS
23 Summary(pt_BR.UTF-8):   Sistema de versionamento concorrente
24 Name:           subversion
25 Version:        1.5.0
26 Release:        0.%{snap}.1
27 License:        Apache/BSD-like
28 Group:          Development/Version Control
29 Source0:        http://subversion.tigris.org/downloads/%{name}-%{version}-%{snap}.tar.bz2
30 # Source0-md5:  3145186e3c1a60fbb4dc360da490b841
31 Source1:        %{name}-dav_svn.conf
32 Source2:        %{name}-authz_svn.conf
33 Source3:        %{name}-svnserve.init
34 Source4:        %{name}-svnserve.sysconfig
35 Source5:        %{name}-convert-typemaps-to-ifdef.py
36 Patch0:         %{name}-home_etc.patch
37 Patch1:         %{name}-DESTDIR.patch
38 URL:            http://subversion.tigris.org/
39 %if %{with net_client_only}
40 %global apache_modules_api 0
41 %else
42 %{?with_apache:BuildRequires:   apache-devel >= 2.2.0-8}
43 BuildRequires:  automake
44 BuildRequires:  db-devel >= 4.1.25
45 BuildRequires:  rpmbuild(macros) >= 1.268
46 %if %{with perl}
47 BuildRequires:  perl-devel >= 1:5.8.0
48 BuildRequires:  rpm-perlprov >= 4.1-13
49 BuildRequires:  swig-perl >= 1.3.24
50 %endif
51 %{?with_javahl:BuildRequires:   jdk}
52 %endif
53 BuildRequires:  apr-devel >= 1:1.0.0
54 BuildRequires:  apr-util-devel >= 1:1.2.8-3
55 BuildRequires:  autoconf >= 2.59
56 BuildRequires:  bison
57 BuildRequires:  cyrus-sasl-devel
58 BuildRequires:  expat-devel
59 BuildRequires:  gettext-devel
60 BuildRequires:  libtool >= 1.4-9
61 BuildRequires:  neon-devel >= 0.26.0
62 BuildRequires:  python >= 2.2
63 BuildRequires:  python-modules >= 2.2
64 %if %{with python}
65 BuildRequires:  python-devel >= 2.2
66 BuildRequires:  sed >= 4.0
67 BuildRequires:  swig-python >= 1.3.24
68 %endif
69 BuildRequires:  texinfo
70 BuildRequires:  which
71 Requires:       %{name}-libs = %{version}-%{release}
72 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
73
74 %define         _libexecdir             %{_libdir}/svn
75 %define         apacheconfdir   %(%{apxs} -q SYSCONFDIR 2>/dev/null)/conf.d
76 %define         apachelibdir    %(%{apxs} -q LIBEXECDIR 2>/dev/null)
77
78 %description
79 The goal of the Subversion project is to build a version control
80 system that is a compelling replacement for CVS in the open source
81 community.
82
83 Our goals are:
84 - All current CVS features.
85 - Directories, renames, and file meta-data are versioned.
86 - Symbolic links, etc, are supported
87 - Commits are truly atomic.
88 - Branching and tagging are cheap (constant time) operations
89 - Repeated merges are handled gracefully
90 - Support for plug-in client side diff programs
91 - Natively client/server
92 - Client/server protocol sends diffs in both directions
93 - Costs are proportional to change size, not project size
94 - Internationalization
95 - Progressive multi-lingual support
96
97 %description -l pl.UTF-8
98 Celem projektu Subversion jest stworzenie systemu kontroli wersji jako
99 zamiennika dla CVS.
100
101 Cele projektu to:
102 - Wszystkie aktualne możliwości CVS.
103 - Katalogi, zmiany nazw oraz metadane plików są wersjonowane.
104 - Obsługa dowiązań symbolicznych itp.
105 - Commity są w pełni atomowe.
106 - Branchowanie oraz tagowanie są tanimi (stałymi w czasie) operacjami.
107 - Dobra obsługa powtarzanego łączenia (merge).
108 - Obsługa wtyczek diff po stronie klienta.
109 - Natywny klient/serwer.
110 - Klient/Serwer przesyłają diffy w obu kierunkach.
111 - Koszty proporcjonalne do rozmiaru zmiany, a nie rozmiaru projektu.
112 - Internacjonalizacja.
113 - Postępujące wsparcie dla wielu języków.
114
115 %description -l pt_BR.UTF-8
116 O objetivo do projeto Subversion é construir um sistema de controle de
117 versões que seja um substituto para o CVS (Concurrent Versioning
118 System) na comunidade opensource, fornecendo grandes melhorias.
119
120 %package libs
121 Summary:        Subversion libraries and modules
122 Summary(pl.UTF-8):      Biblioteka subversion oraz ładowalne moduły
123 Group:          Libraries
124 Requires:       neon >= 0.26.0
125 Obsoletes:      libsubversion0
126
127 %description libs
128 Subversion libraries and modules.
129
130 %description libs -l pl.UTF-8
131 Biblioteka subversion oraz ładowalne moduły.
132
133 %package devel
134 Summary:        Header files and develpment documentation for subversion
135 Summary(pl.UTF-8):      Pliki nagłówkowe i dokumetacja do subversion
136 Summary(pt_BR.UTF-8):   Arquivos de desenvolvimento para o Subversion
137 Group:          Development/Libraries
138 Requires:       %{name}-libs = %{version}-%{release}
139 Requires:       apr-util-devel >= 1:1.0.0
140 Requires:       neon-devel >= 0.26.0
141 Obsoletes:      libsubversion0-devel
142
143 %description devel
144 Header files and develpment documentation for subversion.
145
146 %description devel -l pl.UTF-8
147 Pliki nagłówkowe i dokumetacja do subversion.
148
149 %description devel -l pt_BR.UTF-8
150 Este pacote provê os arquivos necessários para desenvolvedores
151 interagirem com o Subversion.
152
153 %package static
154 Summary:        Static subversion library
155 Summary(pl.UTF-8):      Biblioteka statyczna subversion
156 Summary(pt_BR.UTF-8):   Sistema de versionamento concorrente
157 Group:          Development/Libraries
158 Requires:       %{name}-devel = %{version}
159 Obsoletes:      libsubversion0-static-devel
160
161 %description static
162 Static subversion library.
163
164 %description static -l pl.UTF-8
165 Biblioteka statyczna subversion.
166
167 %description static -l pt_BR.UTF-8
168 Este pacote provê um cliente estático do subversion.
169
170 %package svnserve
171 Summary:        Subversion svnserve
172 Summary(pl.UTF-8):      Subversion svnserve
173 Group:          Networking/Daemons
174 Requires(post,preun):   /sbin/chkconfig
175 Requires(postun):       /usr/sbin/groupdel
176 Requires(postun):       /usr/sbin/userdel
177 Requires(pre):  /bin/id
178 Requires(pre):  /usr/bin/getgid
179 Requires(pre):  /usr/lib/rpm/user_group.sh
180 Requires(pre):  /usr/sbin/groupadd
181 Requires(pre):  /usr/sbin/useradd
182 Requires(pre):  /usr/sbin/usermod
183 Requires:       %{name} = %{version}-%{release}
184 Requires:       rc-scripts
185 Provides:       group(svn)
186 Provides:       user(svn)
187
188 %description svnserve
189 Subversion svnserve server.
190
191 %description svnserve -l pl.UTF-8
192 Serwer subversion svnserve.
193
194 %package tools
195 Summary:        Subversion tools and scripts
196 Summary(pl.UTF-8):      Narzędzia oraz skrypty dla subversion
197 Summary(pt_BR.UTF-8):   Módulos python para acessar os recursos do Subversion
198 Group:          Applications
199 %pyrequires_eq  python
200 Requires:       %{name} = %{version}-%{release}
201 Requires:       python-rcsparse >= 0.1-0.20031026.0
202 Requires:       python-subversion = %{version}
203
204 %description tools
205 Subversion tools and scripts.
206
207 %description tools -l pl.UTF-8
208 Narzędzia oraz skrypty dla subversion.
209
210 %package -n bash-completion-subversion
211 Summary:        bash completion for subversion
212 Summary(pl.UTF-8):      Dopełnienia basha dla subversion
213 Group:          Applications/Shells
214 Requires:       %{name} = %{version}-%{release}
215 Requires:       bash-completion
216 Conflicts:      %{name}-tools <= 1.1.0-0.rc6.1
217
218 %description -n bash-completion-subversion
219 Bash completion for subversion.
220
221 %description -n bash-completion-subversion -l pl.UTF-8
222 Dopełnienia basha dla subversion.
223
224 %package -n java-subversion
225 Summary:        Subversion Java bindings
226 Summary(pl.UTF-8):      Dowiązania do Subversion dla Javy
227 Group:          Development/Languages/Java
228 Requires:       %{name}-libs = %{version}-%{release}
229
230 %description -n java-subversion
231 This is a set of Java classes which provide the functionality of
232 subversion-libs, the Subversion libraries. It is useful if you want
233 to, for example, write a Java class that manipulates a Subversion
234 repository or working copy. See the 'subversion' package for more
235 information.
236
237 %description -n java-subversion -l pl.UTF-8
238 Ten pakiet zawiera zestaw klas Javy udostępniających funkcjonalność
239 subversion-libs, czyli bibliotek Subversion. Jest przydatny przy
240 pisaniu klas Javy np. modyfikujących repozytorium Subversion lub kopię
241 roboczą. Więcej informacji w pakiecie subversion.
242
243 %package -n python-subversion
244 Summary:        Subversion Python bindings
245 Summary(pl.UTF-8):      Dowiązania do Subversion dla Pythona
246 Summary(pt_BR.UTF-8):   Módulos Python para acessar os recursos do Subversion
247 Group:          Development/Languages/Python
248 %pyrequires_eq  python
249 Requires:       %{name}-libs = %{version}-%{release}
250 Obsoletes:      subversion-python
251
252 %description -n python-subversion
253 Subversion Python bindings.
254
255 %description -n python-subversion -l pl.UTF-8
256 Dowiązania do Subversion dla Pythona.
257
258 %description -n python-subversion -l pt_BR.UTF-8
259 Módulos Python para acessar os recursos do Subversion.
260
261 %package -n perl-subversion
262 Summary:        Subversion Perl bindings
263 Summary(pl.UTF-8):      Dowiązania do Subversion dla Perla
264 Summary(pt_BR.UTF-8):   Módulos Perl para acessar os recursos do Subversion
265 Group:          Development/Languages/Perl
266 Requires:       %{name}-libs = %{version}-%{release}
267 Obsoletes:      subversion-perl
268
269 %description -n perl-subversion
270 Subversion Perl bindings.
271
272 %description -n perl-subversion -l pl.UTF-8
273 Dowiązania do Subversion dla Perla.
274
275 %description -n perl-subversion -l pt_BR.UTF-8
276 Módulos Perl para acessar os recursos do Subversion.
277
278 %package -n ruby-subversion
279 Summary:        Subversion Ruby bindings
280 Summary(pl.UTF-8):      Dowiązania do Subversion dla języka Ruby
281 Summary(pt_BR.UTF-8):   Módulos Ruby para acessar os recursos do Subversion
282 Group:          Development/Languages
283 Requires:       %{name}-libs = %{version}-%{release}
284 Obsoletes:      subversion-ruby
285
286 %description -n ruby-subversion
287 Subversion Ruby bindings.
288
289 %description -n ruby-subversion -l pl.UTF-8
290 Dowiązania do Subversion dla języka Ruby.
291
292 %description -n ruby-subversion -l pt_BR.UTF-8
293 Módulos Ruby para acessar os recursos do Subversion.
294
295 %package -n apache-mod_dav_svn
296 Summary:        Apache module: Subversion Server
297 Summary(pl.UTF-8):      Moduł apache: Serwer Subversion
298 Group:          Networking/Daemons
299 Requires:       %{name} = %{version}-%{release}
300 Requires:       apache(modules-api) = %apache_modules_api
301 Requires:       apache-mod_dav
302
303 %description -n apache-mod_dav_svn
304 Apache module: Subversion Server.
305
306 %description -n apache-mod_dav_svn -l pl.UTF-8
307 Moduł apache: Serwer Subversion.
308
309 %package -n apache-mod_authz_svn
310 Summary:        Apache module: Subversion Server - path-based authorization
311 Summary(pl.UTF-8):      Moduł apache: autoryzacja na podstawie ścieżki dla serwera Subversion
312 Group:          Networking/Daemons
313 Requires:       apache(modules-api) = %apache_modules_api
314 Requires:       apache-mod_dav_svn = %{version}-%{release}
315
316 %description -n apache-mod_authz_svn
317 Apache module: Subversion Server - path-based authorization.
318
319 %description -n apache-mod_authz_svn -l pl.UTF-8
320 Moduł apache: autoryzacja na podstawie ścieżki dla serwera Subversion.
321
322 %prep
323 %setup -q -n %{name}-%{version}-%{snap}
324 rm -rf apr apr-util neon
325 %patch0 -p0
326 %patch1 -p1
327
328 %build
329 rm subversion/bindings/swig/proxy/*.swg
330 cd subversion/bindings/swig && python "%{SOURCE5}" && cd ../../..
331 cp -f /usr/share/automake/config.sub ac-helpers
332 chmod +x ./autogen.sh && ./autogen.sh
333
334 # don't enable dso - currently it's broken
335 %configure \
336         --with-editor=vi \
337         --with-zlib=%{_libdir} \
338         --with-python=%{__python} \
339         --with-perl5=%{__perl} \
340 %if %{with net_client_only}
341         --without-apache \
342         --without-swig \
343         --without-apxs \
344         --without-berkeley-db \
345 %else
346         --disable-dso \
347         --disable-mod-activation \
348 %if %{with apache}
349         --with-apxs=%{_sbindir}/apxs \
350 %else
351         --without-apache \
352         --without-apxs \
353         --with-berkeley-db=%{_includedir}/db4:%{_libdir} \
354 %endif
355 %if !%{with python} && !%{with perl}
356         --without-swig \
357 %endif
358         --%{?with_javahl:en}%{!?with_javahl:dis}able-javahl \
359 %endif
360         --with-jdk="%{java_home}" \
361         --with-neon=%{_prefix} \
362         --disable-neon-version-check \
363         --with-apr=%{_bindir}/apr-1-config \
364         --with-apr-util=%{_bindir}/apu-1-config
365
366 %{__make} -j1
367
368 %if !%{with net_client_only}
369 # python
370 %if %{with python}
371 %{__make} swig-py \
372         swig_pydir=%{py_sitedir}/libsvn \
373         swig_pydir_extra=%{py_sitedir}/svn
374 %endif
375 # perl
376 %if %{with perl}
377 %{__make} swig-pl-lib
378 odir=$(pwd)
379 cd subversion/bindings/swig/perl/native
380 %{__perl} Makefile.PL INSTALLDIRS=vendor
381 %{__make}
382 cd $odir
383 %endif
384 %if %{with javahl}
385 %{__make} javahl \
386         javahl_javadir="%{_javadir}"
387 %endif
388 # ruby
389 %if %{with ruby}
390 %{__make} swig-rb
391 %endif
392 %endif
393
394 %if %{with tests}
395 %{__make} check
396 %if %{with python}
397 %{__make} check-swig-py
398 %endif
399 %if %{with perl}
400 %{__make} check-swig-pl
401 %endif
402 %if %{with ruby}
403 %{__make} check-swig-rb
404 %endif
405 %endif
406
407 %install
408 rm -rf $RPM_BUILD_ROOT
409 install -d $RPM_BUILD_ROOT/etc/{rc.d/init.d,sysconfig,bash_completion.d} \
410         $RPM_BUILD_ROOT{%{apacheconfdir},%{apachelibdir},%{_infodir}} \
411         $RPM_BUILD_ROOT%{_examplesdir}/{%{name}-%{version},python-%{name}-%{version}} \
412         $RPM_BUILD_ROOT/home/services/subversion{,/repos}
413
414 %{__make} install -j1 \
415 %if %{with javahl}
416         install-javahl \
417         javahl_javadir="%{_javadir}" \
418 %endif
419 %if !%{with net_client_only}
420 %if %{with python}
421         install-swig-py \
422 %endif
423 %if %{with ruby}
424         install-swig-rb install-swig-rb-doc \
425 %endif
426 %endif
427         APACHE_LIBEXECDIR="$(%{_sbindir}/apxs -q LIBEXECDIR)" \
428         DESTDIR=$RPM_BUILD_ROOT \
429         swig_pydir=%{py_sitedir}/libsvn \
430         swig_pydir_extra=%{py_sitedir}/svn
431
432 %if !%{with net_client_only} && %{with perl}
433 %{__make} install-swig-pl-lib \
434         DESTDIR=$RPM_BUILD_ROOT
435 odir=$(pwd)
436 cd subversion/bindings/swig/perl/native
437 %{__make} install \
438         DESTDIR=$RPM_BUILD_ROOT \
439         PREFIX=$RPM_BUILD_ROOT%{_prefix} \
440         LIBDIR=$RPM_BUILD_ROOT%{_libdir}
441 cd $odir
442 %endif
443
444 %if %{with apache}
445 install %{SOURCE1} $RPM_BUILD_ROOT%{apacheconfdir}/65_mod_dav_svn.conf
446 install %{SOURCE2} $RPM_BUILD_ROOT%{apacheconfdir}/66_mod_authz_svn.conf
447 install %{SOURCE3} $RPM_BUILD_ROOT/etc/rc.d/init.d/svnserve
448 install %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/svnserve
449 %endif
450
451 %if !%{with net_client_only}
452 install tools/backup/hot-backup.py $RPM_BUILD_ROOT%{_bindir}/svn-hot-backup
453 %if %{with python}
454 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
455 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
456 find $RPM_BUILD_ROOT%{py_sitedir} -name "*.py" -o -name "*.a" -o -name "*.la" | xargs rm -f
457 install tools/examples/*.py $RPM_BUILD_ROOT%{_examplesdir}/python-%{name}-%{version}
458 %endif
459 %endif
460
461 install tools/client-side/bash_completion $RPM_BUILD_ROOT/etc/bash_completion.d/%{name}
462 install tools/examples/*.c $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
463
464 %find_lang %{name}
465
466 rm -f $RPM_BUILD_ROOT%{_libdir}/lib*swig*.la
467
468 %clean
469 rm -rf $RPM_BUILD_ROOT
470
471 %pre svnserve
472 %groupadd -g 86 svn
473 %useradd -u 180 -d /home/services/subversion -c "Subversion svnserve" -g svn svn
474
475 %post   libs -p /sbin/ldconfig
476 %postun libs -p /sbin/ldconfig
477
478 %post   devel -p /sbin/postshell
479 -/usr/sbin/fix-info-dir -c %{_infodir}
480
481 %postun devel -p /sbin/postshell
482 -/usr/sbin/fix-info-dir -c %{_infodir}
483
484 %post   -n perl-subversion -p /sbin/ldconfig
485 %postun -n perl-subversion -p /sbin/ldconfig
486
487 %post   -n python-subversion -p /sbin/ldconfig
488 %postun -n python-subversion -p /sbin/ldconfig
489
490 %post svnserve
491 /sbin/chkconfig --add svnserve
492 %service svnserve restart "svnserve daemon"
493
494 %preun svnserve
495 if [ "$1" = "0" ]; then
496         %service svnserve stop
497         /sbin/chkconfig --del svnserve
498 fi
499
500 %postun svnserve
501 if [ "$1" = "0" ]; then
502         %userremove svn
503         %groupremove svn
504 fi
505
506 %post -n apache-mod_dav_svn
507 %service -q httpd restart
508
509 %preun -n apache-mod_dav_svn
510 if [ "$1" = "0" ]; then
511         %service -q httpd restart
512 fi
513
514 %files
515 %defattr(644,root,root,755)
516 %doc BUGS CHANGES COPYING INSTALL README
517 %doc doc/*/*.html
518 %doc tools/hook-scripts/*.{pl,py,example}
519 %doc tools/hook-scripts/mailer/*.{py,example}
520 %doc tools/xslt/*
521 %attr(755,root,root) %{_bindir}/svn*
522 %exclude %{_bindir}/svnserve
523 %if !%{with net_client_only}
524 %exclude %{_bindir}/svn-hot-backup
525 %endif
526 %{_mandir}/man1/*
527 %{_mandir}/man5/*
528 %{_mandir}/man8/*
529 %exclude %{_mandir}/man?/svnserve*
530
531 %files libs -f %{name}.lang
532 %defattr(644,root,root,755)
533 %attr(755,root,root) %{_libdir}/lib*.so.*
534 %if %{with perl} || %{with python}
535 %exclude %{_libdir}/lib*_swig_*.so.*
536 %endif
537 %if %{with javahl}
538 %exclude %{_libdir}/libsvnjavahl*.so.*.*.*
539 %exclude %{_libdir}/libsvnjavahl*.so.?
540 %exclude %{_libdir}/libsvnjavahl*.so
541 %endif
542
543 %files devel
544 %defattr(644,root,root,755)
545 %attr(755,root,root) %{_libdir}/lib*.so
546 %{_libdir}/lib*.la
547 %if %{with perl} || %{with python}
548 %exclude %{_libdir}/lib*_swig_*.so
549 %endif
550 %if %{with javahl}
551 %exclude %{_libdir}/libsvnjavahl*.so
552 %endif
553 %{_includedir}/%{name}*
554 %{_examplesdir}/%{name}-%{version}
555
556 %files static
557 %defattr(644,root,root,755)
558 %{_libdir}/lib*.a
559
560 %if !%{with net_client_only}
561 %files svnserve
562 %defattr(644,root,root,755)
563 %attr(755,root,root) %{_bindir}/svnserve
564 %{_mandir}/man?/svnserve*
565 %dir %attr(750,svn,svn) /home/services/subversion
566 %dir %attr(750,svn,svn) /home/services/subversion/repos
567 %if %{with apache}
568 %attr(754,root,root) /etc/rc.d/init.d/svnserve
569 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/svnserve
570 %endif
571
572 %files tools
573 %defattr(644,root,root,755)
574 %attr(755,root,root) %{_bindir}/svn-hot-backup
575
576 %files -n bash-completion-subversion
577 %defattr(644,root,root,755)
578 /etc/bash_completion.d/%{name}
579
580 %if %{with javahl}
581 %files -n java-subversion
582 %defattr(644,root,root,755)
583 %attr(755,root,root) %{_libdir}/libsvnjavahl*.so.*.*.*
584 %attr(755,root,root) %{_libdir}/libsvnjavahl*.so.?
585 %attr(755,root,root) %{_libdir}/libsvnjavahl*.so
586 %{_javadir}/svn-javahl.jar
587 %endif
588
589 %if %{with python}
590 %files -n python-subversion
591 %defattr(644,root,root,755)
592 %doc tools/backup/*.py tools/examples/*.py
593 %dir %{py_sitedir}/svn
594 %dir %{py_sitedir}/libsvn
595 %{py_sitedir}/svn/*.py[co]
596 %{py_sitedir}/libsvn/*.py[co]
597 %attr(755,root,root) %{py_sitedir}/libsvn/*.so
598 %{_examplesdir}/python-%{name}-%{version}
599 %attr(755,root,root) %{_libdir}/lib*_swig_py*.so*
600 %endif
601
602 %if %{with perl}
603 %files -n perl-subversion
604 %defattr(644,root,root,755)
605 %{perl_vendorarch}/SVN
606 %dir %{perl_vendorarch}/auto/SVN
607 %dir %{perl_vendorarch}/auto/SVN/*
608 %attr(755,root,root) %{perl_vendorarch}/auto/SVN/*/*.so
609 %{perl_vendorarch}/auto/SVN/*/*.bs
610 %{_mandir}/man3/*.3pm*
611 %attr(755,root,root) %{_libdir}/lib*_swig_perl*.so*
612 %endif
613
614 %if %{with ruby}
615 %files -n ruby-subversion
616 %defattr(644,root,root,755)
617 %{_datadir}/ri/*.*/site/Svn
618 %{_datadir}/ri/*.*/site/Time
619 %{_datadir}/ri/*.*/site/Uconv
620 %{_datadir}/ri/*.*/site/*.rid
621 %{_datadir}/ri/*.*/site/Kernel/*
622 %{_datadir}/ri/*.*/site/OptionParser/*
623 %{_libdir}/ruby/site_ruby/svn
624 %endif
625
626 %if %{with apache}
627 %files -n apache-mod_dav_svn
628 %defattr(644,root,root,755)
629 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{apacheconfdir}/*_mod_dav_svn.conf
630 %attr(755,root,root) %{apachelibdir}/mod_dav_svn.so
631
632 %files -n apache-mod_authz_svn
633 %defattr(644,root,root,755)
634 %doc subversion/mod_authz_svn/INSTALL
635 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{apacheconfdir}/*_mod_authz_svn.conf
636 %attr(755,root,root) %{apachelibdir}/mod_authz_svn.so
637 %endif
638
639 %endif # net_client_only
This page took 0.144442 seconds and 4 git commands to generate.