]> git.pld-linux.org Git - packages/subversion.git/blob - subversion.spec
- updated to 1.0.0
[packages/subversion.git] / subversion.spec
1 #
2 # Conditional build:
3 %bcond_with     internal_neon           # build with internal neon
4 %bcond_with     net_client_only         # build only net client
5 #       
6 %include        /usr/lib/rpm/macros.python
7 %{!?with_net_client_only:%include       /usr/lib/rpm/macros.perl}
8 Summary:        A Concurrent Versioning system similar to but better than CVS
9 Summary(pl):    System kontroli wersji podobny, ale lepszy, ni¿ CVS
10 Summary(pt_BR): Sistema de versionamento concorrente
11 Name:           subversion
12 Version:        1.0.0
13 Release:        0
14 License:        Apache/BSD Style
15 Group:          Development/Version Control
16 Source0:        http://svn.collab.net/tarballs/%{name}-%{version}.tar.bz2
17 Source1:        %{name}-dav_svn.conf
18 Source2:        %{name}-authz_svn.conf
19 Source3:        %{name}-svnserve.init
20 Source4:        %{name}-svnserve.sysconfig
21 #Patch0:                %{name}-svnlook.patch
22 #Patch1:                %{name}-hot_backup_num.patch
23 URL:            http://subversion.tigris.org/
24 Requires:       %{name}-libs = %{version}-%{release}
25 %if %{with net_client_only}
26 %global apache_modules_api 0
27 %else
28 BuildRequires:  automake
29 BuildRequires:  apache-devel >= 2.0.47-0.6
30 BuildRequires:  db-devel >= 4.1.25
31 BuildRequires:  rpmbuild(macros) >= 1.120
32 BuildRequires:  swig >= 1.3.19
33 BuildRequires:  swig-python >= 1.3.19
34 BuildRequires:  swig-perl >= 1.3.19
35 BuildRequires:  perl-devel >= 5.8.0
36 BuildRequires:  rpm-perlprov
37 %endif
38 BuildRequires:  apr-devel >= 1:0.9.5
39 BuildRequires:  apr-util-devel >= 1:0.9.5
40 BuildRequires:  autoconf >= 2.59
41 BuildRequires:  bison
42 BuildRequires:  docbook-style-xsl >= 1.56
43 BuildRequires:  expat-devel
44 BuildRequires:  libtool >= 1.4-9
45 BuildRequires:  libxslt-progs
46 %{!?with_internal_neon:BuildRequires:   neon-devel >= 0.24.1}
47 BuildRequires:  python >= 2.2
48 BuildRequires:  rpm-pythonprov >= 4.0.2-50
49 BuildRequires:  texinfo
50 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
51
52 %define         _apachelibdir   /usr/%{_lib}/apache
53 %define         _libexecdir     %{_libdir}/svn
54
55 %description
56 The goal of the Subversion project is to build a version control
57 system that is a compelling replacement for CVS in the open source
58 community.
59
60 Our goals are:
61 - All current CVS features.
62 - Directories, renames, and file meta-data are versioned.
63 - Symbolic links, etc, are supported
64 - Commits are truly atomic.
65 - Branching and tagging are cheap (constant time) operations
66 - Repeated merges are handled gracefully
67 - Support for plug-in client side diff programs
68 - Natively client/server
69 - Client/server protocol sends diffs in both directions
70 - Costs are proportional to change size, not project size
71 - Internationalization
72 - Progressive multi-lingual support
73
74 %description -l pl
75 Celem projektu Subversion jest stworzenie systemu kontroli wersji jako
76 zamiennika dla CVS.
77
78 Cele projektu to:
79 - Wszystkie aktualne mo¿liwo¶ci CVS.
80 - Katalogi, zmiany nazw oraz meta-dane plików s± wersjonowane.
81 - Wsparcie dla linków symbolicznych itp.
82 - Commity s± w pe³ni atomowe.
83 - Branchowanie oraz tagowanie s± tanimi (sta³ymi w czasie) operacjami.
84 - Powtarzaj±ce merge.
85 - Wsparcie dla pluginów diff'a po stronie klienta.
86 - Natywny klient/serwer.
87 - Klient/Serwer przesy³aj± diffy w obu kierunkach.
88 - Koszty proporcjonalne do rozmiaru zmiany, a nie rozmiaru projektu.
89 - Internacjonalizacja.
90 - Postêpuj±ce wsparcie dla wielu jêzyków.
91
92 %description -l pt_BR
93 O objetivo do projeto Subversion é construir um sistema de controle de
94 versões que seja um substituto para o CVS (Concurrent Versioning
95 System) na comunidade opensource, fornecendo grandes melhorias.
96
97 %package libs
98 Summary:        Subversion libraries and modules
99 Summary(pl):    Biblioteka subversion oraz ³adowalne modu³y
100 Group:          Libraries
101 Obsoletes:      libsubversion0
102
103 %description libs
104 Subversion libraries and modules.
105
106 %description libs -l pl
107 Biblioteka subversion oraz ³adowalne modu³y.
108
109 %package devel
110 Summary:        Header files and develpment documentation for subversion
111 Summary(pl):    Pliki nag³ówkowe i dokumetacja do subversion
112 Summary(pt_BR): Arquivos de desenvolvimento para o Subversion
113 Group:          Development/Libraries
114 Requires:       %{name}-libs = %{version}-%{release}
115 Obsoletes:      libsubversion0-devel
116
117 %description devel
118 Header files and develpment documentation for subversion.
119
120 %description devel -l pl
121 Pliki nag³ówkowe i dokumetacja do subversion.
122
123 %description devel -l pt_BR
124 Este pacote provê os arquivos necessários para desenvolvedores
125 interagirem com o Subversion.
126
127 %package static
128 Summary:        Static subversion library
129 Summary(pl):    Biblioteka statyczna subversion
130 Summary(pt_BR): Sistema de versionamento concorrente
131 Group:          Development/Libraries
132 Requires:       %{name}-devel = %{version}
133 Obsoletes:      libsubversion0-static-devel
134
135 %description static
136 Static subversion library.
137
138 %description static -l pl
139 Biblioteka statyczna subversion.
140
141 %description static -l pt_BR
142 Este pacote provê um cliente estático do subversion.
143
144 %package svnserve
145 Summary:        Subversion svnserve
146 Summary(pl):    Subversion svnserve
147 Group:          Networking/Daemons
148 PreReq:         rc-scripts
149 Requires(post,preun):   /sbin/chkconfig
150 Requires:       %{name} = %{version}-%{release}
151
152 %description svnserve
153 Subversion svnserve server.
154
155 %description svnserve -l pl
156 Serwer subversion svnserve.
157
158 %package tools
159 Summary:        Subversion tools and scripts
160 Summary(pl):    Narzêdzia oraz skrypty dla subversion
161 Summary(pt_BR): Módulos python para acessar os recursos do Subversion
162 Group:          Applications
163 %pyrequires_eq  python
164 Requires:       python-rcsparse >= 0.1-0.20031026.0
165 Requires:       python-subversion = %{version}
166 Requires:       %{name} = %{version}-%{release}
167
168 %description tools
169 Subversion tools and scripts.
170
171 %description tools -l pl
172 Narzêdzia oraz skrypty dla subversion.
173
174 %package -n python-subversion
175 Summary:        Subversion python bindings
176 Summary(pl):    Dowi±zania do subversion dla pythona
177 Summary(pt_BR): Módulos python para acessar os recursos do Subversion
178 Group:          Development/Languages/Python
179 %pyrequires_eq  python
180 Obsoletes:      subversion-python
181 Requires:       %{name}-libs = %{version}-%{release}
182
183 %description -n python-subversion
184 Subversion python bindings.
185
186 %description -n python-subversion -l pl
187 Dowi±zania do subversion dla pythona.
188
189 %description -n python-subversion -l pt_BR
190 Módulos python para acessar os recursos do Subversion.
191
192 %package -n perl-subversion
193 Summary:        Subversion perl bindings
194 Summary(pl):    Dowi±zania do subversion dla perla
195 Summary(pt_BR): Módulos perl para acessar os recursos do Subversion
196 Group:          Development/Languages/Perl
197 Obsoletes:      subversion-perl
198 Requires:       %{name}-libs = %{version}-%{release}
199
200 %description -n perl-subversion
201 Subversion perl bindings.
202
203 %description -n perl-subversion -l pl
204 Dowi±zania do subversion dla perl.
205
206 %description -n perl-subversion -l pt_BR
207 Módulos perl para acessar os recursos do Subversion.
208
209 %package -n apache-mod_dav_svn
210 Summary:        Apache module: Subversion Server
211 Summary(pl):    Modu³ apache: Serwer Subversion
212 Group:          Networking/Daemons
213 Requires:       apache >= 2.0.47
214 Requires:       apache(modules-api) = %{apache_modules_api}
215 Requires:       apache-mod_dav
216 Requires:       %{name} = %{version}-%{release}
217
218 %description -n apache-mod_dav_svn
219 Apache module: Subversion Server.
220
221 %description -n apache-mod_dav_svn -l pl
222 Modu³ apache: Serwer Subversion.
223
224 %package -n apache-mod_authz_svn
225 Summary:        Apache module: Subversion Server - path-based authorization
226 Summary(pl):    Modu³ apache: autoryzacja na podstawie ¶cie¿ki dla serwera Subversion
227 Group:          Networking/Daemons
228 Requires:       apache-mod_dav_svn = %{version}-%{release}
229 Requires:       apache >= 2.0.47
230 Requires:       apache(modules-api) = %{apache_modules_api}
231
232 %description -n apache-mod_authz_svn
233 Apache module: Subversion Server - path-based authorization.
234
235 %description -n apache-mod_authz_svn -l pl
236 Modu³ apache: autoryzacja na podstawie ¶cie¿ki dla serwera Subversion.
237
238 %prep
239 %setup -q
240 #%patch0 -p0
241 #%patch1 -p1
242
243 %build
244 cp -f /usr/share/automake/config.sub ac-helpers
245 chmod +x ./autogen.sh && ./autogen.sh
246
247 # don't enable dso - currently it's broken
248 %configure \
249 %if %{with net_client_only}
250         --without-apache \
251         --without-swig \
252         --without-apxs \
253         --without-berkeley-db \
254 %else
255         --disable-dso \
256         --disable-mod-activation \
257         --with-apxs=%{_sbindir}/apxs \
258         --with-berkeley-db=%{_includedir}/db4:%{_libdir} \
259 %endif
260         %{!?with_internal_neon:--with-neon=%{_prefix}} \
261         --with-apr=%{_bindir}/apr-config \
262         --with-apr-util=%{_bindir}/apu-config
263
264 %{__make}
265
266 %if ! %{with net_client_only}
267 # python
268 %{__make} swig-py \
269         swig_pydir=%{py_sitedir}/libsvn \
270         swig_pydir_extra=%{py_sitedir}/svn
271 # perl
272 bdir=$(pwd)
273 %{__make} install-swig-pl-lib \
274         LC_ALL=C \
275         DESTDIR=${bdir}/swig-pl-lib-buildroot
276 %{__make}
277 cd subversion/bindings/swig/perl
278 env APR_CONFIG=%{_bindir}/apr-config \
279     APU_CONFIG=%{_bindir}/apu-config \
280         %{__perl} Makefile.PL \
281         INSTALLDIRS=vendor
282 env LIBRARY_PATH=${bdir}/swig-pl-lib-buildroot%{_libdir} %{__make}
283 cd ../../../../
284 %endif
285
286 # build documentation; build process for documentation is severely
287 # braindamaged -- authors suggests to untar docbook distribution in
288 # build directory, hence the hack here
289 ln -s /usr/share/sgml/docbook/xsl-stylesheets doc/book/tools/xsl
290 %{__make} -C doc/book all-html
291
292 # prepare for %%doc below
293 mv -f doc/book/book/html-chunk svn-handbook
294 mkdir svn-handbook/images/
295 cp -f doc/book/book/images/*.png svn-handbook/images/
296
297 %install
298 rm -rf $RPM_BUILD_ROOT
299 install -d $RPM_BUILD_ROOT/etc/{rc.d/init.d,sysconfig,bash_completion.d} \
300         $RPM_BUILD_ROOT{%{_sysconfdir}/httpd/httpd.conf,%{_apachelibdir},%{_infodir}} \
301         $RPM_BUILD_ROOT%{_examplesdir}/{%{name}-%{version}/auth_provider,python-%{name}-%{version}}
302
303 %{__make} install \
304         LC_ALL=C \
305         %{!?with_net_client_only:install-swig-py} \
306         DESTDIR=$RPM_BUILD_ROOT \
307         swig_pydir=%{py_sitedir}/libsvn \
308         swig_pydir_extra=%{py_sitedir}/svn
309
310 %if ! %{with net_client_only}
311 %{__make} install-swig-pl-lib \
312         LC_ALL=C \
313         DESTDIR=$RPM_BUILD_ROOT
314 %{__make} -C subversion/bindings/swig/perl install \
315         DESTDIR=$RPM_BUILD_ROOT
316 %endif
317
318 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/httpd/httpd.conf/65_mod_dav_svn.conf
319 install %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/httpd/httpd.conf/66_mod_authz_svn.conf
320 install %{SOURCE3} $RPM_BUILD_ROOT/etc/rc.d/init.d/svnserve
321 install %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/svnserve
322 install doc/programmer/design/*.info* $RPM_BUILD_ROOT%{_infodir}/
323
324 %if ! %{with net_client_only}
325 install tools/cvs2svn/cvs2svn.py        $RPM_BUILD_ROOT%{_bindir}/cvs2svn
326 install tools/cvs2svn/cvs2svn.1         $RPM_BUILD_ROOT%{_mandir}/man1
327 cp tools/cvs2svn/README tools/cvs2svn/README.cvs2svn
328 install tools/backup/hot-backup.py $RPM_BUILD_ROOT%{_bindir}/svn-hot-backup
329
330 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
331 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
332 find $RPM_BUILD_ROOT%{py_sitedir} -name "*.py" -o -name "*.a" -o -name "*.la" | xargs rm -f
333 install tools/examples/*.py $RPM_BUILD_ROOT%{_examplesdir}/python-%{name}-%{version}
334 %endif
335
336 install tools/client-side/bash_completion $RPM_BUILD_ROOT/etc/bash_completion.d/%{name}
337 install tools/examples/*.c $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
338 install tools/examples/auth_provider/*.c $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/auth_provider
339
340 %clean
341 rm -rf $RPM_BUILD_ROOT
342
343 %post devel
344 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
345
346 %postun devel
347 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
348
349 %post   libs -p /sbin/ldconfig
350 %postun libs -p /sbin/ldconfig
351
352 %post svnserve
353 if [ -f /var/lock/subsys/svnserve ]; then
354         /etc/rc.d/init.d/svnserve restart 1>&2
355 else
356         echo "Run \"/etc/rc.d/init.d/svnserve start\" to start subversion svnserve daemon."
357 fi
358
359 %preun svnserve
360 if [ "$1" = "0" ]; then
361         if [ -f /var/lock/subsys/svnserve ]; then
362                 /etc/rc.d/init.d/svnserve restart 1>&2
363         fi
364 fi
365
366 %post -n apache-mod_dav_svn
367 if [ -f /var/lock/subsys/httpd ]; then
368         /etc/rc.d/init.d/httpd restart 1>&2
369 else
370         echo "Run \"/etc/rc.d/init.d/httpd start\" to start apache http daemon."
371 fi
372
373 %preun -n apache-mod_dav_svn
374 if [ "$1" = "0" ]; then
375         if [ -f /var/lock/subsys/httpd ]; then
376                 /etc/rc.d/init.d/httpd restart 1>&2
377         fi
378 fi
379
380 %files
381 %defattr(644,root,root,755)
382 %doc BUGS CHANGES COPYING INSTALL README
383 %doc svn-handbook doc/book/misc-docs/misc-docs.html
384 %doc tools/hook-scripts/*.{pl,py,example}
385 %doc tools/hook-scripts/mailer/*.{py,example}
386 %doc tools/xslt/*
387 %attr(755,root,root) %{_bindir}/svn*
388 %exclude %{_bindir}/svnserve
389 %exclude %{_bindir}/svn-hot-backup
390 %{_mandir}/man1/*
391 %{_mandir}/man5/*
392 %{_mandir}/man8/*
393 %exclude %{_mandir}/man?/svnserve*
394 %{?with_internal_neon:%exclude %{_mandir}/man1/neon*}
395
396 %files libs
397 %defattr(644,root,root,755)
398 %attr(755,root,root) %{_libdir}/lib*.so.*
399
400 %files devel
401 %defattr(644,root,root,755)
402 %{_includedir}/%{name}*
403 %attr(755,root,root) %{_libdir}/lib*.so
404 %{_libdir}/lib*.la
405 %{_infodir}/svn*
406 %{_examplesdir}/%{name}-%{version}
407
408 %files static
409 %defattr(644,root,root,755)
410 %{_libdir}/lib*.a
411
412 %if ! %{with net_client_only}
413 %files svnserve
414 %defattr(644,root,root,755)
415 %attr(755,root,root) %{_bindir}/svnserve
416 %{_mandir}/man?/svnserve*
417 %attr(754,root,root) /etc/rc.d/init.d/svnserve
418 %attr(640,root,root) %config(noreplace) %verify(not mtime md5 size) /etc/sysconfig/svnserve
419
420 %files tools
421 %defattr(644,root,root,755)
422 %doc tools/cvs2svn/README*
423 %attr(755,root,root) %{_bindir}/cvs*
424 %attr(755,root,root) %{_bindir}/svn-hot-backup
425 /etc/bash_completion.d/%{name}
426 %{_mandir}/man1/cvs*
427
428 %files -n python-subversion
429 %defattr(644,root,root,755)
430 %doc tools/backup/*.py tools/examples/*.py
431 %dir %{py_sitedir}/svn
432 %dir %{py_sitedir}/libsvn
433 %{py_sitedir}/svn/*.py[co]
434 %{py_sitedir}/libsvn/*.py[co]
435 %attr(755,root,root) %{py_sitedir}/libsvn/*.so
436 %{_examplesdir}/python-%{name}-%{version}
437
438 %files -n perl-subversion
439 %defattr(644,root,root,755)
440 %{perl_vendorarch}/SVN
441 %dir %{perl_vendorarch}/auto/SVN
442 %dir %{perl_vendorarch}/auto/SVN/*
443 %attr(755,root,root) %{perl_vendorarch}/auto/SVN/*/*.so
444 %{perl_vendorarch}/auto/SVN/*/*.bs
445 %{_mandir}/man3/*.3pm*
446
447 %files -n apache-mod_dav_svn
448 %defattr(644,root,root,755)
449 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/httpd/httpd.conf/*_mod_dav_svn.conf
450 %attr(755,root,root) %{_apachelibdir}/mod_dav_svn.so
451
452 %files -n apache-mod_authz_svn
453 %defattr(644,root,root,755)
454 %doc subversion/mod_authz_svn/INSTALL
455 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/httpd/httpd.conf/*_mod_authz_svn.conf
456 %attr(755,root,root) %{_apachelibdir}/mod_authz_svn.so
457 %endif
This page took 0.108736 seconds and 4 git commands to generate.