]> git.pld-linux.org Git - packages/subversion.git/blob - subversion.spec
- release 4
[packages/subversion.git] / subversion.spec
1 # TODO:
2 # - remove net_client_only and add db bcond (then without apache and
3 #   without db => net_client_only - spec will be more simpler, I think)
4 # - finish ruby
5 # - http://subversion.tigris.org/issues/show_bug.cgi?id=2753
6 #
7 # Conditional build:
8 %bcond_with     net_client_only         # build only net client
9 %bcond_without  neon                    # use serf instead of neon
10 %bcond_without  python                  # build without python bindings (broken)
11 %bcond_without  perl                    # build without perl bindings
12 %bcond_without  ruby                    # build without ruby bindings
13 %bcond_without  apache                  # build without apache support (webdav, etc)
14 %bcond_without  javahl                  # build without javahl support (Java high-level bindings)
15 %bcond_without  tests                   # don't perform "make check"
16 %bcond_without  kwallet                 # build without kde4 wallet support
17 %bcond_without  gnome                   # build without gnome keyring support
18
19 %{!?with_net_client_only:%include       /usr/lib/rpm/macros.perl}
20 %define apxs    /usr/sbin/apxs
21 %define pdir    SVN
22 %define pnam    _Core
23
24 %if %{with neon}
25 %define webdavlib       neon
26 %else
27 %define webdavlib       serf
28 %endif
29 Summary:        A Concurrent Versioning system similar to but better than CVS
30 Summary(pl.UTF-8):      System kontroli wersji podobny, ale lepszy, niż CVS
31 Summary(pt_BR.UTF-8):   Sistema de versionamento concorrente
32 Name:           subversion
33 Version:        1.6.13
34 Release:        4
35 License:        Apache/BSD-like
36 Group:          Development/Version Control
37 Source0:        http://subversion.tigris.org/downloads/%{name}-%{version}.tar.bz2
38 # Source0-md5:  7ae1c827689f21cf975804005be30aeb
39 Source1:        %{name}-dav_svn.conf
40 Source2:        %{name}-authz_svn.conf
41 Source3:        %{name}-svnserve.init
42 Source4:        %{name}-svnserve.sysconfig
43 # current subversion tarball has correct *.swg files
44 # but after regeneration these are broken again, so
45 # we still need this script
46 Source5:        %{name}-convert-typemaps-to-ifdef.py
47 Patch0:         %{name}-home_etc.patch
48 Patch1:         %{name}-DESTDIR.patch
49 Patch2:         %{name}-ruby-datadir-path.patch
50 URL:            http://subversion.apache.org/
51 %if %{with net_client_only}
52 %global apache_modules_api 0
53 %else
54 %{?with_apache:BuildRequires:   apache-devel >= 2.2.0-8}
55 BuildRequires:  automake
56 BuildRequires:  db-devel >= 4.1.25
57 BuildRequires:  rpmbuild(macros) >= 1.583
58 %if %{with perl}
59 BuildRequires:  perl-devel >= 1:5.8.0
60 BuildRequires:  rpm-perlprov >= 4.1-13
61 BuildRequires:  swig-perl >= 1.3.24
62 %endif
63 %if %{with python}
64 BuildRequires:  python-ctypesgen
65 BuildRequires:  python-devel >= 2.2
66 BuildRequires:  swig-python >= 1.3.24
67 %endif
68 %if %{with ruby}
69 BuildRequires:  ruby-devel
70 BuildRequires:  swig-ruby >= 1.3.24
71 %endif
72 %if %{with javahl}
73 BuildRequires:  jdk
74 %endif
75 BuildRequires:  cyrus-sasl-devel
76 %endif
77 BuildRequires:  apr-devel >= 1:1.0.0
78 BuildRequires:  apr-util-devel >= 1:1.2.8-3
79 BuildRequires:  autoconf >= 2.59
80 BuildRequires:  bison
81 BuildRequires:  expat-devel
82 BuildRequires:  gettext-devel
83 %{?with_gnome:BuildRequires:    libgnome-keyring-devel}
84 %{?with_kwallet:BuildRequires:  kde4-kdelibs-devel}
85 BuildRequires:  libtool >= 1.4-9
86 BuildRequires:  pkgconfig
87 BuildRequires:  sed >= 4.0
88 BuildRequires:  sqlite3-devel >= 3.6.11
89 BuildRequires:  texinfo
90 BuildRequires:  which
91 %if %{with neon}
92 BuildRequires:  neon-devel >= 0.26.0
93 %else
94 BuildRequires:  serf-devel
95 %endif
96 BuildRequires:  python >= 2.2
97 BuildRequires:  python-modules >= 2.2
98 Requires:       %{name}-libs = %{version}-%{release}
99 %requires_ge    sqlite3
100 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
101
102 %define         _libexecdir             %{_libdir}/svn
103 %define         apacheconfdir   %(%{apxs} -q SYSCONFDIR 2>/dev/null)/conf.d
104 %define         apachelibdir    %(%{apxs} -q LIBEXECDIR 2>/dev/null)
105
106 %define         skip_post_check_so      libsvn_swig_py-1.so.* libsvn_swig_perl-1.so.*
107
108 %description
109 The goal of the Subversion project is to build a version control
110 system that is a compelling replacement for CVS in the open source
111 community.
112
113 Our goals are:
114 - All current CVS features.
115 - Directories, renames, and file meta-data are versioned.
116 - Symbolic links, etc, are supported
117 - Commits are truly atomic.
118 - Branching and tagging are cheap (constant time) operations
119 - Repeated merges are handled gracefully
120 - Support for plug-in client side diff programs
121 - Natively client/server
122 - Client/server protocol sends diffs in both directions
123 - Costs are proportional to change size, not project size
124 - Internationalization
125 - Progressive multi-lingual support
126
127 %description -l pl.UTF-8
128 Celem projektu Subversion jest stworzenie systemu kontroli wersji jako
129 zamiennika dla CVS.
130
131 Cele projektu to:
132 - Wszystkie aktualne możliwości CVS.
133 - Katalogi, zmiany nazw oraz metadane plików są wersjonowane.
134 - Obsługa dowiązań symbolicznych itp.
135 - Commity są w pełni atomowe.
136 - Branchowanie oraz tagowanie są tanimi (stałymi w czasie) operacjami.
137 - Dobra obsługa powtarzanego łączenia (merge).
138 - Obsługa wtyczek diff po stronie klienta.
139 - Natywny klient/serwer.
140 - Klient/Serwer przesyłają diffy w obu kierunkach.
141 - Koszty proporcjonalne do rozmiaru zmiany, a nie rozmiaru projektu.
142 - Internacjonalizacja.
143 - Postępujące wsparcie dla wielu języków.
144
145 %description -l pt_BR.UTF-8
146 O objetivo do projeto Subversion é construir um sistema de controle de
147 versões que seja um substituto para o CVS (Concurrent Versioning
148 System) na comunidade opensource, fornecendo grandes melhorias.
149
150 %package libs
151 Summary:        Subversion libraries and modules
152 Summary(pl.UTF-8):      Biblioteka subversion oraz ładowalne moduły
153 Group:          Libraries
154 %{?with_neon:Requires:  neon >= 0.26.0}
155 Obsoletes:      libsubversion0
156
157 %description libs
158 Subversion libraries and modules.
159
160 %description libs -l pl.UTF-8
161 Biblioteka subversion oraz ładowalne moduły.
162
163 %package devel
164 Summary:        Header files and develpment documentation for subversion
165 Summary(pl.UTF-8):      Pliki nagłówkowe i dokumetacja do subversion
166 Summary(pt_BR.UTF-8):   Arquivos de desenvolvimento para o Subversion
167 Group:          Development/Libraries
168 Requires:       %{name}-libs = %{version}-%{release}
169 Requires:       apr-util-devel >= 1:1.0.0
170 %{?with_neon:Requires:  neon-devel >= 0.26.0}
171 Obsoletes:      libsubversion0-devel
172
173 %description devel
174 Header files and develpment documentation for subversion.
175
176 %description devel -l pl.UTF-8
177 Pliki nagłówkowe i dokumetacja do subversion.
178
179 %description devel -l pt_BR.UTF-8
180 Este pacote provê os arquivos necessários para desenvolvedores
181 interagirem com o Subversion.
182
183 %package static
184 Summary:        Static subversion library
185 Summary(pl.UTF-8):      Biblioteka statyczna subversion
186 Summary(pt_BR.UTF-8):   Sistema de versionamento concorrente
187 Group:          Development/Libraries
188 Requires:       %{name}-devel = %{version}
189 Obsoletes:      libsubversion0-static-devel
190
191 %description static
192 Static subversion library.
193
194 %description static -l pl.UTF-8
195 Biblioteka statyczna subversion.
196
197 %description static -l pt_BR.UTF-8
198 Este pacote provê um cliente estático do subversion.
199
200 %package svnserve
201 Summary:        Subversion svnserve
202 Summary(pl.UTF-8):      Subversion svnserve
203 Group:          Networking/Daemons
204 Requires(post,preun):   /sbin/chkconfig
205 Requires(postun):       /usr/sbin/groupdel
206 Requires(postun):       /usr/sbin/userdel
207 Requires(pre):  /bin/id
208 Requires(pre):  /usr/bin/getgid
209 Requires(pre):  /usr/lib/rpm/user_group.sh
210 Requires(pre):  /usr/sbin/groupadd
211 Requires(pre):  /usr/sbin/useradd
212 Requires(pre):  /usr/sbin/usermod
213 Requires:       %{name} = %{version}-%{release}
214 Requires:       rc-scripts
215 Provides:       group(svn)
216 Provides:       user(svn)
217
218 %description svnserve
219 Subversion svnserve server.
220
221 %description svnserve -l pl.UTF-8
222 Serwer subversion svnserve.
223
224 %package tools
225 Summary:        Subversion tools and scripts
226 Summary(pl.UTF-8):      Narzędzia oraz skrypty dla subversion
227 Summary(pt_BR.UTF-8):   Módulos python para acessar os recursos do Subversion
228 Group:          Applications
229 %pyrequires_eq  python
230 Requires:       %{name} = %{version}-%{release}
231 Requires:       python-subversion = %{version}
232
233 %description tools
234 Subversion tools and scripts.
235
236 %description tools -l pl.UTF-8
237 Narzędzia oraz skrypty dla subversion.
238
239 %package -n bash-completion-subversion
240 Summary:        bash completion for subversion
241 Summary(pl.UTF-8):      Dopełnienia basha dla subversion
242 Group:          Applications/Shells
243 Requires:       %{name} = %{version}-%{release}
244 Requires:       bash-completion
245 Conflicts:      %{name}-tools <= 1.1.0-0.rc6.1
246
247 %description -n bash-completion-subversion
248 Bash completion for subversion.
249
250 %description -n bash-completion-subversion -l pl.UTF-8
251 Dopełnienia basha dla subversion.
252
253 %package -n java-subversion
254 Summary:        Subversion Java bindings
255 Summary(pl.UTF-8):      Dowiązania do Subversion dla Javy
256 Group:          Development/Languages/Java
257 Requires:       %{name}-libs = %{version}-%{release}
258
259 %description -n java-subversion
260 This is a set of Java classes which provide the functionality of
261 subversion-libs, the Subversion libraries. It is useful if you want
262 to, for example, write a Java class that manipulates a Subversion
263 repository or working copy. See the 'subversion' package for more
264 information.
265
266 %description -n java-subversion -l pl.UTF-8
267 Ten pakiet zawiera zestaw klas Javy udostępniających funkcjonalność
268 subversion-libs, czyli bibliotek Subversion. Jest przydatny przy
269 pisaniu klas Javy np. modyfikujących repozytorium Subversion lub kopię
270 roboczą. Więcej informacji w pakiecie subversion.
271
272 %package -n python-subversion
273 Summary:        Subversion Python bindings
274 Summary(pl.UTF-8):      Dowiązania do Subversion dla Pythona
275 Summary(pt_BR.UTF-8):   Módulos Python para acessar os recursos do Subversion
276 Group:          Development/Languages/Python
277 %pyrequires_eq  python
278 Requires:       %{name}-libs = %{version}-%{release}
279 Obsoletes:      subversion-python
280
281 %description -n python-subversion
282 Subversion Python bindings.
283
284 %description -n python-subversion -l pl.UTF-8
285 Dowiązania do Subversion dla Pythona.
286
287 %description -n python-subversion -l pt_BR.UTF-8
288 Módulos Python para acessar os recursos do Subversion.
289
290 %package -n python-csvn
291 Summary:        CTypes Subversion Python bindings
292 Summary(pl.UTF-8):      Dowiązania do Subversion dla Pythona
293 Summary(pt_BR.UTF-8):   Módulos Python para acessar os recursos do Subversion
294 Group:          Development/Languages/Python
295 %pyrequires_eq  python
296 Requires:       %{name}-libs = %{version}-%{release}
297
298 %description -n python-csvn
299 Subversion CTypes Python bindings.
300
301 %description -n python-csvn -l pl.UTF-8
302 Dowiązania do Subversion dla Pythona używające CTypes.
303
304 %description -n python-csvn -l pt_BR.UTF-8
305 Módulos Python para acessar os recursos do Subversion.
306
307 %package -n perl-subversion
308 Summary:        Subversion Perl bindings
309 Summary(pl.UTF-8):      Dowiązania do Subversion dla Perla
310 Summary(pt_BR.UTF-8):   Módulos Perl para acessar os recursos do Subversion
311 Group:          Development/Languages/Perl
312 Requires:       %{name}-libs = %{version}-%{release}
313 Obsoletes:      subversion-perl
314
315 %description -n perl-subversion
316 Subversion Perl bindings.
317
318 %description -n perl-subversion -l pl.UTF-8
319 Dowiązania do Subversion dla Perla.
320
321 %description -n perl-subversion -l pt_BR.UTF-8
322 Módulos Perl para acessar os recursos do Subversion.
323
324 %package -n ruby-subversion
325 Summary:        Subversion Ruby bindings
326 Summary(pl.UTF-8):      Dowiązania do Subversion dla języka Ruby
327 Summary(pt_BR.UTF-8):   Módulos Ruby para acessar os recursos do Subversion
328 Group:          Development/Languages
329 Requires:       %{name}-libs = %{version}-%{release}
330 Obsoletes:      subversion-ruby
331
332 %description -n ruby-subversion
333 Subversion Ruby bindings.
334
335 %description -n ruby-subversion -l pl.UTF-8
336 Dowiązania do Subversion dla języka Ruby.
337
338 %description -n ruby-subversion -l pt_BR.UTF-8
339 Módulos Ruby para acessar os recursos do Subversion.
340
341 %package -n apache-mod_dav_svn
342 Summary:        Apache module: Subversion Server
343 Summary(pl.UTF-8):      Moduł apache: Serwer Subversion
344 Group:          Networking/Daemons
345 Requires:       %{name} = %{version}-%{release}
346 Requires:       apache(modules-api) = %apache_modules_api
347 Requires:       apache-mod_dav
348
349 %description -n apache-mod_dav_svn
350 Apache module: Subversion Server.
351
352 %description -n apache-mod_dav_svn -l pl.UTF-8
353 Moduł apache: Serwer Subversion.
354
355 %package -n apache-mod_authz_svn
356 Summary:        Apache module: Subversion Server - path-based authorization
357 Summary(pl.UTF-8):      Moduł apache: autoryzacja na podstawie ścieżki dla serwera Subversion
358 Group:          Networking/Daemons
359 Requires:       apache(modules-api) = %apache_modules_api
360 Requires:       apache-mod_dav_svn = %{version}-%{release}
361
362 %description -n apache-mod_authz_svn
363 Apache module: Subversion Server - path-based authorization.
364
365 %description -n apache-mod_authz_svn -l pl.UTF-8
366 Moduł apache: autoryzacja na podstawie ścieżki dla serwera Subversion.
367
368 %package -n gnome-keyring-subversion
369 Summary:        Subversion module for Gnome Keyring
370 Summary(pl.UTF-8):      Moduł subversion dla zarządcy kluczy Gnome
371 Group:          X11/Applications
372
373 %description -n gnome-keyring-subversion
374 Subversion module for Gnome Keyring.
375
376 %description -n gnome-keyring-subversion -l pl.UTF-8
377 Moduł subversion dla zarządcy kluczy Gnome.
378
379 %package -n kde4-kwallet-subversion
380 Summary:        Subversion module for KDE Wallet
381 Summary(pl.UTF-8):      Moduł subversion dla Portfela KDE
382 Group:          X11/Applications
383
384 %description -n kde4-kwallet-subversion
385 Subversion module for KDE Wallet.
386
387 %description -n kde4-kwallet-subversion -l pl.UTF-8
388 Moduł subversion dla Portfela KDE.
389
390 %prep
391 %setup -q
392 rm -rf apr apr-util neon
393 %patch0 -p0
394 %patch1 -p1
395 %patch2 -p0
396
397 sed -i -e 's#serf_prefix/lib#serf_prefix/%{_lib}#g' build/ac-macros/serf.m4
398
399 # serf.m4 macro is broken and ignores --without serf
400 %{?with_neon:sed -i -e 's#serf_found="yes"#serf_found="no"#g' build/ac-macros/serf.m4}
401
402 %build
403 rm subversion/bindings/swig/proxy/*.swg
404 cd subversion/bindings/swig && python "%{SOURCE5}" && cd ../../..
405 cp -f /usr/share/automake/config.sub ac-helpers
406 chmod +x ./autogen.sh && ./autogen.sh
407
408 %configure \
409         --with-editor=vi \
410         --with-zlib=%{_libdir} \
411 %if %{with net_client_only}
412         --without-apache \
413         --without-swig \
414         --without-apxs \
415         --without-berkeley-db \
416 %else
417         --disable-runtime-module-search \
418         --disable-mod-activation \
419         --with-berkeley-db="db.h:%{_includedir}:%{_libdir}:db" \
420 %if %{with apache}
421         --with-apxs=%{_sbindir}/apxs \
422 %else
423         --without-apache \
424         --without-apxs \
425 %endif
426 %if !%{with python} && !%{with perl} && !%{with ruby}
427         --without-swig \
428 %endif
429         %{?with_python:--with-ctypesgen=%{_bindir}/ctypesgen.py} \
430         --%{?with_javahl:en}%{!?with_javahl:dis}able-javahl \
431 %endif
432         --with-jdk="%{java_home}" \
433         --without-jikes \
434 %if %{with neon}
435         --without-serf \
436         --with-neon=%{_prefix} \
437         --disable-neon-version-check \
438 %else
439         --with-serf=%{_prefix} \
440         --without-neon \
441 %endif
442         --with-apr=%{_bindir}/apr-1-config \
443         --with-apr-util=%{_bindir}/apu-1-config \
444 %if %{with kwallet}
445         --with-kwallet \
446 %endif
447 %if %{with gnome}
448         --with-gnome-keyring
449 %endif
450
451 %{__make} -j1
452
453 %if !%{with net_client_only}
454 # python
455 %if %{with python}
456 # ctypes bindings
457 %{__make} ctypes-python
458 # swig bindings
459 %{__make} swig-py \
460         swig_pydir=%{py_sitedir}/libsvn \
461         swig_pydir_extra=%{py_sitedir}/svn
462 %endif
463 # perl
464 %if %{with perl}
465 %{__make} -j1 swig-pl-lib
466 odir=$(pwd)
467 cd subversion/bindings/swig/perl/native
468 %{__perl} Makefile.PL INSTALLDIRS=vendor
469 %{__make} -j1
470 cd $odir
471 %endif
472 %if %{with javahl}
473 %{__make} -j1 javahl \
474         javahl_javadir="%{_javadir}"
475 %endif
476 # ruby
477 %if %{with ruby}
478 %{__make} swig-rb
479 %endif
480 %endif
481
482 %if %{with tests}
483 %{__make} check
484 %if %{with python}
485 %{__make} check-ctypes-python
486 %{__make} check-swig-py
487 %endif
488 %if %{with perl}
489 %{__make} check-swig-pl
490 %endif
491 %if %{with ruby}
492 %{__make} check-swig-rb
493 %endif
494 %endif
495
496 %install
497 rm -rf $RPM_BUILD_ROOT
498 install -d $RPM_BUILD_ROOT/etc/{rc.d/init.d,sysconfig,bash_completion.d} \
499         $RPM_BUILD_ROOT{%{apacheconfdir},%{apachelibdir},%{_infodir}} \
500         $RPM_BUILD_ROOT%{_examplesdir}/{%{name}-%{version},python-%{name}-%{version}} \
501         $RPM_BUILD_ROOT/home/services/subversion{,/repos}
502
503 %{__make} install -j1 \
504 %if %{with javahl}
505         install-javahl \
506         javahl_javadir="%{_javadir}" \
507 %endif
508 %if !%{with net_client_only}
509 %if %{with python}
510         install-swig-py \
511         install-ctypes-python \
512 %endif
513 %if %{with ruby}
514         install-swig-rb install-swig-rb-doc \
515 %endif
516 %endif
517         APACHE_LIBEXECDIR="$(%{_sbindir}/apxs -q LIBEXECDIR)" \
518         DESTDIR=$RPM_BUILD_ROOT \
519         swig_pydir=%{py_sitedir}/libsvn \
520         swig_pydir_extra=%{py_sitedir}/svn
521
522 %if !%{with net_client_only} && %{with perl}
523 %{__make} install-swig-pl-lib \
524         DESTDIR=$RPM_BUILD_ROOT
525 %{__make} -C subversion/bindings/swig/perl/native install \
526         DESTDIR=$RPM_BUILD_ROOT \
527         PREFIX=$RPM_BUILD_ROOT%{_prefix} \
528         LIBDIR=$RPM_BUILD_ROOT%{_libdir}
529 %endif
530
531 %if %{with apache}
532 install %{SOURCE1} $RPM_BUILD_ROOT%{apacheconfdir}/65_mod_dav_svn.conf
533 install %{SOURCE2} $RPM_BUILD_ROOT%{apacheconfdir}/66_mod_authz_svn.conf
534 install %{SOURCE3} $RPM_BUILD_ROOT/etc/rc.d/init.d/svnserve
535 install %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/svnserve
536 %endif
537
538 %if !%{with net_client_only}
539 install tools/backup/hot-backup.py $RPM_BUILD_ROOT%{_bindir}/svn-hot-backup
540 %if %{with python}
541 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
542 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
543 find $RPM_BUILD_ROOT%{py_sitedir} -name "*.py" -o -name "*.a" -o -name "*.la" | xargs rm -f
544 install tools/examples/*.py $RPM_BUILD_ROOT%{_examplesdir}/python-%{name}-%{version}
545 %endif
546 %endif
547
548 install tools/client-side/bash_completion $RPM_BUILD_ROOT/etc/bash_completion.d/%{name}
549 install tools/examples/*.c $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
550
551 %find_lang %{name}
552
553 %{?with_javahl:rm $RPM_BUILD_ROOT%{_libdir}/libsvnjavahl*.{la,a}}
554 rm -f $RPM_BUILD_ROOT%{_libdir}/libsvn_swig*.{la,a}
555 rm -f $RPM_BUILD_ROOT%{_libdir}/ruby/site_ruby/*/*/svn/ext/*.la
556
557 %clean
558 rm -rf $RPM_BUILD_ROOT
559
560 %pre svnserve
561 %groupadd -g 86 svn
562 %useradd -u 180 -d /home/services/subversion -c "Subversion svnserve" -g svn svn
563
564 %post   libs -p /sbin/ldconfig
565 %postun libs -p /sbin/ldconfig
566
567 %post   devel -p /sbin/postshell
568 -/usr/sbin/fix-info-dir -c %{_infodir}
569
570 %postun devel -p /sbin/postshell
571 -/usr/sbin/fix-info-dir -c %{_infodir}
572
573 %post   -n java-subversion -p /sbin/ldconfig
574 %postun -n java-subversion -p /sbin/ldconfig
575
576 %post   -n perl-subversion -p /sbin/ldconfig
577 %postun -n perl-subversion -p /sbin/ldconfig
578
579 %post   -n python-subversion -p /sbin/ldconfig
580 %postun -n python-subversion -p /sbin/ldconfig
581
582 %post   -n ruby-subversion -p /sbin/ldconfig
583 %postun -n ruby-subversion -p /sbin/ldconfig
584
585 %post   -n gnome-keyring-subversion -p /sbin/ldconfig
586 %postun -n gnome-keyring-subversion -p /sbin/ldconfig
587
588 %post   -n kde4-kwallet-subversion -p /sbin/ldconfig
589 %postun -n kde4-kwallet-subversion -p /sbin/ldconfig
590
591 %post svnserve
592 /sbin/chkconfig --add svnserve
593 %service svnserve restart "svnserve daemon"
594
595 %preun svnserve
596 if [ "$1" = "0" ]; then
597         %service svnserve stop
598         /sbin/chkconfig --del svnserve
599 fi
600
601 %postun svnserve
602 if [ "$1" = "0" ]; then
603         %userremove svn
604         %groupremove svn
605 fi
606
607 %post -n apache-mod_dav_svn
608 %service -q httpd restart
609
610 %postun -n apache-mod_dav_svn
611 if [ "$1" = "0" ]; then
612         %service -q httpd restart
613 fi
614
615 %post -n apache-mod_authz_svn
616 %service -q httpd restart
617
618 %postun -n apache-mod_authz_svn
619 if [ "$1" = "0" ]; then
620         %service -q httpd restart
621 fi
622
623 %files
624 %defattr(644,root,root,755)
625 %doc BUGS CHANGES COPYING INSTALL README
626 %doc doc/*/*.html
627 %doc tools/hook-scripts/*.{pl,py,example}
628 %doc tools/hook-scripts/mailer/*.{py,example}
629 %doc tools/xslt/*
630 %attr(755,root,root) %{_bindir}/svn
631 %attr(755,root,root) %{_bindir}/svnadmin
632 %attr(755,root,root) %{_bindir}/svndumpfilter
633 %attr(755,root,root) %{_bindir}/svnlook
634 %attr(755,root,root) %{_bindir}/svnsync
635 %attr(755,root,root) %{_bindir}/svnversion
636 %{_mandir}/man1/svn.1*
637 %{_mandir}/man1/svnadmin.1*
638 %{_mandir}/man1/svndumpfilter.1*
639 %{_mandir}/man1/svnlook.1*
640 %{_mandir}/man1/svnsync.1*
641 %{_mandir}/man1/svnversion.1*
642
643 %files libs -f %{name}.lang
644 %defattr(644,root,root,755)
645 %attr(755,root,root) %{_libdir}/libsvn_client-1.so.*.*.*
646 %attr(755,root,root) %ghost %{_libdir}/libsvn_client-1.so.0
647 %attr(755,root,root) %{_libdir}/libsvn_delta-1.so.*.*.*
648 %attr(755,root,root) %ghost %{_libdir}/libsvn_delta-1.so.0
649 %attr(755,root,root) %{_libdir}/libsvn_diff-1.so.*.*.*
650 %attr(755,root,root) %ghost %{_libdir}/libsvn_diff-1.so.0
651 %attr(755,root,root) %{_libdir}/libsvn_fs-1.so.*.*.*
652 %attr(755,root,root) %ghost %{_libdir}/libsvn_fs-1.so.0
653 %attr(755,root,root) %{_libdir}/libsvn_fs_base-1.so.*.*.*
654 %attr(755,root,root) %ghost %{_libdir}/libsvn_fs_base-1.so.0
655 %attr(755,root,root) %{_libdir}/libsvn_fs_fs-1.so.*.*.*
656 %attr(755,root,root) %ghost %{_libdir}/libsvn_fs_fs-1.so.0
657 %attr(755,root,root) %{_libdir}/libsvn_fs_util-1.so.*.*.*
658 %attr(755,root,root) %ghost %{_libdir}/libsvn_fs_util-1.so.0
659 %attr(755,root,root) %{_libdir}/libsvn_ra-1.so.*.*.*
660 %attr(755,root,root) %ghost %{_libdir}/libsvn_ra-1.so.0
661 %attr(755,root,root) %{_libdir}/libsvn_ra_local-1.so.*.*.*
662 %attr(755,root,root) %ghost %{_libdir}/libsvn_ra_local-1.so.0
663 %attr(755,root,root) %{_libdir}/libsvn_ra_%{webdavlib}-1.so.*.*.*
664 %attr(755,root,root) %ghost %{_libdir}/libsvn_ra_%{webdavlib}-1.so.0
665 %attr(755,root,root) %{_libdir}/libsvn_ra_svn-1.so.*.*.*
666 %attr(755,root,root) %ghost %{_libdir}/libsvn_ra_svn-1.so.0
667 %attr(755,root,root) %{_libdir}/libsvn_repos-1.so.*.*.*
668 %attr(755,root,root) %ghost %{_libdir}/libsvn_repos-1.so.0
669 %attr(755,root,root) %{_libdir}/libsvn_subr-1.so.*.*.*
670 %attr(755,root,root) %ghost %{_libdir}/libsvn_subr-1.so.0
671 %attr(755,root,root) %{_libdir}/libsvn_wc-1.so.*.*.*
672 %attr(755,root,root) %ghost %{_libdir}/libsvn_wc-1.so.0
673
674 %files devel
675 %defattr(644,root,root,755)
676 %attr(755,root,root) %{_libdir}/libsvn_client-1.so
677 %attr(755,root,root) %{_libdir}/libsvn_delta-1.so
678 %attr(755,root,root) %{_libdir}/libsvn_diff-1.so
679 %attr(755,root,root) %{_libdir}/libsvn_fs-1.so
680 %attr(755,root,root) %{_libdir}/libsvn_fs_base-1.so
681 %attr(755,root,root) %{_libdir}/libsvn_fs_fs-1.so
682 %attr(755,root,root) %{_libdir}/libsvn_fs_util-1.so
683 %attr(755,root,root) %{_libdir}/libsvn_ra-1.so
684 %attr(755,root,root) %{_libdir}/libsvn_ra_local-1.so
685 %attr(755,root,root) %{_libdir}/libsvn_ra_%{webdavlib}-1.so
686 %attr(755,root,root) %{_libdir}/libsvn_ra_svn-1.so
687 %attr(755,root,root) %{_libdir}/libsvn_repos-1.so
688 %attr(755,root,root) %{_libdir}/libsvn_subr-1.so
689 %attr(755,root,root) %{_libdir}/libsvn_wc-1.so
690 %{_libdir}/libsvn_client-1.la
691 %{_libdir}/libsvn_delta-1.la
692 %{_libdir}/libsvn_diff-1.la
693 %{_libdir}/libsvn_fs-1.la
694 %{_libdir}/libsvn_fs_base-1.la
695 %{_libdir}/libsvn_fs_fs-1.la
696 %{_libdir}/libsvn_fs_util-1.la
697 %{_libdir}/libsvn_ra-1.la
698 %{_libdir}/libsvn_ra_local-1.la
699 %{_libdir}/libsvn_ra_%{webdavlib}-1.la
700 %{_libdir}/libsvn_ra_svn-1.la
701 %{_libdir}/libsvn_repos-1.la
702 %{_libdir}/libsvn_subr-1.la
703 %{_libdir}/libsvn_wc-1.la
704 %{_includedir}/%{name}-1
705 %{_examplesdir}/%{name}-%{version}
706
707 %files static
708 %defattr(644,root,root,755)
709 %{_libdir}/libsvn_client-1.a
710 %{_libdir}/libsvn_delta-1.a
711 %{_libdir}/libsvn_diff-1.a
712 %{_libdir}/libsvn_fs-1.a
713 %{_libdir}/libsvn_fs_base-1.a
714 %{_libdir}/libsvn_fs_fs-1.a
715 %{_libdir}/libsvn_fs_util-1.a
716 %{_libdir}/libsvn_ra-1.a
717 %{_libdir}/libsvn_ra_local-1.a
718 %{_libdir}/libsvn_ra_%{webdavlib}-1.a
719 %{_libdir}/libsvn_ra_svn-1.a
720 %{_libdir}/libsvn_repos-1.a
721 %{_libdir}/libsvn_subr-1.a
722 %{_libdir}/libsvn_wc-1.a
723
724 %if %{with gnome}
725 %files -n gnome-keyring-subversion
726 %defattr(644,root,root,755)
727 %attr(755,root,root) %{_libdir}/libsvn_auth_gnome_keyring-1.so.*.*.*
728 %attr(755,root,root) %ghost %{_libdir}/libsvn_auth_gnome_keyring-1.so.0
729 %endif
730
731 %if %{with kwallet}
732 %files -n kde4-kwallet-subversion
733 %defattr(644,root,root,755)
734 %attr(755,root,root) %{_libdir}/libsvn_auth_kwallet-1.so.*.*.*
735 %attr(755,root,root) %ghost %{_libdir}/libsvn_auth_kwallet-1.so.0
736 %endif
737
738 %if %{without net_client_only}
739 %files svnserve
740 %defattr(644,root,root,755)
741 %attr(755,root,root) %{_bindir}/svnserve
742 %{_mandir}/man5/svnserve.conf.5*
743 %{_mandir}/man8/svnserve.8*
744 %dir %attr(750,svn,svn) /home/services/subversion
745 %dir %attr(750,svn,svn) /home/services/subversion/repos
746 %if %{with apache}
747 %attr(754,root,root) /etc/rc.d/init.d/svnserve
748 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/svnserve
749 %endif
750
751 %files tools
752 %defattr(644,root,root,755)
753 %attr(755,root,root) %{_bindir}/svn-hot-backup
754
755 %files -n bash-completion-subversion
756 %defattr(644,root,root,755)
757 /etc/bash_completion.d/%{name}
758
759 %if %{with javahl}
760 %files -n java-subversion
761 %defattr(644,root,root,755)
762 %attr(755,root,root) %{_libdir}/libsvnjavahl-1.so.*.*.*
763 %attr(755,root,root) %ghost %{_libdir}/libsvnjavahl-1.so.0
764 %attr(755,root,root) %{_libdir}/libsvnjavahl-1.so
765 %{_javadir}/svn-javahl.jar
766 %endif
767
768 %if %{with python}
769 %files -n python-subversion
770 %defattr(644,root,root,755)
771 %doc tools/backup/*.py tools/examples/*.py
772 %attr(755,root,root) %{_libdir}/libsvn_swig_py-1.so.*.*.*
773 %attr(755,root,root) %ghost %{_libdir}/libsvn_swig_py-1.so.0
774 %attr(755,root,root) %{_libdir}/libsvn_swig_py-1.so
775 %dir %{py_sitedir}/libsvn
776 %{py_sitedir}/libsvn/*.py[co]
777 %dir %{py_sitedir}/svn
778 %{py_sitedir}/svn/*.py[co]
779 %attr(755,root,root) %{py_sitedir}/libsvn/*.so
780 %{_examplesdir}/python-%{name}-%{version}
781
782 %files -n python-csvn
783 %defattr(644,root,root,755)
784 %doc subversion/bindings/ctypes-python/{README,TODO}
785 %doc subversion/bindings/ctypes-python/examples/*.py
786 %dir %{py_sitescriptdir}/csvn
787 %{py_sitescriptdir}/csvn/*.py[co]
788 %dir %{py_sitescriptdir}/csvn/core
789 %{py_sitescriptdir}/csvn/core/*.py[co]
790 %dir %{py_sitescriptdir}/csvn/ext
791 %{py_sitescriptdir}/csvn/ext/*.py[co]
792 %{py_sitescriptdir}/*.egg-info
793 %endif
794
795 %if %{with perl}
796 %files -n perl-subversion
797 %defattr(644,root,root,755)
798 %attr(755,root,root) %{_libdir}/libsvn_swig_perl-1.so.*.*.*
799 %attr(755,root,root) %ghost %{_libdir}/libsvn_swig_perl-1.so.0
800 %attr(755,root,root) %{_libdir}/libsvn_swig_perl-1.so
801 %{perl_vendorarch}/SVN
802 %dir %{perl_vendorarch}/auto/SVN
803 %dir %{perl_vendorarch}/auto/SVN/*
804 %attr(755,root,root) %{perl_vendorarch}/auto/SVN/*/*.so
805 %{perl_vendorarch}/auto/SVN/*/*.bs
806 %{_mandir}/man3/*.3pm*
807 %endif
808
809 %if %{with ruby}
810 %files -n ruby-subversion
811 %defattr(644,root,root,755)
812 %attr(755,root,root) %{_libdir}/libsvn_swig_ruby-1.so.*.*.*
813 %attr(755,root,root) %ghost %{_libdir}/libsvn_swig_ruby-1.so.0
814 %attr(755,root,root) %{_libdir}/libsvn_swig_ruby-1.so
815 %dir %{ruby_sitelibdir}/svn
816 %{ruby_sitelibdir}/svn/*.rb
817 %dir %{ruby_sitearchdir}/svn
818 %dir %{ruby_sitearchdir}/svn/ext
819 %attr(755,root,root) %{ruby_sitearchdir}/svn/ext/*.so
820 %{ruby_ridir}/Svn
821 %endif
822
823 %if %{with apache}
824 %files -n apache-mod_dav_svn
825 %defattr(644,root,root,755)
826 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{apacheconfdir}/*_mod_dav_svn.conf
827 %attr(755,root,root) %{apachelibdir}/mod_dav_svn.so
828
829 %files -n apache-mod_authz_svn
830 %defattr(644,root,root,755)
831 %doc subversion/mod_authz_svn/INSTALL
832 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{apacheconfdir}/*_mod_authz_svn.conf
833 %attr(755,root,root) %{apachelibdir}/mod_authz_svn.so
834 %endif
835
836 %endif # net_client_only
This page took 0.688798 seconds and 4 git commands to generate.