]> git.pld-linux.org Git - packages/subversion.git/blob - subversion.spec
- without_gnome bcond added
[packages/subversion.git] / subversion.spec
1 # TODO:
2 # - fix java build with java-gcj-compat and s/java-sun/jdk/
3 # - remove net_client_only and add db bcond (then without apache and
4 #   without db => net_client_only - spec will be more simpler, I think)
5 # - finish ruby
6 #
7 # Conditional build:
8 %bcond_with     net_client_only         # build only net client
9 %bcond_without  neon                    # use serf instead of neon
10 %bcond_without  python                  # build without python bindings (broken)
11 %bcond_without  perl                    # build without perl bindings
12 %bcond_without  ruby                    # build without ruby bindings
13 %bcond_without  apache                  # build without apache support (webdav, etc)
14 %bcond_without  javahl                  # build without javahl support (Java high-level bindings)
15 %bcond_without  tests                   # don't perform "make check"
16 %bcond_without  kwallet                 # build without kde4 wallet support
17 %bcond_without  gnome                   # build without gnome keyring support
18 #
19 %ifnarch i586 i686 pentium3 pentium4 athlon %{x8664}
20 %undefine       with_javahl
21 %endif
22 #
23 %{!?with_net_client_only:%include       /usr/lib/rpm/macros.perl}
24 %define apxs    /usr/sbin/apxs
25 %define pdir    SVN
26 %define pnam    _Core
27 #
28 %if %{with neon}
29 %define webdavlib       neon
30 %else
31 %define webdavlib       serf
32 %endif
33 #
34 Summary:        A Concurrent Versioning system similar to but better than CVS
35 Summary(pl.UTF-8):      System kontroli wersji podobny, ale lepszy, niż CVS
36 Summary(pt_BR.UTF-8):   Sistema de versionamento concorrente
37 Name:           subversion
38 Version:        1.6.6
39 Release:        1
40 License:        Apache/BSD-like
41 Group:          Development/Version Control
42 Source0:        http://subversion.tigris.org/downloads/%{name}-%{version}.tar.bz2
43 # Source0-md5:  e5109da756d74c7d98f683f004a539af
44 Source1:        %{name}-dav_svn.conf
45 Source2:        %{name}-authz_svn.conf
46 Source3:        %{name}-svnserve.init
47 Source4:        %{name}-svnserve.sysconfig
48 # current subversion tarball has correct *.swg files
49 # but after regeneration these are broken again, so
50 # we still need this script
51 Source5:        %{name}-convert-typemaps-to-ifdef.py
52 Patch0:         %{name}-home_etc.patch
53 Patch1:         %{name}-DESTDIR.patch
54 Patch2:         %{name}-ruby-datadir-path.patch
55 URL:            http://subversion.tigris.org/
56 %if %{with net_client_only}
57 %global apache_modules_api 0
58 %else
59 %{?with_apache:BuildRequires:   apache-devel >= 2.2.0-8}
60 BuildRequires:  automake
61 BuildRequires:  db-devel >= 4.1.25
62 BuildRequires:  rpmbuild(macros) >= 1.268
63 %if %{with perl}
64 BuildRequires:  perl-devel >= 1:5.8.0
65 BuildRequires:  rpm-perlprov >= 4.1-13
66 BuildRequires:  swig-perl >= 1.3.24
67 %endif
68 %if %{with python}
69 BuildRequires:  python-ctypesgen
70 BuildRequires:  python-devel >= 2.2
71 BuildRequires:  swig-python >= 1.3.24
72 %endif
73 %if %{with ruby}
74 BuildRequires:  ruby-devel
75 BuildRequires:  swig-ruby >= 1.3.24
76 %endif
77 %if %{with javahl}
78 BuildRequires:  java-sun
79 BuildRequires:  java-sun-tools
80 %endif
81 BuildRequires:  cyrus-sasl-devel
82 %endif
83 BuildRequires:  apr-devel >= 1:1.0.0
84 BuildRequires:  apr-util-devel >= 1:1.2.8-3
85 BuildRequires:  autoconf >= 2.59
86 BuildRequires:  bison
87 BuildRequires:  expat-devel
88 BuildRequires:  gettext-devel
89 %{?with_gnome:BuildRequires:    gnome-keyring-devel}
90 %{?with_kwallet:BuildRequires:  kde4-kdelibs-devel}
91 BuildRequires:  libtool >= 1.4-9
92 BuildRequires:  sed >= 4.0
93 BuildRequires:  sqlite3-devel >= 3.6.11
94 BuildRequires:  texinfo
95 BuildRequires:  which
96 %if %{with neon}
97 BuildRequires:  neon-devel >= 0.26.0
98 %else
99 BuildRequires:  serf-devel
100 %endif
101 BuildRequires:  python >= 2.2
102 BuildRequires:  python-modules >= 2.2
103 Requires:       %{name}-libs = %{version}-%{release}
104 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
105
106 %define         _libexecdir             %{_libdir}/svn
107 %define         apacheconfdir   %(%{apxs} -q SYSCONFDIR 2>/dev/null)/conf.d
108 %define         apachelibdir    %(%{apxs} -q LIBEXECDIR 2>/dev/null)
109
110 %description
111 The goal of the Subversion project is to build a version control
112 system that is a compelling replacement for CVS in the open source
113 community.
114
115 Our goals are:
116 - All current CVS features.
117 - Directories, renames, and file meta-data are versioned.
118 - Symbolic links, etc, are supported
119 - Commits are truly atomic.
120 - Branching and tagging are cheap (constant time) operations
121 - Repeated merges are handled gracefully
122 - Support for plug-in client side diff programs
123 - Natively client/server
124 - Client/server protocol sends diffs in both directions
125 - Costs are proportional to change size, not project size
126 - Internationalization
127 - Progressive multi-lingual support
128
129 %description -l pl.UTF-8
130 Celem projektu Subversion jest stworzenie systemu kontroli wersji jako
131 zamiennika dla CVS.
132
133 Cele projektu to:
134 - Wszystkie aktualne możliwości CVS.
135 - Katalogi, zmiany nazw oraz metadane plików są wersjonowane.
136 - Obsługa dowiązań symbolicznych itp.
137 - Commity są w pełni atomowe.
138 - Branchowanie oraz tagowanie są tanimi (stałymi w czasie) operacjami.
139 - Dobra obsługa powtarzanego łączenia (merge).
140 - Obsługa wtyczek diff po stronie klienta.
141 - Natywny klient/serwer.
142 - Klient/Serwer przesyłają diffy w obu kierunkach.
143 - Koszty proporcjonalne do rozmiaru zmiany, a nie rozmiaru projektu.
144 - Internacjonalizacja.
145 - Postępujące wsparcie dla wielu języków.
146
147 %description -l pt_BR.UTF-8
148 O objetivo do projeto Subversion é construir um sistema de controle de
149 versões que seja um substituto para o CVS (Concurrent Versioning
150 System) na comunidade opensource, fornecendo grandes melhorias.
151
152 %package libs
153 Summary:        Subversion libraries and modules
154 Summary(pl.UTF-8):      Biblioteka subversion oraz ładowalne moduły
155 Group:          Libraries
156 %{?with_neon:Requires:  neon >= 0.26.0}
157 Obsoletes:      libsubversion0
158
159 %description libs
160 Subversion libraries and modules.
161
162 %description libs -l pl.UTF-8
163 Biblioteka subversion oraz ładowalne moduły.
164
165 %package devel
166 Summary:        Header files and develpment documentation for subversion
167 Summary(pl.UTF-8):      Pliki nagłówkowe i dokumetacja do subversion
168 Summary(pt_BR.UTF-8):   Arquivos de desenvolvimento para o Subversion
169 Group:          Development/Libraries
170 Requires:       %{name}-libs = %{version}-%{release}
171 Requires:       apr-util-devel >= 1:1.0.0
172 %{?with_neon:Requires:  neon-devel >= 0.26.0}
173 Obsoletes:      libsubversion0-devel
174
175 %description devel
176 Header files and develpment documentation for subversion.
177
178 %description devel -l pl.UTF-8
179 Pliki nagłówkowe i dokumetacja do subversion.
180
181 %description devel -l pt_BR.UTF-8
182 Este pacote provê os arquivos necessários para desenvolvedores
183 interagirem com o Subversion.
184
185 %package static
186 Summary:        Static subversion library
187 Summary(pl.UTF-8):      Biblioteka statyczna subversion
188 Summary(pt_BR.UTF-8):   Sistema de versionamento concorrente
189 Group:          Development/Libraries
190 Requires:       %{name}-devel = %{version}
191 Obsoletes:      libsubversion0-static-devel
192
193 %description static
194 Static subversion library.
195
196 %description static -l pl.UTF-8
197 Biblioteka statyczna subversion.
198
199 %description static -l pt_BR.UTF-8
200 Este pacote provê um cliente estático do subversion.
201
202 %package svnserve
203 Summary:        Subversion svnserve
204 Summary(pl.UTF-8):      Subversion svnserve
205 Group:          Networking/Daemons
206 Requires(post,preun):   /sbin/chkconfig
207 Requires(postun):       /usr/sbin/groupdel
208 Requires(postun):       /usr/sbin/userdel
209 Requires(pre):  /bin/id
210 Requires(pre):  /usr/bin/getgid
211 Requires(pre):  /usr/lib/rpm/user_group.sh
212 Requires(pre):  /usr/sbin/groupadd
213 Requires(pre):  /usr/sbin/useradd
214 Requires(pre):  /usr/sbin/usermod
215 Requires:       %{name} = %{version}-%{release}
216 Requires:       rc-scripts
217 Provides:       group(svn)
218 Provides:       user(svn)
219
220 %description svnserve
221 Subversion svnserve server.
222
223 %description svnserve -l pl.UTF-8
224 Serwer subversion svnserve.
225
226 %package tools
227 Summary:        Subversion tools and scripts
228 Summary(pl.UTF-8):      Narzędzia oraz skrypty dla subversion
229 Summary(pt_BR.UTF-8):   Módulos python para acessar os recursos do Subversion
230 Group:          Applications
231 %pyrequires_eq  python
232 Requires:       %{name} = %{version}-%{release}
233 Requires:       python-subversion = %{version}
234
235 %description tools
236 Subversion tools and scripts.
237
238 %description tools -l pl.UTF-8
239 Narzędzia oraz skrypty dla subversion.
240
241 %package -n bash-completion-subversion
242 Summary:        bash completion for subversion
243 Summary(pl.UTF-8):      Dopełnienia basha dla subversion
244 Group:          Applications/Shells
245 Requires:       %{name} = %{version}-%{release}
246 Requires:       bash-completion
247 Conflicts:      %{name}-tools <= 1.1.0-0.rc6.1
248
249 %description -n bash-completion-subversion
250 Bash completion for subversion.
251
252 %description -n bash-completion-subversion -l pl.UTF-8
253 Dopełnienia basha dla subversion.
254
255 %package -n java-subversion
256 Summary:        Subversion Java bindings
257 Summary(pl.UTF-8):      Dowiązania do Subversion dla Javy
258 Group:          Development/Languages/Java
259 Requires:       %{name}-libs = %{version}-%{release}
260
261 %description -n java-subversion
262 This is a set of Java classes which provide the functionality of
263 subversion-libs, the Subversion libraries. It is useful if you want
264 to, for example, write a Java class that manipulates a Subversion
265 repository or working copy. See the 'subversion' package for more
266 information.
267
268 %description -n java-subversion -l pl.UTF-8
269 Ten pakiet zawiera zestaw klas Javy udostępniających funkcjonalność
270 subversion-libs, czyli bibliotek Subversion. Jest przydatny przy
271 pisaniu klas Javy np. modyfikujących repozytorium Subversion lub kopię
272 roboczą. Więcej informacji w pakiecie subversion.
273
274 %package -n python-subversion
275 Summary:        Subversion Python bindings
276 Summary(pl.UTF-8):      Dowiązania do Subversion dla Pythona
277 Summary(pt_BR.UTF-8):   Módulos Python para acessar os recursos do Subversion
278 Group:          Development/Languages/Python
279 %pyrequires_eq  python
280 Requires:       %{name}-libs = %{version}-%{release}
281 Obsoletes:      subversion-python
282
283 %description -n python-subversion
284 Subversion Python bindings.
285
286 %description -n python-subversion -l pl.UTF-8
287 Dowiązania do Subversion dla Pythona.
288
289 %description -n python-subversion -l pt_BR.UTF-8
290 Módulos Python para acessar os recursos do Subversion.
291
292 %package -n python-csvn
293 Summary:        CTypes Subversion Python bindings
294 Summary(pl.UTF-8):      Dowiązania do Subversion dla Pythona
295 Summary(pt_BR.UTF-8):   Módulos Python para acessar os recursos do Subversion
296 Group:          Development/Languages/Python
297 %pyrequires_eq  python
298 Requires:       %{name}-libs = %{version}-%{release}
299
300 %description -n python-csvn
301 Subversion CTypes Python bindings.
302
303 %description -n python-csvn -l pl.UTF-8
304 Dowiązania do Subversion dla Pythona używające CTypes.
305
306 %description -n python-csvn -l pt_BR.UTF-8
307 Módulos Python para acessar os recursos do Subversion.
308
309 %package -n perl-subversion
310 Summary:        Subversion Perl bindings
311 Summary(pl.UTF-8):      Dowiązania do Subversion dla Perla
312 Summary(pt_BR.UTF-8):   Módulos Perl para acessar os recursos do Subversion
313 Group:          Development/Languages/Perl
314 Requires:       %{name}-libs = %{version}-%{release}
315 Obsoletes:      subversion-perl
316
317 %description -n perl-subversion
318 Subversion Perl bindings.
319
320 %description -n perl-subversion -l pl.UTF-8
321 Dowiązania do Subversion dla Perla.
322
323 %description -n perl-subversion -l pt_BR.UTF-8
324 Módulos Perl para acessar os recursos do Subversion.
325
326 %package -n ruby-subversion
327 Summary:        Subversion Ruby bindings
328 Summary(pl.UTF-8):      Dowiązania do Subversion dla języka Ruby
329 Summary(pt_BR.UTF-8):   Módulos Ruby para acessar os recursos do Subversion
330 Group:          Development/Languages
331 Requires:       %{name}-libs = %{version}-%{release}
332 Obsoletes:      subversion-ruby
333
334 %description -n ruby-subversion
335 Subversion Ruby bindings.
336
337 %description -n ruby-subversion -l pl.UTF-8
338 Dowiązania do Subversion dla języka Ruby.
339
340 %description -n ruby-subversion -l pt_BR.UTF-8
341 Módulos Ruby para acessar os recursos do Subversion.
342
343 %package -n apache-mod_dav_svn
344 Summary:        Apache module: Subversion Server
345 Summary(pl.UTF-8):      Moduł apache: Serwer Subversion
346 Group:          Networking/Daemons
347 Requires:       %{name} = %{version}-%{release}
348 Requires:       apache(modules-api) = %apache_modules_api
349 Requires:       apache-mod_dav
350
351 %description -n apache-mod_dav_svn
352 Apache module: Subversion Server.
353
354 %description -n apache-mod_dav_svn -l pl.UTF-8
355 Moduł apache: Serwer Subversion.
356
357 %package -n apache-mod_authz_svn
358 Summary:        Apache module: Subversion Server - path-based authorization
359 Summary(pl.UTF-8):      Moduł apache: autoryzacja na podstawie ścieżki dla serwera Subversion
360 Group:          Networking/Daemons
361 Requires:       apache(modules-api) = %apache_modules_api
362 Requires:       apache-mod_dav_svn = %{version}-%{release}
363
364 %description -n apache-mod_authz_svn
365 Apache module: Subversion Server - path-based authorization.
366
367 %description -n apache-mod_authz_svn -l pl.UTF-8
368 Moduł apache: autoryzacja na podstawie ścieżki dla serwera Subversion.
369
370 %package -n gnome-keyring-subversion
371 Summary:        Subversion module for Gnome Keyring
372 Summary(pl.UTF-8):      Moduł subversion dla zarządcy kluczy Gnome
373 Group:          X11/Applications
374
375 %description -n gnome-keyring-subversion
376 Subversion module for Gnome Keyring.
377
378 %description -n gnome-keyring-subversion -l pl.UTF-8
379 Moduł subversion dla zarządcy kluczy Gnome.
380
381 %package -n kde4-kwallet-subversion
382 Summary:        Subversion module for KDE Wallet
383 Summary(pl.UTF-8):      Moduł subversion dla Portfela KDE
384 Group:          X11/Applications
385
386 %description -n kde4-kwallet-subversion
387 Subversion module for KDE Wallet.
388
389 %description -n kde4-kwallet-subversion -l pl.UTF-8
390 Moduł subversion dla Portfela KDE.
391
392 %prep
393 %setup -q
394 rm -rf apr apr-util neon
395 %patch0 -p0
396 %patch1 -p1
397 %patch2 -p0
398
399 sed -i -e 's#serf_prefix/lib#serf_prefix/%{_lib}#g' build/ac-macros/serf.m4
400
401 # serf.m4 macro is broken and ignores --without serf
402 %{?with_neon:sed -i -e 's#serf_found="yes"#serf_found="no"#g' build/ac-macros/serf.m4}
403
404 %build
405 rm subversion/bindings/swig/proxy/*.swg
406 cd subversion/bindings/swig && python "%{SOURCE5}" && cd ../../..
407 cp -f /usr/share/automake/config.sub ac-helpers
408 chmod +x ./autogen.sh && ./autogen.sh
409
410 %configure \
411         --with-editor=vi \
412         --with-zlib=%{_libdir} \
413 %if %{with net_client_only}
414         --without-apache \
415         --without-swig \
416         --without-apxs \
417         --without-berkeley-db \
418 %else
419         --disable-runtime-module-search \
420         --disable-mod-activation \
421         --with-berkeley-db="db.h:%{_includedir}:%{_libdir}:db" \
422 %if %{with apache}
423         --with-apxs=%{_sbindir}/apxs \
424 %else
425         --without-apache \
426         --without-apxs \
427 %endif
428 %if !%{with python} && !%{with perl} && !%{with ruby}
429         --without-swig \
430 %endif
431         %{?with_python:--with-ctypesgen=%{_bindir}/ctypesgen.py} \
432         --%{?with_javahl:en}%{!?with_javahl:dis}able-javahl \
433 %endif
434         --with-jdk="%{java_home}" \
435 %if %{with neon}
436         --without-serf \
437         --with-neon=%{_prefix} \
438         --disable-neon-version-check \
439 %else
440         --with-serf=%{_prefix} \
441         --without-neon \
442 %endif
443         --with-apr=%{_bindir}/apr-1-config \
444         --with-apr-util=%{_bindir}/apu-1-config \
445 %if %{with kwallet}
446         --with-kwallet \
447 %endif
448 %if %{with gnome}
449         --with-gnome-keyring
450 %endif
451
452 %{__make} -j1
453
454 %if !%{with net_client_only}
455 # python
456 %if %{with python}
457 # ctypes bindings
458 %{__make} ctypes-python
459 # swig bindings
460 %{__make} swig-py \
461         swig_pydir=%{py_sitedir}/libsvn \
462         swig_pydir_extra=%{py_sitedir}/svn
463 %endif
464 # perl
465 %if %{with perl}
466 %{__make} -j1 swig-pl-lib
467 odir=$(pwd)
468 cd subversion/bindings/swig/perl/native
469 %{__perl} Makefile.PL INSTALLDIRS=vendor
470 %{__make} -j1
471 cd $odir
472 %endif
473 %if %{with javahl}
474 %{__make} -j1 javahl \
475         javahl_javadir="%{_javadir}"
476 %endif
477 # ruby
478 %if %{with ruby}
479 %{__make} swig-rb
480 %endif
481 %endif
482
483 %if %{with tests}
484 %{__make} check
485 %if %{with python}
486 %{__make} check-ctypes-python
487 %{__make} check-swig-py
488 %endif
489 %if %{with perl}
490 %{__make} check-swig-pl
491 %endif
492 %if %{with ruby}
493 %{__make} check-swig-rb
494 %endif
495 %endif
496
497 %install
498 rm -rf $RPM_BUILD_ROOT
499 install -d $RPM_BUILD_ROOT/etc/{rc.d/init.d,sysconfig,bash_completion.d} \
500         $RPM_BUILD_ROOT{%{apacheconfdir},%{apachelibdir},%{_infodir}} \
501         $RPM_BUILD_ROOT%{_examplesdir}/{%{name}-%{version},python-%{name}-%{version}} \
502         $RPM_BUILD_ROOT/home/services/subversion{,/repos}
503
504 %{__make} install -j1 \
505 %if %{with javahl}
506         install-javahl \
507         javahl_javadir="%{_javadir}" \
508 %endif
509 %if !%{with net_client_only}
510 %if %{with python}
511         install-swig-py \
512         install-ctypes-python \
513 %endif
514 %if %{with ruby}
515         install-swig-rb install-swig-rb-doc \
516 %endif
517 %endif
518         APACHE_LIBEXECDIR="$(%{_sbindir}/apxs -q LIBEXECDIR)" \
519         DESTDIR=$RPM_BUILD_ROOT \
520         swig_pydir=%{py_sitedir}/libsvn \
521         swig_pydir_extra=%{py_sitedir}/svn
522
523 %if !%{with net_client_only} && %{with perl}
524 %{__make} install-swig-pl-lib \
525         DESTDIR=$RPM_BUILD_ROOT
526 %{__make} -C subversion/bindings/swig/perl/native install \
527         DESTDIR=$RPM_BUILD_ROOT \
528         PREFIX=$RPM_BUILD_ROOT%{_prefix} \
529         LIBDIR=$RPM_BUILD_ROOT%{_libdir}
530 %endif
531
532 %if %{with apache}
533 install %{SOURCE1} $RPM_BUILD_ROOT%{apacheconfdir}/65_mod_dav_svn.conf
534 install %{SOURCE2} $RPM_BUILD_ROOT%{apacheconfdir}/66_mod_authz_svn.conf
535 install %{SOURCE3} $RPM_BUILD_ROOT/etc/rc.d/init.d/svnserve
536 install %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/svnserve
537 %endif
538
539 %if !%{with net_client_only}
540 install tools/backup/hot-backup.py $RPM_BUILD_ROOT%{_bindir}/svn-hot-backup
541 %if %{with python}
542 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
543 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
544 find $RPM_BUILD_ROOT%{py_sitedir} -name "*.py" -o -name "*.a" -o -name "*.la" | xargs rm -f
545 install tools/examples/*.py $RPM_BUILD_ROOT%{_examplesdir}/python-%{name}-%{version}
546 %endif
547 %endif
548
549 install tools/client-side/bash_completion $RPM_BUILD_ROOT/etc/bash_completion.d/%{name}
550 install tools/examples/*.c $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
551
552 %find_lang %{name}
553
554 %{?with_javahl:rm $RPM_BUILD_ROOT%{_libdir}/libsvnjavahl*.{la,a}}
555 rm -f $RPM_BUILD_ROOT%{_libdir}/libsvn_swig*.{la,a}
556 rm -f $RPM_BUILD_ROOT%{_libdir}/ruby/site_ruby/*/*/svn/ext/*.la
557
558 %clean
559 rm -rf $RPM_BUILD_ROOT
560
561 %pre svnserve
562 %groupadd -g 86 svn
563 %useradd -u 180 -d /home/services/subversion -c "Subversion svnserve" -g svn svn
564
565 %post   libs -p /sbin/ldconfig
566 %postun libs -p /sbin/ldconfig
567
568 %post   devel -p /sbin/postshell
569 -/usr/sbin/fix-info-dir -c %{_infodir}
570
571 %postun devel -p /sbin/postshell
572 -/usr/sbin/fix-info-dir -c %{_infodir}
573
574 %post   -n perl-subversion -p /sbin/ldconfig
575 %postun -n perl-subversion -p /sbin/ldconfig
576
577 %post   -n python-subversion -p /sbin/ldconfig
578 %postun -n python-subversion -p /sbin/ldconfig
579
580 %post svnserve
581 /sbin/chkconfig --add svnserve
582 %service svnserve restart "svnserve daemon"
583
584 %preun svnserve
585 if [ "$1" = "0" ]; then
586         %service svnserve stop
587         /sbin/chkconfig --del svnserve
588 fi
589
590 %postun svnserve
591 if [ "$1" = "0" ]; then
592         %userremove svn
593         %groupremove svn
594 fi
595
596 %post -n apache-mod_dav_svn
597 %service -q httpd restart
598
599 %preun -n apache-mod_dav_svn
600 if [ "$1" = "0" ]; then
601         %service -q httpd restart
602 fi
603
604 %files
605 %defattr(644,root,root,755)
606 %doc BUGS CHANGES COPYING INSTALL README
607 %doc doc/*/*.html
608 %doc tools/hook-scripts/*.{pl,py,example}
609 %doc tools/hook-scripts/mailer/*.{py,example}
610 %doc tools/xslt/*
611 %attr(755,root,root) %{_bindir}/svn
612 %attr(755,root,root) %{_bindir}/svnadmin
613 %attr(755,root,root) %{_bindir}/svndumpfilter
614 %attr(755,root,root) %{_bindir}/svnlook
615 %attr(755,root,root) %{_bindir}/svnsync
616 %attr(755,root,root) %{_bindir}/svnversion
617 %{_mandir}/man1/svn.1*
618 %{_mandir}/man1/svnadmin.1*
619 %{_mandir}/man1/svndumpfilter.1*
620 %{_mandir}/man1/svnlook.1*
621 %{_mandir}/man1/svnsync.1*
622 %{_mandir}/man1/svnversion.1*
623
624 %files libs -f %{name}.lang
625 %defattr(644,root,root,755)
626 %attr(755,root,root) %{_libdir}/libsvn_client-1.so.*.*.*
627 %attr(755,root,root) %ghost %{_libdir}/libsvn_client-1.so.0
628 %attr(755,root,root) %{_libdir}/libsvn_delta-1.so.*.*.*
629 %attr(755,root,root) %ghost %{_libdir}/libsvn_delta-1.so.0
630 %attr(755,root,root) %{_libdir}/libsvn_diff-1.so.*.*.*
631 %attr(755,root,root) %ghost %{_libdir}/libsvn_diff-1.so.0
632 %attr(755,root,root) %{_libdir}/libsvn_fs-1.so.*.*.*
633 %attr(755,root,root) %ghost %{_libdir}/libsvn_fs-1.so.0
634 %attr(755,root,root) %{_libdir}/libsvn_fs_base-1.so.*.*.*
635 %attr(755,root,root) %ghost %{_libdir}/libsvn_fs_base-1.so.0
636 %attr(755,root,root) %{_libdir}/libsvn_fs_fs-1.so.*.*.*
637 %attr(755,root,root) %ghost %{_libdir}/libsvn_fs_fs-1.so.0
638 %attr(755,root,root) %{_libdir}/libsvn_fs_util-1.so.*.*.*
639 %attr(755,root,root) %ghost %{_libdir}/libsvn_fs_util-1.so.0
640 %attr(755,root,root) %{_libdir}/libsvn_ra-1.so.*.*.*
641 %attr(755,root,root) %ghost %{_libdir}/libsvn_ra-1.so.0
642 %attr(755,root,root) %{_libdir}/libsvn_ra_local-1.so.*.*.*
643 %attr(755,root,root) %ghost %{_libdir}/libsvn_ra_local-1.so.0
644 %attr(755,root,root) %{_libdir}/libsvn_ra_%{webdavlib}-1.so.*.*.*
645 %attr(755,root,root) %ghost %{_libdir}/libsvn_ra_%{webdavlib}-1.so.0
646 %attr(755,root,root) %{_libdir}/libsvn_ra_svn-1.so.*.*.*
647 %attr(755,root,root) %ghost %{_libdir}/libsvn_ra_svn-1.so.0
648 %attr(755,root,root) %{_libdir}/libsvn_repos-1.so.*.*.*
649 %attr(755,root,root) %ghost %{_libdir}/libsvn_repos-1.so.0
650 %attr(755,root,root) %{_libdir}/libsvn_subr-1.so.*.*.*
651 %attr(755,root,root) %ghost %{_libdir}/libsvn_subr-1.so.0
652 %attr(755,root,root) %{_libdir}/libsvn_wc-1.so.*.*.*
653 %attr(755,root,root) %ghost %{_libdir}/libsvn_wc-1.so.0
654
655 %files devel
656 %defattr(644,root,root,755)
657 %attr(755,root,root) %{_libdir}/libsvn_client-1.so
658 %attr(755,root,root) %{_libdir}/libsvn_delta-1.so
659 %attr(755,root,root) %{_libdir}/libsvn_diff-1.so
660 %attr(755,root,root) %{_libdir}/libsvn_fs-1.so
661 %attr(755,root,root) %{_libdir}/libsvn_fs_base-1.so
662 %attr(755,root,root) %{_libdir}/libsvn_fs_fs-1.so
663 %attr(755,root,root) %{_libdir}/libsvn_fs_util-1.so
664 %attr(755,root,root) %{_libdir}/libsvn_ra-1.so
665 %attr(755,root,root) %{_libdir}/libsvn_ra_local-1.so
666 %attr(755,root,root) %{_libdir}/libsvn_ra_%{webdavlib}-1.so
667 %attr(755,root,root) %{_libdir}/libsvn_ra_svn-1.so
668 %attr(755,root,root) %{_libdir}/libsvn_repos-1.so
669 %attr(755,root,root) %{_libdir}/libsvn_subr-1.so
670 %attr(755,root,root) %{_libdir}/libsvn_wc-1.so
671 %{_libdir}/libsvn_client-1.la
672 %{_libdir}/libsvn_delta-1.la
673 %{_libdir}/libsvn_diff-1.la
674 %{_libdir}/libsvn_fs-1.la
675 %{_libdir}/libsvn_fs_base-1.la
676 %{_libdir}/libsvn_fs_fs-1.la
677 %{_libdir}/libsvn_fs_util-1.la
678 %{_libdir}/libsvn_ra-1.la
679 %{_libdir}/libsvn_ra_local-1.la
680 %{_libdir}/libsvn_ra_%{webdavlib}-1.la
681 %{_libdir}/libsvn_ra_svn-1.la
682 %{_libdir}/libsvn_repos-1.la
683 %{_libdir}/libsvn_subr-1.la
684 %{_libdir}/libsvn_wc-1.la
685 %{_includedir}/%{name}-1
686 %{_examplesdir}/%{name}-%{version}
687
688 %files static
689 %defattr(644,root,root,755)
690 %{_libdir}/libsvn_client-1.a
691 %{_libdir}/libsvn_delta-1.a
692 %{_libdir}/libsvn_diff-1.a
693 %{_libdir}/libsvn_fs-1.a
694 %{_libdir}/libsvn_fs_base-1.a
695 %{_libdir}/libsvn_fs_fs-1.a
696 %{_libdir}/libsvn_fs_util-1.a
697 %{_libdir}/libsvn_ra-1.a
698 %{_libdir}/libsvn_ra_local-1.a
699 %{_libdir}/libsvn_ra_%{webdavlib}-1.a
700 %{_libdir}/libsvn_ra_svn-1.a
701 %{_libdir}/libsvn_repos-1.a
702 %{_libdir}/libsvn_subr-1.a
703 %{_libdir}/libsvn_wc-1.a
704
705 %if %{with gnome}
706 %files -n gnome-keyring-subversion
707 %defattr(644,root,root,755)
708 %attr(755,root,root) %{_libdir}/libsvn_auth_gnome_keyring-1.so.*.*.*
709 %attr(755,root,root) %ghost %{_libdir}/libsvn_auth_gnome_keyring-1.so.0
710 %endif
711
712 %if %{with kwallet}
713 %files -n kde4-kwallet-subversion
714 %defattr(644,root,root,755)
715 %attr(755,root,root) %{_libdir}/libsvn_auth_kwallet-1.so.*.*.*
716 %attr(755,root,root) %ghost %{_libdir}/libsvn_auth_kwallet-1.so.0
717 %endif
718
719 %if !%{with net_client_only}
720 %files svnserve
721 %defattr(644,root,root,755)
722 %attr(755,root,root) %{_bindir}/svnserve
723 %{_mandir}/man5/svnserve.conf.5*
724 %{_mandir}/man8/svnserve.8*
725 %dir %attr(750,svn,svn) /home/services/subversion
726 %dir %attr(750,svn,svn) /home/services/subversion/repos
727 %if %{with apache}
728 %attr(754,root,root) /etc/rc.d/init.d/svnserve
729 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/svnserve
730 %endif
731
732 %files tools
733 %defattr(644,root,root,755)
734 %attr(755,root,root) %{_bindir}/svn-hot-backup
735
736 %files -n bash-completion-subversion
737 %defattr(644,root,root,755)
738 /etc/bash_completion.d/%{name}
739
740 %if %{with javahl}
741 %files -n java-subversion
742 %defattr(644,root,root,755)
743 %attr(755,root,root) %{_libdir}/libsvnjavahl-1.so.*.*.*
744 %attr(755,root,root) %ghost %{_libdir}/libsvnjavahl-1.so.0
745 %attr(755,root,root) %{_libdir}/libsvnjavahl-1.so
746 %{_javadir}/svn-javahl.jar
747 %endif
748
749 %if %{with python}
750 %files -n python-subversion
751 %defattr(644,root,root,755)
752 %doc tools/backup/*.py tools/examples/*.py
753 %attr(755,root,root) %{_libdir}/libsvn_swig_py-1.so.*.*.*
754 %attr(755,root,root) %ghost %{_libdir}/libsvn_swig_py-1.so.0
755 %attr(755,root,root) %{_libdir}/libsvn_swig_py-1.so
756 %dir %{py_sitedir}/libsvn
757 %{py_sitedir}/libsvn/*.py[co]
758 %dir %{py_sitedir}/svn
759 %{py_sitedir}/svn/*.py[co]
760 %attr(755,root,root) %{py_sitedir}/libsvn/*.so
761 %{_examplesdir}/python-%{name}-%{version}
762
763 %files -n python-csvn
764 %defattr(644,root,root,755)
765 %doc subversion/bindings/ctypes-python/{README,TODO}
766 %doc subversion/bindings/ctypes-python/examples/*.py
767 %dir %{py_sitescriptdir}/csvn
768 %{py_sitescriptdir}/csvn/*.py[co]
769 %dir %{py_sitescriptdir}/csvn/core
770 %{py_sitescriptdir}/csvn/core/*.py[co]
771 %dir %{py_sitescriptdir}/csvn/ext
772 %{py_sitescriptdir}/csvn/ext/*.py[co]
773 %{py_sitescriptdir}/*.egg-info
774 %endif
775
776 %if %{with perl}
777 %files -n perl-subversion
778 %defattr(644,root,root,755)
779 %attr(755,root,root) %{_libdir}/libsvn_swig_perl-1.so.*.*.*
780 %attr(755,root,root) %ghost %{_libdir}/libsvn_swig_perl-1.so.0
781 %attr(755,root,root) %{_libdir}/libsvn_swig_perl-1.so
782 %{perl_vendorarch}/SVN
783 %dir %{perl_vendorarch}/auto/SVN
784 %dir %{perl_vendorarch}/auto/SVN/*
785 %attr(755,root,root) %{perl_vendorarch}/auto/SVN/*/*.so
786 %{perl_vendorarch}/auto/SVN/*/*.bs
787 %{_mandir}/man3/*.3pm*
788 %endif
789
790 %if %{with ruby}
791 %files -n ruby-subversion
792 %defattr(644,root,root,755)
793 %attr(755,root,root) %{_libdir}/libsvn_swig_ruby-1.so.*.*.*
794 %attr(755,root,root) %ghost %{_libdir}/libsvn_swig_ruby-1.so.0
795 %attr(755,root,root) %{_libdir}/libsvn_swig_ruby-1.so
796 %dir %{_libdir}/ruby/site_ruby/[0-9].[0-9]
797 %dir %{_libdir}/ruby/site_ruby/*/svn
798 %{_libdir}/ruby/site_ruby/*/svn/*.rb
799 %dir %{_libdir}/ruby/site_ruby/*/*-*
800 %dir %{_libdir}/ruby/site_ruby/*/*-*/svn
801 %dir %{_libdir}/ruby/site_ruby/*/*-*/svn/ext
802 %attr(755,root,root) %{_libdir}/ruby/site_ruby/*/*-*/svn/ext/*.so
803 %{_datadir}/ri/*.*/system/OptionParser
804 %{_datadir}/ri/*.*/system/Svn
805 %{_datadir}/ri/*.*/system/Time
806 %{_datadir}/ri/*.*/system/Uconv
807 %{_datadir}/ri/*.*/system/*.rid
808 %{_datadir}/ri/*.*/system/Kernel/*
809 %endif
810
811 %if %{with apache}
812 %files -n apache-mod_dav_svn
813 %defattr(644,root,root,755)
814 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{apacheconfdir}/*_mod_dav_svn.conf
815 %attr(755,root,root) %{apachelibdir}/mod_dav_svn.so
816
817 %files -n apache-mod_authz_svn
818 %defattr(644,root,root,755)
819 %doc subversion/mod_authz_svn/INSTALL
820 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{apacheconfdir}/*_mod_authz_svn.conf
821 %attr(755,root,root) %{apachelibdir}/mod_authz_svn.so
822 %endif
823
824 %endif # net_client_only
This page took 0.118321 seconds and 4 git commands to generate.