]> git.pld-linux.org Git - packages/subversion.git/blob - subversion.spec
- rel 4
[packages/subversion.git] / subversion.spec
1 # TODO:
2 # - fix java build with java-gcj-compat and s/java-sun/jdk/
3 # - remove net_client_only and add db bcond (then without apache and
4 #   without db => net_client_only - spec will be more simpler, I think)
5 # - finish ruby
6 # - http://subversion.tigris.org/issues/show_bug.cgi?id=2753
7 #
8 # Conditional build:
9 %bcond_with     net_client_only         # build only net client
10 %bcond_without  neon                    # use serf instead of neon
11 %bcond_without  python                  # build without python bindings (broken)
12 %bcond_without  perl                    # build without perl bindings
13 %bcond_without  ruby                    # build without ruby bindings
14 %bcond_without  apache                  # build without apache support (webdav, etc)
15 %bcond_without  javahl                  # build without javahl support (Java high-level bindings)
16 %bcond_without  tests                   # don't perform "make check"
17 %bcond_without  kwallet                 # build without kde4 wallet support
18 %bcond_without  gnome                   # build without gnome keyring support
19 #
20 %ifnarch i586 i686 pentium3 pentium4 athlon %{x8664}
21 %undefine       with_javahl
22 %endif
23 #
24 %{!?with_net_client_only:%include       /usr/lib/rpm/macros.perl}
25 %define apxs    /usr/sbin/apxs
26 %define pdir    SVN
27 %define pnam    _Core
28 #
29 %if %{with neon}
30 %define webdavlib       neon
31 %else
32 %define webdavlib       serf
33 %endif
34 #
35 Summary:        A Concurrent Versioning system similar to but better than CVS
36 Summary(pl.UTF-8):      System kontroli wersji podobny, ale lepszy, niż CVS
37 Summary(pt_BR.UTF-8):   Sistema de versionamento concorrente
38 Name:           subversion
39 Version:        1.6.9
40 Release:        4
41 License:        Apache/BSD-like
42 Group:          Development/Version Control
43 Source0:        http://subversion.tigris.org/downloads/%{name}-%{version}.tar.bz2
44 # Source0-md5:  9c30a47b1d48664e7afef68bb4834c53
45 Source1:        %{name}-dav_svn.conf
46 Source2:        %{name}-authz_svn.conf
47 Source3:        %{name}-svnserve.init
48 Source4:        %{name}-svnserve.sysconfig
49 # current subversion tarball has correct *.swg files
50 # but after regeneration these are broken again, so
51 # we still need this script
52 Source5:        %{name}-convert-typemaps-to-ifdef.py
53 Patch0:         %{name}-home_etc.patch
54 Patch1:         %{name}-DESTDIR.patch
55 Patch2:         %{name}-ruby-datadir-path.patch
56 URL:            http://subversion.apache.org/
57 %if %{with net_client_only}
58 %global apache_modules_api 0
59 %else
60 %{?with_apache:BuildRequires:   apache-devel >= 2.2.0-8}
61 BuildRequires:  automake
62 BuildRequires:  db-devel >= 4.1.25
63 BuildRequires:  rpmbuild(macros) >= 1.268
64 %if %{with perl}
65 BuildRequires:  perl-devel >= 1:5.8.0
66 BuildRequires:  rpm-perlprov >= 4.1-13
67 BuildRequires:  swig-perl >= 1.3.24
68 %endif
69 %if %{with python}
70 BuildRequires:  python-ctypesgen
71 BuildRequires:  python-devel >= 2.2
72 BuildRequires:  swig-python >= 1.3.24
73 %endif
74 %if %{with ruby}
75 BuildRequires:  ruby-devel
76 BuildRequires:  swig-ruby >= 1.3.24
77 %endif
78 %if %{with javahl}
79 BuildRequires:  java-sun
80 BuildRequires:  java-sun-tools
81 %endif
82 BuildRequires:  cyrus-sasl-devel
83 %endif
84 BuildRequires:  apr-devel >= 1:1.0.0
85 BuildRequires:  apr-util-devel >= 1:1.2.8-3
86 BuildRequires:  autoconf >= 2.59
87 BuildRequires:  bison
88 BuildRequires:  expat-devel
89 BuildRequires:  gettext-devel
90 %{?with_gnome:BuildRequires:    gnome-keyring-devel}
91 %{?with_kwallet:BuildRequires:  kde4-kdelibs-devel}
92 BuildRequires:  libtool >= 1.4-9
93 BuildRequires:  pkgconfig
94 BuildRequires:  sed >= 4.0
95 BuildRequires:  sqlite3-devel >= 3.6.11
96 BuildRequires:  texinfo
97 BuildRequires:  which
98 %if %{with neon}
99 BuildRequires:  neon-devel >= 0.26.0
100 %else
101 BuildRequires:  serf-devel
102 %endif
103 BuildRequires:  python >= 2.2
104 BuildRequires:  python-modules >= 2.2
105 Requires:       %{name}-libs = %{version}-%{release}
106 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
107
108 %define         _libexecdir             %{_libdir}/svn
109 %define         apacheconfdir   %(%{apxs} -q SYSCONFDIR 2>/dev/null)/conf.d
110 %define         apachelibdir    %(%{apxs} -q LIBEXECDIR 2>/dev/null)
111
112 %description
113 The goal of the Subversion project is to build a version control
114 system that is a compelling replacement for CVS in the open source
115 community.
116
117 Our goals are:
118 - All current CVS features.
119 - Directories, renames, and file meta-data are versioned.
120 - Symbolic links, etc, are supported
121 - Commits are truly atomic.
122 - Branching and tagging are cheap (constant time) operations
123 - Repeated merges are handled gracefully
124 - Support for plug-in client side diff programs
125 - Natively client/server
126 - Client/server protocol sends diffs in both directions
127 - Costs are proportional to change size, not project size
128 - Internationalization
129 - Progressive multi-lingual support
130
131 %description -l pl.UTF-8
132 Celem projektu Subversion jest stworzenie systemu kontroli wersji jako
133 zamiennika dla CVS.
134
135 Cele projektu to:
136 - Wszystkie aktualne możliwości CVS.
137 - Katalogi, zmiany nazw oraz metadane plików są wersjonowane.
138 - Obsługa dowiązań symbolicznych itp.
139 - Commity są w pełni atomowe.
140 - Branchowanie oraz tagowanie są tanimi (stałymi w czasie) operacjami.
141 - Dobra obsługa powtarzanego łączenia (merge).
142 - Obsługa wtyczek diff po stronie klienta.
143 - Natywny klient/serwer.
144 - Klient/Serwer przesyłają diffy w obu kierunkach.
145 - Koszty proporcjonalne do rozmiaru zmiany, a nie rozmiaru projektu.
146 - Internacjonalizacja.
147 - Postępujące wsparcie dla wielu języków.
148
149 %description -l pt_BR.UTF-8
150 O objetivo do projeto Subversion é construir um sistema de controle de
151 versões que seja um substituto para o CVS (Concurrent Versioning
152 System) na comunidade opensource, fornecendo grandes melhorias.
153
154 %package libs
155 Summary:        Subversion libraries and modules
156 Summary(pl.UTF-8):      Biblioteka subversion oraz ładowalne moduły
157 Group:          Libraries
158 %{?with_neon:Requires:  neon >= 0.26.0}
159 Obsoletes:      libsubversion0
160
161 %description libs
162 Subversion libraries and modules.
163
164 %description libs -l pl.UTF-8
165 Biblioteka subversion oraz ładowalne moduły.
166
167 %package devel
168 Summary:        Header files and develpment documentation for subversion
169 Summary(pl.UTF-8):      Pliki nagłówkowe i dokumetacja do subversion
170 Summary(pt_BR.UTF-8):   Arquivos de desenvolvimento para o Subversion
171 Group:          Development/Libraries
172 Requires:       %{name}-libs = %{version}-%{release}
173 Requires:       apr-util-devel >= 1:1.0.0
174 %{?with_neon:Requires:  neon-devel >= 0.26.0}
175 Obsoletes:      libsubversion0-devel
176
177 %description devel
178 Header files and develpment documentation for subversion.
179
180 %description devel -l pl.UTF-8
181 Pliki nagłówkowe i dokumetacja do subversion.
182
183 %description devel -l pt_BR.UTF-8
184 Este pacote provê os arquivos necessários para desenvolvedores
185 interagirem com o Subversion.
186
187 %package static
188 Summary:        Static subversion library
189 Summary(pl.UTF-8):      Biblioteka statyczna subversion
190 Summary(pt_BR.UTF-8):   Sistema de versionamento concorrente
191 Group:          Development/Libraries
192 Requires:       %{name}-devel = %{version}
193 Obsoletes:      libsubversion0-static-devel
194
195 %description static
196 Static subversion library.
197
198 %description static -l pl.UTF-8
199 Biblioteka statyczna subversion.
200
201 %description static -l pt_BR.UTF-8
202 Este pacote provê um cliente estático do subversion.
203
204 %package svnserve
205 Summary:        Subversion svnserve
206 Summary(pl.UTF-8):      Subversion svnserve
207 Group:          Networking/Daemons
208 Requires(post,preun):   /sbin/chkconfig
209 Requires(postun):       /usr/sbin/groupdel
210 Requires(postun):       /usr/sbin/userdel
211 Requires(pre):  /bin/id
212 Requires(pre):  /usr/bin/getgid
213 Requires(pre):  /usr/lib/rpm/user_group.sh
214 Requires(pre):  /usr/sbin/groupadd
215 Requires(pre):  /usr/sbin/useradd
216 Requires(pre):  /usr/sbin/usermod
217 Requires:       %{name} = %{version}-%{release}
218 Requires:       rc-scripts
219 Provides:       group(svn)
220 Provides:       user(svn)
221
222 %description svnserve
223 Subversion svnserve server.
224
225 %description svnserve -l pl.UTF-8
226 Serwer subversion svnserve.
227
228 %package tools
229 Summary:        Subversion tools and scripts
230 Summary(pl.UTF-8):      Narzędzia oraz skrypty dla subversion
231 Summary(pt_BR.UTF-8):   Módulos python para acessar os recursos do Subversion
232 Group:          Applications
233 %pyrequires_eq  python
234 Requires:       %{name} = %{version}-%{release}
235 Requires:       python-subversion = %{version}
236
237 %description tools
238 Subversion tools and scripts.
239
240 %description tools -l pl.UTF-8
241 Narzędzia oraz skrypty dla subversion.
242
243 %package -n bash-completion-subversion
244 Summary:        bash completion for subversion
245 Summary(pl.UTF-8):      Dopełnienia basha dla subversion
246 Group:          Applications/Shells
247 Requires:       %{name} = %{version}-%{release}
248 Requires:       bash-completion
249 Conflicts:      %{name}-tools <= 1.1.0-0.rc6.1
250
251 %description -n bash-completion-subversion
252 Bash completion for subversion.
253
254 %description -n bash-completion-subversion -l pl.UTF-8
255 Dopełnienia basha dla subversion.
256
257 %package -n java-subversion
258 Summary:        Subversion Java bindings
259 Summary(pl.UTF-8):      Dowiązania do Subversion dla Javy
260 Group:          Development/Languages/Java
261 Requires:       %{name}-libs = %{version}-%{release}
262
263 %description -n java-subversion
264 This is a set of Java classes which provide the functionality of
265 subversion-libs, the Subversion libraries. It is useful if you want
266 to, for example, write a Java class that manipulates a Subversion
267 repository or working copy. See the 'subversion' package for more
268 information.
269
270 %description -n java-subversion -l pl.UTF-8
271 Ten pakiet zawiera zestaw klas Javy udostępniających funkcjonalność
272 subversion-libs, czyli bibliotek Subversion. Jest przydatny przy
273 pisaniu klas Javy np. modyfikujących repozytorium Subversion lub kopię
274 roboczą. Więcej informacji w pakiecie subversion.
275
276 %package -n python-subversion
277 Summary:        Subversion Python bindings
278 Summary(pl.UTF-8):      Dowiązania do Subversion dla Pythona
279 Summary(pt_BR.UTF-8):   Módulos Python para acessar os recursos do Subversion
280 Group:          Development/Languages/Python
281 %pyrequires_eq  python
282 Requires:       %{name}-libs = %{version}-%{release}
283 Obsoletes:      subversion-python
284
285 %description -n python-subversion
286 Subversion Python bindings.
287
288 %description -n python-subversion -l pl.UTF-8
289 Dowiązania do Subversion dla Pythona.
290
291 %description -n python-subversion -l pt_BR.UTF-8
292 Módulos Python para acessar os recursos do Subversion.
293
294 %package -n python-csvn
295 Summary:        CTypes Subversion Python bindings
296 Summary(pl.UTF-8):      Dowiązania do Subversion dla Pythona
297 Summary(pt_BR.UTF-8):   Módulos Python para acessar os recursos do Subversion
298 Group:          Development/Languages/Python
299 %pyrequires_eq  python
300 Requires:       %{name}-libs = %{version}-%{release}
301
302 %description -n python-csvn
303 Subversion CTypes Python bindings.
304
305 %description -n python-csvn -l pl.UTF-8
306 Dowiązania do Subversion dla Pythona używające CTypes.
307
308 %description -n python-csvn -l pt_BR.UTF-8
309 Módulos Python para acessar os recursos do Subversion.
310
311 %package -n perl-subversion
312 Summary:        Subversion Perl bindings
313 Summary(pl.UTF-8):      Dowiązania do Subversion dla Perla
314 Summary(pt_BR.UTF-8):   Módulos Perl para acessar os recursos do Subversion
315 Group:          Development/Languages/Perl
316 Requires:       %{name}-libs = %{version}-%{release}
317 Obsoletes:      subversion-perl
318
319 %description -n perl-subversion
320 Subversion Perl bindings.
321
322 %description -n perl-subversion -l pl.UTF-8
323 Dowiązania do Subversion dla Perla.
324
325 %description -n perl-subversion -l pt_BR.UTF-8
326 Módulos Perl para acessar os recursos do Subversion.
327
328 %package -n ruby-subversion
329 Summary:        Subversion Ruby bindings
330 Summary(pl.UTF-8):      Dowiązania do Subversion dla języka Ruby
331 Summary(pt_BR.UTF-8):   Módulos Ruby para acessar os recursos do Subversion
332 Group:          Development/Languages
333 Requires:       %{name}-libs = %{version}-%{release}
334 Obsoletes:      subversion-ruby
335
336 %description -n ruby-subversion
337 Subversion Ruby bindings.
338
339 %description -n ruby-subversion -l pl.UTF-8
340 Dowiązania do Subversion dla języka Ruby.
341
342 %description -n ruby-subversion -l pt_BR.UTF-8
343 Módulos Ruby para acessar os recursos do Subversion.
344
345 %package -n apache-mod_dav_svn
346 Summary:        Apache module: Subversion Server
347 Summary(pl.UTF-8):      Moduł apache: Serwer Subversion
348 Group:          Networking/Daemons
349 Requires:       %{name} = %{version}-%{release}
350 Requires:       apache(modules-api) = %apache_modules_api
351 Requires:       apache-mod_dav
352
353 %description -n apache-mod_dav_svn
354 Apache module: Subversion Server.
355
356 %description -n apache-mod_dav_svn -l pl.UTF-8
357 Moduł apache: Serwer Subversion.
358
359 %package -n apache-mod_authz_svn
360 Summary:        Apache module: Subversion Server - path-based authorization
361 Summary(pl.UTF-8):      Moduł apache: autoryzacja na podstawie ścieżki dla serwera Subversion
362 Group:          Networking/Daemons
363 Requires:       apache(modules-api) = %apache_modules_api
364 Requires:       apache-mod_dav_svn = %{version}-%{release}
365
366 %description -n apache-mod_authz_svn
367 Apache module: Subversion Server - path-based authorization.
368
369 %description -n apache-mod_authz_svn -l pl.UTF-8
370 Moduł apache: autoryzacja na podstawie ścieżki dla serwera Subversion.
371
372 %package -n gnome-keyring-subversion
373 Summary:        Subversion module for Gnome Keyring
374 Summary(pl.UTF-8):      Moduł subversion dla zarządcy kluczy Gnome
375 Group:          X11/Applications
376
377 %description -n gnome-keyring-subversion
378 Subversion module for Gnome Keyring.
379
380 %description -n gnome-keyring-subversion -l pl.UTF-8
381 Moduł subversion dla zarządcy kluczy Gnome.
382
383 %package -n kde4-kwallet-subversion
384 Summary:        Subversion module for KDE Wallet
385 Summary(pl.UTF-8):      Moduł subversion dla Portfela KDE
386 Group:          X11/Applications
387
388 %description -n kde4-kwallet-subversion
389 Subversion module for KDE Wallet.
390
391 %description -n kde4-kwallet-subversion -l pl.UTF-8
392 Moduł subversion dla Portfela KDE.
393
394 %prep
395 %setup -q
396 rm -rf apr apr-util neon
397 %patch0 -p0
398 %patch1 -p1
399 %patch2 -p0
400
401 sed -i -e 's#serf_prefix/lib#serf_prefix/%{_lib}#g' build/ac-macros/serf.m4
402
403 # serf.m4 macro is broken and ignores --without serf
404 %{?with_neon:sed -i -e 's#serf_found="yes"#serf_found="no"#g' build/ac-macros/serf.m4}
405
406 %build
407 rm subversion/bindings/swig/proxy/*.swg
408 cd subversion/bindings/swig && python "%{SOURCE5}" && cd ../../..
409 cp -f /usr/share/automake/config.sub ac-helpers
410 chmod +x ./autogen.sh && ./autogen.sh
411
412 %configure \
413         --with-editor=vi \
414         --with-zlib=%{_libdir} \
415 %if %{with net_client_only}
416         --without-apache \
417         --without-swig \
418         --without-apxs \
419         --without-berkeley-db \
420 %else
421         --disable-runtime-module-search \
422         --disable-mod-activation \
423         --with-berkeley-db="db.h:%{_includedir}:%{_libdir}:db" \
424 %if %{with apache}
425         --with-apxs=%{_sbindir}/apxs \
426 %else
427         --without-apache \
428         --without-apxs \
429 %endif
430 %if !%{with python} && !%{with perl} && !%{with ruby}
431         --without-swig \
432 %endif
433         %{?with_python:--with-ctypesgen=%{_bindir}/ctypesgen.py} \
434         --%{?with_javahl:en}%{!?with_javahl:dis}able-javahl \
435 %endif
436         --with-jdk="%{java_home}" \
437 %if %{with neon}
438         --without-serf \
439         --with-neon=%{_prefix} \
440         --disable-neon-version-check \
441 %else
442         --with-serf=%{_prefix} \
443         --without-neon \
444 %endif
445         --with-apr=%{_bindir}/apr-1-config \
446         --with-apr-util=%{_bindir}/apu-1-config \
447 %if %{with kwallet}
448         --with-kwallet \
449 %endif
450 %if %{with gnome}
451         --with-gnome-keyring
452 %endif
453
454 %{__make} -j1
455
456 %if !%{with net_client_only}
457 # python
458 %if %{with python}
459 # ctypes bindings
460 %{__make} ctypes-python
461 # swig bindings
462 %{__make} swig-py \
463         swig_pydir=%{py_sitedir}/libsvn \
464         swig_pydir_extra=%{py_sitedir}/svn
465 %endif
466 # perl
467 %if %{with perl}
468 %{__make} -j1 swig-pl-lib
469 odir=$(pwd)
470 cd subversion/bindings/swig/perl/native
471 %{__perl} Makefile.PL INSTALLDIRS=vendor
472 %{__make} -j1
473 cd $odir
474 %endif
475 %if %{with javahl}
476 %{__make} -j1 javahl \
477         javahl_javadir="%{_javadir}"
478 %endif
479 # ruby
480 %if %{with ruby}
481 %{__make} swig-rb
482 %endif
483 %endif
484
485 %if %{with tests}
486 %{__make} check
487 %if %{with python}
488 %{__make} check-ctypes-python
489 %{__make} check-swig-py
490 %endif
491 %if %{with perl}
492 %{__make} check-swig-pl
493 %endif
494 %if %{with ruby}
495 %{__make} check-swig-rb
496 %endif
497 %endif
498
499 %install
500 rm -rf $RPM_BUILD_ROOT
501 install -d $RPM_BUILD_ROOT/etc/{rc.d/init.d,sysconfig,bash_completion.d} \
502         $RPM_BUILD_ROOT{%{apacheconfdir},%{apachelibdir},%{_infodir}} \
503         $RPM_BUILD_ROOT%{_examplesdir}/{%{name}-%{version},python-%{name}-%{version}} \
504         $RPM_BUILD_ROOT/home/services/subversion{,/repos}
505
506 %{__make} install -j1 \
507 %if %{with javahl}
508         install-javahl \
509         javahl_javadir="%{_javadir}" \
510 %endif
511 %if !%{with net_client_only}
512 %if %{with python}
513         install-swig-py \
514         install-ctypes-python \
515 %endif
516 %if %{with ruby}
517         install-swig-rb install-swig-rb-doc \
518 %endif
519 %endif
520         APACHE_LIBEXECDIR="$(%{_sbindir}/apxs -q LIBEXECDIR)" \
521         DESTDIR=$RPM_BUILD_ROOT \
522         swig_pydir=%{py_sitedir}/libsvn \
523         swig_pydir_extra=%{py_sitedir}/svn
524
525 %if !%{with net_client_only} && %{with perl}
526 %{__make} install-swig-pl-lib \
527         DESTDIR=$RPM_BUILD_ROOT
528 %{__make} -C subversion/bindings/swig/perl/native install \
529         DESTDIR=$RPM_BUILD_ROOT \
530         PREFIX=$RPM_BUILD_ROOT%{_prefix} \
531         LIBDIR=$RPM_BUILD_ROOT%{_libdir}
532 %endif
533
534 %if %{with apache}
535 install %{SOURCE1} $RPM_BUILD_ROOT%{apacheconfdir}/65_mod_dav_svn.conf
536 install %{SOURCE2} $RPM_BUILD_ROOT%{apacheconfdir}/66_mod_authz_svn.conf
537 install %{SOURCE3} $RPM_BUILD_ROOT/etc/rc.d/init.d/svnserve
538 install %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/svnserve
539 %endif
540
541 %if !%{with net_client_only}
542 install tools/backup/hot-backup.py $RPM_BUILD_ROOT%{_bindir}/svn-hot-backup
543 %if %{with python}
544 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
545 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
546 find $RPM_BUILD_ROOT%{py_sitedir} -name "*.py" -o -name "*.a" -o -name "*.la" | xargs rm -f
547 install tools/examples/*.py $RPM_BUILD_ROOT%{_examplesdir}/python-%{name}-%{version}
548 %endif
549 %endif
550
551 install tools/client-side/bash_completion $RPM_BUILD_ROOT/etc/bash_completion.d/%{name}
552 install tools/examples/*.c $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
553
554 %find_lang %{name}
555
556 %{?with_javahl:rm $RPM_BUILD_ROOT%{_libdir}/libsvnjavahl*.{la,a}}
557 rm -f $RPM_BUILD_ROOT%{_libdir}/libsvn_swig*.{la,a}
558 rm -f $RPM_BUILD_ROOT%{_libdir}/ruby/site_ruby/*/*/svn/ext/*.la
559
560 %clean
561 rm -rf $RPM_BUILD_ROOT
562
563 %pre svnserve
564 %groupadd -g 86 svn
565 %useradd -u 180 -d /home/services/subversion -c "Subversion svnserve" -g svn svn
566
567 %post   libs -p /sbin/ldconfig
568 %postun libs -p /sbin/ldconfig
569
570 %post   devel -p /sbin/postshell
571 -/usr/sbin/fix-info-dir -c %{_infodir}
572
573 %postun devel -p /sbin/postshell
574 -/usr/sbin/fix-info-dir -c %{_infodir}
575
576 %post   -n perl-subversion -p /sbin/ldconfig
577 %postun -n perl-subversion -p /sbin/ldconfig
578
579 %post   -n python-subversion -p /sbin/ldconfig
580 %postun -n python-subversion -p /sbin/ldconfig
581
582 %post svnserve
583 /sbin/chkconfig --add svnserve
584 %service svnserve restart "svnserve daemon"
585
586 %preun svnserve
587 if [ "$1" = "0" ]; then
588         %service svnserve stop
589         /sbin/chkconfig --del svnserve
590 fi
591
592 %postun svnserve
593 if [ "$1" = "0" ]; then
594         %userremove svn
595         %groupremove svn
596 fi
597
598 %post -n apache-mod_dav_svn
599 %service -q httpd restart
600
601 %preun -n apache-mod_dav_svn
602 if [ "$1" = "0" ]; then
603         %service -q httpd restart
604 fi
605
606 %post -n apache-mod_authz_svn
607 %service -q httpd restart
608
609 %preun -n apache-mod_authz_svn
610 if [ "$1" = "0" ]; then
611         %service -q httpd restart
612 fi
613
614 %files
615 %defattr(644,root,root,755)
616 %doc BUGS CHANGES COPYING INSTALL README
617 %doc doc/*/*.html
618 %doc tools/hook-scripts/*.{pl,py,example}
619 %doc tools/hook-scripts/mailer/*.{py,example}
620 %doc tools/xslt/*
621 %attr(755,root,root) %{_bindir}/svn
622 %attr(755,root,root) %{_bindir}/svnadmin
623 %attr(755,root,root) %{_bindir}/svndumpfilter
624 %attr(755,root,root) %{_bindir}/svnlook
625 %attr(755,root,root) %{_bindir}/svnsync
626 %attr(755,root,root) %{_bindir}/svnversion
627 %{_mandir}/man1/svn.1*
628 %{_mandir}/man1/svnadmin.1*
629 %{_mandir}/man1/svndumpfilter.1*
630 %{_mandir}/man1/svnlook.1*
631 %{_mandir}/man1/svnsync.1*
632 %{_mandir}/man1/svnversion.1*
633
634 %files libs -f %{name}.lang
635 %defattr(644,root,root,755)
636 %attr(755,root,root) %{_libdir}/libsvn_client-1.so.*.*.*
637 %attr(755,root,root) %ghost %{_libdir}/libsvn_client-1.so.0
638 %attr(755,root,root) %{_libdir}/libsvn_delta-1.so.*.*.*
639 %attr(755,root,root) %ghost %{_libdir}/libsvn_delta-1.so.0
640 %attr(755,root,root) %{_libdir}/libsvn_diff-1.so.*.*.*
641 %attr(755,root,root) %ghost %{_libdir}/libsvn_diff-1.so.0
642 %attr(755,root,root) %{_libdir}/libsvn_fs-1.so.*.*.*
643 %attr(755,root,root) %ghost %{_libdir}/libsvn_fs-1.so.0
644 %attr(755,root,root) %{_libdir}/libsvn_fs_base-1.so.*.*.*
645 %attr(755,root,root) %ghost %{_libdir}/libsvn_fs_base-1.so.0
646 %attr(755,root,root) %{_libdir}/libsvn_fs_fs-1.so.*.*.*
647 %attr(755,root,root) %ghost %{_libdir}/libsvn_fs_fs-1.so.0
648 %attr(755,root,root) %{_libdir}/libsvn_fs_util-1.so.*.*.*
649 %attr(755,root,root) %ghost %{_libdir}/libsvn_fs_util-1.so.0
650 %attr(755,root,root) %{_libdir}/libsvn_ra-1.so.*.*.*
651 %attr(755,root,root) %ghost %{_libdir}/libsvn_ra-1.so.0
652 %attr(755,root,root) %{_libdir}/libsvn_ra_local-1.so.*.*.*
653 %attr(755,root,root) %ghost %{_libdir}/libsvn_ra_local-1.so.0
654 %attr(755,root,root) %{_libdir}/libsvn_ra_%{webdavlib}-1.so.*.*.*
655 %attr(755,root,root) %ghost %{_libdir}/libsvn_ra_%{webdavlib}-1.so.0
656 %attr(755,root,root) %{_libdir}/libsvn_ra_svn-1.so.*.*.*
657 %attr(755,root,root) %ghost %{_libdir}/libsvn_ra_svn-1.so.0
658 %attr(755,root,root) %{_libdir}/libsvn_repos-1.so.*.*.*
659 %attr(755,root,root) %ghost %{_libdir}/libsvn_repos-1.so.0
660 %attr(755,root,root) %{_libdir}/libsvn_subr-1.so.*.*.*
661 %attr(755,root,root) %ghost %{_libdir}/libsvn_subr-1.so.0
662 %attr(755,root,root) %{_libdir}/libsvn_wc-1.so.*.*.*
663 %attr(755,root,root) %ghost %{_libdir}/libsvn_wc-1.so.0
664
665 %files devel
666 %defattr(644,root,root,755)
667 %attr(755,root,root) %{_libdir}/libsvn_client-1.so
668 %attr(755,root,root) %{_libdir}/libsvn_delta-1.so
669 %attr(755,root,root) %{_libdir}/libsvn_diff-1.so
670 %attr(755,root,root) %{_libdir}/libsvn_fs-1.so
671 %attr(755,root,root) %{_libdir}/libsvn_fs_base-1.so
672 %attr(755,root,root) %{_libdir}/libsvn_fs_fs-1.so
673 %attr(755,root,root) %{_libdir}/libsvn_fs_util-1.so
674 %attr(755,root,root) %{_libdir}/libsvn_ra-1.so
675 %attr(755,root,root) %{_libdir}/libsvn_ra_local-1.so
676 %attr(755,root,root) %{_libdir}/libsvn_ra_%{webdavlib}-1.so
677 %attr(755,root,root) %{_libdir}/libsvn_ra_svn-1.so
678 %attr(755,root,root) %{_libdir}/libsvn_repos-1.so
679 %attr(755,root,root) %{_libdir}/libsvn_subr-1.so
680 %attr(755,root,root) %{_libdir}/libsvn_wc-1.so
681 %{_libdir}/libsvn_client-1.la
682 %{_libdir}/libsvn_delta-1.la
683 %{_libdir}/libsvn_diff-1.la
684 %{_libdir}/libsvn_fs-1.la
685 %{_libdir}/libsvn_fs_base-1.la
686 %{_libdir}/libsvn_fs_fs-1.la
687 %{_libdir}/libsvn_fs_util-1.la
688 %{_libdir}/libsvn_ra-1.la
689 %{_libdir}/libsvn_ra_local-1.la
690 %{_libdir}/libsvn_ra_%{webdavlib}-1.la
691 %{_libdir}/libsvn_ra_svn-1.la
692 %{_libdir}/libsvn_repos-1.la
693 %{_libdir}/libsvn_subr-1.la
694 %{_libdir}/libsvn_wc-1.la
695 %{_includedir}/%{name}-1
696 %{_examplesdir}/%{name}-%{version}
697
698 %files static
699 %defattr(644,root,root,755)
700 %{_libdir}/libsvn_client-1.a
701 %{_libdir}/libsvn_delta-1.a
702 %{_libdir}/libsvn_diff-1.a
703 %{_libdir}/libsvn_fs-1.a
704 %{_libdir}/libsvn_fs_base-1.a
705 %{_libdir}/libsvn_fs_fs-1.a
706 %{_libdir}/libsvn_fs_util-1.a
707 %{_libdir}/libsvn_ra-1.a
708 %{_libdir}/libsvn_ra_local-1.a
709 %{_libdir}/libsvn_ra_%{webdavlib}-1.a
710 %{_libdir}/libsvn_ra_svn-1.a
711 %{_libdir}/libsvn_repos-1.a
712 %{_libdir}/libsvn_subr-1.a
713 %{_libdir}/libsvn_wc-1.a
714
715 %if %{with gnome}
716 %files -n gnome-keyring-subversion
717 %defattr(644,root,root,755)
718 %attr(755,root,root) %{_libdir}/libsvn_auth_gnome_keyring-1.so.*.*.*
719 %attr(755,root,root) %ghost %{_libdir}/libsvn_auth_gnome_keyring-1.so.0
720 %endif
721
722 %if %{with kwallet}
723 %files -n kde4-kwallet-subversion
724 %defattr(644,root,root,755)
725 %attr(755,root,root) %{_libdir}/libsvn_auth_kwallet-1.so.*.*.*
726 %attr(755,root,root) %ghost %{_libdir}/libsvn_auth_kwallet-1.so.0
727 %endif
728
729 %if !%{with net_client_only}
730 %files svnserve
731 %defattr(644,root,root,755)
732 %attr(755,root,root) %{_bindir}/svnserve
733 %{_mandir}/man5/svnserve.conf.5*
734 %{_mandir}/man8/svnserve.8*
735 %dir %attr(750,svn,svn) /home/services/subversion
736 %dir %attr(750,svn,svn) /home/services/subversion/repos
737 %if %{with apache}
738 %attr(754,root,root) /etc/rc.d/init.d/svnserve
739 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/svnserve
740 %endif
741
742 %files tools
743 %defattr(644,root,root,755)
744 %attr(755,root,root) %{_bindir}/svn-hot-backup
745
746 %files -n bash-completion-subversion
747 %defattr(644,root,root,755)
748 /etc/bash_completion.d/%{name}
749
750 %if %{with javahl}
751 %files -n java-subversion
752 %defattr(644,root,root,755)
753 %attr(755,root,root) %{_libdir}/libsvnjavahl-1.so.*.*.*
754 %attr(755,root,root) %ghost %{_libdir}/libsvnjavahl-1.so.0
755 %attr(755,root,root) %{_libdir}/libsvnjavahl-1.so
756 %{_javadir}/svn-javahl.jar
757 %endif
758
759 %if %{with python}
760 %files -n python-subversion
761 %defattr(644,root,root,755)
762 %doc tools/backup/*.py tools/examples/*.py
763 %attr(755,root,root) %{_libdir}/libsvn_swig_py-1.so.*.*.*
764 %attr(755,root,root) %ghost %{_libdir}/libsvn_swig_py-1.so.0
765 %attr(755,root,root) %{_libdir}/libsvn_swig_py-1.so
766 %dir %{py_sitedir}/libsvn
767 %{py_sitedir}/libsvn/*.py[co]
768 %dir %{py_sitedir}/svn
769 %{py_sitedir}/svn/*.py[co]
770 %attr(755,root,root) %{py_sitedir}/libsvn/*.so
771 %{_examplesdir}/python-%{name}-%{version}
772
773 %files -n python-csvn
774 %defattr(644,root,root,755)
775 %doc subversion/bindings/ctypes-python/{README,TODO}
776 %doc subversion/bindings/ctypes-python/examples/*.py
777 %dir %{py_sitescriptdir}/csvn
778 %{py_sitescriptdir}/csvn/*.py[co]
779 %dir %{py_sitescriptdir}/csvn/core
780 %{py_sitescriptdir}/csvn/core/*.py[co]
781 %dir %{py_sitescriptdir}/csvn/ext
782 %{py_sitescriptdir}/csvn/ext/*.py[co]
783 %{py_sitescriptdir}/*.egg-info
784 %endif
785
786 %if %{with perl}
787 %files -n perl-subversion
788 %defattr(644,root,root,755)
789 %attr(755,root,root) %{_libdir}/libsvn_swig_perl-1.so.*.*.*
790 %attr(755,root,root) %ghost %{_libdir}/libsvn_swig_perl-1.so.0
791 %attr(755,root,root) %{_libdir}/libsvn_swig_perl-1.so
792 %{perl_vendorarch}/SVN
793 %dir %{perl_vendorarch}/auto/SVN
794 %dir %{perl_vendorarch}/auto/SVN/*
795 %attr(755,root,root) %{perl_vendorarch}/auto/SVN/*/*.so
796 %{perl_vendorarch}/auto/SVN/*/*.bs
797 %{_mandir}/man3/*.3pm*
798 %endif
799
800 %if %{with ruby}
801 %files -n ruby-subversion
802 %defattr(644,root,root,755)
803 %attr(755,root,root) %{_libdir}/libsvn_swig_ruby-1.so.*.*.*
804 %attr(755,root,root) %ghost %{_libdir}/libsvn_swig_ruby-1.so.0
805 %attr(755,root,root) %{_libdir}/libsvn_swig_ruby-1.so
806 %dir %{ruby_sitelibdir}/svn
807 %{ruby_sitelibdir}/svn/*.rb
808 %dir %{ruby_sitearchdir}/svn
809 %dir %{ruby_sitearchdir}/svn/ext
810 %attr(755,root,root) %{ruby_sitearchdir}/svn/ext/*.so
811 %{ruby_ridir}/Svn
812 %endif
813
814 %if %{with apache}
815 %files -n apache-mod_dav_svn
816 %defattr(644,root,root,755)
817 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{apacheconfdir}/*_mod_dav_svn.conf
818 %attr(755,root,root) %{apachelibdir}/mod_dav_svn.so
819
820 %files -n apache-mod_authz_svn
821 %defattr(644,root,root,755)
822 %doc subversion/mod_authz_svn/INSTALL
823 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{apacheconfdir}/*_mod_authz_svn.conf
824 %attr(755,root,root) %{apachelibdir}/mod_authz_svn.so
825 %endif
826
827 %endif # net_client_only
This page took 0.136174 seconds and 4 git commands to generate.