]> git.pld-linux.org Git - packages/subversion.git/blob - subversion.spec
- rel 2
[packages/subversion.git] / subversion.spec
1 # TODO:
2 # - fix java build with java-gcj-compat and s/java-sun/jdk/
3 # - remove net_client_only and add db bcond (then without apache and
4 #   without db => net_client_only - spec will be more simpler, I think)
5 # - finish ruby
6 #
7 # Conditional build:
8 %bcond_with     net_client_only         # build only net client
9 %bcond_without  neon                    # use serf instead of neon
10 %bcond_without  python                  # build without python bindings (broken)
11 %bcond_without  perl                    # build without perl bindings
12 %bcond_without  ruby                    # build without ruby bindings
13 %bcond_without  apache                  # build without apache support (webdav, etc)
14 %bcond_without  javahl                  # build without javahl support (Java high-level bindings)
15 %bcond_without  tests                   # don't perform "make check"
16 %bcond_without  kwallet                 # build without kde4 wallet support
17 %bcond_without  gnome                   # build without gnome keyring support
18 #
19 %ifnarch i586 i686 pentium3 pentium4 athlon %{x8664}
20 %undefine       with_javahl
21 %endif
22 #
23 %{!?with_net_client_only:%include       /usr/lib/rpm/macros.perl}
24 %define apxs    /usr/sbin/apxs
25 %define pdir    SVN
26 %define pnam    _Core
27 #
28 %if %{with neon}
29 %define webdavlib       neon
30 %else
31 %define webdavlib       serf
32 %endif
33 #
34 Summary:        A Concurrent Versioning system similar to but better than CVS
35 Summary(pl.UTF-8):      System kontroli wersji podobny, ale lepszy, niż CVS
36 Summary(pt_BR.UTF-8):   Sistema de versionamento concorrente
37 Name:           subversion
38 Version:        1.6.9
39 Release:        2
40 License:        Apache/BSD-like
41 Group:          Development/Version Control
42 Source0:        http://subversion.tigris.org/downloads/%{name}-%{version}.tar.bz2
43 # Source0-md5:  9c30a47b1d48664e7afef68bb4834c53
44 Source1:        %{name}-dav_svn.conf
45 Source2:        %{name}-authz_svn.conf
46 Source3:        %{name}-svnserve.init
47 Source4:        %{name}-svnserve.sysconfig
48 # current subversion tarball has correct *.swg files
49 # but after regeneration these are broken again, so
50 # we still need this script
51 Source5:        %{name}-convert-typemaps-to-ifdef.py
52 Patch0:         %{name}-home_etc.patch
53 Patch1:         %{name}-DESTDIR.patch
54 Patch2:         %{name}-ruby-datadir-path.patch
55 URL:            http://subversion.apache.org/
56 %if %{with net_client_only}
57 %global apache_modules_api 0
58 %else
59 %{?with_apache:BuildRequires:   apache-devel >= 2.2.0-8}
60 BuildRequires:  automake
61 BuildRequires:  db-devel >= 4.1.25
62 BuildRequires:  rpmbuild(macros) >= 1.268
63 %if %{with perl}
64 BuildRequires:  perl-devel >= 1:5.8.0
65 BuildRequires:  rpm-perlprov >= 4.1-13
66 BuildRequires:  swig-perl >= 1.3.24
67 %endif
68 %if %{with python}
69 BuildRequires:  python-ctypesgen
70 BuildRequires:  python-devel >= 2.2
71 BuildRequires:  swig-python >= 1.3.24
72 %endif
73 %if %{with ruby}
74 BuildRequires:  ruby-devel
75 BuildRequires:  swig-ruby >= 1.3.24
76 %endif
77 %if %{with javahl}
78 BuildRequires:  java-sun
79 BuildRequires:  java-sun-tools
80 %endif
81 BuildRequires:  cyrus-sasl-devel
82 %endif
83 BuildRequires:  apr-devel >= 1:1.0.0
84 BuildRequires:  apr-util-devel >= 1:1.2.8-3
85 BuildRequires:  autoconf >= 2.59
86 BuildRequires:  bison
87 BuildRequires:  expat-devel
88 BuildRequires:  gettext-devel
89 %{?with_gnome:BuildRequires:    gnome-keyring-devel}
90 %{?with_kwallet:BuildRequires:  kde4-kdelibs-devel}
91 BuildRequires:  libtool >= 1.4-9
92 BuildRequires:  pkgconfig
93 BuildRequires:  sed >= 4.0
94 BuildRequires:  sqlite3-devel >= 3.6.11
95 BuildRequires:  texinfo
96 BuildRequires:  which
97 %if %{with neon}
98 BuildRequires:  neon-devel >= 0.26.0
99 %else
100 BuildRequires:  serf-devel
101 %endif
102 BuildRequires:  python >= 2.2
103 BuildRequires:  python-modules >= 2.2
104 Requires:       %{name}-libs = %{version}-%{release}
105 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
106
107 %define         _libexecdir             %{_libdir}/svn
108 %define         apacheconfdir   %(%{apxs} -q SYSCONFDIR 2>/dev/null)/conf.d
109 %define         apachelibdir    %(%{apxs} -q LIBEXECDIR 2>/dev/null)
110
111 %description
112 The goal of the Subversion project is to build a version control
113 system that is a compelling replacement for CVS in the open source
114 community.
115
116 Our goals are:
117 - All current CVS features.
118 - Directories, renames, and file meta-data are versioned.
119 - Symbolic links, etc, are supported
120 - Commits are truly atomic.
121 - Branching and tagging are cheap (constant time) operations
122 - Repeated merges are handled gracefully
123 - Support for plug-in client side diff programs
124 - Natively client/server
125 - Client/server protocol sends diffs in both directions
126 - Costs are proportional to change size, not project size
127 - Internationalization
128 - Progressive multi-lingual support
129
130 %description -l pl.UTF-8
131 Celem projektu Subversion jest stworzenie systemu kontroli wersji jako
132 zamiennika dla CVS.
133
134 Cele projektu to:
135 - Wszystkie aktualne możliwości CVS.
136 - Katalogi, zmiany nazw oraz metadane plików są wersjonowane.
137 - Obsługa dowiązań symbolicznych itp.
138 - Commity są w pełni atomowe.
139 - Branchowanie oraz tagowanie są tanimi (stałymi w czasie) operacjami.
140 - Dobra obsługa powtarzanego łączenia (merge).
141 - Obsługa wtyczek diff po stronie klienta.
142 - Natywny klient/serwer.
143 - Klient/Serwer przesyłają diffy w obu kierunkach.
144 - Koszty proporcjonalne do rozmiaru zmiany, a nie rozmiaru projektu.
145 - Internacjonalizacja.
146 - Postępujące wsparcie dla wielu języków.
147
148 %description -l pt_BR.UTF-8
149 O objetivo do projeto Subversion é construir um sistema de controle de
150 versões que seja um substituto para o CVS (Concurrent Versioning
151 System) na comunidade opensource, fornecendo grandes melhorias.
152
153 %package libs
154 Summary:        Subversion libraries and modules
155 Summary(pl.UTF-8):      Biblioteka subversion oraz ładowalne moduły
156 Group:          Libraries
157 %{?with_neon:Requires:  neon >= 0.26.0}
158 Obsoletes:      libsubversion0
159
160 %description libs
161 Subversion libraries and modules.
162
163 %description libs -l pl.UTF-8
164 Biblioteka subversion oraz ładowalne moduły.
165
166 %package devel
167 Summary:        Header files and develpment documentation for subversion
168 Summary(pl.UTF-8):      Pliki nagłówkowe i dokumetacja do subversion
169 Summary(pt_BR.UTF-8):   Arquivos de desenvolvimento para o Subversion
170 Group:          Development/Libraries
171 Requires:       %{name}-libs = %{version}-%{release}
172 Requires:       apr-util-devel >= 1:1.0.0
173 %{?with_neon:Requires:  neon-devel >= 0.26.0}
174 Obsoletes:      libsubversion0-devel
175
176 %description devel
177 Header files and develpment documentation for subversion.
178
179 %description devel -l pl.UTF-8
180 Pliki nagłówkowe i dokumetacja do subversion.
181
182 %description devel -l pt_BR.UTF-8
183 Este pacote provê os arquivos necessários para desenvolvedores
184 interagirem com o Subversion.
185
186 %package static
187 Summary:        Static subversion library
188 Summary(pl.UTF-8):      Biblioteka statyczna subversion
189 Summary(pt_BR.UTF-8):   Sistema de versionamento concorrente
190 Group:          Development/Libraries
191 Requires:       %{name}-devel = %{version}
192 Obsoletes:      libsubversion0-static-devel
193
194 %description static
195 Static subversion library.
196
197 %description static -l pl.UTF-8
198 Biblioteka statyczna subversion.
199
200 %description static -l pt_BR.UTF-8
201 Este pacote provê um cliente estático do subversion.
202
203 %package svnserve
204 Summary:        Subversion svnserve
205 Summary(pl.UTF-8):      Subversion svnserve
206 Group:          Networking/Daemons
207 Requires(post,preun):   /sbin/chkconfig
208 Requires(postun):       /usr/sbin/groupdel
209 Requires(postun):       /usr/sbin/userdel
210 Requires(pre):  /bin/id
211 Requires(pre):  /usr/bin/getgid
212 Requires(pre):  /usr/lib/rpm/user_group.sh
213 Requires(pre):  /usr/sbin/groupadd
214 Requires(pre):  /usr/sbin/useradd
215 Requires(pre):  /usr/sbin/usermod
216 Requires:       %{name} = %{version}-%{release}
217 Requires:       rc-scripts
218 Provides:       group(svn)
219 Provides:       user(svn)
220
221 %description svnserve
222 Subversion svnserve server.
223
224 %description svnserve -l pl.UTF-8
225 Serwer subversion svnserve.
226
227 %package tools
228 Summary:        Subversion tools and scripts
229 Summary(pl.UTF-8):      Narzędzia oraz skrypty dla subversion
230 Summary(pt_BR.UTF-8):   Módulos python para acessar os recursos do Subversion
231 Group:          Applications
232 %pyrequires_eq  python
233 Requires:       %{name} = %{version}-%{release}
234 Requires:       python-subversion = %{version}
235
236 %description tools
237 Subversion tools and scripts.
238
239 %description tools -l pl.UTF-8
240 Narzędzia oraz skrypty dla subversion.
241
242 %package -n bash-completion-subversion
243 Summary:        bash completion for subversion
244 Summary(pl.UTF-8):      Dopełnienia basha dla subversion
245 Group:          Applications/Shells
246 Requires:       %{name} = %{version}-%{release}
247 Requires:       bash-completion
248 Conflicts:      %{name}-tools <= 1.1.0-0.rc6.1
249
250 %description -n bash-completion-subversion
251 Bash completion for subversion.
252
253 %description -n bash-completion-subversion -l pl.UTF-8
254 Dopełnienia basha dla subversion.
255
256 %package -n java-subversion
257 Summary:        Subversion Java bindings
258 Summary(pl.UTF-8):      Dowiązania do Subversion dla Javy
259 Group:          Development/Languages/Java
260 Requires:       %{name}-libs = %{version}-%{release}
261
262 %description -n java-subversion
263 This is a set of Java classes which provide the functionality of
264 subversion-libs, the Subversion libraries. It is useful if you want
265 to, for example, write a Java class that manipulates a Subversion
266 repository or working copy. See the 'subversion' package for more
267 information.
268
269 %description -n java-subversion -l pl.UTF-8
270 Ten pakiet zawiera zestaw klas Javy udostępniających funkcjonalność
271 subversion-libs, czyli bibliotek Subversion. Jest przydatny przy
272 pisaniu klas Javy np. modyfikujących repozytorium Subversion lub kopię
273 roboczą. Więcej informacji w pakiecie subversion.
274
275 %package -n python-subversion
276 Summary:        Subversion Python bindings
277 Summary(pl.UTF-8):      Dowiązania do Subversion dla Pythona
278 Summary(pt_BR.UTF-8):   Módulos Python para acessar os recursos do Subversion
279 Group:          Development/Languages/Python
280 %pyrequires_eq  python
281 Requires:       %{name}-libs = %{version}-%{release}
282 Obsoletes:      subversion-python
283
284 %description -n python-subversion
285 Subversion Python bindings.
286
287 %description -n python-subversion -l pl.UTF-8
288 Dowiązania do Subversion dla Pythona.
289
290 %description -n python-subversion -l pt_BR.UTF-8
291 Módulos Python para acessar os recursos do Subversion.
292
293 %package -n python-csvn
294 Summary:        CTypes Subversion Python bindings
295 Summary(pl.UTF-8):      Dowiązania do Subversion dla Pythona
296 Summary(pt_BR.UTF-8):   Módulos Python para acessar os recursos do Subversion
297 Group:          Development/Languages/Python
298 %pyrequires_eq  python
299 Requires:       %{name}-libs = %{version}-%{release}
300
301 %description -n python-csvn
302 Subversion CTypes Python bindings.
303
304 %description -n python-csvn -l pl.UTF-8
305 Dowiązania do Subversion dla Pythona używające CTypes.
306
307 %description -n python-csvn -l pt_BR.UTF-8
308 Módulos Python para acessar os recursos do Subversion.
309
310 %package -n perl-subversion
311 Summary:        Subversion Perl bindings
312 Summary(pl.UTF-8):      Dowiązania do Subversion dla Perla
313 Summary(pt_BR.UTF-8):   Módulos Perl para acessar os recursos do Subversion
314 Group:          Development/Languages/Perl
315 Requires:       %{name}-libs = %{version}-%{release}
316 Obsoletes:      subversion-perl
317
318 %description -n perl-subversion
319 Subversion Perl bindings.
320
321 %description -n perl-subversion -l pl.UTF-8
322 Dowiązania do Subversion dla Perla.
323
324 %description -n perl-subversion -l pt_BR.UTF-8
325 Módulos Perl para acessar os recursos do Subversion.
326
327 %package -n ruby-subversion
328 Summary:        Subversion Ruby bindings
329 Summary(pl.UTF-8):      Dowiązania do Subversion dla języka Ruby
330 Summary(pt_BR.UTF-8):   Módulos Ruby para acessar os recursos do Subversion
331 Group:          Development/Languages
332 Requires:       %{name}-libs = %{version}-%{release}
333 Obsoletes:      subversion-ruby
334
335 %description -n ruby-subversion
336 Subversion Ruby bindings.
337
338 %description -n ruby-subversion -l pl.UTF-8
339 Dowiązania do Subversion dla języka Ruby.
340
341 %description -n ruby-subversion -l pt_BR.UTF-8
342 Módulos Ruby para acessar os recursos do Subversion.
343
344 %package -n apache-mod_dav_svn
345 Summary:        Apache module: Subversion Server
346 Summary(pl.UTF-8):      Moduł apache: Serwer Subversion
347 Group:          Networking/Daemons
348 Requires:       %{name} = %{version}-%{release}
349 Requires:       apache(modules-api) = %apache_modules_api
350 Requires:       apache-mod_dav
351
352 %description -n apache-mod_dav_svn
353 Apache module: Subversion Server.
354
355 %description -n apache-mod_dav_svn -l pl.UTF-8
356 Moduł apache: Serwer Subversion.
357
358 %package -n apache-mod_authz_svn
359 Summary:        Apache module: Subversion Server - path-based authorization
360 Summary(pl.UTF-8):      Moduł apache: autoryzacja na podstawie ścieżki dla serwera Subversion
361 Group:          Networking/Daemons
362 Requires:       apache(modules-api) = %apache_modules_api
363 Requires:       apache-mod_dav_svn = %{version}-%{release}
364
365 %description -n apache-mod_authz_svn
366 Apache module: Subversion Server - path-based authorization.
367
368 %description -n apache-mod_authz_svn -l pl.UTF-8
369 Moduł apache: autoryzacja na podstawie ścieżki dla serwera Subversion.
370
371 %package -n gnome-keyring-subversion
372 Summary:        Subversion module for Gnome Keyring
373 Summary(pl.UTF-8):      Moduł subversion dla zarządcy kluczy Gnome
374 Group:          X11/Applications
375
376 %description -n gnome-keyring-subversion
377 Subversion module for Gnome Keyring.
378
379 %description -n gnome-keyring-subversion -l pl.UTF-8
380 Moduł subversion dla zarządcy kluczy Gnome.
381
382 %package -n kde4-kwallet-subversion
383 Summary:        Subversion module for KDE Wallet
384 Summary(pl.UTF-8):      Moduł subversion dla Portfela KDE
385 Group:          X11/Applications
386
387 %description -n kde4-kwallet-subversion
388 Subversion module for KDE Wallet.
389
390 %description -n kde4-kwallet-subversion -l pl.UTF-8
391 Moduł subversion dla Portfela KDE.
392
393 %prep
394 %setup -q
395 rm -rf apr apr-util neon
396 %patch0 -p0
397 %patch1 -p1
398 %patch2 -p0
399
400 sed -i -e 's#serf_prefix/lib#serf_prefix/%{_lib}#g' build/ac-macros/serf.m4
401
402 # serf.m4 macro is broken and ignores --without serf
403 %{?with_neon:sed -i -e 's#serf_found="yes"#serf_found="no"#g' build/ac-macros/serf.m4}
404
405 %build
406 rm subversion/bindings/swig/proxy/*.swg
407 cd subversion/bindings/swig && python "%{SOURCE5}" && cd ../../..
408 cp -f /usr/share/automake/config.sub ac-helpers
409 chmod +x ./autogen.sh && ./autogen.sh
410
411 %configure \
412         --with-editor=vi \
413         --with-zlib=%{_libdir} \
414 %if %{with net_client_only}
415         --without-apache \
416         --without-swig \
417         --without-apxs \
418         --without-berkeley-db \
419 %else
420         --disable-runtime-module-search \
421         --disable-mod-activation \
422         --with-berkeley-db="db.h:%{_includedir}:%{_libdir}:db" \
423 %if %{with apache}
424         --with-apxs=%{_sbindir}/apxs \
425 %else
426         --without-apache \
427         --without-apxs \
428 %endif
429 %if !%{with python} && !%{with perl} && !%{with ruby}
430         --without-swig \
431 %endif
432         %{?with_python:--with-ctypesgen=%{_bindir}/ctypesgen.py} \
433         --%{?with_javahl:en}%{!?with_javahl:dis}able-javahl \
434 %endif
435         --with-jdk="%{java_home}" \
436 %if %{with neon}
437         --without-serf \
438         --with-neon=%{_prefix} \
439         --disable-neon-version-check \
440 %else
441         --with-serf=%{_prefix} \
442         --without-neon \
443 %endif
444         --with-apr=%{_bindir}/apr-1-config \
445         --with-apr-util=%{_bindir}/apu-1-config \
446 %if %{with kwallet}
447         --with-kwallet \
448 %endif
449 %if %{with gnome}
450         --with-gnome-keyring
451 %endif
452
453 %{__make} -j1
454
455 %if !%{with net_client_only}
456 # python
457 %if %{with python}
458 # ctypes bindings
459 %{__make} ctypes-python
460 # swig bindings
461 %{__make} swig-py \
462         swig_pydir=%{py_sitedir}/libsvn \
463         swig_pydir_extra=%{py_sitedir}/svn
464 %endif
465 # perl
466 %if %{with perl}
467 %{__make} -j1 swig-pl-lib
468 odir=$(pwd)
469 cd subversion/bindings/swig/perl/native
470 %{__perl} Makefile.PL INSTALLDIRS=vendor
471 %{__make} -j1
472 cd $odir
473 %endif
474 %if %{with javahl}
475 %{__make} -j1 javahl \
476         javahl_javadir="%{_javadir}"
477 %endif
478 # ruby
479 %if %{with ruby}
480 %{__make} swig-rb
481 %endif
482 %endif
483
484 %if %{with tests}
485 %{__make} check
486 %if %{with python}
487 %{__make} check-ctypes-python
488 %{__make} check-swig-py
489 %endif
490 %if %{with perl}
491 %{__make} check-swig-pl
492 %endif
493 %if %{with ruby}
494 %{__make} check-swig-rb
495 %endif
496 %endif
497
498 %install
499 rm -rf $RPM_BUILD_ROOT
500 install -d $RPM_BUILD_ROOT/etc/{rc.d/init.d,sysconfig,bash_completion.d} \
501         $RPM_BUILD_ROOT{%{apacheconfdir},%{apachelibdir},%{_infodir}} \
502         $RPM_BUILD_ROOT%{_examplesdir}/{%{name}-%{version},python-%{name}-%{version}} \
503         $RPM_BUILD_ROOT/home/services/subversion{,/repos}
504
505 %{__make} install -j1 \
506 %if %{with javahl}
507         install-javahl \
508         javahl_javadir="%{_javadir}" \
509 %endif
510 %if !%{with net_client_only}
511 %if %{with python}
512         install-swig-py \
513         install-ctypes-python \
514 %endif
515 %if %{with ruby}
516         install-swig-rb install-swig-rb-doc \
517 %endif
518 %endif
519         APACHE_LIBEXECDIR="$(%{_sbindir}/apxs -q LIBEXECDIR)" \
520         DESTDIR=$RPM_BUILD_ROOT \
521         swig_pydir=%{py_sitedir}/libsvn \
522         swig_pydir_extra=%{py_sitedir}/svn
523
524 %if !%{with net_client_only} && %{with perl}
525 %{__make} install-swig-pl-lib \
526         DESTDIR=$RPM_BUILD_ROOT
527 %{__make} -C subversion/bindings/swig/perl/native install \
528         DESTDIR=$RPM_BUILD_ROOT \
529         PREFIX=$RPM_BUILD_ROOT%{_prefix} \
530         LIBDIR=$RPM_BUILD_ROOT%{_libdir}
531 %endif
532
533 %if %{with apache}
534 install %{SOURCE1} $RPM_BUILD_ROOT%{apacheconfdir}/65_mod_dav_svn.conf
535 install %{SOURCE2} $RPM_BUILD_ROOT%{apacheconfdir}/66_mod_authz_svn.conf
536 install %{SOURCE3} $RPM_BUILD_ROOT/etc/rc.d/init.d/svnserve
537 install %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/svnserve
538 %endif
539
540 %if !%{with net_client_only}
541 install tools/backup/hot-backup.py $RPM_BUILD_ROOT%{_bindir}/svn-hot-backup
542 %if %{with python}
543 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
544 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
545 find $RPM_BUILD_ROOT%{py_sitedir} -name "*.py" -o -name "*.a" -o -name "*.la" | xargs rm -f
546 install tools/examples/*.py $RPM_BUILD_ROOT%{_examplesdir}/python-%{name}-%{version}
547 %endif
548 %endif
549
550 install tools/client-side/bash_completion $RPM_BUILD_ROOT/etc/bash_completion.d/%{name}
551 install tools/examples/*.c $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
552
553 %find_lang %{name}
554
555 %{?with_javahl:rm $RPM_BUILD_ROOT%{_libdir}/libsvnjavahl*.{la,a}}
556 rm -f $RPM_BUILD_ROOT%{_libdir}/libsvn_swig*.{la,a}
557 rm -f $RPM_BUILD_ROOT%{_libdir}/ruby/site_ruby/*/*/svn/ext/*.la
558
559 %clean
560 rm -rf $RPM_BUILD_ROOT
561
562 %pre svnserve
563 %groupadd -g 86 svn
564 %useradd -u 180 -d /home/services/subversion -c "Subversion svnserve" -g svn svn
565
566 %post   libs -p /sbin/ldconfig
567 %postun libs -p /sbin/ldconfig
568
569 %post   devel -p /sbin/postshell
570 -/usr/sbin/fix-info-dir -c %{_infodir}
571
572 %postun devel -p /sbin/postshell
573 -/usr/sbin/fix-info-dir -c %{_infodir}
574
575 %post   -n perl-subversion -p /sbin/ldconfig
576 %postun -n perl-subversion -p /sbin/ldconfig
577
578 %post   -n python-subversion -p /sbin/ldconfig
579 %postun -n python-subversion -p /sbin/ldconfig
580
581 %post svnserve
582 /sbin/chkconfig --add svnserve
583 %service svnserve restart "svnserve daemon"
584
585 %preun svnserve
586 if [ "$1" = "0" ]; then
587         %service svnserve stop
588         /sbin/chkconfig --del svnserve
589 fi
590
591 %postun svnserve
592 if [ "$1" = "0" ]; then
593         %userremove svn
594         %groupremove svn
595 fi
596
597 %post -n apache-mod_dav_svn
598 %service -q httpd restart
599
600 %preun -n apache-mod_dav_svn
601 if [ "$1" = "0" ]; then
602         %service -q httpd restart
603 fi
604
605 %files
606 %defattr(644,root,root,755)
607 %doc BUGS CHANGES COPYING INSTALL README
608 %doc doc/*/*.html
609 %doc tools/hook-scripts/*.{pl,py,example}
610 %doc tools/hook-scripts/mailer/*.{py,example}
611 %doc tools/xslt/*
612 %attr(755,root,root) %{_bindir}/svn
613 %attr(755,root,root) %{_bindir}/svnadmin
614 %attr(755,root,root) %{_bindir}/svndumpfilter
615 %attr(755,root,root) %{_bindir}/svnlook
616 %attr(755,root,root) %{_bindir}/svnsync
617 %attr(755,root,root) %{_bindir}/svnversion
618 %{_mandir}/man1/svn.1*
619 %{_mandir}/man1/svnadmin.1*
620 %{_mandir}/man1/svndumpfilter.1*
621 %{_mandir}/man1/svnlook.1*
622 %{_mandir}/man1/svnsync.1*
623 %{_mandir}/man1/svnversion.1*
624
625 %files libs -f %{name}.lang
626 %defattr(644,root,root,755)
627 %attr(755,root,root) %{_libdir}/libsvn_client-1.so.*.*.*
628 %attr(755,root,root) %ghost %{_libdir}/libsvn_client-1.so.0
629 %attr(755,root,root) %{_libdir}/libsvn_delta-1.so.*.*.*
630 %attr(755,root,root) %ghost %{_libdir}/libsvn_delta-1.so.0
631 %attr(755,root,root) %{_libdir}/libsvn_diff-1.so.*.*.*
632 %attr(755,root,root) %ghost %{_libdir}/libsvn_diff-1.so.0
633 %attr(755,root,root) %{_libdir}/libsvn_fs-1.so.*.*.*
634 %attr(755,root,root) %ghost %{_libdir}/libsvn_fs-1.so.0
635 %attr(755,root,root) %{_libdir}/libsvn_fs_base-1.so.*.*.*
636 %attr(755,root,root) %ghost %{_libdir}/libsvn_fs_base-1.so.0
637 %attr(755,root,root) %{_libdir}/libsvn_fs_fs-1.so.*.*.*
638 %attr(755,root,root) %ghost %{_libdir}/libsvn_fs_fs-1.so.0
639 %attr(755,root,root) %{_libdir}/libsvn_fs_util-1.so.*.*.*
640 %attr(755,root,root) %ghost %{_libdir}/libsvn_fs_util-1.so.0
641 %attr(755,root,root) %{_libdir}/libsvn_ra-1.so.*.*.*
642 %attr(755,root,root) %ghost %{_libdir}/libsvn_ra-1.so.0
643 %attr(755,root,root) %{_libdir}/libsvn_ra_local-1.so.*.*.*
644 %attr(755,root,root) %ghost %{_libdir}/libsvn_ra_local-1.so.0
645 %attr(755,root,root) %{_libdir}/libsvn_ra_%{webdavlib}-1.so.*.*.*
646 %attr(755,root,root) %ghost %{_libdir}/libsvn_ra_%{webdavlib}-1.so.0
647 %attr(755,root,root) %{_libdir}/libsvn_ra_svn-1.so.*.*.*
648 %attr(755,root,root) %ghost %{_libdir}/libsvn_ra_svn-1.so.0
649 %attr(755,root,root) %{_libdir}/libsvn_repos-1.so.*.*.*
650 %attr(755,root,root) %ghost %{_libdir}/libsvn_repos-1.so.0
651 %attr(755,root,root) %{_libdir}/libsvn_subr-1.so.*.*.*
652 %attr(755,root,root) %ghost %{_libdir}/libsvn_subr-1.so.0
653 %attr(755,root,root) %{_libdir}/libsvn_wc-1.so.*.*.*
654 %attr(755,root,root) %ghost %{_libdir}/libsvn_wc-1.so.0
655
656 %files devel
657 %defattr(644,root,root,755)
658 %attr(755,root,root) %{_libdir}/libsvn_client-1.so
659 %attr(755,root,root) %{_libdir}/libsvn_delta-1.so
660 %attr(755,root,root) %{_libdir}/libsvn_diff-1.so
661 %attr(755,root,root) %{_libdir}/libsvn_fs-1.so
662 %attr(755,root,root) %{_libdir}/libsvn_fs_base-1.so
663 %attr(755,root,root) %{_libdir}/libsvn_fs_fs-1.so
664 %attr(755,root,root) %{_libdir}/libsvn_fs_util-1.so
665 %attr(755,root,root) %{_libdir}/libsvn_ra-1.so
666 %attr(755,root,root) %{_libdir}/libsvn_ra_local-1.so
667 %attr(755,root,root) %{_libdir}/libsvn_ra_%{webdavlib}-1.so
668 %attr(755,root,root) %{_libdir}/libsvn_ra_svn-1.so
669 %attr(755,root,root) %{_libdir}/libsvn_repos-1.so
670 %attr(755,root,root) %{_libdir}/libsvn_subr-1.so
671 %attr(755,root,root) %{_libdir}/libsvn_wc-1.so
672 %{_libdir}/libsvn_client-1.la
673 %{_libdir}/libsvn_delta-1.la
674 %{_libdir}/libsvn_diff-1.la
675 %{_libdir}/libsvn_fs-1.la
676 %{_libdir}/libsvn_fs_base-1.la
677 %{_libdir}/libsvn_fs_fs-1.la
678 %{_libdir}/libsvn_fs_util-1.la
679 %{_libdir}/libsvn_ra-1.la
680 %{_libdir}/libsvn_ra_local-1.la
681 %{_libdir}/libsvn_ra_%{webdavlib}-1.la
682 %{_libdir}/libsvn_ra_svn-1.la
683 %{_libdir}/libsvn_repos-1.la
684 %{_libdir}/libsvn_subr-1.la
685 %{_libdir}/libsvn_wc-1.la
686 %{_includedir}/%{name}-1
687 %{_examplesdir}/%{name}-%{version}
688
689 %files static
690 %defattr(644,root,root,755)
691 %{_libdir}/libsvn_client-1.a
692 %{_libdir}/libsvn_delta-1.a
693 %{_libdir}/libsvn_diff-1.a
694 %{_libdir}/libsvn_fs-1.a
695 %{_libdir}/libsvn_fs_base-1.a
696 %{_libdir}/libsvn_fs_fs-1.a
697 %{_libdir}/libsvn_fs_util-1.a
698 %{_libdir}/libsvn_ra-1.a
699 %{_libdir}/libsvn_ra_local-1.a
700 %{_libdir}/libsvn_ra_%{webdavlib}-1.a
701 %{_libdir}/libsvn_ra_svn-1.a
702 %{_libdir}/libsvn_repos-1.a
703 %{_libdir}/libsvn_subr-1.a
704 %{_libdir}/libsvn_wc-1.a
705
706 %if %{with gnome}
707 %files -n gnome-keyring-subversion
708 %defattr(644,root,root,755)
709 %attr(755,root,root) %{_libdir}/libsvn_auth_gnome_keyring-1.so.*.*.*
710 %attr(755,root,root) %ghost %{_libdir}/libsvn_auth_gnome_keyring-1.so.0
711 %endif
712
713 %if %{with kwallet}
714 %files -n kde4-kwallet-subversion
715 %defattr(644,root,root,755)
716 %attr(755,root,root) %{_libdir}/libsvn_auth_kwallet-1.so.*.*.*
717 %attr(755,root,root) %ghost %{_libdir}/libsvn_auth_kwallet-1.so.0
718 %endif
719
720 %if !%{with net_client_only}
721 %files svnserve
722 %defattr(644,root,root,755)
723 %attr(755,root,root) %{_bindir}/svnserve
724 %{_mandir}/man5/svnserve.conf.5*
725 %{_mandir}/man8/svnserve.8*
726 %dir %attr(750,svn,svn) /home/services/subversion
727 %dir %attr(750,svn,svn) /home/services/subversion/repos
728 %if %{with apache}
729 %attr(754,root,root) /etc/rc.d/init.d/svnserve
730 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/svnserve
731 %endif
732
733 %files tools
734 %defattr(644,root,root,755)
735 %attr(755,root,root) %{_bindir}/svn-hot-backup
736
737 %files -n bash-completion-subversion
738 %defattr(644,root,root,755)
739 /etc/bash_completion.d/%{name}
740
741 %if %{with javahl}
742 %files -n java-subversion
743 %defattr(644,root,root,755)
744 %attr(755,root,root) %{_libdir}/libsvnjavahl-1.so.*.*.*
745 %attr(755,root,root) %ghost %{_libdir}/libsvnjavahl-1.so.0
746 %attr(755,root,root) %{_libdir}/libsvnjavahl-1.so
747 %{_javadir}/svn-javahl.jar
748 %endif
749
750 %if %{with python}
751 %files -n python-subversion
752 %defattr(644,root,root,755)
753 %doc tools/backup/*.py tools/examples/*.py
754 %attr(755,root,root) %{_libdir}/libsvn_swig_py-1.so.*.*.*
755 %attr(755,root,root) %ghost %{_libdir}/libsvn_swig_py-1.so.0
756 %attr(755,root,root) %{_libdir}/libsvn_swig_py-1.so
757 %dir %{py_sitedir}/libsvn
758 %{py_sitedir}/libsvn/*.py[co]
759 %dir %{py_sitedir}/svn
760 %{py_sitedir}/svn/*.py[co]
761 %attr(755,root,root) %{py_sitedir}/libsvn/*.so
762 %{_examplesdir}/python-%{name}-%{version}
763
764 %files -n python-csvn
765 %defattr(644,root,root,755)
766 %doc subversion/bindings/ctypes-python/{README,TODO}
767 %doc subversion/bindings/ctypes-python/examples/*.py
768 %dir %{py_sitescriptdir}/csvn
769 %{py_sitescriptdir}/csvn/*.py[co]
770 %dir %{py_sitescriptdir}/csvn/core
771 %{py_sitescriptdir}/csvn/core/*.py[co]
772 %dir %{py_sitescriptdir}/csvn/ext
773 %{py_sitescriptdir}/csvn/ext/*.py[co]
774 %{py_sitescriptdir}/*.egg-info
775 %endif
776
777 %if %{with perl}
778 %files -n perl-subversion
779 %defattr(644,root,root,755)
780 %attr(755,root,root) %{_libdir}/libsvn_swig_perl-1.so.*.*.*
781 %attr(755,root,root) %ghost %{_libdir}/libsvn_swig_perl-1.so.0
782 %attr(755,root,root) %{_libdir}/libsvn_swig_perl-1.so
783 %{perl_vendorarch}/SVN
784 %dir %{perl_vendorarch}/auto/SVN
785 %dir %{perl_vendorarch}/auto/SVN/*
786 %attr(755,root,root) %{perl_vendorarch}/auto/SVN/*/*.so
787 %{perl_vendorarch}/auto/SVN/*/*.bs
788 %{_mandir}/man3/*.3pm*
789 %endif
790
791 %if %{with ruby}
792 %files -n ruby-subversion
793 %defattr(644,root,root,755)
794 %attr(755,root,root) %{_libdir}/libsvn_swig_ruby-1.so.*.*.*
795 %attr(755,root,root) %ghost %{_libdir}/libsvn_swig_ruby-1.so.0
796 %attr(755,root,root) %{_libdir}/libsvn_swig_ruby-1.so
797 %dir %{ruby_sitelibdir}/svn
798 %{ruby_sitelibdir}/svn/*.rb
799 %dir %{ruby_sitearchdir}/svn
800 %dir %{ruby_sitearchdir}/svn/ext
801 %attr(755,root,root) %{ruby_sitearchdir}/*.so
802 %{ruby_ridir}/Svn
803 %endif
804
805 %if %{with apache}
806 %files -n apache-mod_dav_svn
807 %defattr(644,root,root,755)
808 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{apacheconfdir}/*_mod_dav_svn.conf
809 %attr(755,root,root) %{apachelibdir}/mod_dav_svn.so
810
811 %files -n apache-mod_authz_svn
812 %defattr(644,root,root,755)
813 %doc subversion/mod_authz_svn/INSTALL
814 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{apacheconfdir}/*_mod_authz_svn.conf
815 %attr(755,root,root) %{apachelibdir}/mod_authz_svn.so
816 %endif
817
818 %endif # net_client_only
This page took 0.078811 seconds and 4 git commands to generate.