]> git.pld-linux.org Git - packages/subversion.git/blob - subversion.spec
- updated BRs
[packages/subversion.git] / subversion.spec
1 #
2 # Conditional build:
3 %bcond_with     net_client_only         # build only net client
4 %bcond_without  neon                    # use serf instead of neon
5 %bcond_without  swig                    # disable bindings generation with Swig
6 %bcond_without  python                  # build without Python bindings (broken)
7 %bcond_without  csvn                    # build Python csvn bindings
8 %bcond_without  perl                    # build without Perl bindings
9 %bcond_with     ruby                    # build without Ruby bindings
10 %bcond_without  apache                  # build without Apache support (webdav, etc)
11 %bcond_without  javahl                  # build without javahl support (Java high-level bindings)
12 %bcond_without  tests                   # don't perform "make check"
13 %bcond_without  kwallet                 # build without kde4 wallet support
14 %bcond_without  kde                     # build without kde4 support (alias for kwallet)
15 %bcond_without  gnome                   # build without gnome keyring support
16 %bcond_without  db                      # disable Subversion Berkeley DB based filesystem library
17
18 %if %{with net_client_only}
19 %undefine       with_apache
20 %undefine       with_db
21 %undefine       with_swig
22 %undefine       with_javahl
23 %endif
24
25 %if %{without swig}
26 %undefine       with_perl
27 %undefine       with_python
28 %undefine       with_ruby
29 %endif
30
31 %if %{without kde}
32 %undefine       with_kwallet
33 %endif
34
35 %if %{without python} && %{without perl} && %{without ruby}
36 %undefine       with_swig
37 %endif
38
39 %define apxs    /usr/sbin/apxs
40 %define pdir    SVN
41 %define pnam    _Core
42
43 %if %{with neon}
44 %define webdavlib       neon
45 %else
46 %define webdavlib       serf
47 %endif
48 %{?with_perl:%include   /usr/lib/rpm/macros.perl}
49 Summary:        A Concurrent Versioning system similar to but better than CVS
50 Summary(pl.UTF-8):      System kontroli wersji podobny, ale lepszy, niż CVS
51 Summary(pt_BR.UTF-8):   Sistema de versionamento concorrente
52 Name:           subversion
53 Version:        1.7.0
54 Release:        2
55 License:        Apache/BSD-like
56 Group:          Development/Version Control
57 Source0:        http://www.apache.org/dist/subversion/%{name}-%{version}.tar.bz2
58 # Source0-md5:  930e6644a1b6094efd268fde6a318f04
59 Source1:        %{name}-dav_svn.conf
60 Source2:        %{name}-authz_svn.conf
61 Source3:        %{name}-svnserve.init
62 Source4:        %{name}-svnserve.sysconfig
63 # current subversion tarball has correct *.swg files
64 # but after regeneration these are broken again, so
65 # we still need this script
66 Source5:        %{name}-convert-typemaps-to-ifdef.py
67 Patch0:         %{name}-home_etc.patch
68 Patch1:         %{name}-DESTDIR.patch
69 Patch2:         %{name}-ruby-datadir-path.patch
70 Patch3:         %{name}-tests.patch
71 URL:            http://subversion.apache.org/
72 %{?with_apache:BuildRequires:   apache-devel >= 2.2.0-8}
73 BuildRequires:  apr-devel >= 1:1.0.0
74 BuildRequires:  apr-util-devel >= 1:1.2.8-3
75 BuildRequires:  autoconf >= 2.59
76 BuildRequires:  automake
77 BuildRequires:  bison
78 BuildRequires:  cyrus-sasl-devel
79 %if %{with kwallet} || %{with gnome}
80 BuildRequires:  dbus-devel
81 %endif
82 BuildRequires:  db-devel >= 4.1.25
83 BuildRequires:  expat-devel
84 BuildRequires:  gettext-devel
85 %{?with_kwallet:BuildRequires:  kde4-kdelibs-devel}
86 %{?with_gnome:BuildRequires:    libgnome-keyring-devel}
87 BuildRequires:  libmagic-devel
88 BuildRequires:  libtool >= 1.4-9
89 BuildRequires:  pkgconfig
90 %{?with_csvn:BuildRequires:     python-ctypesgen}
91 BuildRequires:  rpm-pythonprov
92 BuildRequires:  rpmbuild(macros) >= 1.583
93 BuildRequires:  sed >= 4.0
94 BuildRequires:  sqlite3-devel >= 3.6.18
95 BuildRequires:  texinfo
96 BuildRequires:  which
97 %if %{with neon}
98 BuildRequires:  neon-devel >= 0.26.0
99 %else
100 BuildRequires:  serf-devel >= 0.7.1
101 %endif
102 %if %{with javahl}
103 BuildRequires:  jdk >= 1.5
104 BuildRequires:  libstdc++-devel
105 %endif
106 %if %{with perl}
107 BuildRequires:  perl-devel >= 1:5.8.0
108 BuildRequires:  rpm-perlprov >= 4.1-13
109 BuildRequires:  swig-perl >= 1.3.24
110 %endif
111 %if %{with python}
112 BuildRequires:  python-devel >= 1:2.4
113 BuildRequires:  swig-python >= 1.3.24
114 %endif
115 %if %{with ruby}
116 BuildRequires:  ruby-devel >= 1:1.8.2
117 BuildRequires:  ruby-devel < 1:1.9
118 BuildRequires:  ruby-rubygems
119 BuildRequires:  swig-ruby >= 1.3.24
120 %endif
121 Requires:       %{name}-libs = %{version}-%{release}
122 %requires_ge    sqlite3
123 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
124
125 %define         _libexecdir             %{_libdir}/svn
126 %define         apacheconfdir   %(%{apxs} -q SYSCONFDIR 2>/dev/null)/conf.d
127 %define         apachelibdir    %(%{apxs} -q LIBEXECDIR 2>/dev/null)
128
129 %define         skip_post_check_so      libsvn_swig_py-1.so.* libsvn_swig_perl-1.so.*
130
131 %description
132 The goal of the Subversion project is to build a version control
133 system that is a compelling replacement for CVS in the open source
134 community.
135
136 Our goals are:
137 - All current CVS features.
138 - Directories, renames, and file meta-data are versioned.
139 - Symbolic links, etc, are supported
140 - Commits are truly atomic.
141 - Branching and tagging are cheap (constant time) operations
142 - Repeated merges are handled gracefully
143 - Support for plug-in client side diff programs
144 - Natively client/server
145 - Client/server protocol sends diffs in both directions
146 - Costs are proportional to change size, not project size
147 - Internationalization
148 - Progressive multi-lingual support
149
150 %description -l pl.UTF-8
151 Celem projektu Subversion jest stworzenie systemu kontroli wersji jako
152 zamiennika dla CVS.
153
154 Cele projektu to:
155 - Wszystkie aktualne możliwości CVS.
156 - Katalogi, zmiany nazw oraz metadane plików są wersjonowane.
157 - Obsługa dowiązań symbolicznych itp.
158 - Commity są w pełni atomowe.
159 - Branchowanie oraz tagowanie są tanimi (stałymi w czasie) operacjami.
160 - Dobra obsługa powtarzanego łączenia (merge).
161 - Obsługa wtyczek diff po stronie klienta.
162 - Natywny klient/serwer.
163 - Klient/Serwer przesyłają diffy w obu kierunkach.
164 - Koszty proporcjonalne do rozmiaru zmiany, a nie rozmiaru projektu.
165 - Internacjonalizacja.
166 - Postępujące wsparcie dla wielu języków.
167
168 %description -l pt_BR.UTF-8
169 O objetivo do projeto Subversion é construir um sistema de controle de
170 versões que seja um substituto para o CVS (Concurrent Versioning
171 System) na comunidade opensource, fornecendo grandes melhorias.
172
173 %package libs
174 Summary:        Subversion libraries and modules
175 Summary(pl.UTF-8):      Biblioteka subversion oraz ładowalne moduły
176 Group:          Libraries
177 %if %{with neon}
178 Requires:       neon >= 0.26.0
179 %else
180 Requires:       serf >= 0.7.1
181 %endif
182 Obsoletes:      libsubversion0
183
184 %description libs
185 Subversion libraries and modules.
186
187 %description libs -l pl.UTF-8
188 Biblioteka subversion oraz ładowalne moduły.
189
190 %package devel
191 Summary:        Header files and develpment documentation for subversion
192 Summary(pl.UTF-8):      Pliki nagłówkowe i dokumetacja do subversion
193 Summary(pt_BR.UTF-8):   Arquivos de desenvolvimento para o Subversion
194 Group:          Development/Libraries
195 Requires:       %{name}-libs = %{version}-%{release}
196 Requires:       apr-util-devel >= 1:1.0.0
197 %{?with_neon:Requires:  neon-devel >= 0.26.0}
198 Obsoletes:      libsubversion0-devel
199
200 %description devel
201 Header files and develpment documentation for subversion.
202
203 %description devel -l pl.UTF-8
204 Pliki nagłówkowe i dokumetacja do subversion.
205
206 %description devel -l pt_BR.UTF-8
207 Este pacote provê os arquivos necessários para desenvolvedores
208 interagirem com o Subversion.
209
210 %package static
211 Summary:        Static subversion library
212 Summary(pl.UTF-8):      Biblioteka statyczna subversion
213 Summary(pt_BR.UTF-8):   Sistema de versionamento concorrente
214 Group:          Development/Libraries
215 Requires:       %{name}-devel = %{version}
216 Obsoletes:      libsubversion0-static-devel
217
218 %description static
219 Static subversion library.
220
221 %description static -l pl.UTF-8
222 Biblioteka statyczna subversion.
223
224 %description static -l pt_BR.UTF-8
225 Este pacote provê um cliente estático do subversion.
226
227 %package svnserve
228 Summary:        Subversion svnserve
229 Summary(pl.UTF-8):      Subversion svnserve
230 Group:          Networking/Daemons
231 Requires(post,preun):   /sbin/chkconfig
232 Requires(postun):       /usr/sbin/groupdel
233 Requires(postun):       /usr/sbin/userdel
234 Requires(pre):  /bin/id
235 Requires(pre):  /usr/bin/getgid
236 Requires(pre):  /usr/lib/rpm/user_group.sh
237 Requires(pre):  /usr/sbin/groupadd
238 Requires(pre):  /usr/sbin/useradd
239 Requires(pre):  /usr/sbin/usermod
240 Requires:       %{name} = %{version}-%{release}
241 Requires:       rc-scripts
242 Provides:       group(svn)
243 Provides:       user(svn)
244
245 %description svnserve
246 Subversion svnserve server.
247
248 %description svnserve -l pl.UTF-8
249 Serwer subversion svnserve.
250
251 %package tools
252 Summary:        Subversion tools and scripts
253 Summary(pl.UTF-8):      Narzędzia oraz skrypty dla subversion
254 Summary(pt_BR.UTF-8):   Módulos python para acessar os recursos do Subversion
255 Group:          Applications
256 %pyrequires_eq  python
257 Requires:       %{name} = %{version}-%{release}
258 Requires:       python-subversion = %{version}
259
260 %description tools
261 Subversion tools and scripts.
262
263 %description tools -l pl.UTF-8
264 Narzędzia oraz skrypty dla subversion.
265
266 %package -n bash-completion-subversion
267 Summary:        bash completion for subversion
268 Summary(pl.UTF-8):      Dopełnienia basha dla subversion
269 Group:          Applications/Shells
270 Requires:       %{name} = %{version}-%{release}
271 Requires:       bash-completion
272 Conflicts:      %{name}-tools <= 1.1.0-0.rc6.1
273
274 %description -n bash-completion-subversion
275 Bash completion for subversion.
276
277 %description -n bash-completion-subversion -l pl.UTF-8
278 Dopełnienia basha dla subversion.
279
280 %package -n java-subversion
281 Summary:        Subversion Java bindings
282 Summary(pl.UTF-8):      Dowiązania do Subversion dla Javy
283 Group:          Development/Languages/Java
284 Requires:       %{name}-libs = %{version}-%{release}
285
286 %description -n java-subversion
287 This is a set of Java classes which provide the functionality of
288 subversion-libs, the Subversion libraries. It is useful if you want
289 to, for example, write a Java class that manipulates a Subversion
290 repository or working copy. See the 'subversion' package for more
291 information.
292
293 %description -n java-subversion -l pl.UTF-8
294 Ten pakiet zawiera zestaw klas Javy udostępniających funkcjonalność
295 subversion-libs, czyli bibliotek Subversion. Jest przydatny przy
296 pisaniu klas Javy np. modyfikujących repozytorium Subversion lub kopię
297 roboczą. Więcej informacji w pakiecie subversion.
298
299 %package -n python-subversion
300 Summary:        Subversion Python bindings
301 Summary(pl.UTF-8):      Dowiązania do Subversion dla Pythona
302 Summary(pt_BR.UTF-8):   Módulos Python para acessar os recursos do Subversion
303 Group:          Development/Languages/Python
304 %pyrequires_eq  python
305 Requires:       %{name}-libs = %{version}-%{release}
306 Obsoletes:      subversion-python
307
308 %description -n python-subversion
309 Subversion Python bindings.
310
311 %description -n python-subversion -l pl.UTF-8
312 Dowiązania do Subversion dla Pythona.
313
314 %description -n python-subversion -l pt_BR.UTF-8
315 Módulos Python para acessar os recursos do Subversion.
316
317 %package -n python-csvn
318 Summary:        CTypes Subversion Python bindings
319 Summary(pl.UTF-8):      Dowiązania do Subversion dla Pythona
320 Summary(pt_BR.UTF-8):   Módulos Python para acessar os recursos do Subversion
321 Group:          Development/Languages/Python
322 %pyrequires_eq  python
323 Requires:       %{name}-libs = %{version}-%{release}
324
325 %description -n python-csvn
326 Subversion CTypes Python bindings.
327
328 %description -n python-csvn -l pl.UTF-8
329 Dowiązania do Subversion dla Pythona używające CTypes.
330
331 %description -n python-csvn -l pt_BR.UTF-8
332 Módulos Python para acessar os recursos do Subversion.
333
334 %package -n perl-subversion
335 Summary:        Subversion Perl bindings
336 Summary(pl.UTF-8):      Dowiązania do Subversion dla Perla
337 Summary(pt_BR.UTF-8):   Módulos Perl para acessar os recursos do Subversion
338 Group:          Development/Languages/Perl
339 Requires:       %{name}-libs = %{version}-%{release}
340 Obsoletes:      subversion-perl
341
342 %description -n perl-subversion
343 Subversion Perl bindings.
344
345 %description -n perl-subversion -l pl.UTF-8
346 Dowiązania do Subversion dla Perla.
347
348 %description -n perl-subversion -l pt_BR.UTF-8
349 Módulos Perl para acessar os recursos do Subversion.
350
351 %package -n ruby-subversion
352 Summary:        Subversion Ruby bindings
353 Summary(pl.UTF-8):      Dowiązania do Subversion dla języka Ruby
354 Summary(pt_BR.UTF-8):   Módulos Ruby para acessar os recursos do Subversion
355 Group:          Development/Languages
356 Requires:       %{name}-libs = %{version}-%{release}
357 Obsoletes:      subversion-ruby
358
359 %description -n ruby-subversion
360 Subversion Ruby bindings.
361
362 %description -n ruby-subversion -l pl.UTF-8
363 Dowiązania do Subversion dla języka Ruby.
364
365 %description -n ruby-subversion -l pt_BR.UTF-8
366 Módulos Ruby para acessar os recursos do Subversion.
367
368 %package -n apache-mod_dav_svn
369 Summary:        Apache module: Subversion Server
370 Summary(pl.UTF-8):      Moduł apache: Serwer Subversion
371 Group:          Networking/Daemons
372 Requires:       %{name} = %{version}-%{release}
373 Requires:       apache(modules-api) = %apache_modules_api
374 Requires:       apache-mod_dav
375
376 %description -n apache-mod_dav_svn
377 Apache module: Subversion Server.
378
379 %description -n apache-mod_dav_svn -l pl.UTF-8
380 Moduł apache: Serwer Subversion.
381
382 %package -n apache-mod_authz_svn
383 Summary:        Apache module: Subversion Server - path-based authorization
384 Summary(pl.UTF-8):      Moduł apache: autoryzacja na podstawie ścieżki dla serwera Subversion
385 Group:          Networking/Daemons
386 Requires:       apache(modules-api) = %apache_modules_api
387 Requires:       apache-mod_dav_svn = %{version}-%{release}
388
389 %description -n apache-mod_authz_svn
390 Apache module: Subversion Server - path-based authorization.
391
392 %description -n apache-mod_authz_svn -l pl.UTF-8
393 Moduł apache: autoryzacja na podstawie ścieżki dla serwera Subversion.
394
395 %package -n gnome-keyring-subversion
396 Summary:        GNOME Keyring authentication provider for Subversion
397 Summary(pl.UTF-8):      Moduł uwierzytelniający GNOME Keyring dla Subversion
398 Group:          X11/Applications
399
400 %description -n gnome-keyring-subversion
401 Authentication provider module for Subversion which allows SVN client
402 to authenticate using GNOME Keyring.
403
404 %description -n gnome-keyring-subversion -l pl.UTF-8
405 Moduł uwierzytelniający dla Subversion pozwalający klientom SVN
406 uwierzytelniać się przy użyciu mechanizmu GNOME Keyring.
407
408 %package -n kde4-kwallet-subversion
409 Summary:        KDE Wallet authentication provider for Subversion
410 Summary(pl.UTF-8):      Moduł uwierzytelniający dla Subversion wykorzystujący Portfel KDE
411 Group:          X11/Applications
412
413 %description -n kde4-kwallet-subversion
414 Authentication provider module for Subversion which allows SVN client
415 to authenticate using KDE Wallet.
416
417 %description -n kde4-kwallet-subversion -l pl.UTF-8
418 Moduł uwierzytelniający dla Subversion pozwalający klientom SVN
419 uwierzytelniać się przy użyciu Portfela KDE.
420
421 %prep
422 %setup -q
423 %patch0 -p0
424 %patch1 -p1
425 %patch2 -p0
426 %patch3 -p1
427
428 sed -i -e 's#serf_prefix/lib#serf_prefix/%{_lib}#g' build/ac-macros/serf.m4
429
430 # serf.m4 macro is broken and ignores --without serf
431 %{?with_neon:sed -i -e 's#serf_found="yes"#serf_found="no"#g' build/ac-macros/serf.m4}
432
433 %build
434 # disabled regeneration - subversion 1.6.13 is not ready for swig 2.0.x
435 #%{__rm} subversion/bindings/swig/proxy/*.swg
436 #cd subversion/bindings/swig && python "%{SOURCE5}" && cd ../../..
437 chmod +x ./autogen.sh && ./autogen.sh
438 %{__libtoolize}
439 %configure \
440         --with-editor=vi \
441         --with-zlib=%{_libdir} \
442         --disable-runtime-module-search \
443         --disable-mod-activation \
444 %if %{with db}
445         --with-berkeley-db="db.h:%{_includedir}:%{_libdir}:db" \
446 %else
447         --without-berkeley-db \
448 %endif
449 %if %{with apache}
450         --with-apxs=%{_sbindir}/apxs \
451 %else
452         --without-apxs \
453 %endif
454 %if %{without swig}
455         --without-swig \
456 %endif
457 %if %{without ruby}
458         ac_cv_path_RUBY=none \
459 %endif
460 %if %{with csvn}
461         --with-ctypesgen=%{_bindir}/ctypesgen.py \
462 %endif
463 %if %{with javahl}
464         --enable-javahl \
465         --with-jdk="%{java_home}" \
466         --without-jikes \
467 %else
468         --disable-javahl \
469 %endif
470 %if %{with neon}
471         --without-serf \
472         --with-neon=%{_prefix} \
473         --disable-neon-version-check \
474 %else
475         --with-serf=%{_prefix} \
476         --without-neon \
477 %endif
478         --with-apr=%{_bindir}/apr-1-config \
479         --with-apr-util=%{_bindir}/apu-1-config \
480 %if %{with kwallet}
481         --with-kwallet \
482 %endif
483 %if %{with gnome}
484         --with-gnome-keyring
485 %endif
486
487 %{__make} -j1
488
489 %if %{with csvn}
490 # Python ctypes bindings
491 %{__make} ctypes-python
492 %endif
493 %if %{with python}
494 # Python swig bindings
495 %{__make} swig-py \
496         swig_pydir=%{py_sitedir}/libsvn \
497         swig_pydir_extra=%{py_sitedir}/svn
498 %endif
499 %if %{with perl}
500 # Perl swig bindings
501 %{__make} -j1 swig-pl-lib
502 cd subversion/bindings/swig/perl/native
503 %{__perl} Makefile.PL INSTALLDIRS=vendor
504 %{__make} -j1
505 cd -
506 %endif
507 %if %{with javahl}
508 %{__make} -j1 javahl \
509         javahl_javadir="%{_javadir}"
510 %endif
511 # ruby
512 %if %{with ruby}
513 %{__make} swig-rb
514 %endif
515
516 %if %{with tests}
517 %{__make} -j1 check
518 %if %{with csvn}
519 %{__make} -j1 check-ctypes-python
520 %endif
521 %if %{with python}
522 %{__make} -j1 check-swig-py
523 %endif
524 %if %{with perl}
525 %{__make} -j1 check-swig-pl
526 %endif
527 %if %{with ruby}
528 # disabled, see https://bugs.launchpad.net/pld-linux/+bug/734340
529 #%{__make} check-swig-rb
530 %endif
531 %endif
532
533 %install
534 rm -rf $RPM_BUILD_ROOT
535 install -d $RPM_BUILD_ROOT/etc/{rc.d/init.d,sysconfig,bash_completion.d} \
536         $RPM_BUILD_ROOT{%{apacheconfdir},%{apachelibdir},%{_infodir}} \
537         $RPM_BUILD_ROOT%{_examplesdir}/{%{name}-%{version},python-%{name}-%{version}} \
538         $RPM_BUILD_ROOT%{_sysconfdir}/%{name} \
539         $RPM_BUILD_ROOT/home/services/subversion{,/repos}
540
541 %{__make} install -j1 \
542         DESTDIR=$RPM_BUILD_ROOT \
543         APACHE_LIBEXECDIR="$(%{_sbindir}/apxs -q LIBEXECDIR)" \
544 %if %{with javahl}
545         install-javahl \
546         javahl_javadir="%{_javadir}" \
547 %endif
548 %if %{with python}
549         install-swig-py \
550         swig_pydir=%{py_sitedir}/libsvn \
551         swig_pydir_extra=%{py_sitedir}/svn \
552 %endif
553 %if %{with csvn}
554         install-ctypes-python \
555 %endif
556
557 %if %{with ruby}
558 %{__make} install -j1 \
559         DESTDIR=$RPM_BUILD_ROOT \
560         install-swig-rb install-swig-rb-doc \
561
562 # not our package
563 %{__rm} -r $RPM_BUILD_ROOT%{ruby_ridir}/Kernel
564 %{__rm} -r $RPM_BUILD_ROOT%{ruby_ridir}/OptionParser
565 %{__rm} -r $RPM_BUILD_ROOT%{ruby_ridir}/Time
566 %{__rm} -r $RPM_BUILD_ROOT%{ruby_ridir}/Uconv
567 %{__rm} $RPM_BUILD_ROOT%{ruby_ridir}/cache.ri
568 %{__rm} $RPM_BUILD_ROOT%{ruby_ridir}/created.rid
569 %endif
570
571 %if %{with perl}
572 %{__make} install-swig-pl-lib \
573         DESTDIR=$RPM_BUILD_ROOT
574 %{__make} -C subversion/bindings/swig/perl/native install \
575         DESTDIR=$RPM_BUILD_ROOT \
576         PREFIX=$RPM_BUILD_ROOT%{_prefix} \
577         LIBDIR=$RPM_BUILD_ROOT%{_libdir}
578 %endif
579
580 %if %{with apache}
581 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{apacheconfdir}/65_mod_dav_svn.conf
582 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{apacheconfdir}/66_mod_authz_svn.conf
583 cp -p %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/svnserve
584 install -p %{SOURCE3} $RPM_BUILD_ROOT/etc/rc.d/init.d/svnserve
585 %endif
586
587 %if %{without net_client_only}
588 install -p tools/backup/hot-backup.py $RPM_BUILD_ROOT%{_bindir}/svn-hot-backup
589 %endif
590 %if %{with python} || %{with csvn}
591 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
592 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
593 %py_postclean
594 %endif
595 %if %{with python}
596 %{__rm} $RPM_BUILD_ROOT%{py_sitedir}/libsvn/*.la
597 # .a created on ac only
598 %{__rm} -f $RPM_BUILD_ROOT%{py_sitedir}/libsvn/*.a
599 cp -p tools/examples/*.py $RPM_BUILD_ROOT%{_examplesdir}/python-%{name}-%{version}
600 %endif
601
602 cp -p tools/client-side/bash_completion $RPM_BUILD_ROOT/etc/bash_completion.d/%{name}
603 cp -p tools/examples/*.c $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
604
605 %if %{with javahl}
606 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libsvnjavahl*.{la,a}
607 %endif
608 %if %{with swig}
609 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libsvn_swig*.{la,a}
610 %if %{with ruby}
611 %{__rm} $RPM_BUILD_ROOT%{_libdir}/ruby/site_ruby/*/*/svn/ext/*.la
612 %endif
613 %endif
614 %if %{with gnome} || %{with kwallet}
615 # dlopened by soname (libsvn_auth_*-1.so.0)
616 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libsvn_auth_*-1.{so,la,a}
617 %endif
618
619 %find_lang %{name}
620
621 %clean
622 rm -rf $RPM_BUILD_ROOT
623
624 %pre svnserve
625 %groupadd -g 86 svn
626 %useradd -u 180 -d /home/services/subversion -c "Subversion svnserve" -g svn svn
627
628 %post   libs -p /sbin/ldconfig
629 %postun libs -p /sbin/ldconfig
630
631 %post   devel -p /sbin/postshell
632 -/usr/sbin/fix-info-dir -c %{_infodir}
633
634 %postun devel -p /sbin/postshell
635 -/usr/sbin/fix-info-dir -c %{_infodir}
636
637 %post   -n java-subversion -p /sbin/ldconfig
638 %postun -n java-subversion -p /sbin/ldconfig
639
640 %post   -n perl-subversion -p /sbin/ldconfig
641 %postun -n perl-subversion -p /sbin/ldconfig
642
643 %post   -n python-subversion -p /sbin/ldconfig
644 %postun -n python-subversion -p /sbin/ldconfig
645
646 %post   -n ruby-subversion -p /sbin/ldconfig
647 %postun -n ruby-subversion -p /sbin/ldconfig
648
649 %post   -n gnome-keyring-subversion -p /sbin/ldconfig
650 %postun -n gnome-keyring-subversion -p /sbin/ldconfig
651
652 %post   -n kde4-kwallet-subversion -p /sbin/ldconfig
653 %postun -n kde4-kwallet-subversion -p /sbin/ldconfig
654
655 %post svnserve
656 /sbin/chkconfig --add svnserve
657 %service svnserve restart "svnserve daemon"
658
659 %preun svnserve
660 if [ "$1" = "0" ]; then
661         %service svnserve stop
662         /sbin/chkconfig --del svnserve
663 fi
664
665 %postun svnserve
666 if [ "$1" = "0" ]; then
667         %userremove svn
668         %groupremove svn
669 fi
670
671 %post -n apache-mod_dav_svn
672 %service -q httpd restart
673
674 %postun -n apache-mod_dav_svn
675 if [ "$1" = "0" ]; then
676         %service -q httpd restart
677 fi
678
679 %post -n apache-mod_authz_svn
680 %service -q httpd restart
681
682 %postun -n apache-mod_authz_svn
683 if [ "$1" = "0" ]; then
684         %service -q httpd restart
685 fi
686
687 %files
688 %defattr(644,root,root,755)
689 %doc BUGS CHANGES INSTALL README
690 %doc doc/*/*.html
691 %doc tools/hook-scripts/*.{pl,py,example}
692 %doc tools/hook-scripts/mailer/*.{py,example}
693 %doc tools/xslt/*
694 %attr(755,root,root) %{_bindir}/svn
695 %attr(755,root,root) %{_bindir}/svnadmin
696 %attr(755,root,root) %{_bindir}/svndumpfilter
697 %attr(755,root,root) %{_bindir}/svnrdump
698 %attr(755,root,root) %{_bindir}/svnlook
699 %attr(755,root,root) %{_bindir}/svnsync
700 %attr(755,root,root) %{_bindir}/svnversion
701 %{_mandir}/man1/svn.1*
702 %{_mandir}/man1/svnadmin.1*
703 %{_mandir}/man1/svndumpfilter.1*
704 %{_mandir}/man1/svnrdump.1*
705 %{_mandir}/man1/svnlook.1*
706 %{_mandir}/man1/svnsync.1*
707 %{_mandir}/man1/svnversion.1*
708
709 %files libs -f %{name}.lang
710 %defattr(644,root,root,755)
711 %dir %{_sysconfdir}/%{name}
712 %attr(755,root,root) %{_libdir}/libsvn_client-1.so.*.*.*
713 %attr(755,root,root) %ghost %{_libdir}/libsvn_client-1.so.0
714 %attr(755,root,root) %{_libdir}/libsvn_delta-1.so.*.*.*
715 %attr(755,root,root) %ghost %{_libdir}/libsvn_delta-1.so.0
716 %attr(755,root,root) %{_libdir}/libsvn_diff-1.so.*.*.*
717 %attr(755,root,root) %ghost %{_libdir}/libsvn_diff-1.so.0
718 %attr(755,root,root) %{_libdir}/libsvn_fs-1.so.*.*.*
719 %attr(755,root,root) %ghost %{_libdir}/libsvn_fs-1.so.0
720 %if %{without net_client_only}
721 %attr(755,root,root) %{_libdir}/libsvn_fs_base-1.so.*.*.*
722 %attr(755,root,root) %ghost %{_libdir}/libsvn_fs_base-1.so.0
723 %endif
724 %attr(755,root,root) %{_libdir}/libsvn_fs_fs-1.so.*.*.*
725 %attr(755,root,root) %ghost %{_libdir}/libsvn_fs_fs-1.so.0
726 %attr(755,root,root) %{_libdir}/libsvn_fs_util-1.so.*.*.*
727 %attr(755,root,root) %ghost %{_libdir}/libsvn_fs_util-1.so.0
728 %attr(755,root,root) %{_libdir}/libsvn_ra-1.so.*.*.*
729 %attr(755,root,root) %ghost %{_libdir}/libsvn_ra-1.so.0
730 %attr(755,root,root) %{_libdir}/libsvn_ra_local-1.so.*.*.*
731 %attr(755,root,root) %ghost %{_libdir}/libsvn_ra_local-1.so.0
732 %attr(755,root,root) %{_libdir}/libsvn_ra_%{webdavlib}-1.so.*.*.*
733 %attr(755,root,root) %ghost %{_libdir}/libsvn_ra_%{webdavlib}-1.so.0
734 %attr(755,root,root) %{_libdir}/libsvn_ra_svn-1.so.*.*.*
735 %attr(755,root,root) %ghost %{_libdir}/libsvn_ra_svn-1.so.0
736 %attr(755,root,root) %{_libdir}/libsvn_repos-1.so.*.*.*
737 %attr(755,root,root) %ghost %{_libdir}/libsvn_repos-1.so.0
738 %attr(755,root,root) %{_libdir}/libsvn_subr-1.so.*.*.*
739 %attr(755,root,root) %ghost %{_libdir}/libsvn_subr-1.so.0
740 %attr(755,root,root) %{_libdir}/libsvn_wc-1.so.*.*.*
741 %attr(755,root,root) %ghost %{_libdir}/libsvn_wc-1.so.0
742
743 %files devel
744 %defattr(644,root,root,755)
745 %attr(755,root,root) %{_libdir}/libsvn_client-1.so
746 %attr(755,root,root) %{_libdir}/libsvn_delta-1.so
747 %attr(755,root,root) %{_libdir}/libsvn_diff-1.so
748 %attr(755,root,root) %{_libdir}/libsvn_fs-1.so
749 %if %{without net_client_only}
750 %attr(755,root,root) %{_libdir}/libsvn_fs_base-1.so
751 %endif
752 %attr(755,root,root) %{_libdir}/libsvn_fs_fs-1.so
753 %attr(755,root,root) %{_libdir}/libsvn_fs_util-1.so
754 %attr(755,root,root) %{_libdir}/libsvn_ra-1.so
755 %attr(755,root,root) %{_libdir}/libsvn_ra_local-1.so
756 %attr(755,root,root) %{_libdir}/libsvn_ra_%{webdavlib}-1.so
757 %attr(755,root,root) %{_libdir}/libsvn_ra_svn-1.so
758 %attr(755,root,root) %{_libdir}/libsvn_repos-1.so
759 %attr(755,root,root) %{_libdir}/libsvn_subr-1.so
760 %attr(755,root,root) %{_libdir}/libsvn_wc-1.so
761 %{_libdir}/libsvn_client-1.la
762 %{_libdir}/libsvn_delta-1.la
763 %{_libdir}/libsvn_diff-1.la
764 %{_libdir}/libsvn_fs-1.la
765 %if %{without net_client_only}
766 %{_libdir}/libsvn_fs_base-1.la
767 %endif
768 %{_libdir}/libsvn_fs_fs-1.la
769 %{_libdir}/libsvn_fs_util-1.la
770 %{_libdir}/libsvn_ra-1.la
771 %{_libdir}/libsvn_ra_local-1.la
772 %{_libdir}/libsvn_ra_%{webdavlib}-1.la
773 %{_libdir}/libsvn_ra_svn-1.la
774 %{_libdir}/libsvn_repos-1.la
775 %{_libdir}/libsvn_subr-1.la
776 %{_libdir}/libsvn_wc-1.la
777 %{_includedir}/%{name}-1
778 %{_examplesdir}/%{name}-%{version}
779
780 %files static
781 %defattr(644,root,root,755)
782 %{_libdir}/libsvn_client-1.a
783 %{_libdir}/libsvn_delta-1.a
784 %{_libdir}/libsvn_diff-1.a
785 %{_libdir}/libsvn_fs-1.a
786 %if %{without net_client_only}
787 %{_libdir}/libsvn_fs_base-1.a
788 %endif
789 %{_libdir}/libsvn_fs_fs-1.a
790 %{_libdir}/libsvn_fs_util-1.a
791 %{_libdir}/libsvn_ra-1.a
792 %{_libdir}/libsvn_ra_local-1.a
793 %{_libdir}/libsvn_ra_%{webdavlib}-1.a
794 %{_libdir}/libsvn_ra_svn-1.a
795 %{_libdir}/libsvn_repos-1.a
796 %{_libdir}/libsvn_subr-1.a
797 %{_libdir}/libsvn_wc-1.a
798
799 %if %{with gnome}
800 %files -n gnome-keyring-subversion
801 %defattr(644,root,root,755)
802 %attr(755,root,root) %{_libdir}/libsvn_auth_gnome_keyring-1.so.*.*.*
803 %attr(755,root,root) %ghost %{_libdir}/libsvn_auth_gnome_keyring-1.so.0
804 %endif
805
806 %if %{with kwallet}
807 %files -n kde4-kwallet-subversion
808 %defattr(644,root,root,755)
809 %attr(755,root,root) %{_libdir}/libsvn_auth_kwallet-1.so.*.*.*
810 %attr(755,root,root) %ghost %{_libdir}/libsvn_auth_kwallet-1.so.0
811 %endif
812
813 %if %{without net_client_only}
814 %files svnserve
815 %defattr(644,root,root,755)
816 %attr(755,root,root) %{_bindir}/svnserve
817 %{_mandir}/man5/svnserve.conf.5*
818 %{_mandir}/man8/svnserve.8*
819 %dir %attr(750,svn,svn) /home/services/subversion
820 %dir %attr(750,svn,svn) /home/services/subversion/repos
821 %if %{with apache}
822 %attr(754,root,root) /etc/rc.d/init.d/svnserve
823 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/svnserve
824 %endif
825
826 %files tools
827 %defattr(644,root,root,755)
828 %attr(755,root,root) %{_bindir}/svn-hot-backup
829
830 %files -n bash-completion-subversion
831 %defattr(644,root,root,755)
832 /etc/bash_completion.d/%{name}
833
834 %endif # net_client_only
835
836 %if %{with javahl}
837 %files -n java-subversion
838 %defattr(644,root,root,755)
839 %attr(755,root,root) %{_libdir}/libsvnjavahl-1.so.*.*.*
840 %attr(755,root,root) %ghost %{_libdir}/libsvnjavahl-1.so.0
841 %attr(755,root,root) %{_libdir}/libsvnjavahl-1.so
842 %{_javadir}/svn-javahl.jar
843 %endif
844
845 %if %{with python}
846 %files -n python-subversion
847 %defattr(644,root,root,755)
848 %doc tools/backup/*.py
849 %attr(755,root,root) %{_libdir}/libsvn_swig_py-1.so.*.*.*
850 %attr(755,root,root) %ghost %{_libdir}/libsvn_swig_py-1.so.0
851 %attr(755,root,root) %{_libdir}/libsvn_swig_py-1.so
852 %dir %{py_sitedir}/libsvn
853 %attr(755,root,root) %{py_sitedir}/libsvn/_*.so
854 %{py_sitedir}/libsvn/*.py[co]
855 %dir %{py_sitedir}/svn
856 %{py_sitedir}/svn/*.py[co]
857 %{_examplesdir}/python-%{name}-%{version}
858 %endif
859
860 %if %{with csvn}
861 %files -n python-csvn
862 %defattr(644,root,root,755)
863 %doc subversion/bindings/ctypes-python/{README,TODO}
864 %doc subversion/bindings/ctypes-python/examples/*.py
865 %dir %{py_sitescriptdir}/csvn
866 %{py_sitescriptdir}/csvn/*.py[co]
867 %dir %{py_sitescriptdir}/csvn/core
868 %{py_sitescriptdir}/csvn/core/*.py[co]
869 %dir %{py_sitescriptdir}/csvn/ext
870 %{py_sitescriptdir}/csvn/ext/*.py[co]
871 %{py_sitescriptdir}/svn_ctypes_python_bindings-0.1-py*.egg-info
872 %endif
873
874 %if %{with perl}
875 %files -n perl-subversion
876 %defattr(644,root,root,755)
877 %attr(755,root,root) %{_libdir}/libsvn_swig_perl-1.so.*.*.*
878 %attr(755,root,root) %ghost %{_libdir}/libsvn_swig_perl-1.so.0
879 %attr(755,root,root) %{_libdir}/libsvn_swig_perl-1.so
880 %{perl_vendorarch}/SVN
881 %dir %{perl_vendorarch}/auto/SVN
882 %dir %{perl_vendorarch}/auto/SVN/*
883 %attr(755,root,root) %{perl_vendorarch}/auto/SVN/*/*.so
884 %{perl_vendorarch}/auto/SVN/*/*.bs
885 %{_mandir}/man3/*.3pm*
886 %endif
887
888 %if %{with ruby}
889 %files -n ruby-subversion
890 %defattr(644,root,root,755)
891 %attr(755,root,root) %{_libdir}/libsvn_swig_ruby-1.so.*.*.*
892 %attr(755,root,root) %ghost %{_libdir}/libsvn_swig_ruby-1.so.0
893 %attr(755,root,root) %{_libdir}/libsvn_swig_ruby-1.so
894 %dir %{ruby_sitelibdir}/svn
895 %{ruby_sitelibdir}/svn/*.rb
896 %dir %{ruby_sitearchdir}/svn
897 %dir %{ruby_sitearchdir}/svn/ext
898 %attr(755,root,root) %{ruby_sitearchdir}/svn/ext/*.so
899 %{ruby_ridir}/Svn
900 %endif
901
902 %if %{with apache}
903 %files -n apache-mod_dav_svn
904 %defattr(644,root,root,755)
905 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{apacheconfdir}/*_mod_dav_svn.conf
906 %attr(755,root,root) %{apachelibdir}/mod_dav_svn.so
907
908 %files -n apache-mod_authz_svn
909 %defattr(644,root,root,755)
910 %doc subversion/mod_authz_svn/INSTALL
911 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{apacheconfdir}/*_mod_authz_svn.conf
912 %attr(755,root,root) %{apachelibdir}/mod_authz_svn.so
913 %endif
This page took 0.164131 seconds and 4 git commands to generate.