]> git.pld-linux.org Git - packages/subversion.git/blob - subversion.spec
- disable ruby testing due pld ruby packaging bug
[packages/subversion.git] / subversion.spec
1 # TODO:
2 # - remove net_client_only and add db bcond (then without apache and
3 #   without db => net_client_only - spec will be more simpler, I think)
4 # - finish ruby
5 # - http://subversion.tigris.org/issues/show_bug.cgi?id=2753
6 #
7 # Conditional build:
8 %bcond_with     net_client_only         # build only net client
9 %bcond_without  neon                    # use serf instead of neon
10 %bcond_without  python                  # build without python bindings (broken)
11 %bcond_without  perl                    # build without perl bindings
12 %bcond_without  ruby                    # build without ruby bindings
13 %bcond_without  apache                  # build without apache support (webdav, etc)
14 %bcond_without  javahl                  # build without javahl support (Java high-level bindings)
15 %bcond_without  tests                   # don't perform "make check"
16 %bcond_without  kwallet                 # build without kde4 wallet support
17 %bcond_without  kde                     # build without kde4 support (alias for kwallet)
18 %bcond_without  gnome                   # build without gnome keyring support
19
20 %{!?with_net_client_only:%include       /usr/lib/rpm/macros.perl}
21 %define apxs    /usr/sbin/apxs
22 %define pdir    SVN
23 %define pnam    _Core
24
25 %if %{without kde}
26 %undefine       with_kwallet
27 %endif
28 %if %{with neon}
29 %define webdavlib       neon
30 %else
31 %define webdavlib       serf
32 %endif
33 Summary:        A Concurrent Versioning system similar to but better than CVS
34 Summary(pl.UTF-8):      System kontroli wersji podobny, ale lepszy, niż CVS
35 Summary(pt_BR.UTF-8):   Sistema de versionamento concorrente
36 Name:           subversion
37 Version:        1.6.16
38 Release:        1
39 License:        Apache/BSD-like
40 Group:          Development/Version Control
41 Source0:        http://subversion.tigris.org/downloads/%{name}-%{version}.tar.bz2
42 # Source0-md5:  32f25a6724559fe8691d1f57a63f636e
43 Source1:        %{name}-dav_svn.conf
44 Source2:        %{name}-authz_svn.conf
45 Source3:        %{name}-svnserve.init
46 Source4:        %{name}-svnserve.sysconfig
47 # current subversion tarball has correct *.swg files
48 # but after regeneration these are broken again, so
49 # we still need this script
50 Source5:        %{name}-convert-typemaps-to-ifdef.py
51 Patch0:         %{name}-home_etc.patch
52 Patch1:         %{name}-DESTDIR.patch
53 Patch2:         %{name}-ruby-datadir-path.patch
54 Patch3:         %{name}-tests.patch
55 URL:            http://subversion.apache.org/
56 %if %{with net_client_only}
57 %global apache_modules_api 0
58 %else
59 %{?with_apache:BuildRequires:   apache-devel >= 2.2.0-8}
60 BuildRequires:  autoconf
61 BuildRequires:  automake
62 BuildRequires:  db-devel >= 4.1.25
63 BuildRequires:  libtool
64 BuildRequires:  rpmbuild(macros) >= 1.583
65 %if %{with perl}
66 BuildRequires:  perl-devel >= 1:5.8.0
67 BuildRequires:  rpm-perlprov >= 4.1-13
68 BuildRequires:  swig-perl >= 1.3.24
69 %endif
70 %if %{with python}
71 BuildRequires:  python-ctypesgen
72 BuildRequires:  python-devel >= 1:2.5
73 BuildRequires:  swig-python >= 1.3.24
74 %endif
75 %if %{with ruby}
76 BuildRequires:  ruby-devel
77 BuildRequires:  ruby-rubygems
78 BuildRequires:  swig-ruby >= 1.3.24
79 %endif
80 %if %{with javahl}
81 BuildRequires:  jdk
82 %endif
83 BuildRequires:  cyrus-sasl-devel
84 %endif
85 BuildRequires:  apr-devel >= 1:1.0.0
86 BuildRequires:  apr-util-devel >= 1:1.2.8-3
87 BuildRequires:  autoconf >= 2.59
88 BuildRequires:  bison
89 BuildRequires:  expat-devel
90 BuildRequires:  gettext-devel
91 %{?with_kwallet:BuildRequires:  kde4-kdelibs-devel}
92 %{?with_gnome:BuildRequires:    libgnome-keyring-devel}
93 BuildRequires:  libtool >= 1.4-9
94 BuildRequires:  pkgconfig
95 BuildRequires:  rpm-pythonprov
96 BuildRequires:  sed >= 4.0
97 BuildRequires:  sqlite3-devel >= 3.6.11
98 BuildRequires:  texinfo
99 BuildRequires:  which
100 %if %{with neon}
101 BuildRequires:  neon-devel >= 0.26.0
102 %else
103 BuildRequires:  serf-devel
104 %endif
105 Requires:       %{name}-libs = %{version}-%{release}
106 %requires_ge    sqlite3
107 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
108
109 %define         _libexecdir             %{_libdir}/svn
110 %define         apacheconfdir   %(%{apxs} -q SYSCONFDIR 2>/dev/null)/conf.d
111 %define         apachelibdir    %(%{apxs} -q LIBEXECDIR 2>/dev/null)
112
113 %define         skip_post_check_so      libsvn_swig_py-1.so.* libsvn_swig_perl-1.so.*
114
115 %description
116 The goal of the Subversion project is to build a version control
117 system that is a compelling replacement for CVS in the open source
118 community.
119
120 Our goals are:
121 - All current CVS features.
122 - Directories, renames, and file meta-data are versioned.
123 - Symbolic links, etc, are supported
124 - Commits are truly atomic.
125 - Branching and tagging are cheap (constant time) operations
126 - Repeated merges are handled gracefully
127 - Support for plug-in client side diff programs
128 - Natively client/server
129 - Client/server protocol sends diffs in both directions
130 - Costs are proportional to change size, not project size
131 - Internationalization
132 - Progressive multi-lingual support
133
134 %description -l pl.UTF-8
135 Celem projektu Subversion jest stworzenie systemu kontroli wersji jako
136 zamiennika dla CVS.
137
138 Cele projektu to:
139 - Wszystkie aktualne możliwości CVS.
140 - Katalogi, zmiany nazw oraz metadane plików są wersjonowane.
141 - Obsługa dowiązań symbolicznych itp.
142 - Commity są w pełni atomowe.
143 - Branchowanie oraz tagowanie są tanimi (stałymi w czasie) operacjami.
144 - Dobra obsługa powtarzanego łączenia (merge).
145 - Obsługa wtyczek diff po stronie klienta.
146 - Natywny klient/serwer.
147 - Klient/Serwer przesyłają diffy w obu kierunkach.
148 - Koszty proporcjonalne do rozmiaru zmiany, a nie rozmiaru projektu.
149 - Internacjonalizacja.
150 - Postępujące wsparcie dla wielu języków.
151
152 %description -l pt_BR.UTF-8
153 O objetivo do projeto Subversion é construir um sistema de controle de
154 versões que seja um substituto para o CVS (Concurrent Versioning
155 System) na comunidade opensource, fornecendo grandes melhorias.
156
157 %package libs
158 Summary:        Subversion libraries and modules
159 Summary(pl.UTF-8):      Biblioteka subversion oraz ładowalne moduły
160 Group:          Libraries
161 %{?with_neon:Requires:  neon >= 0.26.0}
162 Obsoletes:      libsubversion0
163
164 %description libs
165 Subversion libraries and modules.
166
167 %description libs -l pl.UTF-8
168 Biblioteka subversion oraz ładowalne moduły.
169
170 %package devel
171 Summary:        Header files and develpment documentation for subversion
172 Summary(pl.UTF-8):      Pliki nagłówkowe i dokumetacja do subversion
173 Summary(pt_BR.UTF-8):   Arquivos de desenvolvimento para o Subversion
174 Group:          Development/Libraries
175 Requires:       %{name}-libs = %{version}-%{release}
176 Requires:       apr-util-devel >= 1:1.0.0
177 %{?with_neon:Requires:  neon-devel >= 0.26.0}
178 Obsoletes:      libsubversion0-devel
179
180 %description devel
181 Header files and develpment documentation for subversion.
182
183 %description devel -l pl.UTF-8
184 Pliki nagłówkowe i dokumetacja do subversion.
185
186 %description devel -l pt_BR.UTF-8
187 Este pacote provê os arquivos necessários para desenvolvedores
188 interagirem com o Subversion.
189
190 %package static
191 Summary:        Static subversion library
192 Summary(pl.UTF-8):      Biblioteka statyczna subversion
193 Summary(pt_BR.UTF-8):   Sistema de versionamento concorrente
194 Group:          Development/Libraries
195 Requires:       %{name}-devel = %{version}
196 Obsoletes:      libsubversion0-static-devel
197
198 %description static
199 Static subversion library.
200
201 %description static -l pl.UTF-8
202 Biblioteka statyczna subversion.
203
204 %description static -l pt_BR.UTF-8
205 Este pacote provê um cliente estático do subversion.
206
207 %package svnserve
208 Summary:        Subversion svnserve
209 Summary(pl.UTF-8):      Subversion svnserve
210 Group:          Networking/Daemons
211 Requires(post,preun):   /sbin/chkconfig
212 Requires(postun):       /usr/sbin/groupdel
213 Requires(postun):       /usr/sbin/userdel
214 Requires(pre):  /bin/id
215 Requires(pre):  /usr/bin/getgid
216 Requires(pre):  /usr/lib/rpm/user_group.sh
217 Requires(pre):  /usr/sbin/groupadd
218 Requires(pre):  /usr/sbin/useradd
219 Requires(pre):  /usr/sbin/usermod
220 Requires:       %{name} = %{version}-%{release}
221 Requires:       rc-scripts
222 Provides:       group(svn)
223 Provides:       user(svn)
224
225 %description svnserve
226 Subversion svnserve server.
227
228 %description svnserve -l pl.UTF-8
229 Serwer subversion svnserve.
230
231 %package tools
232 Summary:        Subversion tools and scripts
233 Summary(pl.UTF-8):      Narzędzia oraz skrypty dla subversion
234 Summary(pt_BR.UTF-8):   Módulos python para acessar os recursos do Subversion
235 Group:          Applications
236 %pyrequires_eq  python
237 Requires:       %{name} = %{version}-%{release}
238 Requires:       python-subversion = %{version}
239
240 %description tools
241 Subversion tools and scripts.
242
243 %description tools -l pl.UTF-8
244 Narzędzia oraz skrypty dla subversion.
245
246 %package -n bash-completion-subversion
247 Summary:        bash completion for subversion
248 Summary(pl.UTF-8):      Dopełnienia basha dla subversion
249 Group:          Applications/Shells
250 Requires:       %{name} = %{version}-%{release}
251 Requires:       bash-completion
252 Conflicts:      %{name}-tools <= 1.1.0-0.rc6.1
253
254 %description -n bash-completion-subversion
255 Bash completion for subversion.
256
257 %description -n bash-completion-subversion -l pl.UTF-8
258 Dopełnienia basha dla subversion.
259
260 %package -n java-subversion
261 Summary:        Subversion Java bindings
262 Summary(pl.UTF-8):      Dowiązania do Subversion dla Javy
263 Group:          Development/Languages/Java
264 Requires:       %{name}-libs = %{version}-%{release}
265
266 %description -n java-subversion
267 This is a set of Java classes which provide the functionality of
268 subversion-libs, the Subversion libraries. It is useful if you want
269 to, for example, write a Java class that manipulates a Subversion
270 repository or working copy. See the 'subversion' package for more
271 information.
272
273 %description -n java-subversion -l pl.UTF-8
274 Ten pakiet zawiera zestaw klas Javy udostępniających funkcjonalność
275 subversion-libs, czyli bibliotek Subversion. Jest przydatny przy
276 pisaniu klas Javy np. modyfikujących repozytorium Subversion lub kopię
277 roboczą. Więcej informacji w pakiecie subversion.
278
279 %package -n python-subversion
280 Summary:        Subversion Python bindings
281 Summary(pl.UTF-8):      Dowiązania do Subversion dla Pythona
282 Summary(pt_BR.UTF-8):   Módulos Python para acessar os recursos do Subversion
283 Group:          Development/Languages/Python
284 %pyrequires_eq  python
285 Requires:       %{name}-libs = %{version}-%{release}
286 Obsoletes:      subversion-python
287
288 %description -n python-subversion
289 Subversion Python bindings.
290
291 %description -n python-subversion -l pl.UTF-8
292 Dowiązania do Subversion dla Pythona.
293
294 %description -n python-subversion -l pt_BR.UTF-8
295 Módulos Python para acessar os recursos do Subversion.
296
297 %package -n python-csvn
298 Summary:        CTypes Subversion Python bindings
299 Summary(pl.UTF-8):      Dowiązania do Subversion dla Pythona
300 Summary(pt_BR.UTF-8):   Módulos Python para acessar os recursos do Subversion
301 Group:          Development/Languages/Python
302 %pyrequires_eq  python
303 Requires:       %{name}-libs = %{version}-%{release}
304
305 %description -n python-csvn
306 Subversion CTypes Python bindings.
307
308 %description -n python-csvn -l pl.UTF-8
309 Dowiązania do Subversion dla Pythona używające CTypes.
310
311 %description -n python-csvn -l pt_BR.UTF-8
312 Módulos Python para acessar os recursos do Subversion.
313
314 %package -n perl-subversion
315 Summary:        Subversion Perl bindings
316 Summary(pl.UTF-8):      Dowiązania do Subversion dla Perla
317 Summary(pt_BR.UTF-8):   Módulos Perl para acessar os recursos do Subversion
318 Group:          Development/Languages/Perl
319 Requires:       %{name}-libs = %{version}-%{release}
320 Obsoletes:      subversion-perl
321
322 %description -n perl-subversion
323 Subversion Perl bindings.
324
325 %description -n perl-subversion -l pl.UTF-8
326 Dowiązania do Subversion dla Perla.
327
328 %description -n perl-subversion -l pt_BR.UTF-8
329 Módulos Perl para acessar os recursos do Subversion.
330
331 %package -n ruby-subversion
332 Summary:        Subversion Ruby bindings
333 Summary(pl.UTF-8):      Dowiązania do Subversion dla języka Ruby
334 Summary(pt_BR.UTF-8):   Módulos Ruby para acessar os recursos do Subversion
335 Group:          Development/Languages
336 Requires:       %{name}-libs = %{version}-%{release}
337 Obsoletes:      subversion-ruby
338
339 %description -n ruby-subversion
340 Subversion Ruby bindings.
341
342 %description -n ruby-subversion -l pl.UTF-8
343 Dowiązania do Subversion dla języka Ruby.
344
345 %description -n ruby-subversion -l pt_BR.UTF-8
346 Módulos Ruby para acessar os recursos do Subversion.
347
348 %package -n apache-mod_dav_svn
349 Summary:        Apache module: Subversion Server
350 Summary(pl.UTF-8):      Moduł apache: Serwer Subversion
351 Group:          Networking/Daemons
352 Requires:       %{name} = %{version}-%{release}
353 Requires:       apache(modules-api) = %apache_modules_api
354 Requires:       apache-mod_dav
355
356 %description -n apache-mod_dav_svn
357 Apache module: Subversion Server.
358
359 %description -n apache-mod_dav_svn -l pl.UTF-8
360 Moduł apache: Serwer Subversion.
361
362 %package -n apache-mod_authz_svn
363 Summary:        Apache module: Subversion Server - path-based authorization
364 Summary(pl.UTF-8):      Moduł apache: autoryzacja na podstawie ścieżki dla serwera Subversion
365 Group:          Networking/Daemons
366 Requires:       apache(modules-api) = %apache_modules_api
367 Requires:       apache-mod_dav_svn = %{version}-%{release}
368
369 %description -n apache-mod_authz_svn
370 Apache module: Subversion Server - path-based authorization.
371
372 %description -n apache-mod_authz_svn -l pl.UTF-8
373 Moduł apache: autoryzacja na podstawie ścieżki dla serwera Subversion.
374
375 %package -n gnome-keyring-subversion
376 Summary:        GNOME Keyring authentication provider for Subversion
377 Summary(pl.UTF-8):      Moduł uwierzytelniający GNOME Keyring dla Subversion
378 Group:          X11/Applications
379
380 %description -n gnome-keyring-subversion
381 Authentication provider module for Subversion which allows SVN client
382 to authenticate using GNOME Keyring.
383
384 %description -n gnome-keyring-subversion -l pl.UTF-8
385 Moduł uwierzytelniający dla Subversion pozwalający klientom SVN
386 uwierzytelniać się przy użyciu mechanizmu GNOME Keyring.
387
388 %package -n kde4-kwallet-subversion
389 Summary:        KDE Wallet authentication provider for Subversion
390 Summary(pl.UTF-8):      Moduł uwierzytelniający dla Subversion wykorzystujący Portfel KDE
391 Group:          X11/Applications
392
393 %description -n kde4-kwallet-subversion
394 Authentication provider module for Subversion which allows SVN client
395 to authenticate using KDE Wallet.
396
397 %description -n kde4-kwallet-subversion -l pl.UTF-8
398 Moduł uwierzytelniający dla Subversion pozwalający klientom SVN
399 uwierzytelniać się przy użyciu Portfela KDE.
400
401 %prep
402 %setup -q
403 %patch0 -p0
404 %patch1 -p1
405 %patch2 -p0
406 %patch3 -p1
407
408 sed -i -e 's#serf_prefix/lib#serf_prefix/%{_lib}#g' build/ac-macros/serf.m4
409
410 # serf.m4 macro is broken and ignores --without serf
411 %{?with_neon:sed -i -e 's#serf_found="yes"#serf_found="no"#g' build/ac-macros/serf.m4}
412
413 %build
414 # disabled regeneration - subversion 1.6.13 is not ready for swig 2.0.x
415 #%{__rm} subversion/bindings/swig/proxy/*.swg
416 #cd subversion/bindings/swig && python "%{SOURCE5}" && cd ../../..
417 chmod +x ./autogen.sh && ./autogen.sh
418 %{__libtoolize}
419 %configure \
420         --with-editor=vi \
421         --with-zlib=%{_libdir} \
422 %if %{with net_client_only}
423         --without-apache \
424         --without-swig \
425         --without-apxs \
426         --without-berkeley-db \
427 %else
428         --disable-runtime-module-search \
429         --disable-mod-activation \
430         --with-berkeley-db="db.h:%{_includedir}:%{_libdir}:db" \
431 %if %{with apache}
432         --with-apxs=%{_sbindir}/apxs \
433 %else
434         --without-apache \
435         --without-apxs \
436 %endif
437 %if %{without python} && %{without perl} && %{without ruby}
438         --without-swig \
439 %endif
440         %{?with_python:--with-ctypesgen=%{_bindir}/ctypesgen.py} \
441         --%{?with_javahl:en}%{!?with_javahl:dis}able-javahl \
442 %endif
443         --with-jdk="%{java_home}" \
444         --without-jikes \
445 %if %{with neon}
446         --without-serf \
447         --with-neon=%{_prefix} \
448         --disable-neon-version-check \
449 %else
450         --with-serf=%{_prefix} \
451         --without-neon \
452 %endif
453         --with-apr=%{_bindir}/apr-1-config \
454         --with-apr-util=%{_bindir}/apu-1-config \
455 %if %{with kwallet}
456         --with-kwallet \
457 %endif
458 %if %{with gnome}
459         --with-gnome-keyring
460 %endif
461
462 %{__make} -j1
463
464 %if %{without net_client_only}
465 # python
466 %if %{with python}
467 # ctypes bindings
468 %{__make} ctypes-python
469 # swig bindings
470 %{__make} swig-py \
471         swig_pydir=%{py_sitedir}/libsvn \
472         swig_pydir_extra=%{py_sitedir}/svn
473 %endif
474 # perl
475 %if %{with perl}
476 %{__make} -j1 swig-pl-lib
477 odir=$(pwd)
478 cd subversion/bindings/swig/perl/native
479 %{__perl} Makefile.PL INSTALLDIRS=vendor
480 %{__make} -j1
481 cd $odir
482 %endif
483 %if %{with javahl}
484 %{__make} -j1 javahl \
485         javahl_javadir="%{_javadir}"
486 %endif
487 # ruby
488 %if %{with ruby}
489 %{__make} swig-rb
490 %endif
491 %endif
492
493 %if %{with tests}
494 %{__make} check
495 %if %{with python}
496 %{__make} check-ctypes-python
497 %{__make} check-swig-py
498 %endif
499 %if %{with perl}
500 %{__make} check-swig-pl
501 %endif
502 %if %{with ruby}
503 # disabled, see https://bugs.launchpad.net/pld-linux/+bug/734340
504 #%{__make} check-swig-rb
505 %endif
506 %endif
507
508 %install
509 rm -rf $RPM_BUILD_ROOT
510 install -d $RPM_BUILD_ROOT/etc/{rc.d/init.d,sysconfig,bash_completion.d} \
511         $RPM_BUILD_ROOT{%{apacheconfdir},%{apachelibdir},%{_infodir}} \
512         $RPM_BUILD_ROOT%{_examplesdir}/{%{name}-%{version},python-%{name}-%{version}} \
513         $RPM_BUILD_ROOT%{_sysconfdir}/%{name} \
514         $RPM_BUILD_ROOT/home/services/subversion{,/repos}
515
516 %{__make} install -j1 \
517 %if %{with javahl}
518         install-javahl \
519         javahl_javadir="%{_javadir}" \
520 %endif
521 %if %{without net_client_only}
522 %if %{with python}
523         install-swig-py \
524         install-ctypes-python \
525 %endif
526 %if %{with ruby}
527         install-swig-rb install-swig-rb-doc \
528 %endif
529 %endif
530         APACHE_LIBEXECDIR="$(%{_sbindir}/apxs -q LIBEXECDIR)" \
531         DESTDIR=$RPM_BUILD_ROOT \
532         swig_pydir=%{py_sitedir}/libsvn \
533         swig_pydir_extra=%{py_sitedir}/svn
534
535 %if %{without net_client_only} && %{with perl}
536 %{__make} install-swig-pl-lib \
537         DESTDIR=$RPM_BUILD_ROOT
538 %{__make} -C subversion/bindings/swig/perl/native install \
539         DESTDIR=$RPM_BUILD_ROOT \
540         PREFIX=$RPM_BUILD_ROOT%{_prefix} \
541         LIBDIR=$RPM_BUILD_ROOT%{_libdir}
542 %endif
543
544 %if %{with apache}
545 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{apacheconfdir}/65_mod_dav_svn.conf
546 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{apacheconfdir}/66_mod_authz_svn.conf
547 cp -p %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/svnserve
548 install -p %{SOURCE3} $RPM_BUILD_ROOT/etc/rc.d/init.d/svnserve
549 %endif
550
551 %if %{without net_client_only}
552 install -p tools/backup/hot-backup.py $RPM_BUILD_ROOT%{_bindir}/svn-hot-backup
553 %if %{with python}
554 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
555 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
556 %py_postclean
557 %{__rm} $RPM_BUILD_ROOT%{py_sitedir}/libsvn/*.la
558 install tools/examples/*.py $RPM_BUILD_ROOT%{_examplesdir}/python-%{name}-%{version}
559 %endif
560 %endif
561
562 cp -p tools/client-side/bash_completion $RPM_BUILD_ROOT/etc/bash_completion.d/%{name}
563 cp -p tools/examples/*.c $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
564
565 %{?with_javahl:%{__rm} $RPM_BUILD_ROOT%{_libdir}/libsvnjavahl*.{la,a}}
566 %if %{without net_client_only}
567 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libsvn_swig*.{la,a}
568 %{__rm} $RPM_BUILD_ROOT%{_libdir}/ruby/site_ruby/*/*/svn/ext/*.la
569 %endif
570 %if %{with gnome} || %{with kwallet}
571 # dlopened by soname (libsvn_auth_*-1.so.0)
572 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libsvn_auth_*-1.{so,la,a}
573 %endif
574
575 %find_lang %{name}
576
577 %clean
578 rm -rf $RPM_BUILD_ROOT
579
580 %pre svnserve
581 %groupadd -g 86 svn
582 %useradd -u 180 -d /home/services/subversion -c "Subversion svnserve" -g svn svn
583
584 %post   libs -p /sbin/ldconfig
585 %postun libs -p /sbin/ldconfig
586
587 %post   devel -p /sbin/postshell
588 -/usr/sbin/fix-info-dir -c %{_infodir}
589
590 %postun devel -p /sbin/postshell
591 -/usr/sbin/fix-info-dir -c %{_infodir}
592
593 %post   -n java-subversion -p /sbin/ldconfig
594 %postun -n java-subversion -p /sbin/ldconfig
595
596 %post   -n perl-subversion -p /sbin/ldconfig
597 %postun -n perl-subversion -p /sbin/ldconfig
598
599 %post   -n python-subversion -p /sbin/ldconfig
600 %postun -n python-subversion -p /sbin/ldconfig
601
602 %post   -n ruby-subversion -p /sbin/ldconfig
603 %postun -n ruby-subversion -p /sbin/ldconfig
604
605 %post   -n gnome-keyring-subversion -p /sbin/ldconfig
606 %postun -n gnome-keyring-subversion -p /sbin/ldconfig
607
608 %post   -n kde4-kwallet-subversion -p /sbin/ldconfig
609 %postun -n kde4-kwallet-subversion -p /sbin/ldconfig
610
611 %post svnserve
612 /sbin/chkconfig --add svnserve
613 %service svnserve restart "svnserve daemon"
614
615 %preun svnserve
616 if [ "$1" = "0" ]; then
617         %service svnserve stop
618         /sbin/chkconfig --del svnserve
619 fi
620
621 %postun svnserve
622 if [ "$1" = "0" ]; then
623         %userremove svn
624         %groupremove svn
625 fi
626
627 %post -n apache-mod_dav_svn
628 %service -q httpd restart
629
630 %postun -n apache-mod_dav_svn
631 if [ "$1" = "0" ]; then
632         %service -q httpd restart
633 fi
634
635 %post -n apache-mod_authz_svn
636 %service -q httpd restart
637
638 %postun -n apache-mod_authz_svn
639 if [ "$1" = "0" ]; then
640         %service -q httpd restart
641 fi
642
643 %files
644 %defattr(644,root,root,755)
645 %doc BUGS CHANGES COPYING INSTALL README
646 %doc doc/*/*.html
647 %doc tools/hook-scripts/*.{pl,py,example}
648 %doc tools/hook-scripts/mailer/*.{py,example}
649 %doc tools/xslt/*
650 %attr(755,root,root) %{_bindir}/svn
651 %attr(755,root,root) %{_bindir}/svnadmin
652 %attr(755,root,root) %{_bindir}/svndumpfilter
653 %attr(755,root,root) %{_bindir}/svnlook
654 %attr(755,root,root) %{_bindir}/svnsync
655 %attr(755,root,root) %{_bindir}/svnversion
656 %{_mandir}/man1/svn.1*
657 %{_mandir}/man1/svnadmin.1*
658 %{_mandir}/man1/svndumpfilter.1*
659 %{_mandir}/man1/svnlook.1*
660 %{_mandir}/man1/svnsync.1*
661 %{_mandir}/man1/svnversion.1*
662
663 %files libs -f %{name}.lang
664 %defattr(644,root,root,755)
665 %dir %{_sysconfdir}/%{name}
666 %attr(755,root,root) %{_libdir}/libsvn_client-1.so.*.*.*
667 %attr(755,root,root) %ghost %{_libdir}/libsvn_client-1.so.0
668 %attr(755,root,root) %{_libdir}/libsvn_delta-1.so.*.*.*
669 %attr(755,root,root) %ghost %{_libdir}/libsvn_delta-1.so.0
670 %attr(755,root,root) %{_libdir}/libsvn_diff-1.so.*.*.*
671 %attr(755,root,root) %ghost %{_libdir}/libsvn_diff-1.so.0
672 %attr(755,root,root) %{_libdir}/libsvn_fs-1.so.*.*.*
673 %attr(755,root,root) %ghost %{_libdir}/libsvn_fs-1.so.0
674 %if %{without net_client_only}
675 %attr(755,root,root) %{_libdir}/libsvn_fs_base-1.so.*.*.*
676 %attr(755,root,root) %ghost %{_libdir}/libsvn_fs_base-1.so.0
677 %endif
678 %attr(755,root,root) %{_libdir}/libsvn_fs_fs-1.so.*.*.*
679 %attr(755,root,root) %ghost %{_libdir}/libsvn_fs_fs-1.so.0
680 %attr(755,root,root) %{_libdir}/libsvn_fs_util-1.so.*.*.*
681 %attr(755,root,root) %ghost %{_libdir}/libsvn_fs_util-1.so.0
682 %attr(755,root,root) %{_libdir}/libsvn_ra-1.so.*.*.*
683 %attr(755,root,root) %ghost %{_libdir}/libsvn_ra-1.so.0
684 %attr(755,root,root) %{_libdir}/libsvn_ra_local-1.so.*.*.*
685 %attr(755,root,root) %ghost %{_libdir}/libsvn_ra_local-1.so.0
686 %attr(755,root,root) %{_libdir}/libsvn_ra_%{webdavlib}-1.so.*.*.*
687 %attr(755,root,root) %ghost %{_libdir}/libsvn_ra_%{webdavlib}-1.so.0
688 %attr(755,root,root) %{_libdir}/libsvn_ra_svn-1.so.*.*.*
689 %attr(755,root,root) %ghost %{_libdir}/libsvn_ra_svn-1.so.0
690 %attr(755,root,root) %{_libdir}/libsvn_repos-1.so.*.*.*
691 %attr(755,root,root) %ghost %{_libdir}/libsvn_repos-1.so.0
692 %attr(755,root,root) %{_libdir}/libsvn_subr-1.so.*.*.*
693 %attr(755,root,root) %ghost %{_libdir}/libsvn_subr-1.so.0
694 %attr(755,root,root) %{_libdir}/libsvn_wc-1.so.*.*.*
695 %attr(755,root,root) %ghost %{_libdir}/libsvn_wc-1.so.0
696
697 %files devel
698 %defattr(644,root,root,755)
699 %attr(755,root,root) %{_libdir}/libsvn_client-1.so
700 %attr(755,root,root) %{_libdir}/libsvn_delta-1.so
701 %attr(755,root,root) %{_libdir}/libsvn_diff-1.so
702 %attr(755,root,root) %{_libdir}/libsvn_fs-1.so
703 %if %{without net_client_only}
704 %attr(755,root,root) %{_libdir}/libsvn_fs_base-1.so
705 %endif
706 %attr(755,root,root) %{_libdir}/libsvn_fs_fs-1.so
707 %attr(755,root,root) %{_libdir}/libsvn_fs_util-1.so
708 %attr(755,root,root) %{_libdir}/libsvn_ra-1.so
709 %attr(755,root,root) %{_libdir}/libsvn_ra_local-1.so
710 %attr(755,root,root) %{_libdir}/libsvn_ra_%{webdavlib}-1.so
711 %attr(755,root,root) %{_libdir}/libsvn_ra_svn-1.so
712 %attr(755,root,root) %{_libdir}/libsvn_repos-1.so
713 %attr(755,root,root) %{_libdir}/libsvn_subr-1.so
714 %attr(755,root,root) %{_libdir}/libsvn_wc-1.so
715 %{_libdir}/libsvn_client-1.la
716 %{_libdir}/libsvn_delta-1.la
717 %{_libdir}/libsvn_diff-1.la
718 %{_libdir}/libsvn_fs-1.la
719 %if %{without net_client_only}
720 %{_libdir}/libsvn_fs_base-1.la
721 %endif
722 %{_libdir}/libsvn_fs_fs-1.la
723 %{_libdir}/libsvn_fs_util-1.la
724 %{_libdir}/libsvn_ra-1.la
725 %{_libdir}/libsvn_ra_local-1.la
726 %{_libdir}/libsvn_ra_%{webdavlib}-1.la
727 %{_libdir}/libsvn_ra_svn-1.la
728 %{_libdir}/libsvn_repos-1.la
729 %{_libdir}/libsvn_subr-1.la
730 %{_libdir}/libsvn_wc-1.la
731 %{_includedir}/%{name}-1
732 %{_examplesdir}/%{name}-%{version}
733
734 %files static
735 %defattr(644,root,root,755)
736 %{_libdir}/libsvn_client-1.a
737 %{_libdir}/libsvn_delta-1.a
738 %{_libdir}/libsvn_diff-1.a
739 %{_libdir}/libsvn_fs-1.a
740 %if %{without net_client_only}
741 %{_libdir}/libsvn_fs_base-1.a
742 %endif
743 %{_libdir}/libsvn_fs_fs-1.a
744 %{_libdir}/libsvn_fs_util-1.a
745 %{_libdir}/libsvn_ra-1.a
746 %{_libdir}/libsvn_ra_local-1.a
747 %{_libdir}/libsvn_ra_%{webdavlib}-1.a
748 %{_libdir}/libsvn_ra_svn-1.a
749 %{_libdir}/libsvn_repos-1.a
750 %{_libdir}/libsvn_subr-1.a
751 %{_libdir}/libsvn_wc-1.a
752
753 %if %{with gnome}
754 %files -n gnome-keyring-subversion
755 %defattr(644,root,root,755)
756 %attr(755,root,root) %{_libdir}/libsvn_auth_gnome_keyring-1.so.*.*.*
757 %attr(755,root,root) %ghost %{_libdir}/libsvn_auth_gnome_keyring-1.so.0
758 %endif
759
760 %if %{with kwallet}
761 %files -n kde4-kwallet-subversion
762 %defattr(644,root,root,755)
763 %attr(755,root,root) %{_libdir}/libsvn_auth_kwallet-1.so.*.*.*
764 %attr(755,root,root) %ghost %{_libdir}/libsvn_auth_kwallet-1.so.0
765 %endif
766
767 %if %{without net_client_only}
768 %files svnserve
769 %defattr(644,root,root,755)
770 %attr(755,root,root) %{_bindir}/svnserve
771 %{_mandir}/man5/svnserve.conf.5*
772 %{_mandir}/man8/svnserve.8*
773 %dir %attr(750,svn,svn) /home/services/subversion
774 %dir %attr(750,svn,svn) /home/services/subversion/repos
775 %if %{with apache}
776 %attr(754,root,root) /etc/rc.d/init.d/svnserve
777 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/svnserve
778 %endif
779
780 %files tools
781 %defattr(644,root,root,755)
782 %attr(755,root,root) %{_bindir}/svn-hot-backup
783
784 %files -n bash-completion-subversion
785 %defattr(644,root,root,755)
786 /etc/bash_completion.d/%{name}
787
788 %if %{with javahl}
789 %files -n java-subversion
790 %defattr(644,root,root,755)
791 %attr(755,root,root) %{_libdir}/libsvnjavahl-1.so.*.*.*
792 %attr(755,root,root) %ghost %{_libdir}/libsvnjavahl-1.so.0
793 %attr(755,root,root) %{_libdir}/libsvnjavahl-1.so
794 %{_javadir}/svn-javahl.jar
795 %endif
796
797 %if %{with python}
798 %files -n python-subversion
799 %defattr(644,root,root,755)
800 %doc tools/backup/*.py tools/examples/*.py
801 %attr(755,root,root) %{_libdir}/libsvn_swig_py-1.so.*.*.*
802 %attr(755,root,root) %ghost %{_libdir}/libsvn_swig_py-1.so.0
803 %attr(755,root,root) %{_libdir}/libsvn_swig_py-1.so
804 %dir %{py_sitedir}/libsvn
805 %attr(755,root,root) %{py_sitedir}/libsvn/_*.so
806 %{py_sitedir}/libsvn/*.py[co]
807 %dir %{py_sitedir}/svn
808 %{py_sitedir}/svn/*.py[co]
809 %{_examplesdir}/python-%{name}-%{version}
810
811 %files -n python-csvn
812 %defattr(644,root,root,755)
813 %doc subversion/bindings/ctypes-python/{README,TODO}
814 %doc subversion/bindings/ctypes-python/examples/*.py
815 %dir %{py_sitescriptdir}/csvn
816 %{py_sitescriptdir}/csvn/*.py[co]
817 %dir %{py_sitescriptdir}/csvn/core
818 %{py_sitescriptdir}/csvn/core/*.py[co]
819 %dir %{py_sitescriptdir}/csvn/ext
820 %{py_sitescriptdir}/csvn/ext/*.py[co]
821 %{py_sitescriptdir}/svn_ctypes_python_bindings-0.1-py*.egg-info
822 %endif
823
824 %if %{with perl}
825 %files -n perl-subversion
826 %defattr(644,root,root,755)
827 %attr(755,root,root) %{_libdir}/libsvn_swig_perl-1.so.*.*.*
828 %attr(755,root,root) %ghost %{_libdir}/libsvn_swig_perl-1.so.0
829 %attr(755,root,root) %{_libdir}/libsvn_swig_perl-1.so
830 %{perl_vendorarch}/SVN
831 %dir %{perl_vendorarch}/auto/SVN
832 %dir %{perl_vendorarch}/auto/SVN/*
833 %attr(755,root,root) %{perl_vendorarch}/auto/SVN/*/*.so
834 %{perl_vendorarch}/auto/SVN/*/*.bs
835 %{_mandir}/man3/*.3pm*
836 %endif
837
838 %if %{with ruby}
839 %files -n ruby-subversion
840 %defattr(644,root,root,755)
841 %attr(755,root,root) %{_libdir}/libsvn_swig_ruby-1.so.*.*.*
842 %attr(755,root,root) %ghost %{_libdir}/libsvn_swig_ruby-1.so.0
843 %attr(755,root,root) %{_libdir}/libsvn_swig_ruby-1.so
844 %dir %{ruby_sitelibdir}/svn
845 %{ruby_sitelibdir}/svn/*.rb
846 %dir %{ruby_sitearchdir}/svn
847 %dir %{ruby_sitearchdir}/svn/ext
848 %attr(755,root,root) %{ruby_sitearchdir}/svn/ext/*.so
849 %{ruby_ridir}/Svn
850 %endif
851
852 %if %{with apache}
853 %files -n apache-mod_dav_svn
854 %defattr(644,root,root,755)
855 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{apacheconfdir}/*_mod_dav_svn.conf
856 %attr(755,root,root) %{apachelibdir}/mod_dav_svn.so
857
858 %files -n apache-mod_authz_svn
859 %defattr(644,root,root,755)
860 %doc subversion/mod_authz_svn/INSTALL
861 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{apacheconfdir}/*_mod_authz_svn.conf
862 %attr(755,root,root) %{apachelibdir}/mod_authz_svn.so
863 %endif
864
865 %endif # net_client_only
This page took 0.086336 seconds and 4 git commands to generate.