]> git.pld-linux.org Git - packages/subversion.git/blob - subversion.spec
- up to 1.6.16
[packages/subversion.git] / subversion.spec
1 # TODO:
2 # - remove net_client_only and add db bcond (then without apache and
3 #   without db => net_client_only - spec will be more simpler, I think)
4 # - finish ruby
5 # - http://subversion.tigris.org/issues/show_bug.cgi?id=2753
6 #
7 # Conditional build:
8 %bcond_with     net_client_only         # build only net client
9 %bcond_without  neon                    # use serf instead of neon
10 %bcond_without  python                  # build without python bindings (broken)
11 %bcond_without  perl                    # build without perl bindings
12 %bcond_without  ruby                    # build without ruby bindings
13 %bcond_without  apache                  # build without apache support (webdav, etc)
14 %bcond_without  javahl                  # build without javahl support (Java high-level bindings)
15 %bcond_without  tests                   # don't perform "make check"
16 %bcond_without  kwallet                 # build without kde4 wallet support
17 %bcond_without  kde                     # build without kde4 support (alias for kwallet)
18 %bcond_without  gnome                   # build without gnome keyring support
19
20 %{!?with_net_client_only:%include       /usr/lib/rpm/macros.perl}
21 %define apxs    /usr/sbin/apxs
22 %define pdir    SVN
23 %define pnam    _Core
24
25 %if !%{with kde}
26 %undefine       with_kwallet
27 %endif
28 %if %{with neon}
29 %define webdavlib       neon
30 %else
31 %define webdavlib       serf
32 %endif
33 Summary:        A Concurrent Versioning system similar to but better than CVS
34 Summary(pl.UTF-8):      System kontroli wersji podobny, ale lepszy, niż CVS
35 Summary(pt_BR.UTF-8):   Sistema de versionamento concorrente
36 Name:           subversion
37 Version:        1.6.16
38 Release:        1
39 License:        Apache/BSD-like
40 Group:          Development/Version Control
41 Source0:        http://subversion.tigris.org/downloads/%{name}-%{version}.tar.bz2
42 # Source0-md5:  32f25a6724559fe8691d1f57a63f636e
43 Source1:        %{name}-dav_svn.conf
44 Source2:        %{name}-authz_svn.conf
45 Source3:        %{name}-svnserve.init
46 Source4:        %{name}-svnserve.sysconfig
47 # current subversion tarball has correct *.swg files
48 # but after regeneration these are broken again, so
49 # we still need this script
50 Source5:        %{name}-convert-typemaps-to-ifdef.py
51 Patch0:         %{name}-home_etc.patch
52 Patch1:         %{name}-DESTDIR.patch
53 Patch2:         %{name}-ruby-datadir-path.patch
54 Patch3:         %{name}-tests.patch
55 URL:            http://subversion.apache.org/
56 %if %{with net_client_only}
57 %global apache_modules_api 0
58 %else
59 %{?with_apache:BuildRequires:   apache-devel >= 2.2.0-8}
60 BuildRequires:  autoconf
61 BuildRequires:  automake
62 BuildRequires:  db-devel >= 4.1.25
63 BuildRequires:  libtool
64 BuildRequires:  rpmbuild(macros) >= 1.583
65 %if %{with perl}
66 BuildRequires:  perl-devel >= 1:5.8.0
67 BuildRequires:  rpm-perlprov >= 4.1-13
68 BuildRequires:  swig-perl >= 1.3.24
69 %endif
70 %if %{with python}
71 BuildRequires:  python-ctypesgen
72 BuildRequires:  python-devel >= 1:2.5
73 BuildRequires:  swig-python >= 1.3.24
74 %endif
75 %if %{with ruby}
76 BuildRequires:  ruby-devel
77 BuildRequires:  ruby-rubygems
78 BuildRequires:  swig-ruby >= 1.3.24
79 %endif
80 %if %{with javahl}
81 BuildRequires:  jdk
82 %endif
83 BuildRequires:  cyrus-sasl-devel
84 %endif
85 BuildRequires:  apr-devel >= 1:1.0.0
86 BuildRequires:  apr-util-devel >= 1:1.2.8-3
87 BuildRequires:  autoconf >= 2.59
88 BuildRequires:  bison
89 BuildRequires:  expat-devel
90 BuildRequires:  gettext-devel
91 %{?with_kwallet:BuildRequires:  kde4-kdelibs-devel}
92 %{?with_gnome:BuildRequires:    libgnome-keyring-devel}
93 BuildRequires:  libtool >= 1.4-9
94 BuildRequires:  pkgconfig
95 BuildRequires:  rpm-pythonprov
96 BuildRequires:  sed >= 4.0
97 BuildRequires:  sqlite3-devel >= 3.6.11
98 BuildRequires:  texinfo
99 BuildRequires:  which
100 %if %{with neon}
101 BuildRequires:  neon-devel >= 0.26.0
102 %else
103 BuildRequires:  serf-devel
104 %endif
105 Requires:       %{name}-libs = %{version}-%{release}
106 %requires_ge    sqlite3
107 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
108
109 %define         _libexecdir             %{_libdir}/svn
110 %define         apacheconfdir   %(%{apxs} -q SYSCONFDIR 2>/dev/null)/conf.d
111 %define         apachelibdir    %(%{apxs} -q LIBEXECDIR 2>/dev/null)
112
113 %define         skip_post_check_so      libsvn_swig_py-1.so.* libsvn_swig_perl-1.so.*
114
115 %description
116 The goal of the Subversion project is to build a version control
117 system that is a compelling replacement for CVS in the open source
118 community.
119
120 Our goals are:
121 - All current CVS features.
122 - Directories, renames, and file meta-data are versioned.
123 - Symbolic links, etc, are supported
124 - Commits are truly atomic.
125 - Branching and tagging are cheap (constant time) operations
126 - Repeated merges are handled gracefully
127 - Support for plug-in client side diff programs
128 - Natively client/server
129 - Client/server protocol sends diffs in both directions
130 - Costs are proportional to change size, not project size
131 - Internationalization
132 - Progressive multi-lingual support
133
134 %description -l pl.UTF-8
135 Celem projektu Subversion jest stworzenie systemu kontroli wersji jako
136 zamiennika dla CVS.
137
138 Cele projektu to:
139 - Wszystkie aktualne możliwości CVS.
140 - Katalogi, zmiany nazw oraz metadane plików są wersjonowane.
141 - Obsługa dowiązań symbolicznych itp.
142 - Commity są w pełni atomowe.
143 - Branchowanie oraz tagowanie są tanimi (stałymi w czasie) operacjami.
144 - Dobra obsługa powtarzanego łączenia (merge).
145 - Obsługa wtyczek diff po stronie klienta.
146 - Natywny klient/serwer.
147 - Klient/Serwer przesyłają diffy w obu kierunkach.
148 - Koszty proporcjonalne do rozmiaru zmiany, a nie rozmiaru projektu.
149 - Internacjonalizacja.
150 - Postępujące wsparcie dla wielu języków.
151
152 %description -l pt_BR.UTF-8
153 O objetivo do projeto Subversion é construir um sistema de controle de
154 versões que seja um substituto para o CVS (Concurrent Versioning
155 System) na comunidade opensource, fornecendo grandes melhorias.
156
157 %package libs
158 Summary:        Subversion libraries and modules
159 Summary(pl.UTF-8):      Biblioteka subversion oraz ładowalne moduły
160 Group:          Libraries
161 %{?with_neon:Requires:  neon >= 0.26.0}
162 Obsoletes:      libsubversion0
163
164 %description libs
165 Subversion libraries and modules.
166
167 %description libs -l pl.UTF-8
168 Biblioteka subversion oraz ładowalne moduły.
169
170 %package devel
171 Summary:        Header files and develpment documentation for subversion
172 Summary(pl.UTF-8):      Pliki nagłówkowe i dokumetacja do subversion
173 Summary(pt_BR.UTF-8):   Arquivos de desenvolvimento para o Subversion
174 Group:          Development/Libraries
175 Requires:       %{name}-libs = %{version}-%{release}
176 Requires:       apr-util-devel >= 1:1.0.0
177 %{?with_neon:Requires:  neon-devel >= 0.26.0}
178 Obsoletes:      libsubversion0-devel
179
180 %description devel
181 Header files and develpment documentation for subversion.
182
183 %description devel -l pl.UTF-8
184 Pliki nagłówkowe i dokumetacja do subversion.
185
186 %description devel -l pt_BR.UTF-8
187 Este pacote provê os arquivos necessários para desenvolvedores
188 interagirem com o Subversion.
189
190 %package static
191 Summary:        Static subversion library
192 Summary(pl.UTF-8):      Biblioteka statyczna subversion
193 Summary(pt_BR.UTF-8):   Sistema de versionamento concorrente
194 Group:          Development/Libraries
195 Requires:       %{name}-devel = %{version}
196 Obsoletes:      libsubversion0-static-devel
197
198 %description static
199 Static subversion library.
200
201 %description static -l pl.UTF-8
202 Biblioteka statyczna subversion.
203
204 %description static -l pt_BR.UTF-8
205 Este pacote provê um cliente estático do subversion.
206
207 %package svnserve
208 Summary:        Subversion svnserve
209 Summary(pl.UTF-8):      Subversion svnserve
210 Group:          Networking/Daemons
211 Requires(post,preun):   /sbin/chkconfig
212 Requires(postun):       /usr/sbin/groupdel
213 Requires(postun):       /usr/sbin/userdel
214 Requires(pre):  /bin/id
215 Requires(pre):  /usr/bin/getgid
216 Requires(pre):  /usr/lib/rpm/user_group.sh
217 Requires(pre):  /usr/sbin/groupadd
218 Requires(pre):  /usr/sbin/useradd
219 Requires(pre):  /usr/sbin/usermod
220 Requires:       %{name} = %{version}-%{release}
221 Requires:       rc-scripts
222 Provides:       group(svn)
223 Provides:       user(svn)
224
225 %description svnserve
226 Subversion svnserve server.
227
228 %description svnserve -l pl.UTF-8
229 Serwer subversion svnserve.
230
231 %package tools
232 Summary:        Subversion tools and scripts
233 Summary(pl.UTF-8):      Narzędzia oraz skrypty dla subversion
234 Summary(pt_BR.UTF-8):   Módulos python para acessar os recursos do Subversion
235 Group:          Applications
236 %pyrequires_eq  python
237 Requires:       %{name} = %{version}-%{release}
238 Requires:       python-subversion = %{version}
239
240 %description tools
241 Subversion tools and scripts.
242
243 %description tools -l pl.UTF-8
244 Narzędzia oraz skrypty dla subversion.
245
246 %package -n bash-completion-subversion
247 Summary:        bash completion for subversion
248 Summary(pl.UTF-8):      Dopełnienia basha dla subversion
249 Group:          Applications/Shells
250 Requires:       %{name} = %{version}-%{release}
251 Requires:       bash-completion
252 Conflicts:      %{name}-tools <= 1.1.0-0.rc6.1
253
254 %description -n bash-completion-subversion
255 Bash completion for subversion.
256
257 %description -n bash-completion-subversion -l pl.UTF-8
258 Dopełnienia basha dla subversion.
259
260 %package -n java-subversion
261 Summary:        Subversion Java bindings
262 Summary(pl.UTF-8):      Dowiązania do Subversion dla Javy
263 Group:          Development/Languages/Java
264 Requires:       %{name}-libs = %{version}-%{release}
265
266 %description -n java-subversion
267 This is a set of Java classes which provide the functionality of
268 subversion-libs, the Subversion libraries. It is useful if you want
269 to, for example, write a Java class that manipulates a Subversion
270 repository or working copy. See the 'subversion' package for more
271 information.
272
273 %description -n java-subversion -l pl.UTF-8
274 Ten pakiet zawiera zestaw klas Javy udostępniających funkcjonalność
275 subversion-libs, czyli bibliotek Subversion. Jest przydatny przy
276 pisaniu klas Javy np. modyfikujących repozytorium Subversion lub kopię
277 roboczą. Więcej informacji w pakiecie subversion.
278
279 %package -n python-subversion
280 Summary:        Subversion Python bindings
281 Summary(pl.UTF-8):      Dowiązania do Subversion dla Pythona
282 Summary(pt_BR.UTF-8):   Módulos Python para acessar os recursos do Subversion
283 Group:          Development/Languages/Python
284 %pyrequires_eq  python
285 Requires:       %{name}-libs = %{version}-%{release}
286 Obsoletes:      subversion-python
287
288 %description -n python-subversion
289 Subversion Python bindings.
290
291 %description -n python-subversion -l pl.UTF-8
292 Dowiązania do Subversion dla Pythona.
293
294 %description -n python-subversion -l pt_BR.UTF-8
295 Módulos Python para acessar os recursos do Subversion.
296
297 %package -n python-csvn
298 Summary:        CTypes Subversion Python bindings
299 Summary(pl.UTF-8):      Dowiązania do Subversion dla Pythona
300 Summary(pt_BR.UTF-8):   Módulos Python para acessar os recursos do Subversion
301 Group:          Development/Languages/Python
302 %pyrequires_eq  python
303 Requires:       %{name}-libs = %{version}-%{release}
304
305 %description -n python-csvn
306 Subversion CTypes Python bindings.
307
308 %description -n python-csvn -l pl.UTF-8
309 Dowiązania do Subversion dla Pythona używające CTypes.
310
311 %description -n python-csvn -l pt_BR.UTF-8
312 Módulos Python para acessar os recursos do Subversion.
313
314 %package -n perl-subversion
315 Summary:        Subversion Perl bindings
316 Summary(pl.UTF-8):      Dowiązania do Subversion dla Perla
317 Summary(pt_BR.UTF-8):   Módulos Perl para acessar os recursos do Subversion
318 Group:          Development/Languages/Perl
319 Requires:       %{name}-libs = %{version}-%{release}
320 Obsoletes:      subversion-perl
321
322 %description -n perl-subversion
323 Subversion Perl bindings.
324
325 %description -n perl-subversion -l pl.UTF-8
326 Dowiązania do Subversion dla Perla.
327
328 %description -n perl-subversion -l pt_BR.UTF-8
329 Módulos Perl para acessar os recursos do Subversion.
330
331 %package -n ruby-subversion
332 Summary:        Subversion Ruby bindings
333 Summary(pl.UTF-8):      Dowiązania do Subversion dla języka Ruby
334 Summary(pt_BR.UTF-8):   Módulos Ruby para acessar os recursos do Subversion
335 Group:          Development/Languages
336 Requires:       %{name}-libs = %{version}-%{release}
337 Obsoletes:      subversion-ruby
338
339 %description -n ruby-subversion
340 Subversion Ruby bindings.
341
342 %description -n ruby-subversion -l pl.UTF-8
343 Dowiązania do Subversion dla języka Ruby.
344
345 %description -n ruby-subversion -l pt_BR.UTF-8
346 Módulos Ruby para acessar os recursos do Subversion.
347
348 %package -n apache-mod_dav_svn
349 Summary:        Apache module: Subversion Server
350 Summary(pl.UTF-8):      Moduł apache: Serwer Subversion
351 Group:          Networking/Daemons
352 Requires:       %{name} = %{version}-%{release}
353 Requires:       apache(modules-api) = %apache_modules_api
354 Requires:       apache-mod_dav
355
356 %description -n apache-mod_dav_svn
357 Apache module: Subversion Server.
358
359 %description -n apache-mod_dav_svn -l pl.UTF-8
360 Moduł apache: Serwer Subversion.
361
362 %package -n apache-mod_authz_svn
363 Summary:        Apache module: Subversion Server - path-based authorization
364 Summary(pl.UTF-8):      Moduł apache: autoryzacja na podstawie ścieżki dla serwera Subversion
365 Group:          Networking/Daemons
366 Requires:       apache(modules-api) = %apache_modules_api
367 Requires:       apache-mod_dav_svn = %{version}-%{release}
368
369 %description -n apache-mod_authz_svn
370 Apache module: Subversion Server - path-based authorization.
371
372 %description -n apache-mod_authz_svn -l pl.UTF-8
373 Moduł apache: autoryzacja na podstawie ścieżki dla serwera Subversion.
374
375 %package -n gnome-keyring-subversion
376 Summary:        GNOME Keyring authentication provider for Subversion
377 Summary(pl.UTF-8):      Moduł uwierzytelniający GNOME Keyring dla Subversion
378 Group:          X11/Applications
379
380 %description -n gnome-keyring-subversion
381 Authentication provider module for Subversion which allows SVN client
382 to authenticate using GNOME Keyring.
383
384 %description -n gnome-keyring-subversion -l pl.UTF-8
385 Moduł uwierzytelniający dla Subversion pozwalający klientom SVN
386 uwierzytelniać się przy użyciu mechanizmu GNOME Keyring.
387
388 %package -n kde4-kwallet-subversion
389 Summary:        KDE Wallet authentication provider for Subversion
390 Summary(pl.UTF-8):      Moduł uwierzytelniający dla Subversion wykorzystujący Portfel KDE
391 Group:          X11/Applications
392
393 %description -n kde4-kwallet-subversion
394 Authentication provider module for Subversion which allows SVN client
395 to authenticate using KDE Wallet.
396
397 %description -n kde4-kwallet-subversion -l pl.UTF-8
398 Moduł uwierzytelniający dla Subversion pozwalający klientom SVN
399 uwierzytelniać się przy użyciu Portfela KDE.
400
401 %prep
402 %setup -q
403 %patch0 -p0
404 %patch1 -p1
405 %patch2 -p0
406 %patch3 -p1
407
408 sed -i -e 's#serf_prefix/lib#serf_prefix/%{_lib}#g' build/ac-macros/serf.m4
409
410 # serf.m4 macro is broken and ignores --without serf
411 %{?with_neon:sed -i -e 's#serf_found="yes"#serf_found="no"#g' build/ac-macros/serf.m4}
412
413 %build
414 # disabled regeneration - subversion 1.6.13 is not ready for swig 2.0.x
415 #%{__rm} subversion/bindings/swig/proxy/*.swg
416 #cd subversion/bindings/swig && python "%{SOURCE5}" && cd ../../..
417 chmod +x ./autogen.sh && ./autogen.sh
418 %{__libtoolize}
419 %configure \
420         --with-editor=vi \
421         --with-zlib=%{_libdir} \
422 %if %{with net_client_only}
423         --without-apache \
424         --without-swig \
425         --without-apxs \
426         --without-berkeley-db \
427 %else
428         --disable-runtime-module-search \
429         --disable-mod-activation \
430         --with-berkeley-db="db.h:%{_includedir}:%{_libdir}:db" \
431 %if %{with apache}
432         --with-apxs=%{_sbindir}/apxs \
433 %else
434         --without-apache \
435         --without-apxs \
436 %endif
437 %if !%{with python} && !%{with perl} && !%{with ruby}
438         --without-swig \
439 %endif
440         %{?with_python:--with-ctypesgen=%{_bindir}/ctypesgen.py} \
441         --%{?with_javahl:en}%{!?with_javahl:dis}able-javahl \
442 %endif
443         --with-jdk="%{java_home}" \
444         --without-jikes \
445 %if %{with neon}
446         --without-serf \
447         --with-neon=%{_prefix} \
448         --disable-neon-version-check \
449 %else
450         --with-serf=%{_prefix} \
451         --without-neon \
452 %endif
453         --with-apr=%{_bindir}/apr-1-config \
454         --with-apr-util=%{_bindir}/apu-1-config \
455 %if %{with kwallet}
456         --with-kwallet \
457 %endif
458 %if %{with gnome}
459         --with-gnome-keyring
460 %endif
461
462 %{__make} -j1
463
464 %if !%{with net_client_only}
465 # python
466 %if %{with python}
467 # ctypes bindings
468 %{__make} ctypes-python
469 # swig bindings
470 %{__make} swig-py \
471         swig_pydir=%{py_sitedir}/libsvn \
472         swig_pydir_extra=%{py_sitedir}/svn
473 %endif
474 # perl
475 %if %{with perl}
476 %{__make} -j1 swig-pl-lib
477 odir=$(pwd)
478 cd subversion/bindings/swig/perl/native
479 %{__perl} Makefile.PL INSTALLDIRS=vendor
480 %{__make} -j1
481 cd $odir
482 %endif
483 %if %{with javahl}
484 %{__make} -j1 javahl \
485         javahl_javadir="%{_javadir}"
486 %endif
487 # ruby
488 %if %{with ruby}
489 %{__make} swig-rb
490 %endif
491 %endif
492
493 %if %{with tests}
494 %{__make} check
495 %if %{with python}
496 %{__make} check-ctypes-python
497 %{__make} check-swig-py
498 %endif
499 %if %{with perl}
500 %{__make} check-swig-pl
501 %endif
502 %if %{with ruby}
503 %{__make} check-swig-rb
504 %endif
505 %endif
506
507 %install
508 rm -rf $RPM_BUILD_ROOT
509 install -d $RPM_BUILD_ROOT/etc/{rc.d/init.d,sysconfig,bash_completion.d} \
510         $RPM_BUILD_ROOT{%{apacheconfdir},%{apachelibdir},%{_infodir}} \
511         $RPM_BUILD_ROOT%{_examplesdir}/{%{name}-%{version},python-%{name}-%{version}} \
512         $RPM_BUILD_ROOT/home/services/subversion{,/repos}
513
514 %{__make} install -j1 \
515 %if %{with javahl}
516         install-javahl \
517         javahl_javadir="%{_javadir}" \
518 %endif
519 %if !%{with net_client_only}
520 %if %{with python}
521         install-swig-py \
522         install-ctypes-python \
523 %endif
524 %if %{with ruby}
525         install-swig-rb install-swig-rb-doc \
526 %endif
527 %endif
528         APACHE_LIBEXECDIR="$(%{_sbindir}/apxs -q LIBEXECDIR)" \
529         DESTDIR=$RPM_BUILD_ROOT \
530         swig_pydir=%{py_sitedir}/libsvn \
531         swig_pydir_extra=%{py_sitedir}/svn
532
533 %if !%{with net_client_only} && %{with perl}
534 %{__make} install-swig-pl-lib \
535         DESTDIR=$RPM_BUILD_ROOT
536 %{__make} -C subversion/bindings/swig/perl/native install \
537         DESTDIR=$RPM_BUILD_ROOT \
538         PREFIX=$RPM_BUILD_ROOT%{_prefix} \
539         LIBDIR=$RPM_BUILD_ROOT%{_libdir}
540 %endif
541
542 %if %{with apache}
543 install %{SOURCE1} $RPM_BUILD_ROOT%{apacheconfdir}/65_mod_dav_svn.conf
544 install %{SOURCE2} $RPM_BUILD_ROOT%{apacheconfdir}/66_mod_authz_svn.conf
545 install %{SOURCE3} $RPM_BUILD_ROOT/etc/rc.d/init.d/svnserve
546 install %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/svnserve
547 %endif
548
549 %if !%{with net_client_only}
550 install tools/backup/hot-backup.py $RPM_BUILD_ROOT%{_bindir}/svn-hot-backup
551 %if %{with python}
552 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
553 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
554 %py_postclean
555 %{__rm} $RPM_BUILD_ROOT%{py_sitedir}/libsvn/*.la
556 install tools/examples/*.py $RPM_BUILD_ROOT%{_examplesdir}/python-%{name}-%{version}
557 %endif
558 %endif
559
560 install tools/client-side/bash_completion $RPM_BUILD_ROOT/etc/bash_completion.d/%{name}
561 install tools/examples/*.c $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
562
563 %{?with_javahl:%{__rm} $RPM_BUILD_ROOT%{_libdir}/libsvnjavahl*.{la,a}}
564 %if %{without net_client_only}
565 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libsvn_swig*.{la,a}
566 %{__rm} $RPM_BUILD_ROOT%{_libdir}/ruby/site_ruby/*/*/svn/ext/*.la
567 %endif
568 %if %{with gnome} || %{with kwallet}
569 # dlopened by soname (libsvn_auth_*-1.so.0)
570 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libsvn_auth_*-1.{so,la,a}
571 %endif
572
573 %find_lang %{name}
574
575 %clean
576 rm -rf $RPM_BUILD_ROOT
577
578 %pre svnserve
579 %groupadd -g 86 svn
580 %useradd -u 180 -d /home/services/subversion -c "Subversion svnserve" -g svn svn
581
582 %post   libs -p /sbin/ldconfig
583 %postun libs -p /sbin/ldconfig
584
585 %post   devel -p /sbin/postshell
586 -/usr/sbin/fix-info-dir -c %{_infodir}
587
588 %postun devel -p /sbin/postshell
589 -/usr/sbin/fix-info-dir -c %{_infodir}
590
591 %post   -n java-subversion -p /sbin/ldconfig
592 %postun -n java-subversion -p /sbin/ldconfig
593
594 %post   -n perl-subversion -p /sbin/ldconfig
595 %postun -n perl-subversion -p /sbin/ldconfig
596
597 %post   -n python-subversion -p /sbin/ldconfig
598 %postun -n python-subversion -p /sbin/ldconfig
599
600 %post   -n ruby-subversion -p /sbin/ldconfig
601 %postun -n ruby-subversion -p /sbin/ldconfig
602
603 %post   -n gnome-keyring-subversion -p /sbin/ldconfig
604 %postun -n gnome-keyring-subversion -p /sbin/ldconfig
605
606 %post   -n kde4-kwallet-subversion -p /sbin/ldconfig
607 %postun -n kde4-kwallet-subversion -p /sbin/ldconfig
608
609 %post svnserve
610 /sbin/chkconfig --add svnserve
611 %service svnserve restart "svnserve daemon"
612
613 %preun svnserve
614 if [ "$1" = "0" ]; then
615         %service svnserve stop
616         /sbin/chkconfig --del svnserve
617 fi
618
619 %postun svnserve
620 if [ "$1" = "0" ]; then
621         %userremove svn
622         %groupremove svn
623 fi
624
625 %post -n apache-mod_dav_svn
626 %service -q httpd restart
627
628 %postun -n apache-mod_dav_svn
629 if [ "$1" = "0" ]; then
630         %service -q httpd restart
631 fi
632
633 %post -n apache-mod_authz_svn
634 %service -q httpd restart
635
636 %postun -n apache-mod_authz_svn
637 if [ "$1" = "0" ]; then
638         %service -q httpd restart
639 fi
640
641 %files
642 %defattr(644,root,root,755)
643 %doc BUGS CHANGES COPYING INSTALL README
644 %doc doc/*/*.html
645 %doc tools/hook-scripts/*.{pl,py,example}
646 %doc tools/hook-scripts/mailer/*.{py,example}
647 %doc tools/xslt/*
648 %attr(755,root,root) %{_bindir}/svn
649 %attr(755,root,root) %{_bindir}/svnadmin
650 %attr(755,root,root) %{_bindir}/svndumpfilter
651 %attr(755,root,root) %{_bindir}/svnlook
652 %attr(755,root,root) %{_bindir}/svnsync
653 %attr(755,root,root) %{_bindir}/svnversion
654 %{_mandir}/man1/svn.1*
655 %{_mandir}/man1/svnadmin.1*
656 %{_mandir}/man1/svndumpfilter.1*
657 %{_mandir}/man1/svnlook.1*
658 %{_mandir}/man1/svnsync.1*
659 %{_mandir}/man1/svnversion.1*
660
661 %files libs -f %{name}.lang
662 %defattr(644,root,root,755)
663 %attr(755,root,root) %{_libdir}/libsvn_client-1.so.*.*.*
664 %attr(755,root,root) %ghost %{_libdir}/libsvn_client-1.so.0
665 %attr(755,root,root) %{_libdir}/libsvn_delta-1.so.*.*.*
666 %attr(755,root,root) %ghost %{_libdir}/libsvn_delta-1.so.0
667 %attr(755,root,root) %{_libdir}/libsvn_diff-1.so.*.*.*
668 %attr(755,root,root) %ghost %{_libdir}/libsvn_diff-1.so.0
669 %attr(755,root,root) %{_libdir}/libsvn_fs-1.so.*.*.*
670 %attr(755,root,root) %ghost %{_libdir}/libsvn_fs-1.so.0
671 %if %{without net_client_only}
672 %attr(755,root,root) %{_libdir}/libsvn_fs_base-1.so.*.*.*
673 %attr(755,root,root) %ghost %{_libdir}/libsvn_fs_base-1.so.0
674 %endif
675 %attr(755,root,root) %{_libdir}/libsvn_fs_fs-1.so.*.*.*
676 %attr(755,root,root) %ghost %{_libdir}/libsvn_fs_fs-1.so.0
677 %attr(755,root,root) %{_libdir}/libsvn_fs_util-1.so.*.*.*
678 %attr(755,root,root) %ghost %{_libdir}/libsvn_fs_util-1.so.0
679 %attr(755,root,root) %{_libdir}/libsvn_ra-1.so.*.*.*
680 %attr(755,root,root) %ghost %{_libdir}/libsvn_ra-1.so.0
681 %attr(755,root,root) %{_libdir}/libsvn_ra_local-1.so.*.*.*
682 %attr(755,root,root) %ghost %{_libdir}/libsvn_ra_local-1.so.0
683 %attr(755,root,root) %{_libdir}/libsvn_ra_%{webdavlib}-1.so.*.*.*
684 %attr(755,root,root) %ghost %{_libdir}/libsvn_ra_%{webdavlib}-1.so.0
685 %attr(755,root,root) %{_libdir}/libsvn_ra_svn-1.so.*.*.*
686 %attr(755,root,root) %ghost %{_libdir}/libsvn_ra_svn-1.so.0
687 %attr(755,root,root) %{_libdir}/libsvn_repos-1.so.*.*.*
688 %attr(755,root,root) %ghost %{_libdir}/libsvn_repos-1.so.0
689 %attr(755,root,root) %{_libdir}/libsvn_subr-1.so.*.*.*
690 %attr(755,root,root) %ghost %{_libdir}/libsvn_subr-1.so.0
691 %attr(755,root,root) %{_libdir}/libsvn_wc-1.so.*.*.*
692 %attr(755,root,root) %ghost %{_libdir}/libsvn_wc-1.so.0
693
694 %files devel
695 %defattr(644,root,root,755)
696 %attr(755,root,root) %{_libdir}/libsvn_client-1.so
697 %attr(755,root,root) %{_libdir}/libsvn_delta-1.so
698 %attr(755,root,root) %{_libdir}/libsvn_diff-1.so
699 %attr(755,root,root) %{_libdir}/libsvn_fs-1.so
700 %if %{without net_client_only}
701 %attr(755,root,root) %{_libdir}/libsvn_fs_base-1.so
702 %endif
703 %attr(755,root,root) %{_libdir}/libsvn_fs_fs-1.so
704 %attr(755,root,root) %{_libdir}/libsvn_fs_util-1.so
705 %attr(755,root,root) %{_libdir}/libsvn_ra-1.so
706 %attr(755,root,root) %{_libdir}/libsvn_ra_local-1.so
707 %attr(755,root,root) %{_libdir}/libsvn_ra_%{webdavlib}-1.so
708 %attr(755,root,root) %{_libdir}/libsvn_ra_svn-1.so
709 %attr(755,root,root) %{_libdir}/libsvn_repos-1.so
710 %attr(755,root,root) %{_libdir}/libsvn_subr-1.so
711 %attr(755,root,root) %{_libdir}/libsvn_wc-1.so
712 %{_libdir}/libsvn_client-1.la
713 %{_libdir}/libsvn_delta-1.la
714 %{_libdir}/libsvn_diff-1.la
715 %{_libdir}/libsvn_fs-1.la
716 %if %{without net_client_only}
717 %{_libdir}/libsvn_fs_base-1.la
718 %endif
719 %{_libdir}/libsvn_fs_fs-1.la
720 %{_libdir}/libsvn_fs_util-1.la
721 %{_libdir}/libsvn_ra-1.la
722 %{_libdir}/libsvn_ra_local-1.la
723 %{_libdir}/libsvn_ra_%{webdavlib}-1.la
724 %{_libdir}/libsvn_ra_svn-1.la
725 %{_libdir}/libsvn_repos-1.la
726 %{_libdir}/libsvn_subr-1.la
727 %{_libdir}/libsvn_wc-1.la
728 %{_includedir}/%{name}-1
729 %{_examplesdir}/%{name}-%{version}
730
731 %files static
732 %defattr(644,root,root,755)
733 %{_libdir}/libsvn_client-1.a
734 %{_libdir}/libsvn_delta-1.a
735 %{_libdir}/libsvn_diff-1.a
736 %{_libdir}/libsvn_fs-1.a
737 %if %{without net_client_only}
738 %{_libdir}/libsvn_fs_base-1.a
739 %endif
740 %{_libdir}/libsvn_fs_fs-1.a
741 %{_libdir}/libsvn_fs_util-1.a
742 %{_libdir}/libsvn_ra-1.a
743 %{_libdir}/libsvn_ra_local-1.a
744 %{_libdir}/libsvn_ra_%{webdavlib}-1.a
745 %{_libdir}/libsvn_ra_svn-1.a
746 %{_libdir}/libsvn_repos-1.a
747 %{_libdir}/libsvn_subr-1.a
748 %{_libdir}/libsvn_wc-1.a
749
750 %if %{with gnome}
751 %files -n gnome-keyring-subversion
752 %defattr(644,root,root,755)
753 %attr(755,root,root) %{_libdir}/libsvn_auth_gnome_keyring-1.so.*.*.*
754 %attr(755,root,root) %ghost %{_libdir}/libsvn_auth_gnome_keyring-1.so.0
755 %endif
756
757 %if %{with kwallet}
758 %files -n kde4-kwallet-subversion
759 %defattr(644,root,root,755)
760 %attr(755,root,root) %{_libdir}/libsvn_auth_kwallet-1.so.*.*.*
761 %attr(755,root,root) %ghost %{_libdir}/libsvn_auth_kwallet-1.so.0
762 %endif
763
764 %if %{without net_client_only}
765 %files svnserve
766 %defattr(644,root,root,755)
767 %attr(755,root,root) %{_bindir}/svnserve
768 %{_mandir}/man5/svnserve.conf.5*
769 %{_mandir}/man8/svnserve.8*
770 %dir %attr(750,svn,svn) /home/services/subversion
771 %dir %attr(750,svn,svn) /home/services/subversion/repos
772 %if %{with apache}
773 %attr(754,root,root) /etc/rc.d/init.d/svnserve
774 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/svnserve
775 %endif
776
777 %files tools
778 %defattr(644,root,root,755)
779 %attr(755,root,root) %{_bindir}/svn-hot-backup
780
781 %files -n bash-completion-subversion
782 %defattr(644,root,root,755)
783 /etc/bash_completion.d/%{name}
784
785 %if %{with javahl}
786 %files -n java-subversion
787 %defattr(644,root,root,755)
788 %attr(755,root,root) %{_libdir}/libsvnjavahl-1.so.*.*.*
789 %attr(755,root,root) %ghost %{_libdir}/libsvnjavahl-1.so.0
790 %attr(755,root,root) %{_libdir}/libsvnjavahl-1.so
791 %{_javadir}/svn-javahl.jar
792 %endif
793
794 %if %{with python}
795 %files -n python-subversion
796 %defattr(644,root,root,755)
797 %doc tools/backup/*.py tools/examples/*.py
798 %attr(755,root,root) %{_libdir}/libsvn_swig_py-1.so.*.*.*
799 %attr(755,root,root) %ghost %{_libdir}/libsvn_swig_py-1.so.0
800 %attr(755,root,root) %{_libdir}/libsvn_swig_py-1.so
801 %dir %{py_sitedir}/libsvn
802 %attr(755,root,root) %{py_sitedir}/libsvn/_*.so
803 %{py_sitedir}/libsvn/*.py[co]
804 %dir %{py_sitedir}/svn
805 %{py_sitedir}/svn/*.py[co]
806 %{_examplesdir}/python-%{name}-%{version}
807
808 %files -n python-csvn
809 %defattr(644,root,root,755)
810 %doc subversion/bindings/ctypes-python/{README,TODO}
811 %doc subversion/bindings/ctypes-python/examples/*.py
812 %dir %{py_sitescriptdir}/csvn
813 %{py_sitescriptdir}/csvn/*.py[co]
814 %dir %{py_sitescriptdir}/csvn/core
815 %{py_sitescriptdir}/csvn/core/*.py[co]
816 %dir %{py_sitescriptdir}/csvn/ext
817 %{py_sitescriptdir}/csvn/ext/*.py[co]
818 %{py_sitescriptdir}/svn_ctypes_python_bindings-0.1-py*.egg-info
819 %endif
820
821 %if %{with perl}
822 %files -n perl-subversion
823 %defattr(644,root,root,755)
824 %attr(755,root,root) %{_libdir}/libsvn_swig_perl-1.so.*.*.*
825 %attr(755,root,root) %ghost %{_libdir}/libsvn_swig_perl-1.so.0
826 %attr(755,root,root) %{_libdir}/libsvn_swig_perl-1.so
827 %{perl_vendorarch}/SVN
828 %dir %{perl_vendorarch}/auto/SVN
829 %dir %{perl_vendorarch}/auto/SVN/*
830 %attr(755,root,root) %{perl_vendorarch}/auto/SVN/*/*.so
831 %{perl_vendorarch}/auto/SVN/*/*.bs
832 %{_mandir}/man3/*.3pm*
833 %endif
834
835 %if %{with ruby}
836 %files -n ruby-subversion
837 %defattr(644,root,root,755)
838 %attr(755,root,root) %{_libdir}/libsvn_swig_ruby-1.so.*.*.*
839 %attr(755,root,root) %ghost %{_libdir}/libsvn_swig_ruby-1.so.0
840 %attr(755,root,root) %{_libdir}/libsvn_swig_ruby-1.so
841 %dir %{ruby_sitelibdir}/svn
842 %{ruby_sitelibdir}/svn/*.rb
843 %dir %{ruby_sitearchdir}/svn
844 %dir %{ruby_sitearchdir}/svn/ext
845 %attr(755,root,root) %{ruby_sitearchdir}/svn/ext/*.so
846 %{ruby_ridir}/Svn
847 %endif
848
849 %if %{with apache}
850 %files -n apache-mod_dav_svn
851 %defattr(644,root,root,755)
852 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{apacheconfdir}/*_mod_dav_svn.conf
853 %attr(755,root,root) %{apachelibdir}/mod_dav_svn.so
854
855 %files -n apache-mod_authz_svn
856 %defattr(644,root,root,755)
857 %doc subversion/mod_authz_svn/INSTALL
858 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{apacheconfdir}/*_mod_authz_svn.conf
859 %attr(755,root,root) %{apachelibdir}/mod_authz_svn.so
860 %endif
861
862 %endif # net_client_only
This page took 0.087425 seconds and 4 git commands to generate.