]> git.pld-linux.org Git - packages/subversion.git/blob - subversion.spec
- rel 2
[packages/subversion.git] / subversion.spec
1 # TODO:
2 # - remove net_client_only and add db bcond (then without apache and
3 #   without db => net_client_only - spec will be more simpler, I think)
4 # - finish ruby
5 # - http://subversion.tigris.org/issues/show_bug.cgi?id=2753
6 #
7 # Conditional build:
8 %bcond_with     net_client_only         # build only net client
9 %bcond_without  neon                    # use serf instead of neon
10 %bcond_without  python                  # build without python bindings (broken)
11 %bcond_without  perl                    # build without perl bindings
12 %bcond_without  ruby                    # build without ruby bindings
13 %bcond_without  apache                  # build without apache support (webdav, etc)
14 %bcond_without  javahl                  # build without javahl support (Java high-level bindings)
15 %bcond_without  tests                   # don't perform "make check"
16 %bcond_without  kwallet                 # build without kde4 wallet support
17 %bcond_without  gnome                   # build without gnome keyring support
18 #
19 %{!?with_net_client_only:%include       /usr/lib/rpm/macros.perl}
20 %define apxs    /usr/sbin/apxs
21 %define pdir    SVN
22 %define pnam    _Core
23 #
24 %if %{with neon}
25 %define webdavlib       neon
26 %else
27 %define webdavlib       serf
28 %endif
29 #
30 Summary:        A Concurrent Versioning system similar to but better than CVS
31 Summary(pl.UTF-8):      System kontroli wersji podobny, ale lepszy, niż CVS
32 Summary(pt_BR.UTF-8):   Sistema de versionamento concorrente
33 Name:           subversion
34 Version:        1.6.13
35 Release:        2
36 License:        Apache/BSD-like
37 Group:          Development/Version Control
38 Source0:        http://subversion.tigris.org/downloads/%{name}-%{version}.tar.bz2
39 # Source0-md5:  7ae1c827689f21cf975804005be30aeb
40 Source1:        %{name}-dav_svn.conf
41 Source2:        %{name}-authz_svn.conf
42 Source3:        %{name}-svnserve.init
43 Source4:        %{name}-svnserve.sysconfig
44 # current subversion tarball has correct *.swg files
45 # but after regeneration these are broken again, so
46 # we still need this script
47 Source5:        %{name}-convert-typemaps-to-ifdef.py
48 Patch0:         %{name}-home_etc.patch
49 Patch1:         %{name}-DESTDIR.patch
50 Patch2:         %{name}-ruby-datadir-path.patch
51 URL:            http://subversion.apache.org/
52 %if %{with net_client_only}
53 %global apache_modules_api 0
54 %else
55 %{?with_apache:BuildRequires:   apache-devel >= 2.2.0-8}
56 BuildRequires:  automake
57 BuildRequires:  db-devel >= 4.1.25
58 BuildRequires:  rpmbuild(macros) >= 1.583
59 %if %{with perl}
60 BuildRequires:  perl-devel >= 1:5.8.0
61 BuildRequires:  rpm-perlprov >= 4.1-13
62 BuildRequires:  swig-perl >= 1.3.24
63 %endif
64 %if %{with python}
65 BuildRequires:  python-ctypesgen
66 BuildRequires:  python-devel >= 2.2
67 BuildRequires:  swig-python >= 1.3.24
68 %endif
69 %if %{with ruby}
70 BuildRequires:  ruby-devel
71 BuildRequires:  swig-ruby >= 1.3.24
72 %endif
73 %if %{with javahl}
74 BuildRequires:  jdk
75 %endif
76 BuildRequires:  cyrus-sasl-devel
77 %endif
78 BuildRequires:  apr-devel >= 1:1.0.0
79 BuildRequires:  apr-util-devel >= 1:1.2.8-3
80 BuildRequires:  autoconf >= 2.59
81 BuildRequires:  bison
82 BuildRequires:  expat-devel
83 BuildRequires:  gettext-devel
84 %{?with_gnome:BuildRequires:    libgnome-keyring-devel}
85 %{?with_kwallet:BuildRequires:  kde4-kdelibs-devel}
86 BuildRequires:  libtool >= 1.4-9
87 BuildRequires:  pkgconfig
88 BuildRequires:  sed >= 4.0
89 BuildRequires:  sqlite3-devel >= 3.6.11
90 BuildRequires:  texinfo
91 BuildRequires:  which
92 %if %{with neon}
93 BuildRequires:  neon-devel >= 0.26.0
94 %else
95 BuildRequires:  serf-devel
96 %endif
97 BuildRequires:  python >= 2.2
98 BuildRequires:  python-modules >= 2.2
99 Requires:       %{name}-libs = %{version}-%{release}
100 %requires_ge    sqlite3
101 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
102
103 %define         _libexecdir             %{_libdir}/svn
104 %define         apacheconfdir   %(%{apxs} -q SYSCONFDIR 2>/dev/null)/conf.d
105 %define         apachelibdir    %(%{apxs} -q LIBEXECDIR 2>/dev/null)
106
107 %define         skip_post_check_so      libsvn_swig_py-1.so.* libsvn_swig_perl-1.so.*
108
109 %description
110 The goal of the Subversion project is to build a version control
111 system that is a compelling replacement for CVS in the open source
112 community.
113
114 Our goals are:
115 - All current CVS features.
116 - Directories, renames, and file meta-data are versioned.
117 - Symbolic links, etc, are supported
118 - Commits are truly atomic.
119 - Branching and tagging are cheap (constant time) operations
120 - Repeated merges are handled gracefully
121 - Support for plug-in client side diff programs
122 - Natively client/server
123 - Client/server protocol sends diffs in both directions
124 - Costs are proportional to change size, not project size
125 - Internationalization
126 - Progressive multi-lingual support
127
128 %description -l pl.UTF-8
129 Celem projektu Subversion jest stworzenie systemu kontroli wersji jako
130 zamiennika dla CVS.
131
132 Cele projektu to:
133 - Wszystkie aktualne możliwości CVS.
134 - Katalogi, zmiany nazw oraz metadane plików są wersjonowane.
135 - Obsługa dowiązań symbolicznych itp.
136 - Commity są w pełni atomowe.
137 - Branchowanie oraz tagowanie są tanimi (stałymi w czasie) operacjami.
138 - Dobra obsługa powtarzanego łączenia (merge).
139 - Obsługa wtyczek diff po stronie klienta.
140 - Natywny klient/serwer.
141 - Klient/Serwer przesyłają diffy w obu kierunkach.
142 - Koszty proporcjonalne do rozmiaru zmiany, a nie rozmiaru projektu.
143 - Internacjonalizacja.
144 - Postępujące wsparcie dla wielu języków.
145
146 %description -l pt_BR.UTF-8
147 O objetivo do projeto Subversion é construir um sistema de controle de
148 versões que seja um substituto para o CVS (Concurrent Versioning
149 System) na comunidade opensource, fornecendo grandes melhorias.
150
151 %package libs
152 Summary:        Subversion libraries and modules
153 Summary(pl.UTF-8):      Biblioteka subversion oraz ładowalne moduły
154 Group:          Libraries
155 %{?with_neon:Requires:  neon >= 0.26.0}
156 Obsoletes:      libsubversion0
157
158 %description libs
159 Subversion libraries and modules.
160
161 %description libs -l pl.UTF-8
162 Biblioteka subversion oraz ładowalne moduły.
163
164 %package devel
165 Summary:        Header files and develpment documentation for subversion
166 Summary(pl.UTF-8):      Pliki nagłówkowe i dokumetacja do subversion
167 Summary(pt_BR.UTF-8):   Arquivos de desenvolvimento para o Subversion
168 Group:          Development/Libraries
169 Requires:       %{name}-libs = %{version}-%{release}
170 Requires:       apr-util-devel >= 1:1.0.0
171 %{?with_neon:Requires:  neon-devel >= 0.26.0}
172 Obsoletes:      libsubversion0-devel
173
174 %description devel
175 Header files and develpment documentation for subversion.
176
177 %description devel -l pl.UTF-8
178 Pliki nagłówkowe i dokumetacja do subversion.
179
180 %description devel -l pt_BR.UTF-8
181 Este pacote provê os arquivos necessários para desenvolvedores
182 interagirem com o Subversion.
183
184 %package static
185 Summary:        Static subversion library
186 Summary(pl.UTF-8):      Biblioteka statyczna subversion
187 Summary(pt_BR.UTF-8):   Sistema de versionamento concorrente
188 Group:          Development/Libraries
189 Requires:       %{name}-devel = %{version}
190 Obsoletes:      libsubversion0-static-devel
191
192 %description static
193 Static subversion library.
194
195 %description static -l pl.UTF-8
196 Biblioteka statyczna subversion.
197
198 %description static -l pt_BR.UTF-8
199 Este pacote provê um cliente estático do subversion.
200
201 %package svnserve
202 Summary:        Subversion svnserve
203 Summary(pl.UTF-8):      Subversion svnserve
204 Group:          Networking/Daemons
205 Requires(post,preun):   /sbin/chkconfig
206 Requires(postun):       /usr/sbin/groupdel
207 Requires(postun):       /usr/sbin/userdel
208 Requires(pre):  /bin/id
209 Requires(pre):  /usr/bin/getgid
210 Requires(pre):  /usr/lib/rpm/user_group.sh
211 Requires(pre):  /usr/sbin/groupadd
212 Requires(pre):  /usr/sbin/useradd
213 Requires(pre):  /usr/sbin/usermod
214 Requires:       %{name} = %{version}-%{release}
215 Requires:       rc-scripts
216 Provides:       group(svn)
217 Provides:       user(svn)
218
219 %description svnserve
220 Subversion svnserve server.
221
222 %description svnserve -l pl.UTF-8
223 Serwer subversion svnserve.
224
225 %package tools
226 Summary:        Subversion tools and scripts
227 Summary(pl.UTF-8):      Narzędzia oraz skrypty dla subversion
228 Summary(pt_BR.UTF-8):   Módulos python para acessar os recursos do Subversion
229 Group:          Applications
230 %pyrequires_eq  python
231 Requires:       %{name} = %{version}-%{release}
232 Requires:       python-subversion = %{version}
233
234 %description tools
235 Subversion tools and scripts.
236
237 %description tools -l pl.UTF-8
238 Narzędzia oraz skrypty dla subversion.
239
240 %package -n bash-completion-subversion
241 Summary:        bash completion for subversion
242 Summary(pl.UTF-8):      Dopełnienia basha dla subversion
243 Group:          Applications/Shells
244 Requires:       %{name} = %{version}-%{release}
245 Requires:       bash-completion
246 Conflicts:      %{name}-tools <= 1.1.0-0.rc6.1
247
248 %description -n bash-completion-subversion
249 Bash completion for subversion.
250
251 %description -n bash-completion-subversion -l pl.UTF-8
252 Dopełnienia basha dla subversion.
253
254 %package -n java-subversion
255 Summary:        Subversion Java bindings
256 Summary(pl.UTF-8):      Dowiązania do Subversion dla Javy
257 Group:          Development/Languages/Java
258 Requires:       %{name}-libs = %{version}-%{release}
259
260 %description -n java-subversion
261 This is a set of Java classes which provide the functionality of
262 subversion-libs, the Subversion libraries. It is useful if you want
263 to, for example, write a Java class that manipulates a Subversion
264 repository or working copy. See the 'subversion' package for more
265 information.
266
267 %description -n java-subversion -l pl.UTF-8
268 Ten pakiet zawiera zestaw klas Javy udostępniających funkcjonalność
269 subversion-libs, czyli bibliotek Subversion. Jest przydatny przy
270 pisaniu klas Javy np. modyfikujących repozytorium Subversion lub kopię
271 roboczą. Więcej informacji w pakiecie subversion.
272
273 %package -n python-subversion
274 Summary:        Subversion Python bindings
275 Summary(pl.UTF-8):      Dowiązania do Subversion dla Pythona
276 Summary(pt_BR.UTF-8):   Módulos Python para acessar os recursos do Subversion
277 Group:          Development/Languages/Python
278 %pyrequires_eq  python
279 Requires:       %{name}-libs = %{version}-%{release}
280 Obsoletes:      subversion-python
281
282 %description -n python-subversion
283 Subversion Python bindings.
284
285 %description -n python-subversion -l pl.UTF-8
286 Dowiązania do Subversion dla Pythona.
287
288 %description -n python-subversion -l pt_BR.UTF-8
289 Módulos Python para acessar os recursos do Subversion.
290
291 %package -n python-csvn
292 Summary:        CTypes Subversion Python bindings
293 Summary(pl.UTF-8):      Dowiązania do Subversion dla Pythona
294 Summary(pt_BR.UTF-8):   Módulos Python para acessar os recursos do Subversion
295 Group:          Development/Languages/Python
296 %pyrequires_eq  python
297 Requires:       %{name}-libs = %{version}-%{release}
298
299 %description -n python-csvn
300 Subversion CTypes Python bindings.
301
302 %description -n python-csvn -l pl.UTF-8
303 Dowiązania do Subversion dla Pythona używające CTypes.
304
305 %description -n python-csvn -l pt_BR.UTF-8
306 Módulos Python para acessar os recursos do Subversion.
307
308 %package -n perl-subversion
309 Summary:        Subversion Perl bindings
310 Summary(pl.UTF-8):      Dowiązania do Subversion dla Perla
311 Summary(pt_BR.UTF-8):   Módulos Perl para acessar os recursos do Subversion
312 Group:          Development/Languages/Perl
313 Requires:       %{name}-libs = %{version}-%{release}
314 Obsoletes:      subversion-perl
315
316 %description -n perl-subversion
317 Subversion Perl bindings.
318
319 %description -n perl-subversion -l pl.UTF-8
320 Dowiązania do Subversion dla Perla.
321
322 %description -n perl-subversion -l pt_BR.UTF-8
323 Módulos Perl para acessar os recursos do Subversion.
324
325 %package -n ruby-subversion
326 Summary:        Subversion Ruby bindings
327 Summary(pl.UTF-8):      Dowiązania do Subversion dla języka Ruby
328 Summary(pt_BR.UTF-8):   Módulos Ruby para acessar os recursos do Subversion
329 Group:          Development/Languages
330 Requires:       %{name}-libs = %{version}-%{release}
331 Obsoletes:      subversion-ruby
332
333 %description -n ruby-subversion
334 Subversion Ruby bindings.
335
336 %description -n ruby-subversion -l pl.UTF-8
337 Dowiązania do Subversion dla języka Ruby.
338
339 %description -n ruby-subversion -l pt_BR.UTF-8
340 Módulos Ruby para acessar os recursos do Subversion.
341
342 %package -n apache-mod_dav_svn
343 Summary:        Apache module: Subversion Server
344 Summary(pl.UTF-8):      Moduł apache: Serwer Subversion
345 Group:          Networking/Daemons
346 Requires:       %{name} = %{version}-%{release}
347 Requires:       apache(modules-api) = %apache_modules_api
348 Requires:       apache-mod_dav
349
350 %description -n apache-mod_dav_svn
351 Apache module: Subversion Server.
352
353 %description -n apache-mod_dav_svn -l pl.UTF-8
354 Moduł apache: Serwer Subversion.
355
356 %package -n apache-mod_authz_svn
357 Summary:        Apache module: Subversion Server - path-based authorization
358 Summary(pl.UTF-8):      Moduł apache: autoryzacja na podstawie ścieżki dla serwera Subversion
359 Group:          Networking/Daemons
360 Requires:       apache(modules-api) = %apache_modules_api
361 Requires:       apache-mod_dav_svn = %{version}-%{release}
362
363 %description -n apache-mod_authz_svn
364 Apache module: Subversion Server - path-based authorization.
365
366 %description -n apache-mod_authz_svn -l pl.UTF-8
367 Moduł apache: autoryzacja na podstawie ścieżki dla serwera Subversion.
368
369 %package -n gnome-keyring-subversion
370 Summary:        Subversion module for Gnome Keyring
371 Summary(pl.UTF-8):      Moduł subversion dla zarządcy kluczy Gnome
372 Group:          X11/Applications
373
374 %description -n gnome-keyring-subversion
375 Subversion module for Gnome Keyring.
376
377 %description -n gnome-keyring-subversion -l pl.UTF-8
378 Moduł subversion dla zarządcy kluczy Gnome.
379
380 %package -n kde4-kwallet-subversion
381 Summary:        Subversion module for KDE Wallet
382 Summary(pl.UTF-8):      Moduł subversion dla Portfela KDE
383 Group:          X11/Applications
384
385 %description -n kde4-kwallet-subversion
386 Subversion module for KDE Wallet.
387
388 %description -n kde4-kwallet-subversion -l pl.UTF-8
389 Moduł subversion dla Portfela KDE.
390
391 %prep
392 %setup -q
393 rm -rf apr apr-util neon
394 %patch0 -p0
395 %patch1 -p1
396 %patch2 -p0
397
398 sed -i -e 's#serf_prefix/lib#serf_prefix/%{_lib}#g' build/ac-macros/serf.m4
399
400 # serf.m4 macro is broken and ignores --without serf
401 %{?with_neon:sed -i -e 's#serf_found="yes"#serf_found="no"#g' build/ac-macros/serf.m4}
402
403 %build
404 rm subversion/bindings/swig/proxy/*.swg
405 cd subversion/bindings/swig && python "%{SOURCE5}" && cd ../../..
406 cp -f /usr/share/automake/config.sub ac-helpers
407 chmod +x ./autogen.sh && ./autogen.sh
408
409 %configure \
410         --with-editor=vi \
411         --with-zlib=%{_libdir} \
412 %if %{with net_client_only}
413         --without-apache \
414         --without-swig \
415         --without-apxs \
416         --without-berkeley-db \
417 %else
418         --disable-runtime-module-search \
419         --disable-mod-activation \
420         --with-berkeley-db="db.h:%{_includedir}:%{_libdir}:db" \
421 %if %{with apache}
422         --with-apxs=%{_sbindir}/apxs \
423 %else
424         --without-apache \
425         --without-apxs \
426 %endif
427 %if !%{with python} && !%{with perl} && !%{with ruby}
428         --without-swig \
429 %endif
430         %{?with_python:--with-ctypesgen=%{_bindir}/ctypesgen.py} \
431         --%{?with_javahl:en}%{!?with_javahl:dis}able-javahl \
432 %endif
433         --with-jdk="%{java_home}" \
434         --without-jikes \
435 %if %{with neon}
436         --without-serf \
437         --with-neon=%{_prefix} \
438         --disable-neon-version-check \
439 %else
440         --with-serf=%{_prefix} \
441         --without-neon \
442 %endif
443         --with-apr=%{_bindir}/apr-1-config \
444         --with-apr-util=%{_bindir}/apu-1-config \
445 %if %{with kwallet}
446         --with-kwallet \
447 %endif
448 %if %{with gnome}
449         --with-gnome-keyring
450 %endif
451
452 %{__make} -j1
453
454 %if !%{with net_client_only}
455 # python
456 %if %{with python}
457 # ctypes bindings
458 %{__make} ctypes-python
459 # swig bindings
460 %{__make} swig-py \
461         swig_pydir=%{py_sitedir}/libsvn \
462         swig_pydir_extra=%{py_sitedir}/svn
463 %endif
464 # perl
465 %if %{with perl}
466 %{__make} -j1 swig-pl-lib
467 odir=$(pwd)
468 cd subversion/bindings/swig/perl/native
469 %{__perl} Makefile.PL INSTALLDIRS=vendor
470 %{__make} -j1
471 cd $odir
472 %endif
473 %if %{with javahl}
474 %{__make} -j1 javahl \
475         javahl_javadir="%{_javadir}"
476 %endif
477 # ruby
478 %if %{with ruby}
479 %{__make} swig-rb
480 %endif
481 %endif
482
483 %if %{with tests}
484 %{__make} check
485 %if %{with python}
486 %{__make} check-ctypes-python
487 %{__make} check-swig-py
488 %endif
489 %if %{with perl}
490 %{__make} check-swig-pl
491 %endif
492 %if %{with ruby}
493 %{__make} check-swig-rb
494 %endif
495 %endif
496
497 %install
498 rm -rf $RPM_BUILD_ROOT
499 install -d $RPM_BUILD_ROOT/etc/{rc.d/init.d,sysconfig,bash_completion.d} \
500         $RPM_BUILD_ROOT{%{apacheconfdir},%{apachelibdir},%{_infodir}} \
501         $RPM_BUILD_ROOT%{_examplesdir}/{%{name}-%{version},python-%{name}-%{version}} \
502         $RPM_BUILD_ROOT/home/services/subversion{,/repos}
503
504 %{__make} install -j1 \
505 %if %{with javahl}
506         install-javahl \
507         javahl_javadir="%{_javadir}" \
508 %endif
509 %if !%{with net_client_only}
510 %if %{with python}
511         install-swig-py \
512         install-ctypes-python \
513 %endif
514 %if %{with ruby}
515         install-swig-rb install-swig-rb-doc \
516 %endif
517 %endif
518         APACHE_LIBEXECDIR="$(%{_sbindir}/apxs -q LIBEXECDIR)" \
519         DESTDIR=$RPM_BUILD_ROOT \
520         swig_pydir=%{py_sitedir}/libsvn \
521         swig_pydir_extra=%{py_sitedir}/svn
522
523 %if !%{with net_client_only} && %{with perl}
524 %{__make} install-swig-pl-lib \
525         DESTDIR=$RPM_BUILD_ROOT
526 %{__make} -C subversion/bindings/swig/perl/native install \
527         DESTDIR=$RPM_BUILD_ROOT \
528         PREFIX=$RPM_BUILD_ROOT%{_prefix} \
529         LIBDIR=$RPM_BUILD_ROOT%{_libdir}
530 %endif
531
532 %if %{with apache}
533 install %{SOURCE1} $RPM_BUILD_ROOT%{apacheconfdir}/65_mod_dav_svn.conf
534 install %{SOURCE2} $RPM_BUILD_ROOT%{apacheconfdir}/66_mod_authz_svn.conf
535 install %{SOURCE3} $RPM_BUILD_ROOT/etc/rc.d/init.d/svnserve
536 install %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/svnserve
537 %endif
538
539 %if !%{with net_client_only}
540 install tools/backup/hot-backup.py $RPM_BUILD_ROOT%{_bindir}/svn-hot-backup
541 %if %{with python}
542 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
543 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
544 find $RPM_BUILD_ROOT%{py_sitedir} -name "*.py" -o -name "*.a" -o -name "*.la" | xargs rm -f
545 install tools/examples/*.py $RPM_BUILD_ROOT%{_examplesdir}/python-%{name}-%{version}
546 %endif
547 %endif
548
549 install tools/client-side/bash_completion $RPM_BUILD_ROOT/etc/bash_completion.d/%{name}
550 install tools/examples/*.c $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
551
552 %find_lang %{name}
553
554 %{?with_javahl:rm $RPM_BUILD_ROOT%{_libdir}/libsvnjavahl*.{la,a}}
555 rm -f $RPM_BUILD_ROOT%{_libdir}/libsvn_swig*.{la,a}
556 rm -f $RPM_BUILD_ROOT%{_libdir}/ruby/site_ruby/*/*/svn/ext/*.la
557
558 %clean
559 rm -rf $RPM_BUILD_ROOT
560
561 %pre svnserve
562 %groupadd -g 86 svn
563 %useradd -u 180 -d /home/services/subversion -c "Subversion svnserve" -g svn svn
564
565 %post   libs -p /sbin/ldconfig
566 %postun libs -p /sbin/ldconfig
567
568 %post   devel -p /sbin/postshell
569 -/usr/sbin/fix-info-dir -c %{_infodir}
570
571 %postun devel -p /sbin/postshell
572 -/usr/sbin/fix-info-dir -c %{_infodir}
573
574 %post   -n perl-subversion -p /sbin/ldconfig
575 %postun -n perl-subversion -p /sbin/ldconfig
576
577 %post   -n python-subversion -p /sbin/ldconfig
578 %postun -n python-subversion -p /sbin/ldconfig
579
580 %post svnserve
581 /sbin/chkconfig --add svnserve
582 %service svnserve restart "svnserve daemon"
583
584 %preun svnserve
585 if [ "$1" = "0" ]; then
586         %service svnserve stop
587         /sbin/chkconfig --del svnserve
588 fi
589
590 %postun svnserve
591 if [ "$1" = "0" ]; then
592         %userremove svn
593         %groupremove svn
594 fi
595
596 %post -n apache-mod_dav_svn
597 %service -q httpd restart
598
599 %postun -n apache-mod_dav_svn
600 if [ "$1" = "0" ]; then
601         %service -q httpd restart
602 fi
603
604 %post -n apache-mod_authz_svn
605 %service -q httpd restart
606
607 %postun -n apache-mod_authz_svn
608 if [ "$1" = "0" ]; then
609         %service -q httpd restart
610 fi
611
612 %files
613 %defattr(644,root,root,755)
614 %doc BUGS CHANGES COPYING INSTALL README
615 %doc doc/*/*.html
616 %doc tools/hook-scripts/*.{pl,py,example}
617 %doc tools/hook-scripts/mailer/*.{py,example}
618 %doc tools/xslt/*
619 %attr(755,root,root) %{_bindir}/svn
620 %attr(755,root,root) %{_bindir}/svnadmin
621 %attr(755,root,root) %{_bindir}/svndumpfilter
622 %attr(755,root,root) %{_bindir}/svnlook
623 %attr(755,root,root) %{_bindir}/svnsync
624 %attr(755,root,root) %{_bindir}/svnversion
625 %{_mandir}/man1/svn.1*
626 %{_mandir}/man1/svnadmin.1*
627 %{_mandir}/man1/svndumpfilter.1*
628 %{_mandir}/man1/svnlook.1*
629 %{_mandir}/man1/svnsync.1*
630 %{_mandir}/man1/svnversion.1*
631
632 %files libs -f %{name}.lang
633 %defattr(644,root,root,755)
634 %attr(755,root,root) %{_libdir}/libsvn_client-1.so.*.*.*
635 %attr(755,root,root) %ghost %{_libdir}/libsvn_client-1.so.0
636 %attr(755,root,root) %{_libdir}/libsvn_delta-1.so.*.*.*
637 %attr(755,root,root) %ghost %{_libdir}/libsvn_delta-1.so.0
638 %attr(755,root,root) %{_libdir}/libsvn_diff-1.so.*.*.*
639 %attr(755,root,root) %ghost %{_libdir}/libsvn_diff-1.so.0
640 %attr(755,root,root) %{_libdir}/libsvn_fs-1.so.*.*.*
641 %attr(755,root,root) %ghost %{_libdir}/libsvn_fs-1.so.0
642 %attr(755,root,root) %{_libdir}/libsvn_fs_base-1.so.*.*.*
643 %attr(755,root,root) %ghost %{_libdir}/libsvn_fs_base-1.so.0
644 %attr(755,root,root) %{_libdir}/libsvn_fs_fs-1.so.*.*.*
645 %attr(755,root,root) %ghost %{_libdir}/libsvn_fs_fs-1.so.0
646 %attr(755,root,root) %{_libdir}/libsvn_fs_util-1.so.*.*.*
647 %attr(755,root,root) %ghost %{_libdir}/libsvn_fs_util-1.so.0
648 %attr(755,root,root) %{_libdir}/libsvn_ra-1.so.*.*.*
649 %attr(755,root,root) %ghost %{_libdir}/libsvn_ra-1.so.0
650 %attr(755,root,root) %{_libdir}/libsvn_ra_local-1.so.*.*.*
651 %attr(755,root,root) %ghost %{_libdir}/libsvn_ra_local-1.so.0
652 %attr(755,root,root) %{_libdir}/libsvn_ra_%{webdavlib}-1.so.*.*.*
653 %attr(755,root,root) %ghost %{_libdir}/libsvn_ra_%{webdavlib}-1.so.0
654 %attr(755,root,root) %{_libdir}/libsvn_ra_svn-1.so.*.*.*
655 %attr(755,root,root) %ghost %{_libdir}/libsvn_ra_svn-1.so.0
656 %attr(755,root,root) %{_libdir}/libsvn_repos-1.so.*.*.*
657 %attr(755,root,root) %ghost %{_libdir}/libsvn_repos-1.so.0
658 %attr(755,root,root) %{_libdir}/libsvn_subr-1.so.*.*.*
659 %attr(755,root,root) %ghost %{_libdir}/libsvn_subr-1.so.0
660 %attr(755,root,root) %{_libdir}/libsvn_wc-1.so.*.*.*
661 %attr(755,root,root) %ghost %{_libdir}/libsvn_wc-1.so.0
662
663 %files devel
664 %defattr(644,root,root,755)
665 %attr(755,root,root) %{_libdir}/libsvn_client-1.so
666 %attr(755,root,root) %{_libdir}/libsvn_delta-1.so
667 %attr(755,root,root) %{_libdir}/libsvn_diff-1.so
668 %attr(755,root,root) %{_libdir}/libsvn_fs-1.so
669 %attr(755,root,root) %{_libdir}/libsvn_fs_base-1.so
670 %attr(755,root,root) %{_libdir}/libsvn_fs_fs-1.so
671 %attr(755,root,root) %{_libdir}/libsvn_fs_util-1.so
672 %attr(755,root,root) %{_libdir}/libsvn_ra-1.so
673 %attr(755,root,root) %{_libdir}/libsvn_ra_local-1.so
674 %attr(755,root,root) %{_libdir}/libsvn_ra_%{webdavlib}-1.so
675 %attr(755,root,root) %{_libdir}/libsvn_ra_svn-1.so
676 %attr(755,root,root) %{_libdir}/libsvn_repos-1.so
677 %attr(755,root,root) %{_libdir}/libsvn_subr-1.so
678 %attr(755,root,root) %{_libdir}/libsvn_wc-1.so
679 %{_libdir}/libsvn_client-1.la
680 %{_libdir}/libsvn_delta-1.la
681 %{_libdir}/libsvn_diff-1.la
682 %{_libdir}/libsvn_fs-1.la
683 %{_libdir}/libsvn_fs_base-1.la
684 %{_libdir}/libsvn_fs_fs-1.la
685 %{_libdir}/libsvn_fs_util-1.la
686 %{_libdir}/libsvn_ra-1.la
687 %{_libdir}/libsvn_ra_local-1.la
688 %{_libdir}/libsvn_ra_%{webdavlib}-1.la
689 %{_libdir}/libsvn_ra_svn-1.la
690 %{_libdir}/libsvn_repos-1.la
691 %{_libdir}/libsvn_subr-1.la
692 %{_libdir}/libsvn_wc-1.la
693 %{_includedir}/%{name}-1
694 %{_examplesdir}/%{name}-%{version}
695
696 %files static
697 %defattr(644,root,root,755)
698 %{_libdir}/libsvn_client-1.a
699 %{_libdir}/libsvn_delta-1.a
700 %{_libdir}/libsvn_diff-1.a
701 %{_libdir}/libsvn_fs-1.a
702 %{_libdir}/libsvn_fs_base-1.a
703 %{_libdir}/libsvn_fs_fs-1.a
704 %{_libdir}/libsvn_fs_util-1.a
705 %{_libdir}/libsvn_ra-1.a
706 %{_libdir}/libsvn_ra_local-1.a
707 %{_libdir}/libsvn_ra_%{webdavlib}-1.a
708 %{_libdir}/libsvn_ra_svn-1.a
709 %{_libdir}/libsvn_repos-1.a
710 %{_libdir}/libsvn_subr-1.a
711 %{_libdir}/libsvn_wc-1.a
712
713 %if %{with gnome}
714 %files -n gnome-keyring-subversion
715 %defattr(644,root,root,755)
716 %attr(755,root,root) %{_libdir}/libsvn_auth_gnome_keyring-1.so.*.*.*
717 %attr(755,root,root) %ghost %{_libdir}/libsvn_auth_gnome_keyring-1.so.0
718 %endif
719
720 %if %{with kwallet}
721 %files -n kde4-kwallet-subversion
722 %defattr(644,root,root,755)
723 %attr(755,root,root) %{_libdir}/libsvn_auth_kwallet-1.so.*.*.*
724 %attr(755,root,root) %ghost %{_libdir}/libsvn_auth_kwallet-1.so.0
725 %endif
726
727 %if !%{with net_client_only}
728 %files svnserve
729 %defattr(644,root,root,755)
730 %attr(755,root,root) %{_bindir}/svnserve
731 %{_mandir}/man5/svnserve.conf.5*
732 %{_mandir}/man8/svnserve.8*
733 %dir %attr(750,svn,svn) /home/services/subversion
734 %dir %attr(750,svn,svn) /home/services/subversion/repos
735 %if %{with apache}
736 %attr(754,root,root) /etc/rc.d/init.d/svnserve
737 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/svnserve
738 %endif
739
740 %files tools
741 %defattr(644,root,root,755)
742 %attr(755,root,root) %{_bindir}/svn-hot-backup
743
744 %files -n bash-completion-subversion
745 %defattr(644,root,root,755)
746 /etc/bash_completion.d/%{name}
747
748 %if %{with javahl}
749 %files -n java-subversion
750 %defattr(644,root,root,755)
751 %attr(755,root,root) %{_libdir}/libsvnjavahl-1.so.*.*.*
752 %attr(755,root,root) %ghost %{_libdir}/libsvnjavahl-1.so.0
753 %attr(755,root,root) %{_libdir}/libsvnjavahl-1.so
754 %{_javadir}/svn-javahl.jar
755 %endif
756
757 %if %{with python}
758 %files -n python-subversion
759 %defattr(644,root,root,755)
760 %doc tools/backup/*.py tools/examples/*.py
761 %attr(755,root,root) %{_libdir}/libsvn_swig_py-1.so.*.*.*
762 %attr(755,root,root) %ghost %{_libdir}/libsvn_swig_py-1.so.0
763 %attr(755,root,root) %{_libdir}/libsvn_swig_py-1.so
764 %dir %{py_sitedir}/libsvn
765 %{py_sitedir}/libsvn/*.py[co]
766 %dir %{py_sitedir}/svn
767 %{py_sitedir}/svn/*.py[co]
768 %attr(755,root,root) %{py_sitedir}/libsvn/*.so
769 %{_examplesdir}/python-%{name}-%{version}
770
771 %files -n python-csvn
772 %defattr(644,root,root,755)
773 %doc subversion/bindings/ctypes-python/{README,TODO}
774 %doc subversion/bindings/ctypes-python/examples/*.py
775 %dir %{py_sitescriptdir}/csvn
776 %{py_sitescriptdir}/csvn/*.py[co]
777 %dir %{py_sitescriptdir}/csvn/core
778 %{py_sitescriptdir}/csvn/core/*.py[co]
779 %dir %{py_sitescriptdir}/csvn/ext
780 %{py_sitescriptdir}/csvn/ext/*.py[co]
781 %{py_sitescriptdir}/*.egg-info
782 %endif
783
784 %if %{with perl}
785 %files -n perl-subversion
786 %defattr(644,root,root,755)
787 %attr(755,root,root) %{_libdir}/libsvn_swig_perl-1.so.*.*.*
788 %attr(755,root,root) %ghost %{_libdir}/libsvn_swig_perl-1.so.0
789 %attr(755,root,root) %{_libdir}/libsvn_swig_perl-1.so
790 %{perl_vendorarch}/SVN
791 %dir %{perl_vendorarch}/auto/SVN
792 %dir %{perl_vendorarch}/auto/SVN/*
793 %attr(755,root,root) %{perl_vendorarch}/auto/SVN/*/*.so
794 %{perl_vendorarch}/auto/SVN/*/*.bs
795 %{_mandir}/man3/*.3pm*
796 %endif
797
798 %if %{with ruby}
799 %files -n ruby-subversion
800 %defattr(644,root,root,755)
801 %attr(755,root,root) %{_libdir}/libsvn_swig_ruby-1.so.*.*.*
802 %attr(755,root,root) %ghost %{_libdir}/libsvn_swig_ruby-1.so.0
803 %attr(755,root,root) %{_libdir}/libsvn_swig_ruby-1.so
804 %dir %{ruby_sitelibdir}/svn
805 %{ruby_sitelibdir}/svn/*.rb
806 %dir %{ruby_sitearchdir}/svn
807 %dir %{ruby_sitearchdir}/svn/ext
808 %attr(755,root,root) %{ruby_sitearchdir}/svn/ext/*.so
809 %{ruby_ridir}/Svn
810 %endif
811
812 %if %{with apache}
813 %files -n apache-mod_dav_svn
814 %defattr(644,root,root,755)
815 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{apacheconfdir}/*_mod_dav_svn.conf
816 %attr(755,root,root) %{apachelibdir}/mod_dav_svn.so
817
818 %files -n apache-mod_authz_svn
819 %defattr(644,root,root,755)
820 %doc subversion/mod_authz_svn/INSTALL
821 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{apacheconfdir}/*_mod_authz_svn.conf
822 %attr(755,root,root) %{apachelibdir}/mod_authz_svn.so
823 %endif
824
825 %endif # net_client_only
This page took 0.075458 seconds and 4 git commands to generate.