]> git.pld-linux.org Git - packages/subversion.git/blob - subversion.spec
- net_client_only bcond (allows to build networked client without need to have apache...
[packages/subversion.git] / subversion.spec
1 %bcond_with     internal_neon
2 %bcond_with     net_client_only
3 %include        /usr/lib/rpm/macros.python
4 %define repov 5977
5 Summary:        A Concurrent Versioning system similar to but better than CVS
6 Summary(pl):    System kontroli wersji podobny, ale lepszy, ni¿ CVS
7 Summary(pt_BR): Sistema de versionamento concorrente
8 Name:           subversion
9 Version:        0.29.0
10 Release:        0.1
11 License:        Apache/BSD Style
12 Group:          Development/Version Control
13 #Source0Download:       http://subversion.tigris.org/servlets/ProjectDocumentList?folderID=260
14 Source0:        http://subversion.tigris.org/files/documents/15/%{repov}/subversion-%{version}.tar.gz
15 # Source0-md5:  5de4d92eae7ea5d83fe6c3964a08e261
16 Source1:        %{name}-dav_svn.conf
17 Source2:        %{name}-authz_svn.conf
18 URL:            http://subversion.tigris.org/
19 %if ! %{with net_client_only}
20 BuildRequires:  apache-devel >= 2.0.47-0.6
21 BuildRequires:  rpmbuild(macros) >= 1.120
22 BuildRequires:  swig >= 1.3.17
23 BuildRequires:  swig-python >= 1.3.17
24 BuildRequires:  db-devel >= 4.1.25
25 %endif
26 BuildRequires:  python >= 2.2
27 BuildRequires:  rpm-pythonprov >= 4.0.2-50
28 BuildRequires:  apr-devel >= 1:0.9.4
29 BuildRequires:  apr-util-devel >= 1:0.9.4
30 BuildRequires:  autoconf >= 2.53
31 BuildRequires:  bison
32 BuildRequires:  docbook-style-xsl >= 1.56
33 BuildRequires:  libxslt-progs
34 BuildRequires:  expat-devel
35 BuildRequires:  libtool >= 1.4-9
36 %{!?with_internal_neon:BuildRequires:   neon-devel >= 0.24.1}
37 BuildRequires:  texinfo
38 Requires(post): /usr/sbin/fix-info-dir
39 Requires(postun):       /usr/sbin/fix-info-dir
40 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
41
42 %define         _apachelibdir   /usr/lib/apache
43 %define         _libexecdir     %{_libdir}/svn
44
45 %description
46 The goal of the Subversion project is to build a version control
47 system that is a compelling replacement for CVS in the open source
48 community.
49
50 Our goals are:
51 - All current CVS features.
52 - Directories, renames, and file meta-data are versioned.
53 - Symbolic links, etc, are supported
54 - Commits are truly atomic.
55 - Branching and tagging are cheap (constant time) operations
56 - Repeated merges are handled gracefully
57 - Support for plug-in client side diff programs
58 - Natively client/server
59 - Client/server protocol sends diffs in both directions
60 - Costs are proportional to change size, not project size
61 - Internationalization
62 - Progressive multi-lingual support
63
64 %description -l pl
65 Celem projektu Subversion jest stworzenie systemu kontroli wersji jako
66 zamiennika dla CVS.
67
68 Cele projektu to:
69 - Wszystkie aktualne mo¿liwo¶ci CVS.
70 - Katalogi, zmiany nazw oraz meta-dane plików s± wersjonowane.
71 - Wsparcie dla linków symbolicznych itp.
72 - Commity s± w pe³ni atomowe.
73 - Branchowanie oraz tagowanie s± tanimi (sta³ymi w czasie) operacjami.
74 - Powtarzaj±ce merge.
75 - Wsparcie dla pluginów diff'a po stronie klienta.
76 - Natywny klient/serwer.
77 - Klient/Serwer przesy³aj± diffy w obu kierunkach.
78 - Koszty proporcjonalne do rozmiaru zmiany, a nie rozmiaru projektu.
79 - Internacjonalizacja.
80 - Postêpuj±ce wsparcie dla wielu jêzyków.
81
82 %description -l pt_BR
83 O objetivo do projeto Subversion é construir um sistema de controle de
84 versões que seja um substituto para o CVS (Concurrent Versioning
85 System) na comunidade opensource, fornecendo grandes melhorias.
86
87 %package libs
88 Summary:        Subversion libraries and modules
89 Summary(pl):    Biblioteka subversion oraz ³adowalne modu³y
90 Group:          Libraries
91 Obsoletes:      libsubversion0
92
93 %description libs
94 Subversion libraries and modules.
95
96 %description libs -l pl
97 Biblioteka subversion oraz ³adowalne modu³y.
98
99 %package devel
100 Summary:        Header files and develpment documentation for subversion
101 Summary(pl):    Pliki nag³ówkowe i dokumetacja do subversion
102 Summary(pt_BR): Arquivos de desenvolvimento para o Subversion
103 Group:          Development/Libraries
104 Requires:       %{name}-libs = %{version}
105 Obsoletes:      libsubversion0-devel
106
107 %description devel
108 Header files and develpment documentation for subversion.
109
110 %description devel -l pl
111 Pliki nag³ówkowe i dokumetacja do subversion.
112
113 %description devel -l pt_BR
114 Este pacote provê os arquivos necessários para desenvolvedores
115 interagirem com o Subversion.
116
117 %package static
118 Summary:        Static subversion library
119 Summary(pl):    Biblioteka statyczna subversion
120 Summary(pt_BR): Sistema de versionamento concorrente
121 Group:          Development/Libraries
122 Requires:       %{name}-devel = %{version}
123 Obsoletes:      libsubversion0-static-devel
124
125 %description static
126 Static subversion library.
127
128 %description static -l pl
129 Biblioteka statyczna subversion.
130
131 %description static -l pt_BR
132 Este pacote provê um cliente estático do subversion.
133
134 %package -n python-subversion
135 Summary:        Subversion python bindings
136 Summary(pl):    Dowi±zania do subversion dla pythona
137 Summary(pt_BR): Módulos python para acessar os recursos do Subversion
138 Group:          Development/Languages/Python
139 Requires:       python >= 2.2
140 Obsoletes:      subversion-python
141 %pyrequires_eq  python
142
143 %description -n python-subversion
144 Subversion python bindings.
145
146 %description -n python-subversion -l pl
147 Dowi±zania do subversion dla pythona.
148
149 %description -n python-subversion -l pt_BR
150 Módulos python para acessar os recursos do Subversion.
151
152 %package -n apache-mod_dav_svn
153 Summary:        Apache module: Subversion Server
154 Summary(pl):    Modu³ apache: Serwer Subversion
155 Group:          Networking/Daemons
156 Requires:       apache >= 2.0.47
157 Requires:       apache(modules-api) = %{apache_modules_api}
158 Requires:       apache-mod_dav
159
160 %description -n apache-mod_dav_svn
161 Apache module: Subversion Server.
162
163 %description -n apache-mod_dav_svn -l pl
164 Modu³ apache: Serwer Subversion.
165
166 %package -n apache-mod_authz_svn
167 Summary:        Apache module: Subversion Server - path-based authorization
168 Summary(pl):    Modu³ apache: autoryzacja na podstawie ¶cie¿ki dla serwera Subversion
169 Group:          Networking/Daemons
170 Requires:       apache-mod_dav_svn = %{version}
171 Requires:       apache >= 2.0.47
172 Requires:       apache(modules-api) = %{apache_modules_api}
173
174 %description -n apache-mod_authz_svn
175 Apache module: Subversion Server - path-based authorization.
176
177 %description -n apache-mod_authz_svn -l pl
178 Modu³ apache: autoryzacja na podstawie ¶cie¿ki dla serwera Subversion.
179
180 %prep
181 %setup -q
182
183 %build
184 chmod +x ./autogen.sh && ./autogen.sh
185
186 # don't enable dso - currently it's broken
187 %configure \
188 %if %{with net_client_only}
189         --without-apache \
190         --without-swig \
191         --without-apxs \
192         --without-berkeley-db \
193 %else
194         --disable-dso \
195         --disable-mod-activation \
196         --with-apxs=%{_sbindir}/apxs \
197         --with-berkeley-db=%{_includedir}/db4:%{_libdir} \
198 %endif
199         %{!?with_internal_neon:--with-neon=%{_prefix}} \
200         --with-apr=%{_bindir}/apr-config \
201         --with-apr-util=%{_bindir}/apu-config
202
203 %{__make}
204
205 %if ! %{with net_client_only}
206 %{__make} swig-py \
207         swig_pydir=%{py_sitedir}/libsvn \
208         swig_pydir_extra=%{py_sitedir}/svn
209 %endif
210
211 # build documentation; build process for documentation is severely
212 # braindamaged -- authors suggests to untar docbook distribution in
213 # build directory, hence the hack here
214 %{__make} -C doc/book XSL_DIR=/usr/share/sgml/docbook/xsl-stylesheets/ all-html
215
216 # prepare for %%doc below
217 mv -f doc/book/book/html-chunk svn-handbook
218 mkdir svn-handbook/images/
219 cp -f doc/book/book/images/*.png svn-handbook/images/
220
221 %install
222 rm -rf $RPM_BUILD_ROOT
223 install -d $RPM_BUILD_ROOT{%{_sysconfdir}/httpd/httpd.conf,%{_apachelibdir},%{_infodir}}
224
225 %{__make} LC_ALL=C \
226         install \
227         %{!?with_net_client_only:install-swig-py} \
228         DESTDIR=$RPM_BUILD_ROOT \
229         swig_pydir=%{py_sitedir}/libsvn \
230         swig_pydir_extra=%{py_sitedir}/svn
231
232 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/httpd/httpd.conf/65_mod_dav_svn.conf
233 install %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/httpd/httpd.conf/66_mod_authz_svn.conf
234 install doc/programmer/design/*.info* $RPM_BUILD_ROOT%{_infodir}/
235
236 %if ! %{with net_client_only}
237 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
238 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
239 %endif
240
241 %clean
242 rm -rf $RPM_BUILD_ROOT
243
244 %post devel
245 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
246
247 %postun devel
248 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
249
250 %post   libs -p /sbin/ldconfig
251 %postun libs -p /sbin/ldconfig
252
253 %post -n apache-mod_dav_svn
254 if [ -f /var/lock/subsys/httpd ]; then
255         /etc/rc.d/init.d/httpd restart 1>&2
256 else
257         echo "Run \"/etc/rc.d/init.d/httpd start\" to start apache http daemon."
258 fi
259
260 %preun -n apache-mod_dav_svn
261 if [ "$1" = "0" ]; then
262         if [ -f /var/lock/subsys/httpd ]; then
263                 /etc/rc.d/init.d/httpd restart 1>&2
264         fi
265 fi
266
267 %files
268 %defattr(644,root,root,755)
269 %doc BUGS CHANGES COPYING IDEAS INSTALL README
270 %doc svn-handbook doc/book/misc-docs/misc-docs.html
271 %attr(755,root,root) %{_bindir}/svn*
272 #%exclude %{_bindir}/svn-config
273 %{_mandir}/man1/*
274 %{?with_internal_neon:%exclude %{_mandir}/man1/neon*}
275
276 %files libs
277 %defattr(644,root,root,755)
278 %attr(755,root,root) %{_libdir}/lib*.so.*
279
280 %files devel
281 %defattr(644,root,root,755)
282 %{_includedir}/%{name}*
283 #%attr(755,root,root) %{_bindir}/svn-config
284 %attr(755,root,root) %{_libdir}/lib*.so
285 %{_libdir}/lib*.la
286 %{_infodir}/svn*
287
288 %files static
289 %defattr(644,root,root,755)
290 %{_libdir}/lib*.a
291
292 %if ! %{with net_client_only}
293
294 %files -n python-subversion
295 %defattr(644,root,root,755)
296 %doc tools/backup tools/cvs2svn/*.py tools/examples/*.py
297 %dir %{py_sitedir}/svn
298 %dir %{py_sitedir}/libsvn
299 %{py_sitedir}/svn/*.py[co]
300 %{py_sitedir}/libsvn/*.py[co]
301 %attr(755,root,root) %{py_sitedir}/libsvn/*.so
302
303 %files -n apache-mod_dav_svn
304 %defattr(644,root,root,755)
305 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/httpd/httpd.conf/*_mod_dav_svn.conf
306 %attr(755,root,root) %{_apachelibdir}/mod_dav_svn.so
307
308 %files -n apache-mod_authz_svn
309 %defattr(644,root,root,755)
310 %doc subversion/mod_authz_svn/INSTALL
311 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/httpd/httpd.conf/*_mod_authz_svn.conf
312 %attr(755,root,root) %{_apachelibdir}/mod_authz_svn.so
313
314 %endif
This page took 0.103124 seconds and 4 git commands to generate.