]> git.pld-linux.org Git - packages/subversion.git/blob - subversion.spec
- up to 1.6.1
[packages/subversion.git] / subversion.spec
1 # TODO:
2 # - fix java build with java-gcj-compat and s/java-sun/jdk/
3 # - remove net_client_only and add db bcond (then without apache and
4 #   without db => net_client_only - spec will be more simpler, I think)
5 # - finish ruby
6 #
7 # Conditional build:
8 %bcond_with     net_client_only         # build only net client
9 %bcond_without  neon                    # use serf instead of neon
10 %bcond_without  python                  # build without python bindings (broken)
11 %bcond_without  perl                    # build without perl bindings
12 %bcond_without  ruby                    # build without ruby bindings
13 %bcond_without  apache                  # build without apache support (webdav, etc)
14 %bcond_without  javahl                  # build without javahl support (Java high-level bindings)
15 %bcond_without  tests                   # don't perform "make check"
16 #
17 %ifnarch i586 i686 pentium3 pentium4 athlon %{x8664}
18 %undefine       with_javahl
19 %endif
20 #
21 %{!?with_net_client_only:%include       /usr/lib/rpm/macros.perl}
22 %define apxs    /usr/sbin/apxs
23 %define pdir    SVN
24 %define pnam    _Core
25 #
26 %if %{with neon}
27 %define webdavlib       neon
28 %else
29 %define webdavlib       serf
30 %endif
31 #
32 Summary:        A Concurrent Versioning system similar to but better than CVS
33 Summary(pl.UTF-8):      System kontroli wersji podobny, ale lepszy, niż CVS
34 Summary(pt_BR.UTF-8):   Sistema de versionamento concorrente
35 Name:           subversion
36 Version:        1.6.1
37 Release:        1
38 License:        Apache/BSD-like
39 Group:          Development/Version Control
40 Source0:        http://subversion.tigris.org/downloads/%{name}-%{version}.tar.bz2
41 # Source0-md5:  95708b96b920faeffca017f43ec96777
42 Source1:        %{name}-dav_svn.conf
43 Source2:        %{name}-authz_svn.conf
44 Source3:        %{name}-svnserve.init
45 Source4:        %{name}-svnserve.sysconfig
46 # current subversion tarball has correct *.swg files
47 # but after regeneration these are broken again, so
48 # we still need this script
49 Source5:        %{name}-convert-typemaps-to-ifdef.py
50 Patch0:         %{name}-home_etc.patch
51 Patch1:         %{name}-DESTDIR.patch
52 Patch2:         %{name}-ruby-datadir-path.patch
53 URL:            http://subversion.tigris.org/
54 %if %{with net_client_only}
55 %global apache_modules_api 0
56 %else
57 %{?with_apache:BuildRequires:   apache-devel >= 2.2.0-8}
58 BuildRequires:  automake
59 BuildRequires:  db-devel >= 4.1.25
60 BuildRequires:  rpmbuild(macros) >= 1.268
61 %if %{with perl}
62 BuildRequires:  perl-devel >= 1:5.8.0
63 BuildRequires:  rpm-perlprov >= 4.1-13
64 BuildRequires:  swig-perl >= 1.3.24
65 %endif
66 %if %{with python}
67 BuildRequires:  python-ctypesgen
68 BuildRequires:  python-devel >= 2.2
69 BuildRequires:  swig-python >= 1.3.24
70 %endif
71 %if %{with ruby}
72 BuildRequires:  ruby-devel
73 BuildRequires:  swig-ruby >= 1.3.24
74 %endif
75 %{?with_javahl:BuildRequires:   java-sun}
76 BuildRequires:  cyrus-sasl-devel
77 %endif
78 BuildRequires:  apr-devel >= 1:1.0.0
79 BuildRequires:  apr-util-devel >= 1:1.2.8-3
80 BuildRequires:  autoconf >= 2.59
81 BuildRequires:  bison
82 BuildRequires:  expat-devel
83 BuildRequires:  gettext-devel
84 BuildRequires:  gnome-keyring-devel
85 BuildRequires:  kde4-kdelibs-devel
86 BuildRequires:  libtool >= 1.4-9
87 BuildRequires:  sed >= 4.0
88 BuildRequires:  sqlite3-devel >= 3.6.11
89 BuildRequires:  texinfo
90 BuildRequires:  which
91 %if %{with neon}
92 BuildRequires:  neon-devel >= 0.26.0
93 %else
94 BuildRequires:  serf-devel
95 %endif
96 BuildRequires:  python >= 2.2
97 BuildRequires:  python-modules >= 2.2
98 Requires:       %{name}-libs = %{version}-%{release}
99 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
100
101 %define         _libexecdir             %{_libdir}/svn
102 %define         apacheconfdir   %(%{apxs} -q SYSCONFDIR 2>/dev/null)/conf.d
103 %define         apachelibdir    %(%{apxs} -q LIBEXECDIR 2>/dev/null)
104
105 %description
106 The goal of the Subversion project is to build a version control
107 system that is a compelling replacement for CVS in the open source
108 community.
109
110 Our goals are:
111 - All current CVS features.
112 - Directories, renames, and file meta-data are versioned.
113 - Symbolic links, etc, are supported
114 - Commits are truly atomic.
115 - Branching and tagging are cheap (constant time) operations
116 - Repeated merges are handled gracefully
117 - Support for plug-in client side diff programs
118 - Natively client/server
119 - Client/server protocol sends diffs in both directions
120 - Costs are proportional to change size, not project size
121 - Internationalization
122 - Progressive multi-lingual support
123
124 %description -l pl.UTF-8
125 Celem projektu Subversion jest stworzenie systemu kontroli wersji jako
126 zamiennika dla CVS.
127
128 Cele projektu to:
129 - Wszystkie aktualne możliwości CVS.
130 - Katalogi, zmiany nazw oraz metadane plików są wersjonowane.
131 - Obsługa dowiązań symbolicznych itp.
132 - Commity są w pełni atomowe.
133 - Branchowanie oraz tagowanie są tanimi (stałymi w czasie) operacjami.
134 - Dobra obsługa powtarzanego łączenia (merge).
135 - Obsługa wtyczek diff po stronie klienta.
136 - Natywny klient/serwer.
137 - Klient/Serwer przesyłają diffy w obu kierunkach.
138 - Koszty proporcjonalne do rozmiaru zmiany, a nie rozmiaru projektu.
139 - Internacjonalizacja.
140 - Postępujące wsparcie dla wielu języków.
141
142 %description -l pt_BR.UTF-8
143 O objetivo do projeto Subversion é construir um sistema de controle de
144 versões que seja um substituto para o CVS (Concurrent Versioning
145 System) na comunidade opensource, fornecendo grandes melhorias.
146
147 %package libs
148 Summary:        Subversion libraries and modules
149 Summary(pl.UTF-8):      Biblioteka subversion oraz ładowalne moduły
150 Group:          Libraries
151 %{?with_neon:Requires:  neon >= 0.26.0}
152 Obsoletes:      libsubversion0
153
154 %description libs
155 Subversion libraries and modules.
156
157 %description libs -l pl.UTF-8
158 Biblioteka subversion oraz ładowalne moduły.
159
160 %package devel
161 Summary:        Header files and develpment documentation for subversion
162 Summary(pl.UTF-8):      Pliki nagłówkowe i dokumetacja do subversion
163 Summary(pt_BR.UTF-8):   Arquivos de desenvolvimento para o Subversion
164 Group:          Development/Libraries
165 Requires:       %{name}-libs = %{version}-%{release}
166 Requires:       apr-util-devel >= 1:1.0.0
167 %{?with_neon:Requires:  neon-devel >= 0.26.0}
168 Obsoletes:      libsubversion0-devel
169
170 %description devel
171 Header files and develpment documentation for subversion.
172
173 %description devel -l pl.UTF-8
174 Pliki nagłówkowe i dokumetacja do subversion.
175
176 %description devel -l pt_BR.UTF-8
177 Este pacote provê os arquivos necessários para desenvolvedores
178 interagirem com o Subversion.
179
180 %package static
181 Summary:        Static subversion library
182 Summary(pl.UTF-8):      Biblioteka statyczna subversion
183 Summary(pt_BR.UTF-8):   Sistema de versionamento concorrente
184 Group:          Development/Libraries
185 Requires:       %{name}-devel = %{version}
186 Obsoletes:      libsubversion0-static-devel
187
188 %description static
189 Static subversion library.
190
191 %description static -l pl.UTF-8
192 Biblioteka statyczna subversion.
193
194 %description static -l pt_BR.UTF-8
195 Este pacote provê um cliente estático do subversion.
196
197 %package svnserve
198 Summary:        Subversion svnserve
199 Summary(pl.UTF-8):      Subversion svnserve
200 Group:          Networking/Daemons
201 Requires(post,preun):   /sbin/chkconfig
202 Requires(postun):       /usr/sbin/groupdel
203 Requires(postun):       /usr/sbin/userdel
204 Requires(pre):  /bin/id
205 Requires(pre):  /usr/bin/getgid
206 Requires(pre):  /usr/lib/rpm/user_group.sh
207 Requires(pre):  /usr/sbin/groupadd
208 Requires(pre):  /usr/sbin/useradd
209 Requires(pre):  /usr/sbin/usermod
210 Requires:       %{name} = %{version}-%{release}
211 Requires:       rc-scripts
212 Provides:       group(svn)
213 Provides:       user(svn)
214
215 %description svnserve
216 Subversion svnserve server.
217
218 %description svnserve -l pl.UTF-8
219 Serwer subversion svnserve.
220
221 %package tools
222 Summary:        Subversion tools and scripts
223 Summary(pl.UTF-8):      Narzędzia oraz skrypty dla subversion
224 Summary(pt_BR.UTF-8):   Módulos python para acessar os recursos do Subversion
225 Group:          Applications
226 %pyrequires_eq  python
227 Requires:       %{name} = %{version}-%{release}
228 Requires:       python-subversion = %{version}
229
230 %description tools
231 Subversion tools and scripts.
232
233 %description tools -l pl.UTF-8
234 Narzędzia oraz skrypty dla subversion.
235
236 %package -n bash-completion-subversion
237 Summary:        bash completion for subversion
238 Summary(pl.UTF-8):      Dopełnienia basha dla subversion
239 Group:          Applications/Shells
240 Requires:       %{name} = %{version}-%{release}
241 Requires:       bash-completion
242 Conflicts:      %{name}-tools <= 1.1.0-0.rc6.1
243
244 %description -n bash-completion-subversion
245 Bash completion for subversion.
246
247 %description -n bash-completion-subversion -l pl.UTF-8
248 Dopełnienia basha dla subversion.
249
250 %package -n java-subversion
251 Summary:        Subversion Java bindings
252 Summary(pl.UTF-8):      Dowiązania do Subversion dla Javy
253 Group:          Development/Languages/Java
254 Requires:       %{name}-libs = %{version}-%{release}
255
256 %description -n java-subversion
257 This is a set of Java classes which provide the functionality of
258 subversion-libs, the Subversion libraries. It is useful if you want
259 to, for example, write a Java class that manipulates a Subversion
260 repository or working copy. See the 'subversion' package for more
261 information.
262
263 %description -n java-subversion -l pl.UTF-8
264 Ten pakiet zawiera zestaw klas Javy udostępniających funkcjonalność
265 subversion-libs, czyli bibliotek Subversion. Jest przydatny przy
266 pisaniu klas Javy np. modyfikujących repozytorium Subversion lub kopię
267 roboczą. Więcej informacji w pakiecie subversion.
268
269 %package -n python-subversion
270 Summary:        Subversion Python bindings
271 Summary(pl.UTF-8):      Dowiązania do Subversion dla Pythona
272 Summary(pt_BR.UTF-8):   Módulos Python para acessar os recursos do Subversion
273 Group:          Development/Languages/Python
274 %pyrequires_eq  python
275 Requires:       %{name}-libs = %{version}-%{release}
276 Obsoletes:      subversion-python
277
278 %description -n python-subversion
279 Subversion Python bindings.
280
281 %description -n python-subversion -l pl.UTF-8
282 Dowiązania do Subversion dla Pythona.
283
284 %description -n python-subversion -l pt_BR.UTF-8
285 Módulos Python para acessar os recursos do Subversion.
286
287 %package -n python-csvn
288 Summary:        CTypes Subversion Python bindings
289 Summary(pl.UTF-8):      Dowiązania do Subversion dla Pythona
290 Summary(pt_BR.UTF-8):   Módulos Python para acessar os recursos do Subversion
291 Group:          Development/Languages/Python
292 %pyrequires_eq  python
293 Requires:       %{name}-libs = %{version}-%{release}
294
295 %description -n python-csvn
296 Subversion CTypes Python bindings.
297
298 %description -n python-csvn -l pl.UTF-8
299 Dowiązania do Subversion dla Pythona używające CTypes.
300
301 %description -n python-csvn -l pt_BR.UTF-8
302 Módulos Python para acessar os recursos do Subversion.
303
304 %package -n perl-subversion
305 Summary:        Subversion Perl bindings
306 Summary(pl.UTF-8):      Dowiązania do Subversion dla Perla
307 Summary(pt_BR.UTF-8):   Módulos Perl para acessar os recursos do Subversion
308 Group:          Development/Languages/Perl
309 Requires:       %{name}-libs = %{version}-%{release}
310 Obsoletes:      subversion-perl
311
312 %description -n perl-subversion
313 Subversion Perl bindings.
314
315 %description -n perl-subversion -l pl.UTF-8
316 Dowiązania do Subversion dla Perla.
317
318 %description -n perl-subversion -l pt_BR.UTF-8
319 Módulos Perl para acessar os recursos do Subversion.
320
321 %package -n ruby-subversion
322 Summary:        Subversion Ruby bindings
323 Summary(pl.UTF-8):      Dowiązania do Subversion dla języka Ruby
324 Summary(pt_BR.UTF-8):   Módulos Ruby para acessar os recursos do Subversion
325 Group:          Development/Languages
326 Requires:       %{name}-libs = %{version}-%{release}
327 Obsoletes:      subversion-ruby
328
329 %description -n ruby-subversion
330 Subversion Ruby bindings.
331
332 %description -n ruby-subversion -l pl.UTF-8
333 Dowiązania do Subversion dla języka Ruby.
334
335 %description -n ruby-subversion -l pt_BR.UTF-8
336 Módulos Ruby para acessar os recursos do Subversion.
337
338 %package -n apache-mod_dav_svn
339 Summary:        Apache module: Subversion Server
340 Summary(pl.UTF-8):      Moduł apache: Serwer Subversion
341 Group:          Networking/Daemons
342 Requires:       %{name} = %{version}-%{release}
343 Requires:       apache(modules-api) = %apache_modules_api
344 Requires:       apache-mod_dav
345
346 %description -n apache-mod_dav_svn
347 Apache module: Subversion Server.
348
349 %description -n apache-mod_dav_svn -l pl.UTF-8
350 Moduł apache: Serwer Subversion.
351
352 %package -n apache-mod_authz_svn
353 Summary:        Apache module: Subversion Server - path-based authorization
354 Summary(pl.UTF-8):      Moduł apache: autoryzacja na podstawie ścieżki dla serwera Subversion
355 Group:          Networking/Daemons
356 Requires:       apache(modules-api) = %apache_modules_api
357 Requires:       apache-mod_dav_svn = %{version}-%{release}
358
359 %description -n apache-mod_authz_svn
360 Apache module: Subversion Server - path-based authorization.
361
362 %description -n apache-mod_authz_svn -l pl.UTF-8
363 Moduł apache: autoryzacja na podstawie ścieżki dla serwera Subversion.
364
365 %package -n gnome-keyring-subversion
366 Summary:        Subversion module for Gnome Keyring
367 Summary(pl.UTF-8):      Moduł subversion dla zarządcy kluczy Gnome
368 Group:          X11/Applications
369
370 %description -n gnome-keyring-subversion
371 Subversion module for Gnome Keyring.
372
373 %description -n gnome-keyring-subversion -l pl.UTF-8
374 Moduł subversion dla zarządcy kluczy Gnome.
375
376 %package -n kde4-kwallet-subversion
377 Summary:        Subversion module for KDE Wallet
378 Summary(pl.UTF-8):      Moduł subversion dla Portfela KDE
379 Group:          X11/Applications
380
381 %description -n kde4-kwallet-subversion
382 Subversion module for KDE Wallet.
383
384 %description -n kde4-kwallet-subversion -l pl.UTF-8
385 Moduł subversion dla Portfela KDE.
386
387 %prep
388 %setup -q
389 rm -rf apr apr-util neon
390 %patch0 -p0
391 %patch1 -p1
392 %patch2 -p0
393
394 sed -i -e 's#serf_prefix/lib#serf_prefix/%{_lib}#g' build/ac-macros/serf.m4
395
396 # serf.m4 macro is broken and ignores --without serf
397 %{?with_neon:sed -i -e 's#serf_found="yes"#serf_found="no"#g' build/ac-macros/serf.m4}
398
399 %build
400 rm subversion/bindings/swig/proxy/*.swg
401 cd subversion/bindings/swig && python "%{SOURCE5}" && cd ../../..
402 cp -f /usr/share/automake/config.sub ac-helpers
403 chmod +x ./autogen.sh && ./autogen.sh
404
405 %configure \
406         --with-editor=vi \
407         --with-zlib=%{_libdir} \
408 %if %{with net_client_only}
409         --without-apache \
410         --without-swig \
411         --without-apxs \
412         --without-berkeley-db \
413 %else
414         --disable-runtime-module-search \
415         --disable-mod-activation \
416 %if %{with apache}
417         --with-apxs=%{_sbindir}/apxs \
418 %else
419         --without-apache \
420         --without-apxs \
421         --with-berkeley-db=%{_includedir}/db4:%{_libdir} \
422 %endif
423 %if !%{with python} && !%{with perl} && !%{with ruby}
424         --without-swig \
425 %endif
426         %{?with_python:--with-ctypesgen=%{_bindir}/ctypesgen.py} \
427         --%{?with_javahl:en}%{!?with_javahl:dis}able-javahl \
428 %endif
429         --with-jdk="%{java_home}" \
430 %if %{with neon}
431         --without-serf \
432         --with-neon=%{_prefix} \
433         --disable-neon-version-check \
434 %else
435         --with-serf=%{_prefix} \
436         --without-neon \
437 %endif
438         --with-apr=%{_bindir}/apr-1-config \
439         --with-apr-util=%{_bindir}/apu-1-config \
440         --with-kwallet \
441         --with-gnome-keyring
442
443 %{__make} -j1
444
445 %if !%{with net_client_only}
446 # python
447 %if %{with python}
448 # ctypes bindings
449 %{__make} ctypes-python
450 # swig bindings
451 %{__make} swig-py \
452         swig_pydir=%{py_sitedir}/libsvn \
453         swig_pydir_extra=%{py_sitedir}/svn
454 %endif
455 # perl
456 %if %{with perl}
457 %{__make} -j1 swig-pl-lib
458 odir=$(pwd)
459 cd subversion/bindings/swig/perl/native
460 %{__perl} Makefile.PL INSTALLDIRS=vendor
461 %{__make} -j1
462 cd $odir
463 %endif
464 %if %{with javahl}
465 %{__make} -j1 javahl \
466         javahl_javadir="%{_javadir}"
467 %endif
468 # ruby
469 %if %{with ruby}
470 %{__make} swig-rb
471 %endif
472 %endif
473
474 %if %{with tests}
475 %{__make} check
476 %if %{with python}
477 %{__make} check-ctypes-python
478 %{__make} check-swig-py
479 %endif
480 %if %{with perl}
481 %{__make} check-swig-pl
482 %endif
483 %if %{with ruby}
484 %{__make} check-swig-rb
485 %endif
486 %endif
487
488 %install
489 rm -rf $RPM_BUILD_ROOT
490 install -d $RPM_BUILD_ROOT/etc/{rc.d/init.d,sysconfig,bash_completion.d} \
491         $RPM_BUILD_ROOT{%{apacheconfdir},%{apachelibdir},%{_infodir}} \
492         $RPM_BUILD_ROOT%{_examplesdir}/{%{name}-%{version},python-%{name}-%{version}} \
493         $RPM_BUILD_ROOT/home/services/subversion{,/repos}
494
495 %{__make} install -j1 \
496 %if %{with javahl}
497         install-javahl \
498         javahl_javadir="%{_javadir}" \
499 %endif
500 %if !%{with net_client_only}
501 %if %{with python}
502         install-swig-py \
503         install-ctypes-python \
504 %endif
505 %if %{with ruby}
506         install-swig-rb install-swig-rb-doc \
507 %endif
508 %endif
509         APACHE_LIBEXECDIR="$(%{_sbindir}/apxs -q LIBEXECDIR)" \
510         DESTDIR=$RPM_BUILD_ROOT \
511         swig_pydir=%{py_sitedir}/libsvn \
512         swig_pydir_extra=%{py_sitedir}/svn
513
514 %if !%{with net_client_only} && %{with perl}
515 %{__make} install-swig-pl-lib \
516         DESTDIR=$RPM_BUILD_ROOT
517 %{__make} -C subversion/bindings/swig/perl/native install \
518         DESTDIR=$RPM_BUILD_ROOT \
519         PREFIX=$RPM_BUILD_ROOT%{_prefix} \
520         LIBDIR=$RPM_BUILD_ROOT%{_libdir}
521 %endif
522
523 %if %{with apache}
524 install %{SOURCE1} $RPM_BUILD_ROOT%{apacheconfdir}/65_mod_dav_svn.conf
525 install %{SOURCE2} $RPM_BUILD_ROOT%{apacheconfdir}/66_mod_authz_svn.conf
526 install %{SOURCE3} $RPM_BUILD_ROOT/etc/rc.d/init.d/svnserve
527 install %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/svnserve
528 %endif
529
530 %if !%{with net_client_only}
531 install tools/backup/hot-backup.py $RPM_BUILD_ROOT%{_bindir}/svn-hot-backup
532 %if %{with python}
533 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
534 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
535 find $RPM_BUILD_ROOT%{py_sitedir} -name "*.py" -o -name "*.a" -o -name "*.la" | xargs rm -f
536 install tools/examples/*.py $RPM_BUILD_ROOT%{_examplesdir}/python-%{name}-%{version}
537 %endif
538 %endif
539
540 install tools/client-side/bash_completion $RPM_BUILD_ROOT/etc/bash_completion.d/%{name}
541 install tools/examples/*.c $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
542
543 %find_lang %{name}
544
545 %{?with_javahl:rm $RPM_BUILD_ROOT%{_libdir}/libsvnjavahl*.{la,a}}
546 rm $RPM_BUILD_ROOT%{_libdir}/libsvn_swig*.{la,a}
547 rm $RPM_BUILD_ROOT%{_libdir}/ruby/site_ruby/*/*/svn/ext/*.la
548
549 %clean
550 rm -rf $RPM_BUILD_ROOT
551
552 %pre svnserve
553 %groupadd -g 86 svn
554 %useradd -u 180 -d /home/services/subversion -c "Subversion svnserve" -g svn svn
555
556 %post   libs -p /sbin/ldconfig
557 %postun libs -p /sbin/ldconfig
558
559 %post   devel -p /sbin/postshell
560 -/usr/sbin/fix-info-dir -c %{_infodir}
561
562 %postun devel -p /sbin/postshell
563 -/usr/sbin/fix-info-dir -c %{_infodir}
564
565 %post   -n perl-subversion -p /sbin/ldconfig
566 %postun -n perl-subversion -p /sbin/ldconfig
567
568 %post   -n python-subversion -p /sbin/ldconfig
569 %postun -n python-subversion -p /sbin/ldconfig
570
571 %post svnserve
572 /sbin/chkconfig --add svnserve
573 %service svnserve restart "svnserve daemon"
574
575 %preun svnserve
576 if [ "$1" = "0" ]; then
577         %service svnserve stop
578         /sbin/chkconfig --del svnserve
579 fi
580
581 %postun svnserve
582 if [ "$1" = "0" ]; then
583         %userremove svn
584         %groupremove svn
585 fi
586
587 %post -n apache-mod_dav_svn
588 %service -q httpd restart
589
590 %preun -n apache-mod_dav_svn
591 if [ "$1" = "0" ]; then
592         %service -q httpd restart
593 fi
594
595 %files
596 %defattr(644,root,root,755)
597 %doc BUGS CHANGES COPYING INSTALL README
598 %doc doc/*/*.html
599 %doc tools/hook-scripts/*.{pl,py,example}
600 %doc tools/hook-scripts/mailer/*.{py,example}
601 %doc tools/xslt/*
602 %attr(755,root,root) %{_bindir}/svn
603 %attr(755,root,root) %{_bindir}/svnadmin
604 %attr(755,root,root) %{_bindir}/svndumpfilter
605 %attr(755,root,root) %{_bindir}/svnlook
606 %attr(755,root,root) %{_bindir}/svnsync
607 %attr(755,root,root) %{_bindir}/svnversion
608 %{_mandir}/man1/svn.1*
609 %{_mandir}/man1/svnadmin.1*
610 %{_mandir}/man1/svndumpfilter.1*
611 %{_mandir}/man1/svnlook.1*
612 %{_mandir}/man1/svnsync.1*
613 %{_mandir}/man1/svnversion.1*
614
615 %files libs -f %{name}.lang
616 %defattr(644,root,root,755)
617 %attr(755,root,root) %{_libdir}/libsvn_client-1.so.*.*.*
618 %attr(755,root,root) %ghost %{_libdir}/libsvn_client-1.so.0
619 %attr(755,root,root) %{_libdir}/libsvn_delta-1.so.*.*.*
620 %attr(755,root,root) %ghost %{_libdir}/libsvn_delta-1.so.0
621 %attr(755,root,root) %{_libdir}/libsvn_diff-1.so.*.*.*
622 %attr(755,root,root) %ghost %{_libdir}/libsvn_diff-1.so.0
623 %attr(755,root,root) %{_libdir}/libsvn_fs-1.so.*.*.*
624 %attr(755,root,root) %ghost %{_libdir}/libsvn_fs-1.so.0
625 %attr(755,root,root) %{_libdir}/libsvn_fs_base-1.so.*.*.*
626 %attr(755,root,root) %ghost %{_libdir}/libsvn_fs_base-1.so.0
627 %attr(755,root,root) %{_libdir}/libsvn_fs_fs-1.so.*.*.*
628 %attr(755,root,root) %ghost %{_libdir}/libsvn_fs_fs-1.so.0
629 %attr(755,root,root) %{_libdir}/libsvn_fs_util-1.so.*.*.*
630 %attr(755,root,root) %ghost %{_libdir}/libsvn_fs_util-1.so.0
631 %attr(755,root,root) %{_libdir}/libsvn_ra-1.so.*.*.*
632 %attr(755,root,root) %ghost %{_libdir}/libsvn_ra-1.so.0
633 %attr(755,root,root) %{_libdir}/libsvn_ra_local-1.so.*.*.*
634 %attr(755,root,root) %ghost %{_libdir}/libsvn_ra_local-1.so.0
635 %attr(755,root,root) %{_libdir}/libsvn_ra_%{webdavlib}-1.so.*.*.*
636 %attr(755,root,root) %ghost %{_libdir}/libsvn_ra_%{webdavlib}-1.so.0
637 %attr(755,root,root) %{_libdir}/libsvn_ra_svn-1.so.*.*.*
638 %attr(755,root,root) %ghost %{_libdir}/libsvn_ra_svn-1.so.0
639 %attr(755,root,root) %{_libdir}/libsvn_repos-1.so.*.*.*
640 %attr(755,root,root) %ghost %{_libdir}/libsvn_repos-1.so.0
641 %attr(755,root,root) %{_libdir}/libsvn_subr-1.so.*.*.*
642 %attr(755,root,root) %ghost %{_libdir}/libsvn_subr-1.so.0
643 %attr(755,root,root) %{_libdir}/libsvn_wc-1.so.*.*.*
644 %attr(755,root,root) %ghost %{_libdir}/libsvn_wc-1.so.0
645
646 %files devel
647 %defattr(644,root,root,755)
648 %attr(755,root,root) %{_libdir}/libsvn_client-1.so
649 %attr(755,root,root) %{_libdir}/libsvn_delta-1.so
650 %attr(755,root,root) %{_libdir}/libsvn_diff-1.so
651 %attr(755,root,root) %{_libdir}/libsvn_fs-1.so
652 %attr(755,root,root) %{_libdir}/libsvn_fs_base-1.so
653 %attr(755,root,root) %{_libdir}/libsvn_fs_fs-1.so
654 %attr(755,root,root) %{_libdir}/libsvn_fs_util-1.so
655 %attr(755,root,root) %{_libdir}/libsvn_ra-1.so
656 %attr(755,root,root) %{_libdir}/libsvn_ra_local-1.so
657 %attr(755,root,root) %{_libdir}/libsvn_ra_%{webdavlib}-1.so
658 %attr(755,root,root) %{_libdir}/libsvn_ra_svn-1.so
659 %attr(755,root,root) %{_libdir}/libsvn_repos-1.so
660 %attr(755,root,root) %{_libdir}/libsvn_subr-1.so
661 %attr(755,root,root) %{_libdir}/libsvn_wc-1.so
662 %{_libdir}/libsvn_client-1.la
663 %{_libdir}/libsvn_delta-1.la
664 %{_libdir}/libsvn_diff-1.la
665 %{_libdir}/libsvn_fs-1.la
666 %{_libdir}/libsvn_fs_base-1.la
667 %{_libdir}/libsvn_fs_fs-1.la
668 %{_libdir}/libsvn_fs_util-1.la
669 %{_libdir}/libsvn_ra-1.la
670 %{_libdir}/libsvn_ra_local-1.la
671 %{_libdir}/libsvn_ra_%{webdavlib}-1.la
672 %{_libdir}/libsvn_ra_svn-1.la
673 %{_libdir}/libsvn_repos-1.la
674 %{_libdir}/libsvn_subr-1.la
675 %{_libdir}/libsvn_wc-1.la
676 %{_includedir}/%{name}-1
677 %{_examplesdir}/%{name}-%{version}
678
679 %files static
680 %defattr(644,root,root,755)
681 %{_libdir}/libsvn_client-1.a
682 %{_libdir}/libsvn_delta-1.a
683 %{_libdir}/libsvn_diff-1.a
684 %{_libdir}/libsvn_fs-1.a
685 %{_libdir}/libsvn_fs_base-1.a
686 %{_libdir}/libsvn_fs_fs-1.a
687 %{_libdir}/libsvn_fs_util-1.a
688 %{_libdir}/libsvn_ra-1.a
689 %{_libdir}/libsvn_ra_local-1.a
690 %{_libdir}/libsvn_ra_%{webdavlib}-1.a
691 %{_libdir}/libsvn_ra_svn-1.a
692 %{_libdir}/libsvn_repos-1.a
693 %{_libdir}/libsvn_subr-1.a
694 %{_libdir}/libsvn_wc-1.a
695
696 %files -n gnome-keyring-subversion
697 %defattr(644,root,root,755)
698 %attr(755,root,root) %{_libdir}/libsvn_auth_gnome_keyring-1.so.*.*.*
699 %attr(755,root,root) %ghost %{_libdir}/libsvn_auth_gnome_keyring-1.so.0
700
701 %files -n kde4-kwallet-subversion
702 %defattr(644,root,root,755)
703 %attr(755,root,root) %{_libdir}/libsvn_auth_kwallet-1.so.*.*.*
704 %attr(755,root,root) %ghost %{_libdir}/libsvn_auth_kwallet-1.so.0
705
706 %if !%{with net_client_only}
707 %files svnserve
708 %defattr(644,root,root,755)
709 %attr(755,root,root) %{_bindir}/svnserve
710 %{_mandir}/man5/svnserve.conf.5*
711 %{_mandir}/man8/svnserve.8*
712 %dir %attr(750,svn,svn) /home/services/subversion
713 %dir %attr(750,svn,svn) /home/services/subversion/repos
714 %if %{with apache}
715 %attr(754,root,root) /etc/rc.d/init.d/svnserve
716 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/svnserve
717 %endif
718
719 %files tools
720 %defattr(644,root,root,755)
721 %attr(755,root,root) %{_bindir}/svn-hot-backup
722
723 %files -n bash-completion-subversion
724 %defattr(644,root,root,755)
725 /etc/bash_completion.d/%{name}
726
727 %if %{with javahl}
728 %files -n java-subversion
729 %defattr(644,root,root,755)
730 %attr(755,root,root) %{_libdir}/libsvnjavahl-1.so.*.*.*
731 %attr(755,root,root) %ghost %{_libdir}/libsvnjavahl-1.so.0
732 %attr(755,root,root) %{_libdir}/libsvnjavahl-1.so
733 %{_javadir}/svn-javahl.jar
734 %endif
735
736 %if %{with python}
737 %files -n python-subversion
738 %defattr(644,root,root,755)
739 %doc tools/backup/*.py tools/examples/*.py
740 %attr(755,root,root) %{_libdir}/libsvn_swig_py-1.so.*.*.*
741 %attr(755,root,root) %ghost %{_libdir}/libsvn_swig_py-1.so.0
742 %attr(755,root,root) %{_libdir}/libsvn_swig_py-1.so
743 %dir %{py_sitedir}/libsvn
744 %{py_sitedir}/libsvn/*.py[co]
745 %dir %{py_sitedir}/svn
746 %{py_sitedir}/svn/*.py[co]
747 %attr(755,root,root) %{py_sitedir}/libsvn/*.so
748 %{_examplesdir}/python-%{name}-%{version}
749
750 %files -n python-csvn
751 %defattr(644,root,root,755)
752 %doc subversion/bindings/ctypes-python/{README,TODO}
753 %doc subversion/bindings/ctypes-python/examples/*.py
754 %dir %{py_sitescriptdir}/csvn
755 %{py_sitescriptdir}/csvn/*.py[co]
756 %dir %{py_sitescriptdir}/csvn/core
757 %{py_sitescriptdir}/csvn/core/*.py[co]
758 %dir %{py_sitescriptdir}/csvn/ext
759 %{py_sitescriptdir}/csvn/ext/*.py[co]
760 %{py_sitescriptdir}/*.egg-info
761 %endif
762
763 %if %{with perl}
764 %files -n perl-subversion
765 %defattr(644,root,root,755)
766 %attr(755,root,root) %{_libdir}/libsvn_swig_perl-1.so.*.*.*
767 %attr(755,root,root) %ghost %{_libdir}/libsvn_swig_perl-1.so.0
768 %attr(755,root,root) %{_libdir}/libsvn_swig_perl-1.so
769 %{perl_vendorarch}/SVN
770 %dir %{perl_vendorarch}/auto/SVN
771 %dir %{perl_vendorarch}/auto/SVN/*
772 %attr(755,root,root) %{perl_vendorarch}/auto/SVN/*/*.so
773 %{perl_vendorarch}/auto/SVN/*/*.bs
774 %{_mandir}/man3/*.3pm*
775 %endif
776
777 %if %{with ruby}
778 %files -n ruby-subversion
779 %defattr(644,root,root,755)
780 %attr(755,root,root) %{_libdir}/libsvn_swig_ruby-1.so.*.*.*
781 %attr(755,root,root) %ghost %{_libdir}/libsvn_swig_ruby-1.so.0
782 %attr(755,root,root) %{_libdir}/libsvn_swig_ruby-1.so
783 %dir %{_libdir}/ruby/site_ruby/[0-9].[0-9]
784 %dir %{_libdir}/ruby/site_ruby/*/svn
785 %{_libdir}/ruby/site_ruby/*/svn/*.rb
786 %dir %{_libdir}/ruby/site_ruby/*/*-*
787 %dir %{_libdir}/ruby/site_ruby/*/*-*/svn/ext
788 %attr(755,root,root) %{_libdir}/ruby/site_ruby/*/*-*/svn/ext/*.so
789 %{_datadir}/ri/*.*/system/OptionParser
790 %{_datadir}/ri/*.*/system/Svn
791 %{_datadir}/ri/*.*/system/Time
792 %{_datadir}/ri/*.*/system/Uconv
793 %{_datadir}/ri/*.*/system/*.rid
794 %{_datadir}/ri/*.*/system/Kernel/*
795 %endif
796
797 %if %{with apache}
798 %files -n apache-mod_dav_svn
799 %defattr(644,root,root,755)
800 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{apacheconfdir}/*_mod_dav_svn.conf
801 %attr(755,root,root) %{apachelibdir}/mod_dav_svn.so
802
803 %files -n apache-mod_authz_svn
804 %defattr(644,root,root,755)
805 %doc subversion/mod_authz_svn/INSTALL
806 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{apacheconfdir}/*_mod_authz_svn.conf
807 %attr(755,root,root) %{apachelibdir}/mod_authz_svn.so
808 %endif
809
810 %endif # net_client_only
This page took 0.105293 seconds and 4 git commands to generate.