]> git.pld-linux.org Git - packages/subversion.git/blob - subversion.spec
- updated to 1.0.3 (fixes CAN-2004-0397 - remote date parsing vuln)
[packages/subversion.git] / subversion.spec
1 #
2 # Conditional build:
3 %bcond_with     internal_neon           # build with internal neon
4 %bcond_with     net_client_only         # build only net client
5 #       
6 %include        /usr/lib/rpm/macros.python
7 %{!?with_net_client_only:%include       /usr/lib/rpm/macros.perl}
8 Summary:        A Concurrent Versioning system similar to but better than CVS
9 Summary(pl):    System kontroli wersji podobny, ale lepszy, ni¿ CVS
10 Summary(pt_BR): Sistema de versionamento concorrente
11 Name:           subversion
12 Version:        1.0.3
13 Release:        1
14 License:        Apache/BSD Style
15 Group:          Development/Version Control
16 Source0:        http://subversion.tigris.org/tarballs/%{name}-%{version}.tar.bz2
17 # Source0-md5:  a8961f86a2bbd8deb59b2b62db303461
18 Source1:        %{name}-dav_svn.conf
19 Source2:        %{name}-authz_svn.conf
20 Source3:        %{name}-svnserve.init
21 Source4:        %{name}-svnserve.sysconfig
22 #Patch0:                %{name}-svnlook.patch
23 #Patch1:                %{name}-hot_backup_num.patch
24 URL:            http://subversion.tigris.org/
25 %if %{with net_client_only}
26 %global apache_modules_api 0
27 %else
28 BuildRequires:  automake
29 BuildRequires:  apache-devel >= 2.0.47-0.6
30 BuildRequires:  db-devel >= 4.1.25
31 BuildRequires:  rpmbuild(macros) >= 1.120
32 BuildRequires:  swig >= 1.3.19
33 BuildRequires:  swig-python >= 1.3.19
34 BuildRequires:  swig-perl >= 1.3.19
35 BuildRequires:  perl-devel >= 1:5.8.0
36 BuildRequires:  rpm-perlprov >= 4.1-13
37 %endif
38 BuildRequires:  apr-devel >= 1:0.9.5
39 BuildRequires:  apr-util-devel >= 1:0.9.5
40 BuildRequires:  autoconf >= 2.59
41 BuildRequires:  bison
42 BuildRequires:  docbook-style-xsl >= 1.56
43 BuildRequires:  expat-devel
44 BuildRequires:  libtool >= 1.4-9
45 BuildRequires:  libxslt-progs
46 %{!?with_internal_neon:BuildRequires:   neon-devel >= 0.24.6}
47 BuildRequires:  python-devel >= 2.2
48 BuildRequires:  rpm-pythonprov >= 4.0.2-50
49 BuildRequires:  texinfo
50 BuildRequires:  which
51 Requires:       %{name}-libs = %{version}-%{release}
52 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
53
54 %define         _apachelibdir   /usr/%{_lib}/apache
55 %define         _libexecdir     %{_libdir}/svn
56
57 %description
58 The goal of the Subversion project is to build a version control
59 system that is a compelling replacement for CVS in the open source
60 community.
61
62 Our goals are:
63 - All current CVS features.
64 - Directories, renames, and file meta-data are versioned.
65 - Symbolic links, etc, are supported
66 - Commits are truly atomic.
67 - Branching and tagging are cheap (constant time) operations
68 - Repeated merges are handled gracefully
69 - Support for plug-in client side diff programs
70 - Natively client/server
71 - Client/server protocol sends diffs in both directions
72 - Costs are proportional to change size, not project size
73 - Internationalization
74 - Progressive multi-lingual support
75
76 %description -l pl
77 Celem projektu Subversion jest stworzenie systemu kontroli wersji jako
78 zamiennika dla CVS.
79
80 Cele projektu to:
81 - Wszystkie aktualne mo¿liwo¶ci CVS.
82 - Katalogi, zmiany nazw oraz meta-dane plików s± wersjonowane.
83 - Wsparcie dla linków symbolicznych itp.
84 - Commity s± w pe³ni atomowe.
85 - Branchowanie oraz tagowanie s± tanimi (sta³ymi w czasie) operacjami.
86 - Powtarzaj±ce merge.
87 - Wsparcie dla pluginów diff'a po stronie klienta.
88 - Natywny klient/serwer.
89 - Klient/Serwer przesy³aj± diffy w obu kierunkach.
90 - Koszty proporcjonalne do rozmiaru zmiany, a nie rozmiaru projektu.
91 - Internacjonalizacja.
92 - Postêpuj±ce wsparcie dla wielu jêzyków.
93
94 %description -l pt_BR
95 O objetivo do projeto Subversion é construir um sistema de controle de
96 versões que seja um substituto para o CVS (Concurrent Versioning
97 System) na comunidade opensource, fornecendo grandes melhorias.
98
99 %package libs
100 Summary:        Subversion libraries and modules
101 Summary(pl):    Biblioteka subversion oraz ³adowalne modu³y
102 Group:          Libraries
103 Obsoletes:      libsubversion0
104 %{!?with_internal_neon:Requires:        neon >= 0.24.6}
105
106 %description libs
107 Subversion libraries and modules.
108
109 %description libs -l pl
110 Biblioteka subversion oraz ³adowalne modu³y.
111
112 %package devel
113 Summary:        Header files and develpment documentation for subversion
114 Summary(pl):    Pliki nag³ówkowe i dokumetacja do subversion
115 Summary(pt_BR): Arquivos de desenvolvimento para o Subversion
116 Group:          Development/Libraries
117 Requires:       %{name}-libs = %{version}-%{release}
118 Requires:       apr-util-devel >= 1:0.9.5
119 %{!?with_internal_neon:Requires:        neon-devel >= 0.24.6}
120 Obsoletes:      libsubversion0-devel
121
122 %description devel
123 Header files and develpment documentation for subversion.
124
125 %description devel -l pl
126 Pliki nag³ówkowe i dokumetacja do subversion.
127
128 %description devel -l pt_BR
129 Este pacote provê os arquivos necessários para desenvolvedores
130 interagirem com o Subversion.
131
132 %package static
133 Summary:        Static subversion library
134 Summary(pl):    Biblioteka statyczna subversion
135 Summary(pt_BR): Sistema de versionamento concorrente
136 Group:          Development/Libraries
137 Requires:       %{name}-devel = %{version}
138 Obsoletes:      libsubversion0-static-devel
139
140 %description static
141 Static subversion library.
142
143 %description static -l pl
144 Biblioteka statyczna subversion.
145
146 %description static -l pt_BR
147 Este pacote provê um cliente estático do subversion.
148
149 %package svnserve
150 Summary:        Subversion svnserve
151 Summary(pl):    Subversion svnserve
152 Group:          Networking/Daemons
153 PreReq:         rc-scripts
154 Requires(post,preun):   /sbin/chkconfig
155 Requires:       %{name} = %{version}-%{release}
156
157 %description svnserve
158 Subversion svnserve server.
159
160 %description svnserve -l pl
161 Serwer subversion svnserve.
162
163 %package tools
164 Summary:        Subversion tools and scripts
165 Summary(pl):    Narzêdzia oraz skrypty dla subversion
166 Summary(pt_BR): Módulos python para acessar os recursos do Subversion
167 Group:          Applications
168 %pyrequires_eq  python
169 Requires:       python-rcsparse >= 0.1-0.20031026.0
170 Requires:       python-subversion = %{version}
171 Requires:       %{name} = %{version}-%{release}
172
173 %description tools
174 Subversion tools and scripts.
175
176 %description tools -l pl
177 Narzêdzia oraz skrypty dla subversion.
178
179 %package -n python-subversion
180 Summary:        Subversion python bindings
181 Summary(pl):    Dowi±zania do subversion dla pythona
182 Summary(pt_BR): Módulos python para acessar os recursos do Subversion
183 Group:          Development/Languages/Python
184 %pyrequires_eq  python
185 Obsoletes:      subversion-python
186 Requires:       %{name}-libs = %{version}-%{release}
187
188 %description -n python-subversion
189 Subversion python bindings.
190
191 %description -n python-subversion -l pl
192 Dowi±zania do subversion dla pythona.
193
194 %description -n python-subversion -l pt_BR
195 Módulos python para acessar os recursos do Subversion.
196
197 %package -n perl-subversion
198 Summary:        Subversion perl bindings
199 Summary(pl):    Dowi±zania do subversion dla perla
200 Summary(pt_BR): Módulos perl para acessar os recursos do Subversion
201 Group:          Development/Languages/Perl
202 Obsoletes:      subversion-perl
203 Requires:       %{name}-libs = %{version}-%{release}
204
205 %description -n perl-subversion
206 Subversion perl bindings.
207
208 %description -n perl-subversion -l pl
209 Dowi±zania do subversion dla perl.
210
211 %description -n perl-subversion -l pt_BR
212 Módulos perl para acessar os recursos do Subversion.
213
214 %package -n apache-mod_dav_svn
215 Summary:        Apache module: Subversion Server
216 Summary(pl):    Modu³ apache: Serwer Subversion
217 Group:          Networking/Daemons
218 Requires:       apache >= 2.0.47
219 Requires:       apache(modules-api) = %{apache_modules_api}
220 Requires:       apache-mod_dav
221 Requires:       %{name} = %{version}-%{release}
222
223 %description -n apache-mod_dav_svn
224 Apache module: Subversion Server.
225
226 %description -n apache-mod_dav_svn -l pl
227 Modu³ apache: Serwer Subversion.
228
229 %package -n apache-mod_authz_svn
230 Summary:        Apache module: Subversion Server - path-based authorization
231 Summary(pl):    Modu³ apache: autoryzacja na podstawie ¶cie¿ki dla serwera Subversion
232 Group:          Networking/Daemons
233 Requires:       apache-mod_dav_svn = %{version}-%{release}
234 Requires:       apache >= 2.0.47
235 Requires:       apache(modules-api) = %{apache_modules_api}
236
237 %description -n apache-mod_authz_svn
238 Apache module: Subversion Server - path-based authorization.
239
240 %description -n apache-mod_authz_svn -l pl
241 Modu³ apache: autoryzacja na podstawie ¶cie¿ki dla serwera Subversion.
242
243 %prep
244 %setup -q
245 #%patch0 -p0
246 #%patch1 -p1
247
248 rm -rf apr-util{,/xml/expat}/autom4te.cache
249
250 %build
251 cp -f /usr/share/automake/config.sub ac-helpers
252 chmod +x ./autogen.sh && ./autogen.sh
253
254 # don't enable dso - currently it's broken
255 %configure \
256 %if %{with net_client_only}
257         --without-apache \
258         --without-swig \
259         --without-apxs \
260         --without-berkeley-db \
261 %else
262         --disable-dso \
263         --disable-mod-activation \
264         --with-apxs=%{_sbindir}/apxs \
265         --with-berkeley-db=%{_includedir}/db4:%{_libdir} \
266 %endif
267         %{!?with_internal_neon:--with-neon=%{_prefix}} \
268         --with-apr=%{_bindir}/apr-config \
269         --with-apr-util=%{_bindir}/apu-config
270
271 %{__make}
272
273 %if ! %{with net_client_only}
274 # python
275 %{__make} swig-py \
276         swig_pydir=%{py_sitedir}/libsvn \
277         swig_pydir_extra=%{py_sitedir}/svn
278 # perl
279 bdir=$(pwd)
280 %{__make} install-swig-pl-lib \
281         LC_ALL=C \
282         DESTDIR=${bdir}/swig-pl-lib-buildroot
283 %{__make}
284 cd subversion/bindings/swig/perl
285 env APR_CONFIG=%{_bindir}/apr-config \
286     APU_CONFIG=%{_bindir}/apu-config \
287         %{__perl} Makefile.PL \
288         INSTALLDIRS=vendor
289 env LIBRARY_PATH=${bdir}/swig-pl-lib-buildroot%{_libdir} %{__make}
290 cd ../../../../
291 %endif
292
293 # build documentation; build process for documentation is severely
294 # braindamaged -- authors suggests to untar docbook distribution in
295 # build directory, hence the hack here
296 ln -s /usr/share/sgml/docbook/xsl-stylesheets doc/book/tools/xsl
297 %{__make} -C doc/book all-html
298
299 # prepare for %%doc below
300 mv -f doc/book/book/html-chunk svn-handbook
301 mkdir svn-handbook/images/
302 cp -f doc/book/book/images/*.png svn-handbook/images/
303
304 %install
305 rm -rf $RPM_BUILD_ROOT
306 install -d $RPM_BUILD_ROOT/etc/{rc.d/init.d,sysconfig,bash_completion.d} \
307         $RPM_BUILD_ROOT{%{_sysconfdir}/httpd/httpd.conf,%{_apachelibdir},%{_infodir}} \
308         $RPM_BUILD_ROOT%{_examplesdir}/{%{name}-%{version},python-%{name}-%{version}}
309
310 %{__make} install \
311         LC_ALL=C \
312         %{!?with_net_client_only:install-swig-py} \
313         DESTDIR=$RPM_BUILD_ROOT \
314         swig_pydir=%{py_sitedir}/libsvn \
315         swig_pydir_extra=%{py_sitedir}/svn
316
317 %if ! %{with net_client_only}
318 %{__make} install-swig-pl-lib \
319         LC_ALL=C \
320         DESTDIR=$RPM_BUILD_ROOT
321 %{__make} -C subversion/bindings/swig/perl install \
322         DESTDIR=$RPM_BUILD_ROOT
323 %endif
324
325 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/httpd/httpd.conf/65_mod_dav_svn.conf
326 install %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/httpd/httpd.conf/66_mod_authz_svn.conf
327 install %{SOURCE3} $RPM_BUILD_ROOT/etc/rc.d/init.d/svnserve
328 install %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/svnserve
329 install doc/programmer/design/*.info* $RPM_BUILD_ROOT%{_infodir}/
330
331 %if ! %{with net_client_only}
332 install tools/backup/hot-backup.py $RPM_BUILD_ROOT%{_bindir}/svn-hot-backup
333
334 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
335 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
336 find $RPM_BUILD_ROOT%{py_sitedir} -name "*.py" -o -name "*.a" -o -name "*.la" | xargs rm -f
337 install tools/examples/*.py $RPM_BUILD_ROOT%{_examplesdir}/python-%{name}-%{version}
338 %endif
339
340 install tools/client-side/bash_completion $RPM_BUILD_ROOT/etc/bash_completion.d/%{name}
341 install tools/examples/*.c $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
342
343 %clean
344 rm -rf $RPM_BUILD_ROOT
345
346 %post devel
347 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
348
349 %postun devel
350 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
351
352 %post   libs -p /sbin/ldconfig
353 %postun libs -p /sbin/ldconfig
354
355 %post svnserve
356 if [ -f /var/lock/subsys/svnserve ]; then
357         /etc/rc.d/init.d/svnserve restart 1>&2
358 else
359         echo "Run \"/etc/rc.d/init.d/svnserve start\" to start subversion svnserve daemon."
360 fi
361
362 %preun svnserve
363 if [ "$1" = "0" ]; then
364         if [ -f /var/lock/subsys/svnserve ]; then
365                 /etc/rc.d/init.d/svnserve restart 1>&2
366         fi
367 fi
368
369 %post -n apache-mod_dav_svn
370 if [ -f /var/lock/subsys/httpd ]; then
371         /etc/rc.d/init.d/httpd restart 1>&2
372 else
373         echo "Run \"/etc/rc.d/init.d/httpd start\" to start apache http daemon."
374 fi
375
376 %preun -n apache-mod_dav_svn
377 if [ "$1" = "0" ]; then
378         if [ -f /var/lock/subsys/httpd ]; then
379                 /etc/rc.d/init.d/httpd restart 1>&2
380         fi
381 fi
382
383 %files
384 %defattr(644,root,root,755)
385 %doc BUGS CHANGES COPYING INSTALL README
386 %doc svn-handbook doc/book/misc-docs/misc-docs.html
387 %doc tools/hook-scripts/*.{pl,py,example}
388 %doc tools/hook-scripts/mailer/*.{py,example}
389 %doc tools/xslt/*
390 %attr(755,root,root) %{_bindir}/svn*
391 %exclude %{_bindir}/svnserve
392 %exclude %{_bindir}/svn-hot-backup
393 %{_mandir}/man1/*
394 %{_mandir}/man5/*
395 %{_mandir}/man8/*
396 %exclude %{_mandir}/man?/svnserve*
397 %{?with_internal_neon:%exclude %{_mandir}/man1/neon*}
398
399 %files libs
400 %defattr(644,root,root,755)
401 %attr(755,root,root) %{_libdir}/lib*.so.*
402
403 %files devel
404 %defattr(644,root,root,755)
405 %{_includedir}/%{name}*
406 %attr(755,root,root) %{_libdir}/lib*.so
407 %{_libdir}/lib*.la
408 %{_infodir}/svn*
409 %{_examplesdir}/%{name}-%{version}
410
411 %files static
412 %defattr(644,root,root,755)
413 %{_libdir}/lib*.a
414
415 %if ! %{with net_client_only}
416 %files svnserve
417 %defattr(644,root,root,755)
418 %attr(755,root,root) %{_bindir}/svnserve
419 %{_mandir}/man?/svnserve*
420 %attr(754,root,root) /etc/rc.d/init.d/svnserve
421 %attr(640,root,root) %config(noreplace) %verify(not mtime md5 size) /etc/sysconfig/svnserve
422
423 %files tools
424 %defattr(644,root,root,755)
425 %attr(755,root,root) %{_bindir}/svn-hot-backup
426 /etc/bash_completion.d/%{name}
427
428 %files -n python-subversion
429 %defattr(644,root,root,755)
430 %doc tools/backup/*.py tools/examples/*.py
431 %dir %{py_sitedir}/svn
432 %dir %{py_sitedir}/libsvn
433 %{py_sitedir}/svn/*.py[co]
434 %{py_sitedir}/libsvn/*.py[co]
435 %attr(755,root,root) %{py_sitedir}/libsvn/*.so
436 %{_examplesdir}/python-%{name}-%{version}
437
438 %files -n perl-subversion
439 %defattr(644,root,root,755)
440 %{perl_vendorarch}/SVN
441 %dir %{perl_vendorarch}/auto/SVN
442 %dir %{perl_vendorarch}/auto/SVN/*
443 %attr(755,root,root) %{perl_vendorarch}/auto/SVN/*/*.so
444 %{perl_vendorarch}/auto/SVN/*/*.bs
445 %{_mandir}/man3/*.3pm*
446
447 %files -n apache-mod_dav_svn
448 %defattr(644,root,root,755)
449 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/httpd/httpd.conf/*_mod_dav_svn.conf
450 %attr(755,root,root) %{_apachelibdir}/mod_dav_svn.so
451
452 %files -n apache-mod_authz_svn
453 %defattr(644,root,root,755)
454 %doc subversion/mod_authz_svn/INSTALL
455 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/httpd/httpd.conf/*_mod_authz_svn.conf
456 %attr(755,root,root) %{_apachelibdir}/mod_authz_svn.so
457 %endif
This page took 0.064531 seconds and 4 git commands to generate.