]> git.pld-linux.org Git - packages/subversion.git/blob - subversion.spec
- rel. 4 - apache-mod_dav_svn requires some more modules (at least default
[packages/subversion.git] / subversion.spec
1 # TODO:
2 # - remove net_client_only and add db bcond (then without apache and
3 #   without db => net_client_only - spec will be more simpler, I think)
4 #
5 # Conditional build:
6 %bcond_with     net_client_only                 # build only net client
7 %bcond_without  python                          # build without python bindings
8 %bcond_without  perl                            # build without perl bindings
9 %bcond_without  apache                          # build without apache support (webdav, etc)
10 #
11 %{!?with_net_client_only:%include       /usr/lib/rpm/macros.perl}
12 %define apxs    /usr/sbin/apxs
13 %define pdir    SVN
14 %define pnam    _Core
15 Summary:        A Concurrent Versioning system similar to but better than CVS
16 Summary(pl):    System kontroli wersji podobny, ale lepszy, ni¿ CVS
17 Summary(pt_BR): Sistema de versionamento concorrente
18 Name:           subversion
19 Version:        1.4.0
20 Release:        4
21 License:        Apache/BSD Style
22 Group:          Development/Version Control
23 Source0:        http://subversion.tigris.org/downloads/%{name}-%{version}.tar.gz
24 # Source0-md5:  6f7485986776204138a1d221ac5eec40
25 Source1:        %{name}-dav_svn.conf
26 Source2:        %{name}-authz_svn.conf
27 Source3:        %{name}-svnserve.init
28 Source4:        %{name}-svnserve.sysconfig
29 Patch0:         %{name}-home_etc.patch
30 Patch1:         %{name}-DESTDIR.patch
31 Patch2:         %{name}-neon.patch
32 URL:            http://subversion.tigris.org/
33 %if %{with net_client_only}
34 %global apache_modules_api 0
35 %else
36 %{?with_apache:BuildRequires:   apache-devel >= 2.2.0-8}
37 BuildRequires:  automake
38 BuildRequires:  db-devel >= 4.1.25
39 BuildRequires:  rpmbuild(macros) >= 1.268
40 %if %{with perl}
41 BuildRequires:  perl-devel >= 1:5.8.0
42 BuildRequires:  rpm-perlprov >= 4.1-13
43 BuildRequires:  swig-perl >= 1.3.24
44 %endif
45 %endif
46 BuildRequires:  apr-devel >= 1:1.0.0
47 BuildRequires:  apr-util-devel >= 1:1.2.7-4
48 BuildRequires:  autoconf >= 2.59
49 BuildRequires:  bison
50 BuildRequires:  expat-devel
51 BuildRequires:  gettext-devel
52 BuildRequires:  libtool >= 1.4-9
53 BuildRequires:  neon-devel >= 0.26.0
54 %if %{with python}
55 BuildRequires:  python >= 2.2
56 BuildRequires:  python-devel >= 2.2
57 BuildRequires:  python-modules >= 2.2
58 BuildRequires:  sed >= 4.0
59 BuildRequires:  swig-python >= 1.3.24
60 %endif
61 BuildRequires:  texinfo
62 BuildRequires:  which
63 Requires:       %{name}-libs = %{version}-%{release}
64 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
65
66 %define         _apachelibdir   %(%{apxs} -q LIBEXECDIR 2>/dev/null)
67 %define         _libexecdir             %{_libdir}/svn
68
69 %description
70 The goal of the Subversion project is to build a version control
71 system that is a compelling replacement for CVS in the open source
72 community.
73
74 Our goals are:
75 - All current CVS features.
76 - Directories, renames, and file meta-data are versioned.
77 - Symbolic links, etc, are supported
78 - Commits are truly atomic.
79 - Branching and tagging are cheap (constant time) operations
80 - Repeated merges are handled gracefully
81 - Support for plug-in client side diff programs
82 - Natively client/server
83 - Client/server protocol sends diffs in both directions
84 - Costs are proportional to change size, not project size
85 - Internationalization
86 - Progressive multi-lingual support
87
88 %description -l pl
89 Celem projektu Subversion jest stworzenie systemu kontroli wersji jako
90 zamiennika dla CVS.
91
92 Cele projektu to:
93 - Wszystkie aktualne mo¿liwo¶ci CVS.
94 - Katalogi, zmiany nazw oraz meta-dane plików s± wersjonowane.
95 - Wsparcie dla linków symbolicznych itp.
96 - Commity s± w pe³ni atomowe.
97 - Branchowanie oraz tagowanie s± tanimi (sta³ymi w czasie) operacjami.
98 - Powtarzaj±ce merge.
99 - Wsparcie dla pluginów diff'a po stronie klienta.
100 - Natywny klient/serwer.
101 - Klient/Serwer przesy³aj± diffy w obu kierunkach.
102 - Koszty proporcjonalne do rozmiaru zmiany, a nie rozmiaru projektu.
103 - Internacjonalizacja.
104 - Postêpuj±ce wsparcie dla wielu jêzyków.
105
106 %description -l pt_BR
107 O objetivo do projeto Subversion é construir um sistema de controle de
108 versões que seja um substituto para o CVS (Concurrent Versioning
109 System) na comunidade opensource, fornecendo grandes melhorias.
110
111 %package libs
112 Summary:        Subversion libraries and modules
113 Summary(pl):    Biblioteka subversion oraz ³adowalne modu³y
114 Group:          Libraries
115 Requires:       neon >= 0.24.7
116 Obsoletes:      libsubversion0
117
118 %description libs
119 Subversion libraries and modules.
120
121 %description libs -l pl
122 Biblioteka subversion oraz ³adowalne modu³y.
123
124 %package devel
125 Summary:        Header files and develpment documentation for subversion
126 Summary(pl):    Pliki nag³ówkowe i dokumetacja do subversion
127 Summary(pt_BR): Arquivos de desenvolvimento para o Subversion
128 Group:          Development/Libraries
129 Requires:       %{name}-libs = %{version}-%{release}
130 Requires:       apr-util-devel >= 1:1.0.0
131 Requires:       neon-devel >= 0.24.7
132 Obsoletes:      libsubversion0-devel
133
134 %description devel
135 Header files and develpment documentation for subversion.
136
137 %description devel -l pl
138 Pliki nag³ówkowe i dokumetacja do subversion.
139
140 %description devel -l pt_BR
141 Este pacote provê os arquivos necessários para desenvolvedores
142 interagirem com o Subversion.
143
144 %package static
145 Summary:        Static subversion library
146 Summary(pl):    Biblioteka statyczna subversion
147 Summary(pt_BR): Sistema de versionamento concorrente
148 Group:          Development/Libraries
149 Requires:       %{name}-devel = %{version}
150 Obsoletes:      libsubversion0-static-devel
151
152 %description static
153 Static subversion library.
154
155 %description static -l pl
156 Biblioteka statyczna subversion.
157
158 %description static -l pt_BR
159 Este pacote provê um cliente estático do subversion.
160
161 %package svnserve
162 Summary:        Subversion svnserve
163 Summary(pl):    Subversion svnserve
164 Group:          Networking/Daemons
165 Requires(post,preun):   /sbin/chkconfig
166 Requires:       %{name} = %{version}-%{release}
167 Requires:       rc-scripts
168
169 %description svnserve
170 Subversion svnserve server.
171
172 %description svnserve -l pl
173 Serwer subversion svnserve.
174
175 %package tools
176 Summary:        Subversion tools and scripts
177 Summary(pl):    Narzêdzia oraz skrypty dla subversion
178 Summary(pt_BR): Módulos python para acessar os recursos do Subversion
179 Group:          Applications
180 %pyrequires_eq  python
181 Requires:       %{name} = %{version}-%{release}
182 Requires:       python-rcsparse >= 0.1-0.20031026.0
183 Requires:       python-subversion = %{version}
184
185 %description tools
186 Subversion tools and scripts.
187
188 %description tools -l pl
189 Narzêdzia oraz skrypty dla subversion.
190
191 %package -n bash-completion-subversion
192 Summary:        bash completion for subversion
193 Summary(pl):    Dope³nienia basha dla subversion
194 Group:          Applications/Shells
195 Requires:       %{name} = %{version}-%{release}
196 Requires:       bash-completion
197 Conflicts:      %{name}-tools <= 1.1.0-0.rc6.1
198
199 %description -n bash-completion-subversion
200 Bash completion for subversion.
201
202 %description -n bash-completion-subversion -l pl
203 Dope³nienia basha dla subversion.
204
205 %package -n python-subversion
206 Summary:        Subversion python bindings
207 Summary(pl):    Dowi±zania do subversion dla pythona
208 Summary(pt_BR): Módulos python para acessar os recursos do Subversion
209 Group:          Development/Languages/Python
210 %pyrequires_eq  python
211 Requires:       %{name}-libs = %{version}-%{release}
212 Obsoletes:      subversion-python
213
214 %description -n python-subversion
215 Subversion python bindings.
216
217 %description -n python-subversion -l pl
218 Dowi±zania do subversion dla pythona.
219
220 %description -n python-subversion -l pt_BR
221 Módulos python para acessar os recursos do Subversion.
222
223 %package -n perl-subversion
224 Summary:        Subversion perl bindings
225 Summary(pl):    Dowi±zania do subversion dla perla
226 Summary(pt_BR): Módulos perl para acessar os recursos do Subversion
227 Group:          Development/Languages/Perl
228 Requires:       %{name}-libs = %{version}-%{release}
229 Obsoletes:      subversion-perl
230
231 %description -n perl-subversion
232 Subversion perl bindings.
233
234 %description -n perl-subversion -l pl
235 Dowi±zania do subversion dla perl.
236
237 %description -n perl-subversion -l pt_BR
238 Módulos perl para acessar os recursos do Subversion.
239
240 %package -n apache-mod_dav_svn
241 Summary:        Apache module: Subversion Server
242 Summary(pl):    Modu³ apache: Serwer Subversion
243 Group:          Networking/Daemons
244 Requires:       %{name} = %{version}-%{release}
245 Requires:       apache(modules-api) = %apache_modules_api
246 Requires:       apache-mod_authn_file
247 Requires:       apache-mod_dav
248 Requires:       apache-mod_setenvif
249
250 %description -n apache-mod_dav_svn
251 Apache module: Subversion Server.
252
253 %description -n apache-mod_dav_svn -l pl
254 Modu³ apache: Serwer Subversion.
255
256 %package -n apache-mod_authz_svn
257 Summary:        Apache module: Subversion Server - path-based authorization
258 Summary(pl):    Modu³ apache: autoryzacja na podstawie ¶cie¿ki dla serwera Subversion
259 Group:          Networking/Daemons
260 Requires:       apache(modules-api) = %apache_modules_api
261 Requires:       apache-mod_dav_svn = %{version}-%{release}
262
263 %description -n apache-mod_authz_svn
264 Apache module: Subversion Server - path-based authorization.
265
266 %description -n apache-mod_authz_svn -l pl
267 Modu³ apache: autoryzacja na podstawie ¶cie¿ki dla serwera Subversion.
268
269 %prep
270 %setup -q
271 rm -rf apr apr-util neon
272 %patch0 -p0
273 %patch1 -p1
274 %patch2 -p1
275
276 %build
277 cp -f /usr/share/automake/config.sub ac-helpers
278 chmod +x ./autogen.sh && ./autogen.sh
279
280 # don't enable dso - currently it's broken
281 %configure \
282         --with-editor=vi \
283         --with-zlib \
284         --with-python=%{_bindir}/python \
285         --with-perl5=%{_bindir}/perl \
286 %if %{with net_client_only}
287         --without-apache \
288         --without-swig \
289         --without-apxs \
290         --without-berkeley-db \
291 %else
292         --disable-dso \
293         --disable-mod-activation \
294 %if %{with apache}
295         --with-apxs=%{_sbindir}/apxs \
296 %else
297         --without-apache \
298         --without-apxs \
299         --with-berkeley-db=%{_includedir}/db4:%{_libdir} \
300 %endif
301 %if %{without python} && %{without perl}
302         --without-swig \
303 %endif
304 %endif
305         --with-neon=%{_prefix} \
306         --disable-neon-version-check \
307         --with-apr=%{_bindir}/apr-1-config \
308         --with-apr-util=%{_bindir}/apu-1-config
309
310 %{__make} -j1
311
312 %if %{without net_client_only}
313 # python
314 %if %{with python}
315 %{__make} swig-py \
316         swig_pydir=%{py_sitedir}/libsvn \
317         swig_pydir_extra=%{py_sitedir}/svn
318 %endif
319 # perl
320 %if %{with perl}
321 %{__make} swig-pl-lib
322 odir=$(pwd)
323 cd subversion/bindings/swig/perl/native
324 %{__perl} Makefile.PL INSTALLDIRS=vendor
325 %{__make}
326 cd $odir
327 %endif
328 %endif
329
330 %install
331 rm -rf $RPM_BUILD_ROOT
332 install -d $RPM_BUILD_ROOT/etc/{rc.d/init.d,sysconfig,bash_completion.d} \
333         $RPM_BUILD_ROOT{%{_sysconfdir}/httpd/httpd.conf,%{_apachelibdir},%{_infodir}} \
334         $RPM_BUILD_ROOT%{_examplesdir}/{%{name}-%{version},python-%{name}-%{version}} \
335         $RPM_BUILD_ROOT/home/services/subversion{,/repos}
336
337 %{__make} install -j1 \
338 %if %{without net_client_only} && %{with python}
339         install-swig-py \
340 %endif
341         APACHE_LIBEXECDIR="$(%{_sbindir}/apxs -q LIBEXECDIR)" \
342         DESTDIR=$RPM_BUILD_ROOT \
343         swig_pydir=%{py_sitedir}/libsvn \
344         swig_pydir_extra=%{py_sitedir}/svn
345
346 %if %{without net_client_only} && %{with perl}
347 %{__make} install-swig-pl-lib \
348         DESTDIR=$RPM_BUILD_ROOT
349 odir=$(pwd)
350 cd subversion/bindings/swig/perl/native
351 %{__make} install \
352         DESTDIR=$RPM_BUILD_ROOT \
353         PREFIX=$RPM_BUILD_ROOT%{_prefix} \
354         LIBDIR=$RPM_BUILD_ROOT%{_libdir}
355 cd $odir
356 %endif
357
358 %if %{with apache}
359 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/httpd/httpd.conf/65_mod_dav_svn.conf
360 install %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/httpd/httpd.conf/66_mod_authz_svn.conf
361 install %{SOURCE3} $RPM_BUILD_ROOT/etc/rc.d/init.d/svnserve
362 install %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/svnserve
363 %endif
364
365 %if %{without net_client_only}
366 install tools/backup/hot-backup.py $RPM_BUILD_ROOT%{_bindir}/svn-hot-backup
367 %if %{with python}
368 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
369 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
370 find $RPM_BUILD_ROOT%{py_sitedir} -name "*.py" -o -name "*.a" -o -name "*.la" | xargs rm -f
371 install tools/examples/*.py $RPM_BUILD_ROOT%{_examplesdir}/python-%{name}-%{version}
372 %endif
373 %endif
374
375 install tools/client-side/bash_completion $RPM_BUILD_ROOT/etc/bash_completion.d/%{name}
376 install tools/examples/*.c $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
377
378 %find_lang %{name}
379
380 %clean
381 rm -rf $RPM_BUILD_ROOT
382
383 %post devel
384 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
385
386 %postun devel
387 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
388
389 %post   libs -p /sbin/ldconfig
390 %postun libs -p /sbin/ldconfig
391 %post   -n python-subversion -p /sbin/ldconfig
392 %postun -n perl-subversion -p /sbin/ldconfig
393
394 %post svnserve
395 /sbin/chkconfig --add svnserve
396 %service svnserve restart "svnserve daemon"
397
398 %preun svnserve
399 if [ "$1" = "0" ]; then
400         %service svnserve stop
401         /sbin/chkconfig --del svnserve
402 fi
403
404 %post -n apache-mod_dav_svn
405 %service -q httpd restart
406
407 %preun -n apache-mod_dav_svn
408 if [ "$1" = "0" ]; then
409         %service -q httpd restart
410 fi
411
412 %files
413 %defattr(644,root,root,755)
414 %doc BUGS CHANGES COPYING INSTALL README
415 %doc doc/*/*.html
416 %doc tools/hook-scripts/*.{pl,py,example}
417 %doc tools/hook-scripts/mailer/*.{py,example}
418 %doc tools/xslt/*
419 %attr(755,root,root) %{_bindir}/svn*
420 %exclude %{_bindir}/svnserve
421 %if %{without net_client_only}
422 %exclude %{_bindir}/svn-hot-backup
423 %endif
424 %{_mandir}/man1/*
425 %{_mandir}/man5/*
426 %{_mandir}/man8/*
427 %exclude %{_mandir}/man?/svnserve*
428
429 %files libs -f %{name}.lang
430 %defattr(644,root,root,755)
431 %attr(755,root,root) %{_libdir}/lib*.so.*
432 %if %{with perl} || %{with python}
433 %exclude %{_libdir}/lib*_swig_*.so.*
434 %endif
435
436 %files devel
437 %defattr(644,root,root,755)
438 %{_includedir}/%{name}*
439 %attr(755,root,root) %{_libdir}/lib*.so
440 %{_libdir}/lib*.la
441 %if %{with perl} || %{with python}
442 %exclude %{_libdir}/lib*_swig_*.so
443 %exclude %{_libdir}/lib*swig*.la
444 %endif
445 %{_examplesdir}/%{name}-%{version}
446
447 %files static
448 %defattr(644,root,root,755)
449 %{_libdir}/lib*.a
450
451 %if %{without net_client_only}
452 %files svnserve
453 %defattr(644,root,root,755)
454 %attr(755,root,root) %{_bindir}/svnserve
455 %{_mandir}/man?/svnserve*
456 %dir /home/services/subversion
457 %dir /home/services/subversion/repos
458 %if %{with apache}
459 %attr(754,root,root) /etc/rc.d/init.d/svnserve
460 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/svnserve
461 %endif
462
463 %files tools
464 %defattr(644,root,root,755)
465 %attr(755,root,root) %{_bindir}/svn-hot-backup
466
467 %files -n bash-completion-subversion
468 %defattr(644,root,root,755)
469 /etc/bash_completion.d/%{name}
470
471 %if %{with python}
472 %files -n python-subversion
473 %defattr(644,root,root,755)
474 %doc tools/backup/*.py tools/examples/*.py
475 %dir %{py_sitedir}/svn
476 %dir %{py_sitedir}/libsvn
477 %{py_sitedir}/svn/*.py[co]
478 %{py_sitedir}/libsvn/*.py[co]
479 %attr(755,root,root) %{py_sitedir}/libsvn/*.so
480 %{_examplesdir}/python-%{name}-%{version}
481 %attr(755,root,root) %{_libdir}/lib*_swig_py*.so*
482 %{_libdir}/lib*_swig_py*.la
483 %endif
484
485 %if %{with perl}
486 %files -n perl-subversion
487 %defattr(644,root,root,755)
488 %{perl_vendorarch}/SVN
489 %dir %{perl_vendorarch}/auto/SVN
490 %dir %{perl_vendorarch}/auto/SVN/*
491 %attr(755,root,root) %{perl_vendorarch}/auto/SVN/*/*.so
492 %{perl_vendorarch}/auto/SVN/*/*.bs
493 %{_mandir}/man3/*.3pm*
494 %attr(755,root,root) %{_libdir}/lib*_swig_perl*.so*
495 %{_libdir}/lib*_swig_perl*.la
496 %endif
497
498 %if %{with apache}
499 %files -n apache-mod_dav_svn
500 %defattr(644,root,root,755)
501 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/httpd/httpd.conf/*_mod_dav_svn.conf
502 %attr(755,root,root) %{_apachelibdir}/mod_dav_svn.so
503
504 %files -n apache-mod_authz_svn
505 %defattr(644,root,root,755)
506 %doc subversion/mod_authz_svn/INSTALL
507 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/httpd/httpd.conf/*_mod_authz_svn.conf
508 %attr(755,root,root) %{_apachelibdir}/mod_authz_svn.so
509 %endif
510
511 %endif # net_client_only
This page took 0.085182 seconds and 3 git commands to generate.