]> git.pld-linux.org Git - packages/subversion.git/blob - subversion.spec
ec4769ee0788e4776166c9fd072b6d67606f5259
[packages/subversion.git] / subversion.spec
1 # TODO:
2 # - remove net_client_only and add db bcond (then without apache and
3 #   without db => net_client_only - spec will be more simpler, I think)
4 # - finish ruby
5 #
6 # Conditional build:
7 %bcond_with     net_client_only         # build only net client
8 %bcond_without  python                  # build without python bindings (broken)
9 %bcond_without  perl                    # build without perl bindings
10 %bcond_without  ruby                    # build without ruby bindings
11 %bcond_without  apache                  # build without apache support (webdav, etc)
12 %bcond_without  javahl                  # build without javahl support (Java high-level bindings)
13 %bcond_without  tests                   # don't perform "make check"
14 #
15 %ifnarch i586 i686 pentium3 pentium4 athlon %{x8664}
16 %undefine       with_javahl
17 %endif
18 #
19 %{!?with_net_client_only:%include       /usr/lib/rpm/macros.perl}
20 %define apxs    /usr/sbin/apxs
21 %define pdir    SVN
22 %define pnam    _Core
23 #
24 Summary:        A Concurrent Versioning system similar to but better than CVS
25 Summary(pl.UTF-8):      System kontroli wersji podobny, ale lepszy, niż CVS
26 Summary(pt_BR.UTF-8):   Sistema de versionamento concorrente
27 Name:           subversion
28 Version:        1.5.0
29 Release:        1
30 License:        Apache/BSD-like
31 Group:          Development/Version Control
32 Source0:        http://subversion.tigris.org/downloads/%{name}-%{version}.tar.bz2
33 # Source0-md5:  004b57643406dd10957ec87955702189
34 Source1:        %{name}-dav_svn.conf
35 Source2:        %{name}-authz_svn.conf
36 Source3:        %{name}-svnserve.init
37 Source4:        %{name}-svnserve.sysconfig
38 Source5:        %{name}-convert-typemaps-to-ifdef.py
39 Patch0:         %{name}-home_etc.patch
40 Patch1:         %{name}-DESTDIR.patch
41 URL:            http://subversion.tigris.org/
42 %if %{with net_client_only}
43 %global apache_modules_api 0
44 %else
45 %{?with_apache:BuildRequires:   apache-devel >= 2.2.0-8}
46 BuildRequires:  automake
47 BuildRequires:  db-devel >= 4.1.25
48 BuildRequires:  rpmbuild(macros) >= 1.268
49 %if %{with perl}
50 BuildRequires:  perl-devel >= 1:5.8.0
51 BuildRequires:  rpm-perlprov >= 4.1-13
52 BuildRequires:  swig-perl >= 1.3.24
53 %endif
54 %{?with_javahl:BuildRequires:   jdk}
55 %endif
56 BuildRequires:  apr-devel >= 1:1.0.0
57 BuildRequires:  apr-util-devel >= 1:1.2.8-3
58 BuildRequires:  autoconf >= 2.59
59 BuildRequires:  bison
60 BuildRequires:  cyrus-sasl-devel
61 BuildRequires:  expat-devel
62 BuildRequires:  gettext-devel
63 BuildRequires:  libtool >= 1.4-9
64 BuildRequires:  neon-devel >= 0.26.0
65 BuildRequires:  python >= 2.2
66 BuildRequires:  python-modules >= 2.2
67 %if %{with python}
68 BuildRequires:  python-devel >= 2.2
69 BuildRequires:  sed >= 4.0
70 BuildRequires:  swig-python >= 1.3.24
71 %endif
72 %{?with_ruby:BuildRequires:     swig-ruby >= 1.3.24}
73 BuildRequires:  texinfo
74 BuildRequires:  which
75 Requires:       %{name}-libs = %{version}-%{release}
76 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
77
78 %define         _libexecdir             %{_libdir}/svn
79 %define         apacheconfdir   %(%{apxs} -q SYSCONFDIR 2>/dev/null)/conf.d
80 %define         apachelibdir    %(%{apxs} -q LIBEXECDIR 2>/dev/null)
81
82 %description
83 The goal of the Subversion project is to build a version control
84 system that is a compelling replacement for CVS in the open source
85 community.
86
87 Our goals are:
88 - All current CVS features.
89 - Directories, renames, and file meta-data are versioned.
90 - Symbolic links, etc, are supported
91 - Commits are truly atomic.
92 - Branching and tagging are cheap (constant time) operations
93 - Repeated merges are handled gracefully
94 - Support for plug-in client side diff programs
95 - Natively client/server
96 - Client/server protocol sends diffs in both directions
97 - Costs are proportional to change size, not project size
98 - Internationalization
99 - Progressive multi-lingual support
100
101 %description -l pl.UTF-8
102 Celem projektu Subversion jest stworzenie systemu kontroli wersji jako
103 zamiennika dla CVS.
104
105 Cele projektu to:
106 - Wszystkie aktualne możliwości CVS.
107 - Katalogi, zmiany nazw oraz metadane plików są wersjonowane.
108 - Obsługa dowiązań symbolicznych itp.
109 - Commity są w pełni atomowe.
110 - Branchowanie oraz tagowanie są tanimi (stałymi w czasie) operacjami.
111 - Dobra obsługa powtarzanego łączenia (merge).
112 - Obsługa wtyczek diff po stronie klienta.
113 - Natywny klient/serwer.
114 - Klient/Serwer przesyłają diffy w obu kierunkach.
115 - Koszty proporcjonalne do rozmiaru zmiany, a nie rozmiaru projektu.
116 - Internacjonalizacja.
117 - Postępujące wsparcie dla wielu języków.
118
119 %description -l pt_BR.UTF-8
120 O objetivo do projeto Subversion é construir um sistema de controle de
121 versões que seja um substituto para o CVS (Concurrent Versioning
122 System) na comunidade opensource, fornecendo grandes melhorias.
123
124 %package libs
125 Summary:        Subversion libraries and modules
126 Summary(pl.UTF-8):      Biblioteka subversion oraz ładowalne moduły
127 Group:          Libraries
128 Requires:       neon >= 0.26.0
129 Obsoletes:      libsubversion0
130
131 %description libs
132 Subversion libraries and modules.
133
134 %description libs -l pl.UTF-8
135 Biblioteka subversion oraz ładowalne moduły.
136
137 %package devel
138 Summary:        Header files and develpment documentation for subversion
139 Summary(pl.UTF-8):      Pliki nagłówkowe i dokumetacja do subversion
140 Summary(pt_BR.UTF-8):   Arquivos de desenvolvimento para o Subversion
141 Group:          Development/Libraries
142 Requires:       %{name}-libs = %{version}-%{release}
143 Requires:       apr-util-devel >= 1:1.0.0
144 Requires:       neon-devel >= 0.26.0
145 Obsoletes:      libsubversion0-devel
146
147 %description devel
148 Header files and develpment documentation for subversion.
149
150 %description devel -l pl.UTF-8
151 Pliki nagłówkowe i dokumetacja do subversion.
152
153 %description devel -l pt_BR.UTF-8
154 Este pacote provê os arquivos necessários para desenvolvedores
155 interagirem com o Subversion.
156
157 %package static
158 Summary:        Static subversion library
159 Summary(pl.UTF-8):      Biblioteka statyczna subversion
160 Summary(pt_BR.UTF-8):   Sistema de versionamento concorrente
161 Group:          Development/Libraries
162 Requires:       %{name}-devel = %{version}
163 Obsoletes:      libsubversion0-static-devel
164
165 %description static
166 Static subversion library.
167
168 %description static -l pl.UTF-8
169 Biblioteka statyczna subversion.
170
171 %description static -l pt_BR.UTF-8
172 Este pacote provê um cliente estático do subversion.
173
174 %package svnserve
175 Summary:        Subversion svnserve
176 Summary(pl.UTF-8):      Subversion svnserve
177 Group:          Networking/Daemons
178 Requires(post,preun):   /sbin/chkconfig
179 Requires(postun):       /usr/sbin/groupdel
180 Requires(postun):       /usr/sbin/userdel
181 Requires(pre):  /bin/id
182 Requires(pre):  /usr/bin/getgid
183 Requires(pre):  /usr/lib/rpm/user_group.sh
184 Requires(pre):  /usr/sbin/groupadd
185 Requires(pre):  /usr/sbin/useradd
186 Requires(pre):  /usr/sbin/usermod
187 Requires:       %{name} = %{version}-%{release}
188 Requires:       rc-scripts
189 Provides:       group(svn)
190 Provides:       user(svn)
191
192 %description svnserve
193 Subversion svnserve server.
194
195 %description svnserve -l pl.UTF-8
196 Serwer subversion svnserve.
197
198 %package tools
199 Summary:        Subversion tools and scripts
200 Summary(pl.UTF-8):      Narzędzia oraz skrypty dla subversion
201 Summary(pt_BR.UTF-8):   Módulos python para acessar os recursos do Subversion
202 Group:          Applications
203 %pyrequires_eq  python
204 Requires:       %{name} = %{version}-%{release}
205 Requires:       python-rcsparse >= 0.1-0.20031026.0
206 Requires:       python-subversion = %{version}
207
208 %description tools
209 Subversion tools and scripts.
210
211 %description tools -l pl.UTF-8
212 Narzędzia oraz skrypty dla subversion.
213
214 %package -n bash-completion-subversion
215 Summary:        bash completion for subversion
216 Summary(pl.UTF-8):      Dopełnienia basha dla subversion
217 Group:          Applications/Shells
218 Requires:       %{name} = %{version}-%{release}
219 Requires:       bash-completion
220 Conflicts:      %{name}-tools <= 1.1.0-0.rc6.1
221
222 %description -n bash-completion-subversion
223 Bash completion for subversion.
224
225 %description -n bash-completion-subversion -l pl.UTF-8
226 Dopełnienia basha dla subversion.
227
228 %package -n java-subversion
229 Summary:        Subversion Java bindings
230 Summary(pl.UTF-8):      Dowiązania do Subversion dla Javy
231 Group:          Development/Languages/Java
232 Requires:       %{name}-libs = %{version}-%{release}
233
234 %description -n java-subversion
235 This is a set of Java classes which provide the functionality of
236 subversion-libs, the Subversion libraries. It is useful if you want
237 to, for example, write a Java class that manipulates a Subversion
238 repository or working copy. See the 'subversion' package for more
239 information.
240
241 %description -n java-subversion -l pl.UTF-8
242 Ten pakiet zawiera zestaw klas Javy udostępniających funkcjonalność
243 subversion-libs, czyli bibliotek Subversion. Jest przydatny przy
244 pisaniu klas Javy np. modyfikujących repozytorium Subversion lub kopię
245 roboczą. Więcej informacji w pakiecie subversion.
246
247 %package -n python-subversion
248 Summary:        Subversion Python bindings
249 Summary(pl.UTF-8):      Dowiązania do Subversion dla Pythona
250 Summary(pt_BR.UTF-8):   Módulos Python para acessar os recursos do Subversion
251 Group:          Development/Languages/Python
252 %pyrequires_eq  python
253 Requires:       %{name}-libs = %{version}-%{release}
254 Obsoletes:      subversion-python
255
256 %description -n python-subversion
257 Subversion Python bindings.
258
259 %description -n python-subversion -l pl.UTF-8
260 Dowiązania do Subversion dla Pythona.
261
262 %description -n python-subversion -l pt_BR.UTF-8
263 Módulos Python para acessar os recursos do Subversion.
264
265 %package -n perl-subversion
266 Summary:        Subversion Perl bindings
267 Summary(pl.UTF-8):      Dowiązania do Subversion dla Perla
268 Summary(pt_BR.UTF-8):   Módulos Perl para acessar os recursos do Subversion
269 Group:          Development/Languages/Perl
270 Requires:       %{name}-libs = %{version}-%{release}
271 Obsoletes:      subversion-perl
272
273 %description -n perl-subversion
274 Subversion Perl bindings.
275
276 %description -n perl-subversion -l pl.UTF-8
277 Dowiązania do Subversion dla Perla.
278
279 %description -n perl-subversion -l pt_BR.UTF-8
280 Módulos Perl para acessar os recursos do Subversion.
281
282 %package -n ruby-subversion
283 Summary:        Subversion Ruby bindings
284 Summary(pl.UTF-8):      Dowiązania do Subversion dla języka Ruby
285 Summary(pt_BR.UTF-8):   Módulos Ruby para acessar os recursos do Subversion
286 Group:          Development/Languages
287 Requires:       %{name}-libs = %{version}-%{release}
288 Obsoletes:      subversion-ruby
289
290 %description -n ruby-subversion
291 Subversion Ruby bindings.
292
293 %description -n ruby-subversion -l pl.UTF-8
294 Dowiązania do Subversion dla języka Ruby.
295
296 %description -n ruby-subversion -l pt_BR.UTF-8
297 Módulos Ruby para acessar os recursos do Subversion.
298
299 %package -n apache-mod_dav_svn
300 Summary:        Apache module: Subversion Server
301 Summary(pl.UTF-8):      Moduł apache: Serwer Subversion
302 Group:          Networking/Daemons
303 Requires:       %{name} = %{version}-%{release}
304 Requires:       apache(modules-api) = %apache_modules_api
305 Requires:       apache-mod_dav
306
307 %description -n apache-mod_dav_svn
308 Apache module: Subversion Server.
309
310 %description -n apache-mod_dav_svn -l pl.UTF-8
311 Moduł apache: Serwer Subversion.
312
313 %package -n apache-mod_authz_svn
314 Summary:        Apache module: Subversion Server - path-based authorization
315 Summary(pl.UTF-8):      Moduł apache: autoryzacja na podstawie ścieżki dla serwera Subversion
316 Group:          Networking/Daemons
317 Requires:       apache(modules-api) = %apache_modules_api
318 Requires:       apache-mod_dav_svn = %{version}-%{release}
319
320 %description -n apache-mod_authz_svn
321 Apache module: Subversion Server - path-based authorization.
322
323 %description -n apache-mod_authz_svn -l pl.UTF-8
324 Moduł apache: autoryzacja na podstawie ścieżki dla serwera Subversion.
325
326 %prep
327 %setup -q
328 rm -rf apr apr-util neon
329 %patch0 -p0
330 %patch1 -p1
331
332 %build
333 rm subversion/bindings/swig/proxy/*.swg
334 cd subversion/bindings/swig && python "%{SOURCE5}" && cd ../../..
335 cp -f /usr/share/automake/config.sub ac-helpers
336 chmod +x ./autogen.sh && ./autogen.sh
337
338 %configure \
339         --with-editor=vi \
340         --with-zlib=%{_libdir} \
341 %if %{with net_client_only}
342         --without-apache \
343         --without-swig \
344         --without-apxs \
345         --without-berkeley-db \
346 %else
347         --disable-runtime-module-search \
348         --disable-mod-activation \
349 %if %{with apache}
350         --with-apxs=%{_sbindir}/apxs \
351 %else
352         --without-apache \
353         --without-apxs \
354         --with-berkeley-db=%{_includedir}/db4:%{_libdir} \
355 %endif
356 %if !%{with python} && !%{with perl} && !%{with ruby}
357         --without-swig \
358 %endif
359         --%{?with_javahl:en}%{!?with_javahl:dis}able-javahl \
360 %endif
361         --with-jdk="%{java_home}" \
362         --with-neon=%{_prefix} \
363         --disable-neon-version-check \
364         --with-apr=%{_bindir}/apr-1-config \
365         --with-apr-util=%{_bindir}/apu-1-config
366
367 %{__make} -j1
368
369 %if !%{with net_client_only}
370 # python
371 %if %{with python}
372 %{__make} swig-py \
373         swig_pydir=%{py_sitedir}/libsvn \
374         swig_pydir_extra=%{py_sitedir}/svn
375 %endif
376 # perl
377 %if %{with perl}
378 %{__make} swig-pl-lib
379 odir=$(pwd)
380 cd subversion/bindings/swig/perl/native
381 %{__perl} Makefile.PL INSTALLDIRS=vendor
382 %{__make} -j1
383 cd $odir
384 %endif
385 %if %{with javahl}
386 %{__make} -j1 javahl \
387         javahl_javadir="%{_javadir}"
388 %endif
389 # ruby
390 %if %{with ruby}
391 %{__make} swig-rb
392 %endif
393 %endif
394
395 %if %{with tests}
396 %{__make} check
397 %if %{with python}
398 %{__make} check-swig-py
399 %endif
400 %if %{with perl}
401 %{__make} check-swig-pl
402 %endif
403 %if %{with ruby}
404 %{__make} check-swig-rb
405 %endif
406 %endif
407
408 %install
409 rm -rf $RPM_BUILD_ROOT
410 install -d $RPM_BUILD_ROOT/etc/{rc.d/init.d,sysconfig,bash_completion.d} \
411         $RPM_BUILD_ROOT{%{apacheconfdir},%{apachelibdir},%{_infodir}} \
412         $RPM_BUILD_ROOT%{_examplesdir}/{%{name}-%{version},python-%{name}-%{version}} \
413         $RPM_BUILD_ROOT/home/services/subversion{,/repos}
414
415 %{__make} install -j1 \
416 %if %{with javahl}
417         install-javahl \
418         javahl_javadir="%{_javadir}" \
419 %endif
420 %if !%{with net_client_only}
421 %if %{with python}
422         install-swig-py \
423 %endif
424 %if %{with ruby}
425         install-swig-rb install-swig-rb-doc \
426 %endif
427 %endif
428         APACHE_LIBEXECDIR="$(%{_sbindir}/apxs -q LIBEXECDIR)" \
429         DESTDIR=$RPM_BUILD_ROOT \
430         swig_pydir=%{py_sitedir}/libsvn \
431         swig_pydir_extra=%{py_sitedir}/svn
432
433 %if !%{with net_client_only} && %{with perl}
434 %{__make} install-swig-pl-lib \
435         DESTDIR=$RPM_BUILD_ROOT
436 %{__make} -C subversion/bindings/swig/perl/native install \
437         DESTDIR=$RPM_BUILD_ROOT \
438         PREFIX=$RPM_BUILD_ROOT%{_prefix} \
439         LIBDIR=$RPM_BUILD_ROOT%{_libdir}
440 %endif
441
442 %if %{with apache}
443 install %{SOURCE1} $RPM_BUILD_ROOT%{apacheconfdir}/65_mod_dav_svn.conf
444 install %{SOURCE2} $RPM_BUILD_ROOT%{apacheconfdir}/66_mod_authz_svn.conf
445 install %{SOURCE3} $RPM_BUILD_ROOT/etc/rc.d/init.d/svnserve
446 install %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/svnserve
447 %endif
448
449 %if !%{with net_client_only}
450 install tools/backup/hot-backup.py $RPM_BUILD_ROOT%{_bindir}/svn-hot-backup
451 %if %{with python}
452 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
453 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
454 find $RPM_BUILD_ROOT%{py_sitedir} -name "*.py" -o -name "*.a" -o -name "*.la" | xargs rm -f
455 install tools/examples/*.py $RPM_BUILD_ROOT%{_examplesdir}/python-%{name}-%{version}
456 %endif
457 %endif
458
459 install tools/client-side/bash_completion $RPM_BUILD_ROOT/etc/bash_completion.d/%{name}
460 install tools/examples/*.c $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
461
462 %find_lang %{name}
463
464 rm -f $RPM_BUILD_ROOT%{_libdir}/libsvn{javahl,_swig}*.{la,a}
465 rm -f $RPM_BUILD_ROOT%{_libdir}/ruby/site_ruby/svn/ext/*.la
466
467 %clean
468 rm -rf $RPM_BUILD_ROOT
469
470 %pre svnserve
471 %groupadd -g 86 svn
472 %useradd -u 180 -d /home/services/subversion -c "Subversion svnserve" -g svn svn
473
474 %post   libs -p /sbin/ldconfig
475 %postun libs -p /sbin/ldconfig
476
477 %post   devel -p /sbin/postshell
478 -/usr/sbin/fix-info-dir -c %{_infodir}
479
480 %postun devel -p /sbin/postshell
481 -/usr/sbin/fix-info-dir -c %{_infodir}
482
483 %post   -n perl-subversion -p /sbin/ldconfig
484 %postun -n perl-subversion -p /sbin/ldconfig
485
486 %post   -n python-subversion -p /sbin/ldconfig
487 %postun -n python-subversion -p /sbin/ldconfig
488
489 %post svnserve
490 /sbin/chkconfig --add svnserve
491 %service svnserve restart "svnserve daemon"
492
493 %preun svnserve
494 if [ "$1" = "0" ]; then
495         %service svnserve stop
496         /sbin/chkconfig --del svnserve
497 fi
498
499 %postun svnserve
500 if [ "$1" = "0" ]; then
501         %userremove svn
502         %groupremove svn
503 fi
504
505 %post -n apache-mod_dav_svn
506 %service -q httpd restart
507
508 %preun -n apache-mod_dav_svn
509 if [ "$1" = "0" ]; then
510         %service -q httpd restart
511 fi
512
513 %files
514 %defattr(644,root,root,755)
515 %doc BUGS CHANGES COPYING INSTALL README
516 %doc doc/*/*.html
517 %doc tools/hook-scripts/*.{pl,py,example}
518 %doc tools/hook-scripts/mailer/*.{py,example}
519 %doc tools/xslt/*
520 %attr(755,root,root) %{_bindir}/svn
521 %attr(755,root,root) %{_bindir}/svnadmin
522 %attr(755,root,root) %{_bindir}/svndumpfilter
523 %attr(755,root,root) %{_bindir}/svnlook
524 %attr(755,root,root) %{_bindir}/svnsync
525 %attr(755,root,root) %{_bindir}/svnversion
526 %{_mandir}/man1/svn.1*
527 %{_mandir}/man1/svnadmin.1*
528 %{_mandir}/man1/svndumpfilter.1*
529 %{_mandir}/man1/svnlook.1*
530 %{_mandir}/man1/svnsync.1*
531 %{_mandir}/man1/svnversion.1*
532
533 %files libs -f %{name}.lang
534 %defattr(644,root,root,755)
535 %attr(755,root,root) %{_libdir}/libsvn_client-1.so.*.*.*
536 %attr(755,root,root) %ghost %{_libdir}/libsvn_client-1.so.0
537 %attr(755,root,root) %{_libdir}/libsvn_delta-1.so.*.*.*
538 %attr(755,root,root) %ghost %{_libdir}/libsvn_delta-1.so.0
539 %attr(755,root,root) %{_libdir}/libsvn_diff-1.so.*.*.*
540 %attr(755,root,root) %ghost %{_libdir}/libsvn_diff-1.so.0
541 %attr(755,root,root) %{_libdir}/libsvn_fs-1.so.*.*.*
542 %attr(755,root,root) %ghost %{_libdir}/libsvn_fs-1.so.0
543 %attr(755,root,root) %{_libdir}/libsvn_fs_base-1.so.*.*.*
544 %attr(755,root,root) %ghost %{_libdir}/libsvn_fs_base-1.so.0
545 %attr(755,root,root) %{_libdir}/libsvn_fs_fs-1.so.*.*.*
546 %attr(755,root,root) %ghost %{_libdir}/libsvn_fs_fs-1.so.0
547 %attr(755,root,root) %{_libdir}/libsvn_fs_util-1.so.*.*.*
548 %attr(755,root,root) %ghost %{_libdir}/libsvn_fs_util-1.so.0
549 %attr(755,root,root) %{_libdir}/libsvn_ra-1.so.*.*.*
550 %attr(755,root,root) %ghost %{_libdir}/libsvn_ra-1.so.0
551 %attr(755,root,root) %{_libdir}/libsvn_ra_local-1.so.*.*.*
552 %attr(755,root,root) %ghost %{_libdir}/libsvn_ra_local-1.so.0
553 %attr(755,root,root) %{_libdir}/libsvn_ra_neon-1.so.*.*.*
554 %attr(755,root,root) %ghost %{_libdir}/libsvn_ra_neon-1.so.0
555 %attr(755,root,root) %{_libdir}/libsvn_ra_svn-1.so.*.*.*
556 %attr(755,root,root) %ghost %{_libdir}/libsvn_ra_svn-1.so.0
557 %attr(755,root,root) %{_libdir}/libsvn_repos-1.so.*.*.*
558 %attr(755,root,root) %ghost %{_libdir}/libsvn_repos-1.so.0
559 %attr(755,root,root) %{_libdir}/libsvn_subr-1.so.*.*.*
560 %attr(755,root,root) %ghost %{_libdir}/libsvn_subr-1.so.0
561 %attr(755,root,root) %{_libdir}/libsvn_wc-1.so.*.*.*
562 %attr(755,root,root) %ghost %{_libdir}/libsvn_wc-1.so.0
563
564 %files devel
565 %defattr(644,root,root,755)
566 %attr(755,root,root) %{_libdir}/libsvn_client-1.so
567 %attr(755,root,root) %{_libdir}/libsvn_delta-1.so
568 %attr(755,root,root) %{_libdir}/libsvn_diff-1.so
569 %attr(755,root,root) %{_libdir}/libsvn_fs-1.so
570 %attr(755,root,root) %{_libdir}/libsvn_fs_base-1.so
571 %attr(755,root,root) %{_libdir}/libsvn_fs_fs-1.so
572 %attr(755,root,root) %{_libdir}/libsvn_fs_util-1.so
573 %attr(755,root,root) %{_libdir}/libsvn_ra-1.so
574 %attr(755,root,root) %{_libdir}/libsvn_ra_local-1.so
575 %attr(755,root,root) %{_libdir}/libsvn_ra_neon-1.so
576 %attr(755,root,root) %{_libdir}/libsvn_ra_svn-1.so
577 %attr(755,root,root) %{_libdir}/libsvn_repos-1.so
578 %attr(755,root,root) %{_libdir}/libsvn_subr-1.so
579 %attr(755,root,root) %{_libdir}/libsvn_wc-1.so
580 %{_libdir}/libsvn_client-1.la
581 %{_libdir}/libsvn_delta-1.la
582 %{_libdir}/libsvn_diff-1.la
583 %{_libdir}/libsvn_fs-1.la
584 %{_libdir}/libsvn_fs_base-1.la
585 %{_libdir}/libsvn_fs_fs-1.la
586 %{_libdir}/libsvn_fs_util-1.la
587 %{_libdir}/libsvn_ra-1.la
588 %{_libdir}/libsvn_ra_local-1.la
589 %{_libdir}/libsvn_ra_neon-1.la
590 %{_libdir}/libsvn_ra_svn-1.la
591 %{_libdir}/libsvn_repos-1.la
592 %{_libdir}/libsvn_subr-1.la
593 %{_libdir}/libsvn_wc-1.la
594 %{_includedir}/%{name}-1
595 %{_examplesdir}/%{name}-%{version}
596
597 %files static
598 %defattr(644,root,root,755)
599 %{_libdir}/libsvn_client-1.a
600 %{_libdir}/libsvn_delta-1.a
601 %{_libdir}/libsvn_diff-1.a
602 %{_libdir}/libsvn_fs-1.a
603 %{_libdir}/libsvn_fs_base-1.a
604 %{_libdir}/libsvn_fs_fs-1.a
605 %{_libdir}/libsvn_fs_util-1.a
606 %{_libdir}/libsvn_ra-1.a
607 %{_libdir}/libsvn_ra_local-1.a
608 %{_libdir}/libsvn_ra_neon-1.a
609 %{_libdir}/libsvn_ra_svn-1.a
610 %{_libdir}/libsvn_repos-1.a
611 %{_libdir}/libsvn_subr-1.a
612 %{_libdir}/libsvn_wc-1.a
613
614 %if !%{with net_client_only}
615 %files svnserve
616 %defattr(644,root,root,755)
617 %attr(755,root,root) %{_bindir}/svnserve
618 %{_mandir}/man5/svnserve.conf.5*
619 %{_mandir}/man8/svnserve.8*
620 %dir %attr(750,svn,svn) /home/services/subversion
621 %dir %attr(750,svn,svn) /home/services/subversion/repos
622 %if %{with apache}
623 %attr(754,root,root) /etc/rc.d/init.d/svnserve
624 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/svnserve
625 %endif
626
627 %files tools
628 %defattr(644,root,root,755)
629 %attr(755,root,root) %{_bindir}/svn-hot-backup
630
631 %files -n bash-completion-subversion
632 %defattr(644,root,root,755)
633 /etc/bash_completion.d/%{name}
634
635 %if %{with javahl}
636 %files -n java-subversion
637 %defattr(644,root,root,755)
638 %attr(755,root,root) %{_libdir}/libsvnjavahl-1.so.*.*.*
639 %attr(755,root,root) %ghost %{_libdir}/libsvnjavahl-1.so.0
640 %attr(755,root,root) %{_libdir}/libsvnjavahl-1.so
641 %{_javadir}/svn-javahl.jar
642 %endif
643
644 %if %{with python}
645 %files -n python-subversion
646 %defattr(644,root,root,755)
647 %doc tools/backup/*.py tools/examples/*.py
648 %attr(755,root,root) %{_libdir}/libsvn_swig_py-1.so.*.*.*
649 %attr(755,root,root) %ghost %{_libdir}/libsvn_swig_py-1.so.0
650 %attr(755,root,root) %{_libdir}/libsvn_swig_py-1.so
651 %dir %{py_sitedir}/libsvn
652 %{py_sitedir}/libsvn/*.py[co]
653 %dir %{py_sitedir}/svn
654 %{py_sitedir}/svn/*.py[co]
655 %attr(755,root,root) %{py_sitedir}/libsvn/*.so
656 %{_examplesdir}/python-%{name}-%{version}
657 %endif
658
659 %if %{with perl}
660 %files -n perl-subversion
661 %defattr(644,root,root,755)
662 %attr(755,root,root) %{_libdir}/libsvn_swig_perl-1.so.*.*.*
663 %attr(755,root,root) %ghost %{_libdir}/libsvn_swig_perl-1.so.0
664 %attr(755,root,root) %{_libdir}/libsvn_swig_perl-1.so
665 %{perl_vendorarch}/SVN
666 %dir %{perl_vendorarch}/auto/SVN
667 %dir %{perl_vendorarch}/auto/SVN/*
668 %attr(755,root,root) %{perl_vendorarch}/auto/SVN/*/*.so
669 %{perl_vendorarch}/auto/SVN/*/*.bs
670 %{_mandir}/man3/*.3pm*
671 %endif
672
673 %if %{with ruby}
674 %files -n ruby-subversion
675 %defattr(644,root,root,755)
676 %attr(755,root,root) %{_libdir}/libsvn_swig_ruby-1.so.*.*.*
677 %attr(755,root,root) %ghost %{_libdir}/libsvn_swig_ruby-1.so.0
678 %attr(755,root,root) %{_libdir}/libsvn_swig_ruby-1.so
679 %dir %{_libdir}/ruby/site_ruby/svn
680 %{_libdir}/ruby/site_ruby/svn/*.rb
681 %dir %{_libdir}/ruby/site_ruby/svn/ext
682 %attr(755,root,root) %{_libdir}/ruby/site_ruby/svn/ext/*.so
683 %{_datadir}/ri/*.*/site/Svn
684 %{_datadir}/ri/*.*/site/Time
685 %{_datadir}/ri/*.*/site/Uconv
686 %{_datadir}/ri/*.*/site/*.rid
687 %{_datadir}/ri/*.*/site/Kernel/*
688 %{_datadir}/ri/*.*/site/OptionParser/*
689 %endif
690
691 %if %{with apache}
692 %files -n apache-mod_dav_svn
693 %defattr(644,root,root,755)
694 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{apacheconfdir}/*_mod_dav_svn.conf
695 %attr(755,root,root) %{apachelibdir}/mod_dav_svn.so
696
697 %files -n apache-mod_authz_svn
698 %defattr(644,root,root,755)
699 %doc subversion/mod_authz_svn/INSTALL
700 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{apacheconfdir}/*_mod_authz_svn.conf
701 %attr(755,root,root) %{apachelibdir}/mod_authz_svn.so
702 %endif
703
704 %endif # net_client_only
This page took 0.093329 seconds and 2 git commands to generate.