]> git.pld-linux.org Git - packages/subversion.git/blob - subversion.spec
- cosmetics on bconds
[packages/subversion.git] / subversion.spec
1 # TODO:
2 # - remove net_client_only and add db bcond (then without apache and
3 #   without db => net_client_only - spec will be more simpler, I think)
4 #
5 # Conditional build:
6 %bcond_with     net_client_only                 # build only net client
7 %bcond_without  python                          # build without python bindings
8 %bcond_without  perl                            # build without perl bindings
9 %bcond_without  apache                          # build without apache support (webdav, etc)
10 #
11 %{!?with_net_client_only:%include       /usr/lib/rpm/macros.perl}
12 %define apxs    /usr/sbin/apxs
13 %define pdir    SVN
14 %define pnam    _Core
15 Summary:        A Concurrent Versioning system similar to but better than CVS
16 Summary(pl):    System kontroli wersji podobny, ale lepszy, ni¿ CVS
17 Summary(pt_BR): Sistema de versionamento concorrente
18 Name:           subversion
19 Version:        1.3.2
20 Release:        1
21 License:        Apache/BSD Style
22 Group:          Development/Version Control
23 Source0:        http://subversion.tigris.org/downloads/%{name}-%{version}.tar.gz
24 # Source0-md5:  f790c49c219b4196e37ebfa71ab797d5
25 Source1:        %{name}-dav_svn.conf
26 Source2:        %{name}-authz_svn.conf
27 Source3:        %{name}-svnserve.init
28 Source4:        %{name}-svnserve.sysconfig
29 Patch0:         %{name}-home_etc.patch
30 Patch1:         %{name}-DESTDIR.patch
31 Patch2:         %{name}-neon.patch
32 URL:            http://subversion.tigris.org/
33 %if %{with net_client_only}
34 %global apache_modules_api 0
35 %else
36 %{?with_apache:BuildRequires:   apache-devel >= 2.2.0-8}
37 BuildRequires:  automake
38 BuildRequires:  db-devel >= 4.1.25
39 BuildRequires:  rpmbuild(macros) >= 1.268
40 %if %{with perl}
41 BuildRequires:  perl-devel >= 1:5.8.0
42 BuildRequires:  rpm-perlprov >= 4.1-13
43 BuildRequires:  swig-perl >= 1.3.24
44 %endif
45 %endif
46 BuildRequires:  apr-devel >= 1:1.0.0
47 BuildRequires:  apr-util-devel >= 1:1.0.0
48 BuildRequires:  autoconf >= 2.59
49 BuildRequires:  bison
50 BuildRequires:  expat-devel
51 BuildRequires:  gettext-devel
52 BuildRequires:  libtool >= 1.4-9
53 BuildRequires:  neon-devel >= 0.26.0
54 %if %{with python}
55 BuildRequires:  python >= 2.2
56 BuildRequires:  python-devel >= 2.2
57 BuildRequires:  python-modules >= 2.2
58 BuildRequires:  sed >= 4.0
59 BuildRequires:  swig-python >= 1.3.24
60 %endif
61 BuildRequires:  texinfo
62 BuildRequires:  which
63 Requires:       %{name}-libs = %{version}-%{release}
64 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
65
66 %define         _apachelibdir   %(%{apxs} -q LIBEXECDIR 2>/dev/null)
67 %define         _libexecdir             %{_libdir}/svn
68
69 %description
70 The goal of the Subversion project is to build a version control
71 system that is a compelling replacement for CVS in the open source
72 community.
73
74 Our goals are:
75 - All current CVS features.
76 - Directories, renames, and file meta-data are versioned.
77 - Symbolic links, etc, are supported
78 - Commits are truly atomic.
79 - Branching and tagging are cheap (constant time) operations
80 - Repeated merges are handled gracefully
81 - Support for plug-in client side diff programs
82 - Natively client/server
83 - Client/server protocol sends diffs in both directions
84 - Costs are proportional to change size, not project size
85 - Internationalization
86 - Progressive multi-lingual support
87
88 %description -l pl
89 Celem projektu Subversion jest stworzenie systemu kontroli wersji jako
90 zamiennika dla CVS.
91
92 Cele projektu to:
93 - Wszystkie aktualne mo¿liwo¶ci CVS.
94 - Katalogi, zmiany nazw oraz meta-dane plików s± wersjonowane.
95 - Wsparcie dla linków symbolicznych itp.
96 - Commity s± w pe³ni atomowe.
97 - Branchowanie oraz tagowanie s± tanimi (sta³ymi w czasie) operacjami.
98 - Powtarzaj±ce merge.
99 - Wsparcie dla pluginów diff'a po stronie klienta.
100 - Natywny klient/serwer.
101 - Klient/Serwer przesy³aj± diffy w obu kierunkach.
102 - Koszty proporcjonalne do rozmiaru zmiany, a nie rozmiaru projektu.
103 - Internacjonalizacja.
104 - Postêpuj±ce wsparcie dla wielu jêzyków.
105
106 %description -l pt_BR
107 O objetivo do projeto Subversion é construir um sistema de controle de
108 versões que seja um substituto para o CVS (Concurrent Versioning
109 System) na comunidade opensource, fornecendo grandes melhorias.
110
111 %package libs
112 Summary:        Subversion libraries and modules
113 Summary(pl):    Biblioteka subversion oraz ³adowalne modu³y
114 Group:          Libraries
115 Requires:       neon >= 0.24.7
116 Obsoletes:      libsubversion0
117
118 %description libs
119 Subversion libraries and modules.
120
121 %description libs -l pl
122 Biblioteka subversion oraz ³adowalne modu³y.
123
124 %package devel
125 Summary:        Header files and develpment documentation for subversion
126 Summary(pl):    Pliki nag³ówkowe i dokumetacja do subversion
127 Summary(pt_BR): Arquivos de desenvolvimento para o Subversion
128 Group:          Development/Libraries
129 Requires:       %{name}-libs = %{version}-%{release}
130 Requires:       apr-util-devel >= 1:1.0.0
131 Requires:       neon-devel >= 0.24.7
132 Obsoletes:      libsubversion0-devel
133
134 %description devel
135 Header files and develpment documentation for subversion.
136
137 %description devel -l pl
138 Pliki nag³ówkowe i dokumetacja do subversion.
139
140 %description devel -l pt_BR
141 Este pacote provê os arquivos necessários para desenvolvedores
142 interagirem com o Subversion.
143
144 %package static
145 Summary:        Static subversion library
146 Summary(pl):    Biblioteka statyczna subversion
147 Summary(pt_BR): Sistema de versionamento concorrente
148 Group:          Development/Libraries
149 Requires:       %{name}-devel = %{version}
150 Obsoletes:      libsubversion0-static-devel
151
152 %description static
153 Static subversion library.
154
155 %description static -l pl
156 Biblioteka statyczna subversion.
157
158 %description static -l pt_BR
159 Este pacote provê um cliente estático do subversion.
160
161 %package svnserve
162 Summary:        Subversion svnserve
163 Summary(pl):    Subversion svnserve
164 Group:          Networking/Daemons
165 Requires(post,preun):   /sbin/chkconfig
166 Requires:       %{name} = %{version}-%{release}
167 Requires:       rc-scripts
168
169 %description svnserve
170 Subversion svnserve server.
171
172 %description svnserve -l pl
173 Serwer subversion svnserve.
174
175 %package tools
176 Summary:        Subversion tools and scripts
177 Summary(pl):    Narzêdzia oraz skrypty dla subversion
178 Summary(pt_BR): Módulos python para acessar os recursos do Subversion
179 Group:          Applications
180 %pyrequires_eq  python
181 Requires:       %{name} = %{version}-%{release}
182 Requires:       python-rcsparse >= 0.1-0.20031026.0
183 Requires:       python-subversion = %{version}
184
185 %description tools
186 Subversion tools and scripts.
187
188 %description tools -l pl
189 Narzêdzia oraz skrypty dla subversion.
190
191 %package -n bash-completion-subversion
192 Summary:        bash completion for subversion
193 Summary(pl):    Dope³nienia basha dla subversion
194 Group:          Applications/Shells
195 Requires:       %{name} = %{version}-%{release}
196 Requires:       bash-completion
197 Conflicts:      %{name}-tools <= 1.1.0-0.rc6.1
198
199 %description -n bash-completion-subversion
200 Bash completion for subversion.
201
202 %description -n bash-completion-subversion -l pl
203 Dope³nienia basha dla subversion.
204
205 %package -n python-subversion
206 Summary:        Subversion python bindings
207 Summary(pl):    Dowi±zania do subversion dla pythona
208 Summary(pt_BR): Módulos python para acessar os recursos do Subversion
209 Group:          Development/Languages/Python
210 %pyrequires_eq  python
211 Requires:       %{name}-libs = %{version}-%{release}
212 Obsoletes:      subversion-python
213
214 %description -n python-subversion
215 Subversion python bindings.
216
217 %description -n python-subversion -l pl
218 Dowi±zania do subversion dla pythona.
219
220 %description -n python-subversion -l pt_BR
221 Módulos python para acessar os recursos do Subversion.
222
223 %package -n perl-subversion
224 Summary:        Subversion perl bindings
225 Summary(pl):    Dowi±zania do subversion dla perla
226 Summary(pt_BR): Módulos perl para acessar os recursos do Subversion
227 Group:          Development/Languages/Perl
228 Requires:       %{name}-libs = %{version}-%{release}
229 Obsoletes:      subversion-perl
230
231 %description -n perl-subversion
232 Subversion perl bindings.
233
234 %description -n perl-subversion -l pl
235 Dowi±zania do subversion dla perl.
236
237 %description -n perl-subversion -l pt_BR
238 Módulos perl para acessar os recursos do Subversion.
239
240 %package -n apache-mod_dav_svn
241 Summary:        Apache module: Subversion Server
242 Summary(pl):    Modu³ apache: Serwer Subversion
243 Group:          Networking/Daemons
244 Requires:       %{name} = %{version}-%{release}
245 Requires:       apache(modules-api) = %apache_modules_api
246 Requires:       apache-mod_dav
247
248 %description -n apache-mod_dav_svn
249 Apache module: Subversion Server.
250
251 %description -n apache-mod_dav_svn -l pl
252 Modu³ apache: Serwer Subversion.
253
254 %package -n apache-mod_authz_svn
255 Summary:        Apache module: Subversion Server - path-based authorization
256 Summary(pl):    Modu³ apache: autoryzacja na podstawie ¶cie¿ki dla serwera Subversion
257 Group:          Networking/Daemons
258 Requires:       apache(modules-api) = %apache_modules_api
259 Requires:       apache-mod_dav_svn = %{version}-%{release}
260
261 %description -n apache-mod_authz_svn
262 Apache module: Subversion Server - path-based authorization.
263
264 %description -n apache-mod_authz_svn -l pl
265 Modu³ apache: autoryzacja na podstawie ¶cie¿ki dla serwera Subversion.
266
267 %prep
268 %setup -q
269 rm -rf apr apr-util neon
270 %patch0 -p0
271 %patch1 -p1
272 %patch2 -p1
273
274 %build
275 cp -f /usr/share/automake/config.sub ac-helpers
276 chmod +x ./autogen.sh && ./autogen.sh
277
278 # don't enable dso - currently it's broken
279 %configure \
280         --with-editor=vi \
281         --with-zlib \
282         --with-python=%{_bindir}/python \
283         --with-perl5=%{_bindir}/perl \
284 %if %{with net_client_only}
285         --without-apache \
286         --without-swig \
287         --without-apxs \
288         --without-berkeley-db \
289 %else
290         --disable-dso \
291         --disable-mod-activation \
292 %if %{with apache}
293         --with-apxs=%{_sbindir}/apxs \
294 %else
295         --without-apache \
296         --without-apxs \
297         --with-berkeley-db=%{_includedir}/db4:%{_libdir} \
298 %endif
299 %if %{without python} && %{without perl}
300         --without-swig \
301 %endif
302 %endif
303         --with-neon=%{_prefix} \
304         --disable-neon-version-check \
305         --with-apr=%{_bindir}/apr-1-config \
306         --with-apr-util=%{_bindir}/apu-1-config
307
308 %{__make} -j1
309
310 %if %{without net_client_only}
311 # python
312 %if %{with python}
313 %{__make} swig-py \
314         swig_pydir=%{py_sitedir}/libsvn \
315         swig_pydir_extra=%{py_sitedir}/svn
316 %endif
317 # perl
318 %if %{with perl}
319 %{__make} swig-pl-lib
320 odir=$(pwd)
321 cd subversion/bindings/swig/perl/native
322 %{__perl} Makefile.PL INSTALLDIRS=vendor
323 %{__make}
324 cd $odir
325 %endif
326 %endif
327
328 %{__sed} -i -e 's/@SVN_DB_INCLUDES@//g' -e 's/@SVN_DB_LIBS@//g' svn-config
329
330 %install
331 rm -rf $RPM_BUILD_ROOT
332 install -d $RPM_BUILD_ROOT/etc/{rc.d/init.d,sysconfig,bash_completion.d} \
333         $RPM_BUILD_ROOT{%{_sysconfdir}/httpd/httpd.conf,%{_apachelibdir},%{_infodir}} \
334         $RPM_BUILD_ROOT%{_examplesdir}/{%{name}-%{version},python-%{name}-%{version}} \
335         $RPM_BUILD_ROOT/home/services/subversion{,/repos}
336
337 %{__make} install -j1 \
338 %if %{without net_client_only} && %{with python}
339         install-swig-py \
340 %endif
341         APACHE_LIBEXECDIR="$(%{_sbindir}/apxs -q LIBEXECDIR)" \
342         DESTDIR=$RPM_BUILD_ROOT \
343         swig_pydir=%{py_sitedir}/libsvn \
344         swig_pydir_extra=%{py_sitedir}/svn
345
346 %if %{without net_client_only} && %{with perl}
347 %{__make} install-swig-pl-lib \
348         DESTDIR=$RPM_BUILD_ROOT
349 odir=$(pwd)
350 cd subversion/bindings/swig/perl/native
351 %{__make} install \
352         DESTDIR=$RPM_BUILD_ROOT \
353         PREFIX=$RPM_BUILD_ROOT%{_prefix} \
354         LIBDIR=$RPM_BUILD_ROOT%{_libdir}
355 cd $odir
356 %endif
357
358 install svn-config $RPM_BUILD_ROOT%{_bindir}
359
360 %if %{with apache}
361 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/httpd/httpd.conf/65_mod_dav_svn.conf
362 install %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/httpd/httpd.conf/66_mod_authz_svn.conf
363 install %{SOURCE3} $RPM_BUILD_ROOT/etc/rc.d/init.d/svnserve
364 install %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/svnserve
365 %endif
366
367 %if %{without net_client_only}
368 install tools/backup/hot-backup.py $RPM_BUILD_ROOT%{_bindir}/svn-hot-backup
369 %if %{with python}
370 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
371 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
372 find $RPM_BUILD_ROOT%{py_sitedir} -name "*.py" -o -name "*.a" -o -name "*.la" | xargs rm -f
373 install tools/examples/*.py $RPM_BUILD_ROOT%{_examplesdir}/python-%{name}-%{version}
374 %endif
375 %endif
376
377 install tools/client-side/bash_completion $RPM_BUILD_ROOT/etc/bash_completion.d/%{name}
378 install tools/examples/*.c $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
379
380 %find_lang %{name}
381
382 %clean
383 rm -rf $RPM_BUILD_ROOT
384
385 %post devel
386 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
387
388 %postun devel
389 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
390
391 %post   libs -p /sbin/ldconfig
392 %postun libs -p /sbin/ldconfig
393 %post   -n python-subversion -p /sbin/ldconfig
394 %postun -n perl-subversion -p /sbin/ldconfig
395
396 %post svnserve
397 /sbin/chkconfig --add svnserve
398 %service svnserve restart "svnserve daemon"
399
400 %preun svnserve
401 if [ "$1" = "0" ]; then
402         %service svnserve stop
403         /sbin/chkconfig --del svnserve
404 fi
405
406 %post -n apache-mod_dav_svn
407 %service -q httpd restart
408
409 %preun -n apache-mod_dav_svn
410 if [ "$1" = "0" ]; then
411         %service -q httpd restart
412 fi
413
414 %files
415 %defattr(644,root,root,755)
416 %doc BUGS CHANGES COPYING INSTALL README
417 %doc doc/*/*.html
418 %doc tools/hook-scripts/*.{pl,py,example}
419 %doc tools/hook-scripts/mailer/*.{py,example}
420 %doc tools/xslt/*
421 %attr(755,root,root) %{_bindir}/svn*
422 %exclude %{_bindir}/svnserve
423 %exclude %{_bindir}/svn-config
424 %if %{without net_client_only}
425 %exclude %{_bindir}/svn-hot-backup
426 %endif
427 %{_mandir}/man1/*
428 %{_mandir}/man5/*
429 %{_mandir}/man8/*
430 %exclude %{_mandir}/man?/svnserve*
431
432 %files libs -f %{name}.lang
433 %defattr(644,root,root,755)
434 %attr(755,root,root) %{_libdir}/lib*.so.*
435 %if %{with perl} || %{with python}
436 %exclude %{_libdir}/lib*_swig_*.so.*
437 %endif
438
439 %files devel
440 %defattr(644,root,root,755)
441 %attr(755,root,root) %{_bindir}/svn-config
442 %{_includedir}/%{name}*
443 %attr(755,root,root) %{_libdir}/lib*.so
444 %{_libdir}/lib*.la
445 %if %{with perl} || %{with python}
446 %exclude %{_libdir}/lib*_swig_*.so
447 %exclude %{_libdir}/lib*swig*.la
448 %endif
449 %{_examplesdir}/%{name}-%{version}
450
451 %files static
452 %defattr(644,root,root,755)
453 %{_libdir}/lib*.a
454
455 %if %{without net_client_only}
456 %files svnserve
457 %defattr(644,root,root,755)
458 %attr(755,root,root) %{_bindir}/svnserve
459 %{_mandir}/man?/svnserve*
460 %dir /home/services/subversion
461 %dir /home/services/subversion/repos
462 %if %{with apache}
463 %attr(754,root,root) /etc/rc.d/init.d/svnserve
464 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/svnserve
465 %endif
466
467 %files tools
468 %defattr(644,root,root,755)
469 %attr(755,root,root) %{_bindir}/svn-hot-backup
470
471 %files -n bash-completion-subversion
472 %defattr(644,root,root,755)
473 /etc/bash_completion.d/%{name}
474
475 %if %{with python}
476 %files -n python-subversion
477 %defattr(644,root,root,755)
478 %doc tools/backup/*.py tools/examples/*.py
479 %dir %{py_sitedir}/svn
480 %dir %{py_sitedir}/libsvn
481 %{py_sitedir}/svn/*.py[co]
482 %{py_sitedir}/libsvn/*.py[co]
483 %attr(755,root,root) %{py_sitedir}/libsvn/*.so
484 %{_examplesdir}/python-%{name}-%{version}
485 %attr(755,root,root) %{_libdir}/lib*_swig_py*.so*
486 %{_libdir}/lib*_swig_py*.la
487 %endif
488
489 %if %{with perl}
490 %files -n perl-subversion
491 %defattr(644,root,root,755)
492 %{perl_vendorarch}/SVN
493 %dir %{perl_vendorarch}/auto/SVN
494 %dir %{perl_vendorarch}/auto/SVN/*
495 %attr(755,root,root) %{perl_vendorarch}/auto/SVN/*/*.so
496 %{perl_vendorarch}/auto/SVN/*/*.bs
497 %{_mandir}/man3/*.3pm*
498 %attr(755,root,root) %{_libdir}/lib*_swig_perl*.so*
499 %{_libdir}/lib*_swig_perl*.la
500 %endif
501
502 %if %{with apache}
503 %files -n apache-mod_dav_svn
504 %defattr(644,root,root,755)
505 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/httpd/httpd.conf/*_mod_dav_svn.conf
506 %attr(755,root,root) %{_apachelibdir}/mod_dav_svn.so
507
508 %files -n apache-mod_authz_svn
509 %defattr(644,root,root,755)
510 %doc subversion/mod_authz_svn/INSTALL
511 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/httpd/httpd.conf/*_mod_authz_svn.conf
512 %attr(755,root,root) %{_apachelibdir}/mod_authz_svn.so
513 %endif
514
515 %endif # net_client_only
This page took 0.092175 seconds and 3 git commands to generate.